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Welcome to CAMPS
The Only MIDI Sequencer with Musical Intelligence

CAMPS Help provides detailed information on CAMPS features and functions. Use this Contents to find the
information you're looking for.

  

CAMPS Overview CAMPS is different kind of Sequencer. Reading this Overview will give you an
introduction to the unique functional and user-interface concepts in CAMPS, making
them easier to understand and utilize.

Using CAMPS Common topics using CAMPS..

Editors Editors allow you to edit MIDI data while composing and arranging music.

Dialog boxes Dialog boxes allow you to adjust parameters for various features in CAMPS including
Auto Composing and Harmonization.

Menu Bar The Menu Bar located at the top of the window allows you to access most features in
CAMPS.

Toolbars Several Toolbars are implemented in CAMPS for MIDI data monitoring and control.

Music Glossary Music Terms used in CAMPS including Key / Mode / Harmonize / Voicing

License Agreement Please read this License carefully before Using your Microworks product.

Support Link to Frequently Asked Questions at our website
Send your questions by email to support@mxw.com
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Using CAMPS v4   

 

Here is a list showing the most common topics you may need to be familiar with in CAMPS v4.

Getting Started

Installation●   

Uninstallation●   

Authorization●   

Reinstalling in another Directory●   

Reinstalling in another PC●   

Defragmentation●   

MIDI Settings●   

Grid Settings●   

Working with Documents

Creating a New Document●   

Opening a Document●   

Opening a CAMPS v3 Document●   

Opening a Standard MIDI File●   

Saving a Document●   

Exporting as a Standard MIDI File●   

For Chord Definitions

Creating New Chords●   

Assigning a Key and Mode●   

Manual Chord Definitions●   

Tensions and Inversions●   

Playing back Chords●   

Auto Harmonization●   

Auto Harmonization of an entire Document●   

Auto Chord Progression Generation●   

Auto Chord Name Detection from your MIDI Input●   

Auto Roman Numeral Analysis●   

Auto Scale Name Analysis●   

Auto Song Form Detection●   

file:///C|/My Documents/CampsHelp/Contents/getstart1.htm
file:///C|/My Documents/CampsHelp/Contents/getstart2.htm
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For Lines

Creating New Tracks●   

Creating New Line Blocks●   

Controlling Track Playback●   

Auto Composition from Scratch●   

Auto Composition based on Analysis of your Melody●   

Customizing Auto Composition●   

Auto Composition based on a mouse-drawn contour●   

Understanding Takes●   

Playing back Lines●   

Recording Lines●   

Auto Voicing●   

Auto Scale Spelling●   

Auto Dissonant Interval Detection●   

Working with Lyric●   

Other Features

The "EZ" tools in CAMPS●   

SMPTE or manual Tap Tempo Synchronization●   

Organizing a Composition●   

Multiple Document editing environment●   

 



CAMPS Overview  
Contents

Menu Bar

  

Environment  CAMPS allows you to open multiple documents and exchange data
between them while maintaining an enhanced level of MIDI
functionality. Most editing tasks can be carried out while CAMPS is in
Playback mode. The more powerful your computer, the more you can
exploit the power of CAMPS.

We'd like to point out that CAMPS devotes a large amount of its
processing power to Music Theory. While CAMPS is a fully functional
sequencer, some sequencer features have been left aside in favor of
music theory implementation and tightly written software code.

With this point in mind, it should also be noted that CAMPS is a very
"hands-on" application. The flexibility of the musical tools presented
here would not be possible if their functions were made mostly
automatic. For example, the "EZ" tools in CAMPS are designed to give
a quick starting point and help in familiarization with CAMPS objects
used for building compositions. They are not designed to automatically
create some great music for you. Consequentially, the more
parameters you define, the better your musical results will be. Bringing
a previously written Standard MIDI File into CAMPS will immediately
enable you to unleash CAMPS more powerful features. This is the
nature of CAMPS; who's very name is an acronym for Computer
Assisted Music Processing System.

Menus To manage the wide range of available functions and their complex
musical relationships with your object selection options, CAMPS uses
an object-oriented approach to doing things, employing a conditional
menu system. This not only effects menu item availability (inactive or
"grayed out" status), but also whether menu items appear at all, how
they manifest themselves, and in what combination. Attempting to
"Browse" the user-interface (menus, etc.) without a file loaded will
prove fruitless. In general, you'll first need to mouse-select an object to
work on, after which all possible actions for that object will become
available.

Main Objects Tracks CAMPS organizes a song's MIDI Line data into Tracks, as any MIDI
Sequencer. However, the first Track (unnumbered) is dedicated to
Chords, a proprietary Track used to build a Tonality reference for use
by Auto Composing and other unique features in CAMPS.

The rest of the Tracks are basically universal with regards to other
MIDI Sequencers, but are assignable to different Orchestration
Categories, a proprietary designation used for Auto Harmonizing and
other unique features in CAMPS. Track Categories for Melodic or
Harmonic Line data are typically referred to in these Help Documents
as "Tonal", while Tracks used for Percussion Line data are considered
"Drums".



Chord Blocks The Chord Track contains Chord Blocks, each Block being a set of
Chord Containers. A Chord Block can vary in size, depending on the
quantity and size of the Chord Containers residing within it. Rather than
having one long Block of Chord Containers for a whole Composition,
Chord Containers are typically grouped into smaller Blocks, each
having its own Tonal tendencies corresponding to a section of your
Composition. This allows CAMPS to assist in Chord Progression
development within each Chord Block, which in turn will help you
Harmonize individual sections of your Composition more accurately.

CAMPS automatically selects (highlights) a Chord Block for analysis
whenever a Chord Container within it is selected. Conversely, if any
Chord Containers are selected, Chord Block Menu items will not be
available in favor of Chord Container items. To get control of Chord
Blocks, make sure no Chord Containers are highlighted in the Block
being selected, and click the thin horizontal Chord Block Selection Bar
across the top of a Chord Block.

Chord Containers CAMPS stores both MIDI and musical analysis data for Chord
Containers, enabling you to Audition them, as well as employ their
Composition functions. Chord Containers include several modifiers,
including individually assignable Chord Name, Key and Chord
Functions which all contribute to resulting Chords. Drag the dividing bar
between the Chord and Line areas down to view them all.

From a user interface point of view, the phrases "Chord" and "Chord
Container" are generally synonymous in the CAMPS environment.
There can be only one Chord per Container. However, for the purpose
of differentiating between Musical Chords and their assignment as
CAMPS Chord Definitions, the phrase "Chord Container" is used as
much as possible throughout these Help documents to describe
CAMPS Chord Definitions in the Chord Track. Simultaneous Notes
constituting Musical Chords in Track Line data are typically referred to
as "Chordal Line data", or "Voicings". Understanding these distinctions
will help to avoid confusion when using these Help documents.

Line Blocks CAMPS organizes a song Track's MIDI Line data into Line Blocks for
musical analysis and manipulation control. These Blocks are mostly
separated by Line Phrases, that is, a Line of continuous Notes. When
importing a Standard MIDI File or Recording in CAMPS, a "pause" in a
Track's Note data at a Bar division typically constitutes the end of a
Line Block, and the beginning of another.

Getting
Results

Chord data CAMPS references the Chord Blocks to facilitate the musical changes
and adjustments you choose to make in your Line data with the Auto
Compose and Voicing features. Existing Chords in a given Chord Block
are also referenced when manipulating Chords within that Block. Some
of the richest features CAMPS has to offer depend on attention to
accurate Chord Definitions, so taking the time to familiarize yourself
with CAMPS Chords will help you get the best results.



Track Categories CAMPS uses its proprietary Track Categories such as "Melody",
"Bass", etc., to associate a musical role with each Track. This role is in
turn used by CAMPS during Auto Harmonization and other processes.
As a simple example, Note data in a Drum Track represents Drum
sounds mapped to certain Keys of a MIDI Keyboard. Since these
"Notes" don't usually represent Pitches constituting Harmony in your
Composition, you wouldn't want CAMPS to consider them when Auto
Harmonizing. On the other hand, referencing a Drum Track is desirable
for Rhythmic Composing. Properly assigning Track Categories is
another important part of employing CAMPS special features.

Editing Notes Notes can be edited in the Event list, Pianoroll and Notation Editors,
but the Pianoroll Editor is probably the best for visually editing the
Notes in a Line Block. The Event List editor is useful for editing Notes
and other MIDI data by their numerical values. The Notation Editor is
intended mostly as a display tool, and precisely editing Note Duration
values while the Notation display interprets them from absolute MIDI
values can be challenging.

Auditioning While Auditioning in Chord related dialog boxes, making a new result
selection in the dialog box during Audition Playback resets the
Playback Loop to it's beginning. This allows you to hear how your
selection effects a given Chord Progression in its entirety.

While Auditioning in Line related dialog boxes, making a new result
selection in the dialog box during Audition Playback does not reset the
Playback Loop to it's beginning, allowing selection changes to occur at
any point in the Playback Loop without interrupting it's flow. This allows
you to compare different MIDI Lines from intermediate points without
interrupting the flow. Additionally, some Line related dialog boxes allow
you to manipulate background window functions for added flexibility.

MIDI
operation

The MIDI Setup dialog box offers a vast array of MIDI settings, but one
of niftiest MIDI features in CAMPS is the ability to assign a different
MIDI Output Device to each Track. Depending on how many MIDI
interfaces are installed on your computer, this allows you to send each
Track's MIDI data to a different Synth module or other device. It is also
possible to change these settings during Playback.

Each Track also provides a numerical entry area and a real-time flying
fader control, each of which can have one of twelve MIDI Control
Events assigned to it.

Using your computer's
keyboard

If you like using your keyboard in combination with or instead of your
mouse, you'll find most of the CAMPS menu system is "hot key"
implemented, using the customary ALT + Underlined keystroke
combination.

Many graphic selection areas such as edit/selection boxes and graphic
data itself can be manipulated with your computer keyboard arrow
keys. The Home and End keys allow you to instantly jump to the top or
end of a Composition Document. The Space Bar starts and stops the
CAMPS Sequencer.



Managing Files CAMPS stores Chord Block and Line Block information along with MIDI
Chord and Line data in it's proprietary (*.CDC) file format. When
exporting your work out to a Standard MIDI File, Chord definitions are
converted to Standard MIDI Chord change text. Text and Lyric Events
are maintained, but Track Categories and Line Block information are
discarded.

On-Line Help These Help documents are primarily arranged according to CAMPS
areas and interfaces. A great level of detail has been included here,
though probably not enough for some, and too much for others. It is
assumed that the user has a basic understanding of music, MIDI and
computers, as these Help documents focus on CAMPS functionality.
We sincerely hope that this software helps your musical endeavors,
and that these Help documents help you use this software.

 



Installation   

 

To install CAMPS v4, please follow the instructions below :

1 Turn off all programs. If you are using a virus protection program, deactivate it.
2 Place the CAMPS 4 CD-ROM in the CD-ROM drive.
3 Double-click the CAMPS 4 Setup.exe icon on the CD-ROM to start installation.
4 Follow the instructions asking you to specify the installation location.
5 Click the Close button in the Installation dialog box to complete installation.

 Authorization

If you are installing CAMPS v4 for the first time, the installed program will expire in 30 days. Reinstallation
doesn't extend this valid period. Please obtain your license from us for unlimited use of CAMPS v4.

For the Licensing instructions, please refer to ReadMe.doc in the CAMPS 4 folder.

 Reinstallation

If you are reinstalling CAMPS v4 while having a licensed CAMPS v4 installed in a different directory or PC,
you MUST transfer your digital license from the authorized program to the newly installed one. Between
directories, Between PC's

 



Uninstallation   

 

If you are using an Authorized copy of CAMPS v4, you MUST temporarily transfer your license from the
currently Authorized copy of CAMPS v4 BEFORE any uninstallation. To uninstall CAMPS v4, please follow
the instructions below :

1 Turn off all programs. If you are using a virus protection program, deactivate it.
2 Click the Start button at the left bottom corner of the Windows screen and then choose Uninstall CAMPS
4 from the Program / CAMPS 4 submenu.
3 Follow the instructions in the Uninstallation dialog box.
4 Click the OK button in the Uninstallation dialog box to complete uninstallation.

 Transferring your License

It is VERY important to understand that you need to transfer your digital license from the authorized
program to the newly installed one BEFORE uninstalling the authorized program. Uninstalling CAMPS
without License transferring also destroys your purchased license. More details.

 



Authorization   

 

To enable your license for unlimited use of CAMPS v4, you need to authorize your copy of CAMPS v4.
Otherwise your copy of CAMPS v4 will expire in 30 days. Once authorized, you can repeat Installations and
Uninstallations between different directories and PC's by transferring the Digital License. To authorize your
copy of CAMPS v4, please follow the instructions below :

Opening the License Configuration dialog box

1 Turn off all programs. If you are using a virus protection program, deactivate it.
2 Double-click the CAMPS icon in the CAMPS 4 folder on your Hard Drive.
3 Hit the Enter key on your Computer Keyboard when the License Status dialog box appears right after
launching.
4 The License Configuration dialog box appears.

Automatically creating a Site Code

In the License Configuration dialog box, you'll receive a unique Site Code automatically created for you. As
soon as you provide us with the Site Code via one of methods explained below, our 24-hour fully automated
Authorization Server will issue a corresponding Site Key to the provided Site Code. Type in the Site Key in
the License Configuration dialog box to unlock your copy for unlimited use.

5 Click the Display Site Code... button.
6 Click the Yes button if you agree to the terms of the License Agreement.
7 Make a copy of the generated Site Code for your record.

Authorizing your copy with a Site Key

Please provide us with your Site Code and customer information via mail, fax, email or our Authorization
Site. You will receive a Site Key in 24 hours by email or fax, or in a few days by mail.

Whether you've purchased CAMPS v4 through retailers or mail order, you must also provide us with your
Serial Number.

8 Click the Authorization Site link in the message area of the dialog box to proceed the automated and
secure Authorization over the Internet.
9 Follow the instructions asking for your Site Code and customer information.
10 When your Site Key is provided, type in the Key in the Site Key text box and then click Validate button.
11 Now your Digital License is preserved in the authorized copy of CAMPS v4.

 Relocating the authorized program

It is VERY important to understand that you must extract your Digital License from the authorized copy of
CAMPS v4 BEFORE any relocation of CAMPS v4. Uninstalling or deleting CAMPS without License
transferring destroys your purchased License. More details.





Reinstalling in another Directory   

 

To move the current CAMPS 4 folder between directories on the same computer, you naturally need to
duplicate the complete CAMPS 4 folder. More importantly, you also need to transfer the license from the
currently Authorized program to the copy.

1 Turn off all programs. If you are using a virus protection program, deactivate it.
2 Make a duplication of the CAMPS 4 folder using either CAMPS 4 Setup.exe or Windows "Copy & Paste"
function.
3 Double-click the authorized CAMPS icon in the CAMPS 4 folder on your Hard Drive.
4 Hit the Enter key on your Computer Keyboard when the License Status dialog box appears right after
launching.
5 The License Configuration dialog box appears.
6 Choose Transfer to Directory... from the License menu.
7 Enter the destination directory for the license where prompted or press Browse to display a list of
directories.
8 Press OK. The license will be moved from the source copy of the program to the destination copy.
9 You can now delete the source copy of the CAMPS 4 folder to avoid unnecessary future confusion.

 Uninstalling CAMPS

It is VERY important to understand that you NEVER delete or uninstall the licensed (authorized) copy of
CAMPS v4. You MUST first extract your Digital license from the licensed copy of CAMPS v4. More details.
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Reinstalling in another PC   

 

To reinstall CAMPS v4 into another PC, you MUST transfer a Digital License from this PC to a copy of
CAMPS v4 on another PC via a Floppy Disk.

On Another PC

1 Turn off all programs. If you are using a virus protection program, deactivate it.
2 Place the CAMPS 4 CD-ROM in the CD-ROM drive.
3 Install a set of CAMPS using CAMPS 4 Setup.exe.
4 Place a blank Floppy Disk in the Floppy Disk drive.
5 Double-click the Non Licensed CAMPS icon in the CAMPS 4 folder on your Hard Drive.
6 Hit Enter key on your Computer Keyboard when the License Status dialog box appears right after
launching.
7 The License Configuration dialog box appears.
8 Choose Transfer in from another computer... from the License menu.
9 Enter a directory on a Floppy Disk that will be used to hold the temporary transfer information.
10 Press OK. The transfer information will be written to the Floppy Disk.

On Source PC

11 Take the Floppy Disk to the Licensed computer.
12 Choose Transfer out to another computer... from the License menu.

Back on Another PC

13 Bring the Floppy Disk back to this computer and then press Continue Transfer.
14 This program will now be authorized.

More Details

 



Defragmentation   

 

BEFORE using the defragmentation utility (such as Speed Disk of Symantec's Norton Utilities) on the
volume the authorized CAMPS v4 resides, You MUST first extract your digital license from the licensed
copy to a floppy disk. Otherwise the defragmentation utility will destroys your purchased license. After
defragmentation, transfer your digital license back to the program on the volume from the floppy disk. See
also Reinstalling in another PC and Reinstalling in another Directory.

 



MIDI Settings   

 

The MIDI Setup dialog box offers a vast array of MIDI settings. Before making any setting in the dialog box,
you need to choose a MIDI Driver software for use in CAMPS from TWO options, the Windows Operating
System MIDI Mapper or MIDI Driver you've installed.

Choosing MIDI Mapper from the MIDI menu switches between enable or disable the Windows Operating
System MIDI Mapper. When enabled, CAMPS passes MIDI Output Device selection control to the Windows
Multimedia applet in the Control Panel. When disabled, MIDI Output Devices can be selected from within
CAMPS, allowing much greater flexibility. A checkmark appears next to this item when enabled.

Choosing MIDI Setup from the MIDI menu opens the MIDI Setup dialog box, allowing you to manage many
MIDI signaling details. This includes settings for input, output, sync and Devices.

 One of niftiest MIDI features in CAMPS is the ability to assign a different MIDI Output Device to each
Track. Depending on how many MIDI interfaces are installed on your computer, this allows you to send
each Track's MIDI data to a different Synth module or other device. It is also possible to change these
settings during Playback.

Each Track also provides a numerical entry area and a real-time flying fader control, each of which can
have one of twelve MIDI Control Events assigned to it.



Creating a New Document   

 

Choose New from the File menu to creates a New untitled Document as specified by the settings in the
New Document Setup dialog box.

 



Opening a Document   

 

Choose Open... from the File menu to open previously saved CAMPS v4 Documents. CAMPS allows you
to open multiple documents and exchange data between them.

More Details

 



Opening a CAMPS v3 Document   

 

Choose Open... from the File menu to open CAMPS v3 ( for Mac ) Documents with ".cdc" extension.
CAMPS allows you to open multiple documents and exchange data between them.

CAMPS organizes a song Track's MIDI Line data into Line Blocks for musical analysis and manipulation
control. These Blocks are mostly separated by Line Phrases, that is, a Line of continuous Notes. When
importing a Standard MIDI File or CAMPS v3 Document, or Recording in CAMPS, a "pause" in a Track's
Note data at a Bar division typically constitutes the end of a Line Block, and the beginning of another.

More Details

 



Opening a Standard MIDI File   

 

Choose Open... from the File menu to open Standard MIDI Files ( S.M.F.). CAMPS allows you to open
multiple documents and exchange data between them.

 When opening a Standard MIDI File, CAMPS automatically analyzes Line data and assigns appropriate
Line Blocks and one of six Category settings to each Track. You can alter these settings at any time.

CAMPS organizes a song Track's MIDI Line data into Line Blocks for musical analysis and manipulation
control. These Blocks are mostly separated by Line Phrases, that is, a Line of continuous Notes. When
importing a Standard MIDI File or CAMPS v3 Document, or Recording in CAMPS, a "pause" in a Track's
Note data at a Bar division typically constitutes the end of a Line Block, and the beginning of another.

More Details

 



Saving a Document   

 

Choose Save or Save As... from the File menu to save the current Document using its existing filename
and location.

CAMPS stores Chord Block and Line Block information along with MIDI Chord and Line data in it's proprietary
(*.CDC) file format.

 



Exporting as a Standard MIDI File   

 

Choose Export SMF... from the File menu to open the Export Standard MIDI File dialog box, allowing you
to save the current Document as a Standard MIDI File. After specifying a filename and location and clicking
Save, the Export Options dialog box opens, allowing you to make final file format conversion settings.

When exporting your work out to a Standard MIDI File, Chord definitions are converted to Standard MIDI
Chord change text. Text and Lyric Events are maintained, but Track Categories and Line Block information
are discarded.

 



Creating New Tracks   

 

CAMPS organizes a song's MIDI Line data into Tracks, as any MIDI Sequencer. Tracks are basically
universal with regards to other MIDI Sequencers, but are assignable to different Orchestration Categories, a
proprietary designation used for Auto Harmonizing and other unique features in CAMPS. Each Track's MIDI
Line data are organized into Line Blocks for musical analysis and manipulation control.

To Create New Tracks
Since Line Blocks reside in Tracks, you'll first need to have Tracks in the Track Area of your Document
before you can individually manipulate Line Blocks.

More Details

 



Working with Lyric   

 

Lyric Events allow you to include song Lyrics (sung words) in your Composition. You can create, edit, copy,
duplicate, move or delete Lyric Events as needed. Lyrics can then be Saved and Exported with the rest of
your Composition Document. Unlike general Text Events which have a common location in a Document, a
different set of Lyrics can be saved with each Line Block.

You can display, create and edit Lyric Events in the Pianoroll, Control Draw and Event List Editors. Lyric
Events are also displayed in the Notation Editor.

From the Pianoroll / Control Draw Editors
Right-click a desired location in the Lyric Area and choose New Lyric to create a new Lyric text box. Enter
desired Lyric text data in the edit box.

From the Event List Editor
Right click a desired location in the List Area and choose New Lyric to create a new Lyric Event. Double
click the new Lyric Event to open the Edit a Text Event dialog box and then enter desired Lyric text data in
the edit box.

More Details



Playing back Lines and Chords   

 

CAMPS offers a number of different methods for Playing back MIDI data. Depending on the Editors as well
as the method you've chosen, CAMPS works in slightly different ways during Playback in order to provide
the most useful settings for the various situations.

CAMPS provides FIVE basic methods for Playing back MIDI data :

Playback from the right-click drop-down menu●   

Playback from the MIDI menu●   

Play from the MIDI menu●   

Playback Control Toolbar●   

The Playback Edit Button●   

Methods in the Document Window In the Other available Editors

Playback Control ( Toolbar ) Activated Tracks 2 Activated Tracks + Line data 1, 2

Play ( MIDI menu ) Activated Tracks 2 Activated Tracks + Line data 1, 2

Playback ( Right-click ) Chords Chord Tracks 4, 5 Chord Track 1 + Line data 1

Lines Line Block 4, 5 + Chord 3 Chord Track 3 + Line data 1

Playback ( MIDI menu ) Activated Tracks 2 Chord Track 3 + Line data 1

Playback ( Edit Button ) X Chord Track 3 + Line data 1

Playback with Others
( Right-click )

Chords Chord 4 + Activated Tracks
6

Chord Track 1 + Line data 1 +
Activated Tracks

Lines Line Block 4 + Activated
Tracks 6 + Chord 3

Chord Track 3 + Line data 1 +
Activated Tracks

Playback with Others ( MIDI menu ) X Chord Track 3 + Line data 1 +
Activated Tracks

Playback with Others ( Edit Button ) X Chord Track 3 + Line data 1 +
Activated Tracks

Methods in the Chord related dialog
boxes

in the Line related dialog boxes

Playback ( Dialog boxes ) Chord Track 1 Chord Track 3 + Line data 1

Playback with Others ( Dialog boxes ) Chord Track 1 + Activated
Tracks

Line data 1 + Activated Tracks



Notes
1 even when Track is inactivated
2 plays back an existing Loop
3 only when Chord Track is activated
4 activates Track if it is inactivated
5 inactivates all the other Line Tracks
6 activates all the Line Tracks if no Track is activated

More about the Dialog box related Playback



Recording Lines   

 

CAMPS offers a number of different methods for Recording MIDI data. Depending on the Editors as well as
the method you've chosen, CAMPS works in slightly different ways during Recording in order to provide the
most useful settings for the various situations.

You can Record in real time, Over-Dub or Step modes in the Document Window, as well as the Event List,
Pianoroll, Control Draw and Notation Editors.

You can only Record one Track at a time. In the Document Window, the desired Track must be Armed for
Recording. In the Event List, Pianoroll, Control Draw and Notation Editors, your Track (Line Block) selection
has already been made, so Recording is immediately available.

CAMPS provides TWO paths to access Recording Control over MIDI data :

Record from the MIDI menu●   

Record Control Toolbar●   

CAMPS provides THREE methods for Recording Control over MIDI data :

Record Starts Real-Time Recording●   

OverDub Record Starts Over-Dubbing Recording●   

Step Record Starts Step-Write Recording●   

Notes
All activated Tracks will be played back simultaneously during Recording.

More Details



Creating New Line Blocks   

 

CAMPS organizes a song's MIDI Line data into Tracks, as any MIDI Sequencer. Tracks are basically
universal with regards to other MIDI Sequencers, but are assignable to different Orchestration Categories, a
proprietary designation used for Auto Harmonizing and other unique features in CAMPS.

Each Track's MIDI Line data are organized into Line Blocks for musical analysis and manipulation control.
These Blocks are mostly separated by Line Phrases, that is, a Line of continuous Notes.

To Create New Line Blocks
Since Line Blocks reside in Tracks, you'll first need to have Tracks in the Track Area of your Document
before you can individually manipulate Line Blocks.

CAMPS offers a number of different methods for creating new Line Blocks including the Pen tool. Select the
Pen tool at the top of the Document Window and then click and drag horizontally in the desired region of
the Line Area to assign the starting and ending locations of the Line Block you are about to create. (
Settings for Line Block such as Location, Color and Duration are adjustable at any later time.)

More Details

 



Auto Composition from Scratch   

 

CAMPS offers a number of different methods for Auto Composition including the Magic Wand tool. Select
the Magic Wand tool at the top of the Document Window and then click and drag horizontally in the desired
region of the Line Area to assign the starting and ending locations of the Line Block you are about to create.
( Settings for Line Block such as Location, Color and Duration are adjustable at any later time.)

If any Chords exist in the same Bar region as the New Line Block being created with the Magic Wand tool,
CAMPS will Auto Compose Line data using existing Chord Harmony instead of arbitrarily creating Line
data.

Depending on the Track Category for the Line Block you select, an appropriate type of Line data for the
Track Category will be created.

If any Line data exist in the Line Block being clicked with the Magic Wand tool, now CAMPS instantly
analyzes the Line data and recreates them with a click of your mouse. Doing this repeatedly can yield
hundreds of variations.

Using the Magic Wand tool in the Pianoroll and Notation Editors
allows you to reCompose a region of Notes. Click the Magic Wand
tool button at the top of the Editor. Then, click and hold your mouse
button down at an empty location in the Pianoroll Area (or Notation
Area) and drag your mouse over desired Note Events.

 The flexibility of the musical tools presented in CAMPS would not be possible if their functions were
made mostly automatic. The Magic Wand tool in CAMPS is designed to give a quick starting point and help
in familiarization with CAMPS objects used for building compositions. They are not designed to
automatically create some great music for you. Consequentially, the more parameters you define, the better
your musical results will be.

More Details

More Controls



Auto Composition based on Analysis of your Melody   

 

Import your Standard MIDI File into CAMPS, manually or automatically assign Chord Definitions, and you're
ready to go ! Once Chord Definitions are assigned, you can Auto Compose hundreds of new Lines based
on Chord Definitions and auto analysis of existing Lines. CAMPS can yield very surprising results.

CAMPS offers a number of different methods for Auto Composition including the Magic Wand tool. Select
the Magic Wand tool at the top of the Document Window and then click the desired Line Block to Auto
Compose its new Line data based on its existing Line data. Doing this repeatedly can yield hundreds of
variations.

Depending on the Track Category for the Line Block you select, an appropriate type of Line data for the
Track Category will be reComposed.

Using the Magic Wand tool in the Piano roll and Notation Editors
allows you to reCompose a region of Notes. Click the Magic Wand
tool button at the top of the Editor. Then, click and hold your mouse
button down at an empty location in the Pianoroll Area (or Notation
Area) and drag your mouse over desired Note Events.

 The flexibility of the musical tools presented in CAMPS would not be possible if their functions were
made mostly automatic. The Magic Wand tool in CAMPS is designed to give a quick starting point and help
in familiarization with CAMPS objects used for building compositions. They are not designed to
automatically create some great music for you. Consequentially, the more parameters you define, the better
your musical results will be.

More Details

More Controls



Customizing Auto Composition   

 

Import your Standard MIDI File into CAMPS, manually or automatically assign Chord Definitions, and you're
ready to go ! Once Chord Definitions are assigned, you can Auto Compose hundreds of new Lines based
on Chord Definitions and auto analysis of existing Lines. CAMPS can yield very surprising results.

CAMPS offers a number of different methods for Auto Composition including the Compose dialog box. The
Compose dialog box allows you to adjust guidelines for Auto Composing new Melodic, Chordal or Rhythmic
Line data, and allows you to Auto Compose these Lines with the click of a button. Doing this repeatedly can
yield hundreds of variations.

Depending on the Track Category for the Line Block you select, an appropriate type of Line data for the
Track Category will be reComposed.

From the Document Window
Select desired Line Blocks and then choose Compose from the Line menu to open the Compose dialog
box. You can adjust guidelines for Auto Composing, and to Auto Compose the entire Line data in the
selected Line Blocks.

From the Pianoroll/Notation Editors
Select desired Notes and then choose Compose from the Line menu to open the Compose dialog box.
You can adjust guidelines for Auto Composing, and to Auto Compose the selected Notes.

More Details



Auto Composition based on a mouse-drawn contour   

 

Import your Standard MIDI File into CAMPS, manually or automatically assign Chord Definitions, and you're
ready to go ! Once Chord Definitions are assigned, you can Auto Compose hundreds of new Lines based
on Chord Definitions and auto analysis of existing Lines. CAMPS can yield very surprising results.

CAMPS offers a number of different methods for Auto Composition including the MelodyDraw pane in the
Compose dialog box. The MelodyDraw pane allows you a unique freestyle drawing for directing the Pitch
occurrences in Line data being Auto Composed. MelodyDraw will guide the vertical motion of Melodic and
Chordal Line data Auto Composition. Doing this repeatedly can yield hundreds of variations.

Depending on the Track Category for the Line Block you select, an appropriate type of Line data for the
Track Category will be reComposed.

From the Document Window
Select desired Line Blocks, choose Compose from the Line menu to open the Compose dialog box and
then choose MelodyDraw pane. You can adjust drawing for Auto Composing, and to Auto Compose the
entire Line data in the selected Line Blocks.

From the Pianoroll/Notation Editors
Select desired Notes, choose Compose from the Line menu to open the Compose dialog box and then
choose MelodyDraw pane. You can adjust drawing for Auto Composing, and to Auto Compose the selected
Notes.

More Details



Understanding Takes   

 

CAMPS allows you to store different Takes within each Line Block.Takes are different versions of a given
Line Block. Except for MIDI Events in the Line data, Length and other attributes are the same as the
original. This allows you to store and choose between alternate performances of a particular Line Block.

While a given location in the Line Area can contain multiple Line Blocks, Takes are stored in the
"background" of each individual Line Block. If you delete a Line Block, all of its Takes will also be deleted.

From the Document Window
Select a desired Line Block and then choose Take List... from the Take submenu of the Line menu to open
the Take List dialog box. You can create an empty or EZcomposed Take, and select, remove, rename,
duplicate an existing Take. Selecting an existing Take switches Line data for the Line Block.

From the Event List / Pianoroll / Control Draw / Notation Editors
Choose Take List... from the Take submenu of the Line menu to open the Take List dialog box You can
create an empty or EZcomposed Take, and select, remove, rename, duplicate an existing Take. Selecting
an existing Take switches an active Line data for the Line Block.

More Details



Auto Voicing   

 

Most often melody lines consist of a series of individual Notes, but sometimes Harmonies are added in
certain places to provide musical variation or impact. The different arrangement of harmony Notes under
the melody is known as Voicing.

CAMPS automatically analyzes the selected Note data along with relevant Chords to provide you with
various kinds of Voicing for your Line data.

From the Pianoroll / Notation Editors
Select Notes being Voiced and then choose Voicing... from the Line menu to open the Voicing dialog box.
You can select Voicing Modes, Harmonic Tensions, and quantity of Voices to be used for each selected
Note's Voicing results. It is also possible to temporarily assign a different Chord by clicking the Note's
Chord button and selecting "Reharmonize..." from the drop-down menu.

More Details



Auto Scale Spelling   

 

Unlike other MIDI sequencers, CAMPS automatically displays Scale Degree for each Melodic Note to
relevant Chords as well as Avoid Notes, Chord Tones and Scale Notes corresponding to each Chord.
These features may help users instantly recognize Melody - Harmony relationship by Note and by Chord.

Scale Degree for each Note
Once Chord definitions are assigned, CAMPS displays Chord Tones and Tension Notes ( Root, b3, 9, etc.)
as you move cursor over Notes in the Pianoroll and Notation Editors.

Scale Spelling for each Chord
Once Chord definitions are assigned, CAMPS displays Scale Spelling, listing intervals from the Root (R,
3,5,7, etc.). Choose Scale Spelling from the Chord View submenu of the View menu to set Chord display
to Scale Spelling in the Document Window and the Pianoroll Editor.

Avoid Notes, Chord Tones and Scale Notes
Once Chord definitions are assigned, CAMPS displays Scale Notes, Chord Tones and Avoid Notes for
each Chord in the Pianoroll Editor. Choose Scale Notes, Chord Tones or Avoid Notes from the Note
View submenu of the View menu to display a light gray background color to differentiate between Scale
Notes, Chord Tones or Avoid Notes in the Pianoroll Area.



Creating New Chords   

 

CAMPS organizes a song's MIDI Line data into Tracks, as any MIDI Sequencer. However, the first Track
(unnumbered) is dedicated to Chords, a proprietary Track used to build a Tonality reference for use by Auto
Composing and other unique features in CAMPS.

The Chord Track contains Chord Blocks, each Block being a set of Chord Containers. A Chord Block can
vary in size, depending on the quantity and size of the Chord Containers residing within it.

Rather than having one long Block of Chord Containers for a whole Composition, Chord Containers are
typically grouped into smaller Blocks, each having its own Tonal tendencies corresponding to a section of
your Composition. This allows CAMPS to assist in Chord Progression development within each Chord
Block, which in turn will help you Harmonize individual sections of your Composition more accurately.

To Create New Chords
Since Chord Containers reside in Chord Blocks, you'll first need to have Chord Blocks in the Chord Area of
your Document before you can individually manipulate Chords.

CAMPS offers a number of different methods for creating new Chord Blocks including the Pen tool. Select
the Pen tool at the top of the Document Window and then click and drag from horizontally in the Chord Area
to assign the starting and ending locations of the Chord Block you are about to create. Settings for Chords
in the new Chord Block such as Key, Mode and Duration are adjustable at any later time.

More Details

 



Auto Roman Numeral Analysis   

 

CAMPS allows you to set display of Chord Containers to Roman Numeral Analysis (II-7, V7, etc.).

In Editors
Choose Roman Numeral from the View menu to set display of Chord Containers to Roman Numeral
Analysis.

In Dialog boxes
Select Roman Numeral radio button in Dialog boxes.

 



Auto Scale Name Analysis   

 

CAMPS allows you to set display of Chord Containers to Scale Name, also known as Mode (Dorian,
Mixolydian, etc.)

In Editors
Choose Scale Name from the View menu to set display of Chord Containers to Scale Name Analysis.

 



Tensions and Inversions   

 

Right click desired Chord and then choose a Chord from the Tensions submenu. You can replace the
desired Chord with/without a Tension Chord ( C-7, C-7(9)(11), etc.) or a simpler Triad ( C-, Eb, etc.).

Right click desired Chord and then choose a Chord from the Inversions submenu. You can replace the
desired Chord with a Inverted Chord ( C-7/Eb, C-/G, etc.) or a non-Inverted Chord ( C-7, C-, etc.).

 



Auto Chord Progression Generation   

 

CAMPS organizes a song's MIDI Line data into Tracks, as any MIDI Sequencer. However, the first Track
(unnumbered) is dedicated to Chords, a proprietary Track used to build a Tonality reference for use by Auto
Composing and other unique features in CAMPS.

The Chord Track contains Chord Blocks, each Block being a set of Chord Containers. A Chord Block can
vary in size, depending on the quantity and size of the Chord Containers residing within it.

Rather than having one long Block of Chord Containers for a whole Composition, Chord Containers are
typically grouped into smaller Blocks, each having its own Tonal tendencies corresponding to a section of
your Composition. This allows CAMPS to assist in Chord Progression development within each Chord
Block, which in turn will help you Harmonize individual sections of your Composition more accurately.

To generate New Chord Progressions
Since Chord Containers reside in Chord Blocks, you'll first need to have Chord Blocks in the Chord Area of
your Document before you can individually manipulate Chords.

CAMPS offers a number of different methods for creating new Chord Blocks with Chords including the
Magic Wand tool. Select the Magic Wand tool at the top of the Document Window and then click and drag
from horizontally in the Chord Area to assign the starting and ending locations of the Chord Block you are
about to create. ( Settings for Chords in the new Chord Block such as Key, Mode and Duration are
adjustable at any later time.)

If any Chords exist in the Chord Block being clicked with the Magic Wand tool, now CAMPS instantly
analyzes the Chords and regenerates them with a click of your mouse. Doing this repeatedly can yield
hundreds of variations.

More Details

More Controls



Auto Harmonization   

 

CAMPS organizes a song's MIDI Line data into Tracks, as any MIDI Sequencer. However, the first Track
(unnumbered) is dedicated to Chords, a proprietary Track used to build a Tonality reference for use by Auto
Composing and other unique features in CAMPS.

The Chord Track contains Chord Blocks, each Block being a set of Chord Containers. A Chord Block can
vary in size, depending on the quantity and size of the Chord Containers residing within it.

Rather than having one long Block of Chord Containers for a whole Composition, Chord Containers are
typically grouped into smaller Blocks, each having its own Tonal tendencies corresponding to a section of
your Composition. This allows CAMPS to assist in Chord Progression development within each Chord
Block, which in turn will help you Harmonize individual sections of your Composition more accurately.

To Auto Harmonize the existing Lines
Since Chord Containers reside in Chord Blocks, you'll first need to have Chord Blocks in the Chord Area of
your Document before you can individually manipulate Chords.

CAMPS offers a number of different methods for Auto Harmonization including the Magic Wand tool. Select
the Magic Wand tool at the top of the Document Window and then click and drag from horizontally in the
Chord Area to assign the starting and ending locations of the Chord Block you are about to create. If any
Line Blocks in Categories other than Drums exist in the same Bar region as the Chord being created with
the Magic Wand tool, CAMPS will generate Chords that Harmonize with the existing Line data. ( Settings
for Chords in the new Chord Block such as Key, Mode and Duration are adjustable at any later time.)

Click on desired Chord Block's Selection Bar (or a Chord) for alternative Harmonization. Doing this
repeatedly can yield hundreds of variations.

More Details

More Controls



The "EZ" tools in CAMPS   

 

The "EZ" tools in CAMPS are designed to give a quick starting point and help in familiarization with CAMPS
objects used for building compositions. They are not designed to automatically create some great music for
you. Consequentially, the more parameters you define, the better your musical results will be. The flexibility
of the musical tools presented in CAMPS is possible in various dialog boxes.

"EZ" Tools

Menu items EZcompose
EZharmonize With
EZgenerate
EZharmonize
EZharmonize with Same Key
EZcompose Lines in Region
EZharmonize All

Dialog boxes EZgenerate Chords (The New Chord and New Chord Block)
EZgenerate Line data (The New Line Block and New Take)

Editors Magic Wand



Organizing a Composition   

 

Line Blocks
When Importing a Standard MIDI File, the original data is left unchanged, but CAMPS divides or
encapsulates a Track's Line data into Line Blocks according to data continuity. If no MIDI Events span a
given Bar line, the related Line Block ends and a new one starts at this point. Empty Bars are not initially
assigned any Line Blocks.

Any or all of a Track's Line Blocks can be merged into a longer one, but you may find it more productive to
work with smaller sections of MIDI Line data when using CAMPS Editors. Line Blocks can also be split at
any point.

Line Blocks of any length can be created in any location of each Track, with or without Line data, and
whether or not other Line Blocks already exist.

When Line Blocks are used to organize different Sections in your composition, such as a Verse or Bridge,
they serve to enable quick musical arranging changes because they are referenced by CAMPS during Auto
Harmonization and other functions. You can assign a unique name and color to each Line Block, making
them easier to distinguish at a glance. You can create, edit, resize, split, copy, duplicate, move or delete
Line Blocks as needed.

Chord Blocks
A Chord Block is an array containing a group of Chords Containers. It is indicated and manipulated by its
Chord Block Selection Bar, a thin horizontal bar across the top of a Chord Block.

Chord Blocks serve to enable quick musical arranging changes, as they are referenced by CAMPS during
Auto Composition and other functions. They also help organize the Tonality of different Sections in your
composition, such as a Verse or Bridge. When using CAMPS to Generate Chords, Tonality settings for the
current or potential Chord Block are referenced, allowing creation of Chords that flow smoothly from one to
the next within a Chord Block. You can create, copy, duplicate, move or delete Chord Blocks as needed.

More Details



SMPTE or manual Tap Tempo Synchronization   

 

MIDI Sequencers
Besides its own Internal MIDI clock, you can set CAMPS to Playback and Record in "slave" mode using an
external MIDI Clock source (another Sequence, etc.) with the Professional-Quality precision.

Your manual Tap Tempo Input
You can also set CAMPS to the "Tap Tempo" mode using "freewheel" Tempo pulses input by you on your
computer's keyboard or your MIDI Instrument.

Film and Video
When synchronizing sounds with motion picture events in film and video, CAMPS provides all the ratios of
SMPTE Time Code to be used.

More Details



Multiple Document editing environment   

 

CAMPS allows you to open multiple Documents and exchange data between them while maintaining an
enhanced level of MIDI functionality. Most editing tasks can be carried out while CAMPS is in Playback
mode. The more powerful your computer, the more you can exploit the power of CAMPS.

CAMPS's multi-document environment allows you to have a number of Document Window open
simultaneously. This means you can copy & paste between Document Windows and listen to part of one
Document while editing another part in a different Document.

More Details



Editors  Contents

  

Editors Eight Editors are employed in CAMPS for MIDI data monitoring and editing as follows:

 

Editor Types Document Window The Document Window is the primary Editor in CAMPS.

Event List Editor The Event List Editor allows you to directly edit a Line Block's MIDI Event
data values.

Pianoroll Editor The Pianoroll Editor allows you to visually edit a Line Block's MIDI Note
data.

Control Draw Editor The Control Draw Editor allows you to edit a Line Block's MIDI Control
data with a unique freestyle curve drawing method.

Notation Editor The Notation Editor allows you to edit a Line Block's MIDI Note data in
musical notation form.

Tempo List Editor The Tempo List Editor allows you to edit the master Tempo value.

Tempo Draw Editor The Tempo Draw Editor allows you to change the master Tempo with a
unique freestyle curve drawing method.

Text List Editor The Text List Editor allows you to create and edit Text Events appearing
in the Text Info Area of the Document Window and various other Editors.

 



Document Window  
Contents

Editors

  

Description The Document Window is the primary Editor in CAMPS.

To begin working with anything in CAMPS, you must first open a Document Window.

 

Items The Document Window contains various Controls and Editing Areas for manipulating objects.
You can choose to Show or Hide the Controls with the Edit Buttons command in the View
menu. You can adjust the size of each Editing Area by clicking and dragging the horizontal or
vertical separator bar between Areas.

Edit Buttons The Edit Buttons give you quick access to viewing and manipulation tools for
the Document Window, as well as the many Editors available in CAMPS.

Track Area The Track Area displays all a Document's MIDI Track Controls in separate
rows, one for each Track of MIDI Line data, allowing you to manage each Track
independently.

Bar Area The Bar Area displays a range of Bar lines. Besides managing a song's Time
Grid, this area also allows you to manipulate Playback Loop and Punch In\Out
Recording functions.

Text Info Area The Text Info Area allows you to create general Text Events such as Rehearsal
Letters and Markers.

Chord Area Document Chord Blocks reside in the Chord Area. Each Chord Block in this row
contains Chord Containers to which you assign your song's Chords.

Line Area Document Line Blocks for each Track reside the Line Area. Line Blocks are
sectional containers for your MIDI Line data.

 



Bar Area of the Document Window  
Contents

Document Window

  

Description The Bar Area displays Measures or divisions of musical Time, known as Bars, in a continuous
row. This includes Bar Numbers, the Bar Grid and Beat Grid.

 

Uses Besides displaying Bar related information, the Bar Area allows you to manage a song's Time
Signature setup, location of the Playback Pointer, and the Playback Loop and Punch In/Out
Recording settings.

 

Items Playback Pointer
Loop region
Punch In/Out region
Bar Number
Bar Grid
Beat Grid
Location Cursor

 



Items in the Bar Area  
Description of this Area

Using this Area

  

Positioning the
Playback Pointer

Playback Pointer The Playback Pointer resides in its own dark gray area at the top of the
bar area, displaying the current Playback location in the Document
Window. It also allows you to change the current Playback point.

Inserting a
Playback Loop

Loop
region

Displays your current Loop region. Starting Playback repeats (Loops)
Playback in this region until you stop. This region is indicated by the
color blue in the upper portion of the Bar Area in the Document
Window.

Inserting a
Punch In/Out
Record region

Punch In/Out
region

Displays your current Punch In/Out region. This region is indicated by
the color magenta or dark gray in the lower portion of the Bar Area,
depending on whether or not a Track is Armed for Recording.

Viewing
Bar related
items

Bar Number A series of numbers given to Bars, starting on the left side with 1.

Bar Grid Vertical lines horizontally spaced across the Bar Area indicating Bar
divisions.

Beat Grid Vertical lines horizontally spaced across Bars indicating Beat divisions.

Location Cursor A vertical Location Cursor line in the Bar Area represents the horizontal
position of your mouse as it relates to the time location in your
Document. Corresponding numerical information is also displayed in
the order of "Bar, Beat and Division" in the Interactive Information area
at the bottom of the Document Window. The color of the Location
Cursor depends on your settings in the Microsoft Windows Control
Panel "Display" applet, under the heading "Selected Items" in the
"Items" list of the "Appearance" pane.

 

  



Using the Bar Area  
Description of this Area

Items in this Area

  

Positioning the
Playback Pointer

Playback Pointer
and area

You can use the Playback Pointer to change the Playback point in the
Document Window in two ways: Clicking a desired location in the dark
gray Playback Pointer area at the top, or clicking and dragging the
Playback Pointer to a desired location. Choose Play from the MIDI
menu (or click the Play button in the Playback Control toolbar) to begin
Playback. The Playback Pointer displays the current Playback location
as CAMPS plays or records MIDI data.

Inserting a
Playback Loop

Loop
region

You can create a Loop region by clicking and dragging with your mouse
in the upper portion of the Bar Area, below the Playback Pointer Area.
As you drag your mouse, the Loop region appears blue in color,
displaying a new Loop region. A Punch In/Out region of the same size
is automatically inserted below the new Loop region.

Choose Play from the MIDI menu (or click the Play button in the
Playback Control toolbar) to begin Playback. CAMPS repeats Loop
region Playback until you stop it. Click anywhere in the upper portion of
the Bar Area to delete a Loop region.

 The start and end points of the Loop region snap to the Grid
resolution set in the Grid Setup dialog box, if Align to Grid is selected
in the Grid View submenu of the View menu.

Inserting a
Punch In/Out
Record region

Punch In/Out
region

You can create a Punch In/Out region by clicking and dragging your
mouse in the lower portion of the Bar Area (below the Loop region). As
you drag your mouse without any Track Armed for Recording, this
region appears dark gray in color, displaying a new Punch In/Out
region. A Loop of the same size is automatically inserted above the
new Punch In/Out region. Click anywhere in the lower portion of the Bar
Area to delete a Punch In/Out region.

If a Track is Armed using its Record button in the Track Area of the
Document Window, the Punch In/Out region becomes magenta in
color, indicating it is ready for recording. Choose Record from the MIDI
menu (or click the Record button in the Record Control toolbar) to
begin recording.

If the automatically inserted Playback Loop is removed, CAMPS begins
Playback from the Playback Pointer's current position, but Recording is
only active as the Playback Pointer travels through the Punch In/Out
region. This provides a true Cued Punch In/Out environment.

 By combining with a Loop region beginning before the Punch
In/Out region, CAMPS provides a continuous Cued Punch In/Out
recording environment. Remove the automatically inserted Loop and
insert a new one starting before the Punch In/Out region, or remove the
Punch In/Out region and insert a new one starting after the Loop
region.



 The start and end points of the Punch In/Out region are aligned to
the Grid resolution set in the Grid Setup dialog box, if Align to Grid is
selected in the Grid View submenu of the View menu.

Assigning a
Time Signature

Time Signature
settings

CAMPS allows you to assign different Time Signatures to individual
Bars. Right-click a Bar to which you are assigning a new Time
Signature and then choose Time Signature Setup... to open the Time
Signature Setup dialog box. Set a Time Signature in the dialog box and
click OK. (Choosing Time Signature Setup... from the Edit menu
opens the same dialog box.)

 

  



Edit Buttons Area of the Document Window  
Contents

Document Window

  

Description The Edit Buttons are located at the top of the Document Window. These Buttons give you quick
access to frequently used items like View Adjustments, Tools and Editors.

 

Uses The Edit Buttons in the Document Window include most of the View menu commands and all of
the Editors menu commands. Four of the seven Editor buttons on the right side only become
available when Line Blocks are selected. The Tool buttons work in slightly different ways
according to which Area of the Document Window you are working in. Choose Edit Buttons
from the View menu to show or hide the Edit Buttons.

 

Items Auto Scroll button
Jump To Location button
Zoom Out (V) button
Zoom In (V) button
Zoom Out (H) button
Zoom In (H) button
Align To Grid button
Grid Setup button
Arrow Tool button
Pen Tool button
Magic Wand Tool button
Eraser Tool button
Razor Tool button
Event List Editor button
Pianoroll Editor button
Control Draw Editor button
Notation Editor button
Tempo List Editor button
Tempo Draw Editor button
Text List Editor button

 



Items in the Edit Buttons Area  Description of this Area

  

Adjusting
View

Auto Scroll
button

Sets the viewable area in the Bar, Text Info, Chord and Line Areas to follow
the Playback Pointer during Playback and Recording.

Jump To Location
button

Opens the Jump To Location dialog box which allows you to move the
current viewpoint to a specified Bar in the Document Window.

Zoom Out (V)
button

Incrementally decreases the Vertical size of the Track and Line Areas,
increasing their viewable area.

Zoom In (V)
button

Incrementally increases the Vertical size of the Track and Line Areas,
decreasing their viewable area.

Zoom Out (H)
button

Incrementally decreases the Horizontal size of the Bar, Text Info, Chord and
Line Areas, increasing their viewable area.

Zoom In (H)
button

Incrementally increases the Horizontal size of the Bar, Text Info, Chord and
Line Areas, decreasing their viewable area.

Align To Grid
button

Switches between Activate or Deactivate Align To Grid in the Text Info,
Chord and Line Areas. Grid Alignment is specified in the Grid Setup dialog
box.

Grid Setup
button

Opens the Grid Setup dialog box, allowing you to adjust the Alignment Grid
Resolution for individual areas of the Document Window and applicable
Editors. Depending on which Area of the Document Window is active before
choosing this Menu Item, the corresponding pane in the Grid Setup dialog
box will be preselected.

Selecting
Tools

Arrow Tool
button

Selects the Arrow Tool, allowing you to select and manipulate objects in the
Document Window. Objects need to be selected before related functions
become available.

Pen Tool
button

Selects the Pen Tool, allowing you to quickly create objects or define values
with a unique freestyle drawing method. The function of this Tool changes
depending on the Area you are working in.

Magic Wand Tool
button

Selects the Magic Wand Tool, allowing you to quickly create Chord Blocks
or Line Blocks with automatically filled-in data (EZgenerate).

Eraser Tool
button

Selects the Eraser Tool, allowing you to quickly delete objects in a
Document.

Razor Tool
button

Selects the Razor Tool, allowing you to quickly split a Chord Block at any
Chord boundary, or split a Line Block at any point.

Opening
Editors

Event List Editor
button

Opens the Event List Editor, allowing you to edit individual Events of the
selected Line Block in vertical list format. If multiple Line Blocks are
selected, a separate Editor window will be be opened for each Line Block
with one click of this button.

Pianoroll Editor
button

Opens the Pianoroll Editor, allowing you to edit Notes of a selected Line
Block in Pianoroll graph format. If multiple Line Blocks are selected, a
separate Editor window will be be opened for each Line Block with one click
of this button.



Control Draw Editor
button

Opens the Control Draw Editor, allowing you to edit MIDI Control events of a
selected Line Block with a unique freestyle drawing method. If multiple Line
Blocks are selected, a separate Editor window will be be opened for each
Line Block with one click of this button.

Notation Editor
button

Opens the Notation Editor, allowing you to edit Notes of a selected Line
Block in Musical Notation form. If multiple Line Blocks are selected, a
separate Editor window will be be opened for each Line Block with one click
of this button.

Tempo List Editor
button

Opens the Tempo List Editor, allowing you to edit individual Tempo Events
of the current Document in vertical list format.

Tempo Draw Editor
button

Opens the Tempo Draw Editor, allowing you to edit Tempo Events of the
current Document with a unique freestyle curve drawing method.

Text List Editor
button

Opens the Text List Editor, allowing you to edit Text Events of the current
Document in vertical list format.

 



Chord Area of the Document Window  
Contents

Document Window

  

Description A Document's Chord Blocks reside in the Chord Area. Each Chord Block in this row contains
Chord Containers to which you assign your song's Chords. These make up the Chord Track,
which is used by the CAMPS Composition Logic Engine during the use of Auto Composition and
other unique features in CAMPS.

 

Uses The Chord Area is where you manage a song's Chords. Besides allowing you to create, resize,
duplicate, move and delete Chords and groups of Chords (Chord Blocks), you can display
Chords in various ways, such as Chord Name, Roman Numeral or Scale Name.

You can assign a Chord Name, Key, Mode and several Functions to each Chord. These settings
allow CAMPS to help you create a composition which modulates to desired Tonalities; following
Chords as they change. This resulting Chord Track can also be Played back in different voicing
styles, alone or with your song's main Tracks, allowing you to audibly compare these Chord
definitions with the Tonality of your Line data.

CAMPS provides a number of automated and manual methods of assigning Chord Names,
including Auto Harmonizing, Chord Generation and Chord Detection from your MIDI instrument.
All settings can then be saved with the Document.

 

Items Chord Block
Chord Container
Key and Mode button
Chord Function check list
Bar Grid
Beat Grid

 



Items in the Chord Area  
Description of this Area

Using this Area

  

Manipulating
Chord Blocks

Chord Block A Chord Block is an array containing a group of Chords Containers. It is
indicated and manipulated by its Chord Block Selection Bar, a thin
horizontal bar across the top of a Chord Block.

Chord Blocks serve to enable quick musical arranging changes, as they
are referenced by CAMPS during Auto Composition and other functions.
They also help organize the Tonality of different Sections in your
composition, such as a Verse or Bridge.

When using CAMPS to Generate Chords, Tonality settings for the
current or potential Chord Block are referenced, allowing creation of
Chords that flow smoothly from one to the next within a Chord Block.
You can create, copy, duplicate, move or delete Chord Blocks as
needed.

Manipulating
Chords

Chord Container You can assign a Chord Name in a Key and Mode of your choice to
each Chord Container using various methods provided in CAMPS. A
Chord Name must be assigned to each Chord Container to get
appropriate results from musical tools in CAMPS, such as Compose...
and Voicing.... You can create, edit, resize, copy, duplicate, move or
delete Chord Containers as needed.

Assigning a
Key and Mode

Key and Mode
button

The Key and Mode button displays its current settings and opens a
Chord's Key and Mode drop-down menu. This allows you to assign a
Key and Mode (G major, D Mixolydian, etc.) to each Chord. This Key
and Mode setting is referred to by CAMPS during Auto Chord Detection,
Chord Progression Generation and Chord Construction.

Selecting
Chord Functions

Chord Function
check list

The Chord Function check list (visible below each Chord's Key and
Mode button when the Chord Area is extended downward) displays its
current settings and allows you to assign Chord Functions such as
Diatonic and Secondary Dominant. These settings are referred to by
CAMPS during Auto Chord Detection, Chord Progression Generation
and Chord Construction.

Auditioning
Chords

Chord
Track

The Chord Track controls in the Track Area allow you to assign various
settings for Chord Playback. See Track Area documentation for more
details.



Adjusting
Chord Display

Chord View
Menu Item

Choosing one of the five Chord Display Modes from the Chord View
submenu of the View menu changes the Chord's naming convention.
The current selection is indicated with a bullet. See Chord Menu
documentation for more details.

Depending on the amount of info being displayed and the Document
Window's current horizontal Display resolution, Chord, Key and Mode
names may appear abbreviated. To see all of a Chord's Name, Key or
Mode, use the Zoom In/Out (horizontal) buttons at the top of the
Document Window to adjust the horizontal Display resolution.

Adjusting the
Grid display

Bar Grid Vertical lines horizontally spaced across the Chord Area indicating the
dividing points between Bars.

Beat Grid Vertical lines horizontally spaced across Bars indicating the dividing
points between Beats.

 



Using the Chord Area  
Description of this Area

Items in this Area

  

Manipulating
Chord Blocks

Chord Block Note:

Many Chord Block related operations require selection of only the Chord Block
itself without highlighting any of its Chord Containers. To do this, click the Chord
Block Selection Bar across the top of a Chord Block.

After using any of the special Tool buttons at the top of the Document Window,
be sure to switch back to the standard Arrow Tool for regular manipulation
operations.

CREATING A NEW BLANK CHORD BLOCK

Method 1:

Select the Pen tool at the top of the Document Window and then click and drag
from horizontally in the Chord Area to assign the starting and ending locations
of the Chord Block you are about to create. Settings for Chords in the new
Chord Block such as Key, Mode and Duration are adjustable at any later time.

Method 2:

Right-click an empty location in the Chord Area and choose New Chord
Block... to open the New Chord Block dialog box. Alternatively, select an empty
location in the Chord Area and choose New Chord Block... from the Edit
menu.

The New Chord Block dialog box allows you to set Quantity, Duration, Key and
Mode of Chords in the new Chord Block. To create a new empty Chord Block
without automatically assigned Chords, be sure the EZgenerate option is not
checkmarked. These settings will be automatically saved and used as defaults
for your next New Chord Block dialog box session. However, they can be
changed at any time.

 When choosing New Chord Block... from the Edit menu, you must have
clicked an empty location in the Chord Area, otherwise the New Chord Block...
item won't be available.



CREATING A NEW CHORD BLOCK WITH CHORDS

Method 1:

Select the Magic Wand tool at the top of the Document Window and then click
and drag horizontally in the Chord Area to assign the starting and ending
locations of the Chord Block you are about to create. If executed where a Chord
Block already exists, this method will create a new Chord Block on top of the
original. Settings for Chords in the new Chord Block such as Chord Name, Key,
Mode and Duration are adjustable at any later time.

Method 2:

Right-click an empty location in the Chord Area and choose New Chord
Block... to open the New Chord Block dialog box. Alternatively, select an empty
location in the Chord Area and choose New Chord Block... from the Edit
menu.

The New Chord Block dialog box allows you to set Quantity, Duration, Key and
Mode of Chords in a new Chord Block. Be sure to checkmark the EZgenerate
Chords option in the dialog box if you want CAMPS to automatically generate a
Chord Progression in the New Chord Block. These settings will be automatically
saved and used as defaults for your next New Chord Block dialog box session.
However, they can be changed at any time.

 If any Line Blocks in Categories other than Drums exist in the same Bar
region as the New Chord Block being created with the Magic Wand tool or the
EZgenerate Chords option, CAMPS will generate Chords that Harmonize with
the existing Line data instead of arbitrarily creating a Chord Progression.

 When choosing New Chord Block... from the Edit menu, you must have
clicked an empty location in the Chord Area, otherwise the New Chord Block...
item won't be available.



EDITING CHORD BLOCKS

Select the Magic Wand tool at the top of the Document Window.and then click
on desired Chord Block's Selection Bar.

See also Manipulating Chords in the Chord Area of the Document Window.

SELECTING CHORD BLOCKS

Using the Arrow tool, you can select individual Chord Blocks. You can select
multiple Chord Blocks by holding the Ctrl (or Shift) key down as you select.
Alternatively, Clicking and holding your mouse button at an empty location in
the Chord Area and dragging your mouse over desired Chord Blocks allows you
to select multiple Chord Blocks in one quick operation

Selecting Chord Blocks enables use of Chord related commands under the
Chord Menu bar item including Harmonize... and Detect from MIDI
Instrument..... Once selected, you can then move, duplicate, make an Alias of,
copy, paste or delete a group of Chord Blocks at one time using the right click,
menu bar or click and drag method.

 Selecting multiple Chord Blocks will not be possible if the Magic Wand or
Eraser tool button at the top of the Document Window is currently active. In
these cases, Chord Blocks will be created, EZgenerated or deleted one at a
time (depending on which of these buttons is active).



PLAYING BACK CHORD BLOCKS

Select desired Chord Blocks, right-click the Chord Blocks and then choose
Playback Chord Block from the drop-down menu to start Playback of the
selected Chord Blocks. A Loop region for the selected Chord Blocks will be
automatically created and CAMPS repeats (Loops) Playback in this region until
you stop. The Loop to be created may include empty sub-regions depending on
your Chord Block selections. Choose Playback with Lines from the drop-down
menu to audition the selected Chord Blocks with Line Blocks on all the activated
Line Tracks.

To stop Playback, choose Stop from the MIDI menu. Alternatively, click the
Stop button of the Playback Toolbar.

 Choosing Playback Chord Block will automatically activate the Play
button for the Chord Track while deactivating the Play button for all the existing
Line Tracks. If no Line Track is activated, choosing Playback with Lines will
automatically activate the play button for all the existing Line Tracks as well as
the Play button for the Chord Track.

MOVING CHORD BLOCKS

Method 1:

Click and drag desired Chord Block Selection Bar to a new location in the Chord
Area.

Method 2:

Select desired Chord Block with your mouse and use your computer keyboard's
left/right arrow keys to move Chord Blocks a Division at a time.

Method 3:

This method allows you to move Chord Blocks between Documents.

Right-click a Chord Block's Selection Bar and choose Cut Chord Block to
remove the Chord Block from its current location. Alternatively, click desired
Chord Block Selection Bar and choose Cut Chord Block from the Edit menu.
Using the Ctrl (or Shift) key while selecting allows you to Cut multiple Chord
Blocks in one operation.

Next, right-click a desired location in the Chord Area of the desired Document's
Document Window or Pianoroll Editor and choose Paste Chord Block to Paste
the Cut Chord Block(s). Alternatively, select a desired location in the Chord
Area and choose Paste Chord Block from the Edit menu.

 When Align To Grid is activated, the Chord Block being moved will be
Pasted to the nearest Horizontal Grid Resolution point of the selected Chord
Area location as defined in the Grid Setup dialog box.



 When one Chord Block overlaps another Chord Block, CAMPS always
refers to Chords appearing in front, ignoring the Chords in back. If only part of a
Chord Block overlaps, then only the Chords in the overlapping area will be
effected this way. Right-click a Chord Block's Selection Bar and use the Bring
to Front or Send to Back commands to activate the desired overlapping Chord
Block.

DUPLICATING CHORD BLOCKS

Right-click a Chord Block's Selection Bar and choose Duplicate Chord Block
to Duplicate the selected Chord Block. Alternatively, click desired Chord Block
Selection Bar and choose Duplicate Chord Block from the Edit menu. Using
the Ctrl (or Shift) key while selecting allows you to Duplicate multiple Chord
Blocks in one operation.

Unlike the Copy/Paste operation which allows you to choose the location of the
"copy" before it is created, Duplicating a Chord Block automatically places the
"duplicate" on top of the original, offset slightly to the right. You can then move it
at any time.

COPYING / PASTING CHORD BLOCKS

Right-click a Chord Block's Selection Bar and choose Copy Chord Block to
copy the selected Chord Block. Alternatively, click desired Chord Block
Selection Bar and choose Copy Chord Block from the Edit menu. Using the
Ctrl (or Shift) key while selecting allows you to copy multiple Chord Blocks in
one operation.

Next, right-click a desired location in the Chord Area of the desired Document's
Document Window or Pianoroll Editor and choose Paste Chord Block to Paste
the Copied Chord Block(s). Alternatively, select a desired location in the Chord
Area and choose Paste Chord Block from the Edit menu.

 When Align To Grid is activated, the Chord Block being Copied will be
Pasted to the nearest Horizontal Grid Resolution point of the selected Chord
Area location as defined in the Grid Setup dialog box.



CREATING AN ALIAS OF CHORD BLOCKS

Right-click Chord Block Selection Bar and choose Make Alias of Chord Block
to make an Alias of the selected Chord Block. Alternatively, select desired
Chord Block Selection Bar and choose Make Alias of Chord Block from the
Edit menu. Using the Ctrl (or Shift) key while selecting allows you to Make
Aliases of multiple Chord Blocks in one operation.

 An Alias is, in effect, an active copy of its original. Except for Copy/Paste,
Duplicate, Move and Delete operations, changes you make to one of the
Aliases effects all of its Aliases. This holds true whether you make changes to
the original, or the Aliases. In fact, there is no effective difference between an
Alias and its original. A small circle appearing in the left corner of the Chord
Block Selection Bar at the top of a Chord Block indicates the Alias status.

DELETING CHORD BLOCKS

Method 1:

Select the Eraser tool at the top of the Document Window and simply click on a
Chord Block's Selection Bar to delete it. The Eraser tool can be used to delete
multiple Chord Blocks in one quick operation by clicking and holding your
mouse button at an empty location in the Chord Area and dragging the Eraser
over desired Chord Blocks.

Method 2:

Right-click a Chord Block Selection Bar and choose Clear Chord Block to
delete the selected Chord Block. Alternatively, click desired Chord Block
Selection Bar and choose Clear Chord Block from the Edit menu. Using the
Ctrl (or Shift) key while selecting allows you to Clear multiple Chord Blocks in
one operation.

 



See also:

Manipulating Chords
Assigning a Key and Mode
Assigning Chord Functions
Adjusting the Grid display

 



Using the Chord Area  
Description of this Area

Items in this Area

  

Manipulating
Chords

Chord Container Note:

Since Chord Containers reside in Chord Blocks, you'll first need to have
Chord Blocks in the Chord Area of your Document before you can
individually manipulate Chords.

Many of these operations will result in changes of Chord Block size. When
adding to a Chord Block, existing Chords get moved to the right. Keep in
mind that if another Chord Block already exists right after the Chord Block
which increases in size, Chords being moved to the right will slip behind the
next Chord Block, resulting in overlapping Chord Blocks. The visible Chords
in an overlapping area will become the active Chords in that area for all
Chord related CAMPS functions.

To choose which Chord Block is visible and active in an overlapping Chord
Area, right click the desired Chord Block Selection Bar and choose Bring to
Front or Send to Back.

CREATING NEW BLANK CHORD CONTAINERS

Right-click the Chord at a desired location and choose New Chord... to
open the New Chord dialog box. Alternatively, click the Chord at a desired
location and choose New Chord... from the Edit menu.

The New Chord dialog box allows you set Quantity, Duration, Key and Mode
of new Chords. To create a new empty Chord Container, be sure the
EZgenerate option is not checkmarked. These settings will be automatically
saved and used as defaults for your next New Chord dialog box session.
However, they can be changed at any time.

 When choosing New Chord... from the Edit menu, you must have
clicked a Chord, otherwise the New Chord... item won't be available.



CREATING NEW CHORD CONTAINERS WITH ASSIGNED CHORDS

Right-click a Chord and then choose New Chord... to open the New Chord
dialog box. Alternatively, select a Chord and choose New Chord... from the
Edit menu.

The New Chord dialog box allows you to set Quantity, Duration, Key and
Mode of new Chord Containers being created. Be sure to checkmark the
EZgenerate option in the dialog box to automatically generate a Chord.
These settings will be automatically saved and used as defaults for your
next New Chord dialog box session. However, they can be changed at any
later time.

 If any Line Blocks in Categories other than Drums exist in the same Bar
region as the New Chord being created with the EZgenerate Chords option
activated, CAMPS will generate Chords that Harmonize with the existing
Line data instead of arbitrarily creating a Chord Progression.

 When choosing New Chord... from the Edit menu, you must have
clicked a Chord, otherwise the New Chord... item won't be available.

ASSIGNING AND EDITING CHORDS

Method 1:

Select the Magic Wand tool at the top of the Document Window and simply
click a Chord you wish to assign a Chord Name to. This can be done with
empty or filled-in Chord Containers. In the latter case, existing Chords will
be replaced. Settings for the new Chord such as Chord Name, Key, Mode
and Duration are adjustable at any later time. To assign or reassign Chords
to all Chord Containers in a Chord Block, click only the Chord Block
Selection Bar with the Magic Wand tool.

 If any Line Blocks in Categories other than Drums exist in the same Bar
region as the Chord being created with the Magic Wand tool, CAMPS will
generate Chords that Harmonize with the existing Line data instead of
arbitrarily creating new Chords.



Other Methods:

Select desired Chords and choose a Chord assignment method from the
Chord menu. Alternatively, right click desired Chord and choose a Chord
assignment method from the Actions submenu.

These options include Generate..., EZgenerate, Harmonize...,
EZharmonize, EZharmonize with Same Key, Detect from MIDI
Instrument... and Construct.... See an option's menu or dialog box
documentation for more details.

SELECTING CHORD CONTAINERS

Using the Arrow tool, you can select individual Chords. You can select
multiple Chords by holding the Ctrl (or Shift) key down as you select.
Alternatively, Clicking and holding your mouse button on a Chord, and then
dragging your mouse over other Chords allows you to select multiple
Chords in one operation. Once selected, you can then move, duplicate,
make an Alias of, copy, paste or delete a group of Chords at one time using
the right click, menu or click and drag method. This operation can be used
with most of the commands in the Chord Menu as well.

 Selecting multiple Chords will not be possible if the Pen, Magic Wand
or Eraser tool is currently selected from the top of the Document Window. In
these cases, Chords will be created, generated or deleted (depending on
which of these buttons is active).



PLAYING BACK CHORD CONTAINERS

Select desired Chords, right-click the Chords and then choose Playback
Chord from the drop-down menu to start Playback of the selected Chords.
A Loop region for the selected Chords will be automatically created and
CAMPS repeats (Loops) Playback in this region until you stop. Choose
Playback with Lines from the drop-down menu to audition the selected
Chords with Line Blocks on all the activated Line Tracks.

To stop Playback, choose Stop from the MIDI menu. Alternatively, click the
Stop button of the Playback Toolbar.

 Choosing Playback Chord will automatically activate the Play button
for the Chord Track while deactivating the Play button for all the existing
Line Tracks. If no Line Track is activated, choosing Playback with Lines
will automatically activate the play button for all the existing Line Tracks as
well as the Play button for the Chord Track.

MOVING CHORD CONTAINERS

Method 1:

Select desired Chords and drag them to a new location in a Chord Block.

When moving Chords in this manner, a vertical indicator appears at the
boundary between Chords being moved and other existing Chords. Drag
the Chords being moved past this indicator to drop Chords in a new
location.

Method 2:

This method allows you to move Chord Containers between Documents.

Right-click a Chord Container and then choose Cut Chord to remove a
Chord Container from its current location. Alternatively, select a Chord
Container and choose Cut Chord from the Edit menu. Using the Ctrl (or
Shift) key while selecting allows you to Cut multiple Chord Containers in one
operation.

Next, right-click a desired location in a Chord Block of the desired Document
and choose Paste Chord to Paste the Cut Chord Container(s).
Alternatively, select a location in a Chord Block and choose Paste Chord
from the Edit menu.

When Pasting a Chord in an existing Chord Container's location, the
existing Chord will be moved to the right. When a Chord is being moved
from one Chord Block to another, the destination Chord Block will increase
in size, while the originating Chord Block will decrease in size.



RESIZING CHORD CONTAINERS

Using the Arrow Tool, position your mouse cursor over the right edge of a
desired Chord Container until the cursor changes to a double arrow. Then
click and drag the right edge of the Chord Container to the desired size.

Keep in mind that this effects the size of the Chord Block in which the Chord
Container is being resized, effecting its Playback time. Additionally,
enlarging a Chord may cause Chord Blocks to overlap.

 When Align To Grid is active in the Chord Area, the Chord size will
snap to the nearest Horizontal Resolution Grid point.

 When one Chord Block overlaps another Chord Block, CAMPS always
refers to Chords appearing in front, ignoring the Chords in back. If only part
of a Chord Block overlaps, then only the Chords in the overlapping area will
be effected this way. Right-click a Chord Block's Selection Bar and use the
Bring to Front or Send to Back commands to activate the desired
overlapping Chord Block.

DUPLICATING CHORD CONTAINERS

Right-click a Chord Container and choose Duplicate Chord to duplicate the
selected Chord Container. Alternatively, select a Chord and choose
Duplicate Chord from the Edit menu. Using the Ctrl (or Shift) key while
selecting allows you to Duplicate multiple Chord Containers in one
operation.

Unlike the Copy/Paste operation which allows you to choose the location of
the "copy" before it's actually created, Duplicating a Chord automatically
places the "duplicate" to the right of the original. You can then move it at
any time.



COPYING / PASTING CHORD CONTAINERS

Right-click a Chord and then choose Copy Chord to copy the selected
Chord. Alternatively, select a Chord and choose Copy Chord from the Edit
menu. Using the Ctrl (or Shift) key while selecting allows you to copy
multiple Chords in one operation.

Right-click a desired location in a Chord Block of the desired Document and
choose Paste Chord to Paste the Copied Chord Container(s). Alternatively,
select a location in a Chord Block and choose Paste Chord from the Edit
menu.

When Pasting a Chord in an existing Chord Container's location, the
existing Chord will be moved to the right, increasing the size of its Chord
Block.

DELETING CHORD CONTAINERS

Method 1:

Select the Eraser tool at the top of the Document Window and simply click
on a Chord to delete it.

Method 2:

Right-click a Chord and choose Clear Chord to delete the selected Chord.
Alternatively, select a desired Chord and choose Clear Chord from the Edit
menu. Using the Ctrl (or Shift) key while selecting allows you to Clear
multiple Chords in one operation.

 

See also:

Manipulating Chord Blocks
Assigning a Key and Mode
Assigning Chord Functions
Adjusting the Grid display

 



Using the Chord Area  
Description of this Area

Items in this Area

  

Assigning a
Key and Mode

Key and Mode
button

The Key and Mode button, located right below each Chord Name, displays
its current settings and opens the Key and Mode drop-down menu. This
allows you to adjust Chord Container Tonality settings originally made in the
New Chord or New Chord Block dialog boxes. You can independently
choose a Key and Mode such as G major, D Mixolydian, etc., for each
Chord.

This Key and Mode setting is referred to by CAMPS during Auto Chord
Detection, Chord Progression Generation and Chord Construction.

If Chord Key and Mode buttons are not visible, click on the dividing line
between the Chord and Line Areas and drag your mouse downward,
extending the bottom of the Chord Area.

 

See also:

Manipulating Chord Blocks
Manipulating Chords
Assigning Chord Functions
Adjusting the Grid display

 



Using the Chord Area  
Description of this Area

Items in this Area

  

Assigning
Chord Functions

Chord Function
check list

The Chord Function check list, located below each Chord's Key and
Mode button, displays its current settings with checkmarks and allows
you to turn individual Chord Functions on or off for each Chord. These
settings are referred to by CAMPS during Auto Chord Detection, Chord
Progression Generation and Chord Construction.

CAMPS comes with four "plug-in" Chord Functions for each Chord,
including Diatonic, Diminished, Sub V7 and Secondary Dominant. The
more Chord Functions you activate, the more types of Harmony CAMPS
deals with. For example, if you activate Sub V7 (appearing in a darker
shade of gray), you'll get more "Jazzy" Chords with the Auto Chord
Detection, Chord Progression Generation and Harmonize functions.

If the Chord Function check lists are not visible under existing Chords,
click on the dividing line between the Chord and Line Areas and drag it
downward, extending the bottom of the Chord Area.

 You must at least activate the Diatonic Chord Function for a Chord to
be effective in directing CAMPS Composition functions.

 

See also:

Manipulating Chord Blocks
Manipulating Chords
Assigning a Key and Mode
Adjusting the Grid display

 



Using the Chord Area  
Description of this Area

Items in this Area

  

Adjusting the
Grid display

Bar Grid The Bar Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Bars (Measures) for visual reference. Choose Bar Grid from the
Grid View submenu of the View menu to show or hide the Bar Grid in the Chord
Area, as well as the Text Info and Line Areas.

Beat Grid The Beat Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Beats in each Bar for visual reference. (This is not necessarily
the same as the Alignment Grid.) Choose Beat Grid from the Grid View submenu
of the View menu to show or hide the Beat Grid in the Chord Area, as well as the
Text Info and Line Areas.

See also:

Manipulating Chord Blocks
Manipulating Chords
Assigning a Key and Mode
Assigning Chord Functions

 



Line Area of the Document Window  
Contents

Document Window

  

Description The Line Area is home to a Document's Line Blocks, which contain each Track's MIDI Line data.
A Track can contain multiple Line Blocks, depending on its musical phrasing. Each Line Block
can have multiple Takes, allowing you to make alternate edits of each Line Block. While a large
degree of Playback control is available in the Track Area, including Category settings used by the
CAMPS Composition Logic Engine, a Track's permanent Playback Control data is stored and
edited in Line Blocks along with Notes and other MIDI Event data.

 

Uses The Line Area is where you manage a song's Line data. You can create, duplicate, move or
delete Line data within each Line Block, as well as create, duplicate, move, delete, merge or split
entire Line Blocks. Line Blocks serve to enable quick musical arranging changes.

A Line Block must be selected to enable Line menu commands, Line related Editors other than
the Document Window and some of the Edit Buttons at the top of the Document Window. Once a
Line Block is selected, CAMPS provides a number of automated and manual methods of
composing and editing Line data, including Auto Composing, Articulation adjustment, Voicing,
Dissonant Interval Detection and Recording from your MIDI instrument.

Line Blocks display their Note data contents with a miniaturized Pianoroll type of graphic. Each
Line Block also displays a unique name, which can be edited or hidden at anytime.

Arranged in an end-to-end fashion, each Track's Line Blocks normally Playback in a continuous
sequence as one Track. However, Line Blocks can be Played back in different ways, alone or
with other Tracks, allowing you to audibly compare a newly Composed "Take" with other existing
"Takes". All settings can then be saved with the Document.

 

Items Line Block
Take
Bar Grid
Beat Grid
Track Grid



 



Items in the Line Area  
Description of this Area

Using this Area

  

Manipulating
Line Blocks

Line Block A Line Block is a section of a Track's MIDI Line data.

When Importing a Standard MIDI File, the original data is left unchanged, but
CAMPS divides or encapsulates a Track's Line data into Line Blocks according
to data continuity. If no MIDI Events span a given Bar line, the related Line Block
ends and a new one starts at this point. Empty Bars are not initially assigned any
Line Blocks. Any or all of a Track's Line Blocks can be merged into a longer one,
but you may find it more productive to work with smaller sections of MIDI Line
data when using CAMPS Editors. Line Blocks can also be split at any point. Line
Blocks of any length can be created in any location of each Track, with or
without Line data, and whether or not other Line Blocks already exist.

When Line Blocks are used to organize different Sections in your composition,
such as a Verse or Bridge, they serve to enable quick musical arranging
changes because they are referenced by CAMPS during Auto Harmonization
and other functions. You can assign a unique name and color to each Line
Block, making them easier to distinguish at a glance. You can create, edit,
resize, split, copy, duplicate, move or delete Line Blocks as needed.

Understanding
Takes

Take Each Line Block can contain different Takes, allowing you to create and store
different musical versions of any Line Block.

Adjusting the
Grid display

Bar Grid Vertical lines horizontally spaced across the Line Area indicating the dividing
lines between Bars.

Beat Grid Vertical lines horizontally spaced across Bars indicating the dividing lines
between Beats.

Track Grid Horizontal lines vertically spaced across the Line Area indicating the dividing
lines between Tracks.



 

  



Using the Line Area  
Description of this Area

Items in this Area

  

Adjusting the
Grid display

Bar Grid The Bar Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Bars (Measures) for visual reference. Choose Bar Grid from
the Grid View submenu of the View menu to show or hide the Bar Grid in the Line
Area, as well as the Text Info and Chord Areas.

Beat Grid The Beat Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Beats in each Bar for visual reference. (This is not necessarily
the same as the Alignment Grid.) Choose Beat Grid from the Grid View submenu
of the View menu to show or hide the Beat Grid in the Line Area, as well as the
Text Info and Chord Areas.

Track Grid The Track Grid is a pattern of evenly spaced horizontal lines marking vertical
divisions between MIDI Tracks for visual reference. (This is not necessarily the
same as the Alignment Grid.) Choose Track Grid from the Grid View submenu of
the View menu to show or hide the Track Grid in the Line and Track Areas.

 

See also:

Manipulating Line Blocks
Understanding Takes

 



Using the Line Area  
Description of this Area

Items in this Area

  

Manipulating
Line Blocks

Line Block Note:

Most Line Block operations require selection of a Line Block.
After using any of the special Tool buttons at the top of the Document Window, be
sure to switch back to the standard Arrow Tool for regular manipulation
operations.

CREATING A NEW LINE BLOCK IN REAL TIME

With the Playback Pointer at the beginning of your Document, Arm desired Track
for recording, click the Record button in the Record Control Toolbar or choose the
desired Recording command from the Record submenu of the MIDI menu and
begin playing your MIDI Instrument.

If you wish to create a New Line Block "on the fly" from some point other than the
beginning of a document, you'll first need to insert a Punch In/Out region for the
desired location. In this case however, any existing Line Block matching the size
and location of your Punch In/Out region and Armed Track will be replaced.

CREATING A NEW BLANK LINE BLOCK

Method 1:

Select the Pen tool at the top of the Document Window and then click and drag
from left to right in the Line Area to assign the starting and ending locations of the
Line Block you are about to create. Settings for the Line Block such as Location,
Color and Duration are adjustable at any time.

Method 2:

Right-click an empty location in the Line Area and then choose New Line Block...
to open the New Line Block dialog box. Alternatively, select an empty location in
the Line Area and choose New Line Block... from the Edit menu to open the New
Line Block dialog box.

Depending on the Track Category for the Line Area you select and the menu path
you use to execute the New Line Block... command, a different version of the
New Line Block dialog box will appear.

The New Line Block dialog box allows you to set Bar Quantity and Take Name of
the new Line Block. To create a new empty Line Block without automatically
assigned Line data, be sure the EZgenerate option is not checkmarked. These
settings will be saved and used as defaults for your next New Line Block dialog
box session. However, they can be changed at any time.



 When choosing New Line Block... from the Edit menu, you must have
clicked an empty location in the Line Area, otherwise the New Line Block... item
won't be available.

CREATING A NEW LINE BLOCK WITH AUTO COMPOSED LINE DATA

Method 1:

Select the Magic Wand tool at the top of the Document Window and then click
and drag horizontally in the desired region of the Line Area to assign the starting
and ending locations of the Line Block you are about to create. Settings for Line
Block such as Location, Color and Duration are adjustable at any later time.

 If any Chords exist in the same Bar region as the New Line Block being
created with the Magic Wand tool, CAMPS will Auto Compose Line data using
existing Chord Harmony instead of arbitrarily creating Line data.

Method 2:

Right-click an empty location in the Line Area and choose New Line Block... to
open the New Line Block dialog box. Alternatively, select an empty location in the
Line Area and choose New Line Block... from the Edit menu to open the New
Line Block dialog box.

Depending on the Track Category for the Line Area you select and the menu path
you use to execute the New Line Block... command, a different version of the
New Line Block dialog box will appear.

The New Line Block dialog box allows you to set the Bar Quantity and Take Name
of the new Line Block. Be sure to check mark the EZgenerate Line data option in



the dialog box if you want CAMPS to automatically generate Line data in the new
Line Block. These settings will be automatically saved and used as defaults for
your next New Line Block dialog box session. However, they can be changed at
any time.

 When choosing New Line Block... from the Edit menu, you must have
clicked an empty location in the Line Area, otherwise the New Line Block... item
won't be available.

EDITING LINE BLOCKS

Method 1:

Select the Magic Wand tool at the top of the Document Window and then click the
desired Line Block to Auto Compose its new Line data based on its existing Line
data.

 If any Chords exist in the same Bar region as the New Line Block being
created with the Magic Wand tool, CAMPS will Auto Compose Line data using
existing Chord Harmony instead of arbitrarily creating Line data.

Method 2:

Select desired Line Block and click the desired Editor button in the Edit Buttons
Area of the Document Window. Alternatively, click desired Line Block and choose
desired Editor from the Editors menu.

Method 3:

Right click desired Line Block and choose desired dialog box command from the



Actions submenu. Alternatively, click desired Line Block and choose desired
dialog box command from the Line menu.

See also CREATING LINE BLOCKS above.

SELECTING LINE BLOCKS

Using the Arrow tool, you can select individual Line Blocks. You can select
multiple Line Blocks by holding the Ctrl (or Shift) key down as you select.
Alternatively, Clicking and holding your mouse button down at an empty location in
the Line Area and dragging your mouse over desired Line Blocks allows you to
select multiple Line Blocks in one quick operation. Once selected, you can then
move, duplicate, make an Alias of, copy, paste or delete a group of Line Blocks at
one time using the right click, menu bar or click and drag method.

Selecting Line Blocks enables use of Line related commands under the Line Menu
bar item including Compose... and Detect Dissonant Intervals....

 Selecting multiple Line Blocks will not be possible if the Pen, Magic Wand or
Eraser tool button at the top of the Document Window is currently active. In these
cases, Line Blocks will be created, EZgenerated or deleted (depending on which
of these buttons is active).



PLAYING BACK LINE BLOCKS

Select desired Line Blocks, right-click the Line Blocks and then choose Playback
from the drop-down menu to start Playback of the selected Line Blocks. A Loop
region for the selected Line Blocks will be automatically created and CAMPS
repeats (Loops) Playback in this region until you stop. The Loop to be created may
include empty sub-regions depending on your Line Block selections. Choose
Playback with Others from the drop-down menu to audition the selected Line
Blocks with Line Blocks on all the activated Tracks.

To stop Playback, choose Stop from the MIDI menu. Alternatively, click the Stop
button of the Playback Toolbar.

 Choosing Playback will automatically activate the Play button for the selected
Line Tracks while deactivating the Play button for the rest of existing Line Tracks.
If no Track is activated, choosing Playback with Others will automatically activate
the Play button for all the existing Line Tracks. Neither command effects the Play
button settings for the Chord Track.

MOVING LINE BLOCKS

Method 1:

Click and drag desired Line Blocks to a new location in the Line Area. Vertical
mouse motion while dragging will move the Line Block to a different Track.

Method 2:

Select a desired Line Block with your mouse and use your computer keyboard's
arrow keys to move it more precisely. The up/down arrow keys move a Line Block
from Track to Track, while the left/right arrow keys move a Line Block in time by
Divisions.

Method 3:

This method allows you to move Line Blocks between Documents.

Right-click a Line Block and choose Cut Line Block to remove a Line Block from
its current location. Alternatively, click desired Line Block and choose Cut Line
Block from the Edit menu. Using the Ctrl (or Shift) key while selecting allows you
to Cut multiple Line Blocks in one operation.

Next, right-click a desired location in the Line Area of the desired Document and
choose Paste Line Block to Paste the Cut Line Block(s). Alternatively, select a
desired location in the Line Area and choose Paste Line Block from the Edit
menu. If you are moving a Line Block to a different Document, a new Track will be
automatically created for it, regardless of destination Track selection.

 When Align To Grid is activated, the Line Block being moved will be Pasted
to the nearest Horizontal Grid Resolution point of the selected Line Area location
as defined in the Grid Setup dialog box.



 Even if Line Blocks overlap, CAMPS always refers to all Line Blocks for Auto
Harmonizing and Playback. Right-click a Line Block and use the Bring to Front or
Send to Back commands to move the desired overlapping Line Block in or out of
view.

RESIZING LINE BLOCKS

Using the Arrow Tool, position your mouse cursor over the left or right edge of a
desired Line Block until the cursor changes to a double arrow. Then click and drag
the edge of the Line Block to the desired size.

Keep in mind that resizing a Line Block effects its total Playback time, but doesn't
change the time value or position of its Line data. Enlarging a Line Block
effectively adds empty space to it. However, shrinking a Line Block may
abbreviate its Line data. Additionally, enlarging a Line Block may cause Line
Blocks to overlap.

 Even if Line Blocks overlap, CAMPS always refers to all Line Blocks for Auto
Harmonizing and Playback. Right-click a Line Block and use the Bring to Front or
Send to Back commands to move the desired overlapping Line Block in or out of
view.



SPLITTING LINE BLOCKS

Select the Razor tool at the top of the Document Window and simply click on a
Line Block at the desired point to split it. When the Interactive Information display
is enabled, you can watch it for an exact Bar, Beat and Division location while
dragging the Razor Tool across a Line Block. Once you reach the desired location,
click your mouse button to split the Line Block.

DUPLICATING LINE BLOCKS

Right-click a Line Block and choose Duplicate Line Block to duplicate a Line
Block. Alternatively, click desired Line Blocks and choose Duplicate Line Block
from the Edit menu. Using the Ctrl (or Shift) key while selecting allows you to
Duplicate multiple Line Blocks in one operation.

Unlike the Copy/Paste operation which allows you to choose the location of the
"copy" before it is created, Duplicating a Line Block automatically places the
"duplicate" on top of the original, offset slightly to the right. You can then move the
"duplicate" at any time.

COPYING / PASTING LINE BLOCKS

Right-click a Line Block and choose Copy Line Block to Copy a Line Block.
Alternatively, click desired Line Block and choose Copy Line Block from the Edit
menu. Using the Ctrl (or Shift) key while selecting allows you to copy multiple Line
Blocks in one operation.

Then, right-click a desired location in the Line Area of the desired Document and
choose Paste Line Block to Paste the Copied Line Block(s). Alternatively, select
a desired location in the Line Area and choose Paste Line Block from the Edit
menu. If you are moving a Line Block to a different Document, a new Track will be
automatically created for it, regardless of destination Track selection.

 When Align To Grid is activated, the Line Block being Copied will be Pasted
to the nearest Horizontal Grid Resolution point of the selected Line Area location
as defined in the Grid Setup dialog box.



CREATING AN ALIAS OF LINE BLOCKS

Right-click desired Line Block and choose Make Alias of Line Block to make an
Alias of a Line Block. Alternatively, select desired Line Blocks and choose Make
Alias of Line Block from the Edit menu to make Alias of the selected Line Blocks.
Using the Ctrl (or Shift) key while selecting allows you to to Make Aliases of
multiple Line Blocks in one operation.

 An Alias is, in effect, an active copy of its original. Except for Copy/Paste,
Duplicate, Move and Delete operations, changes you make to one of the Aliases
effects all of its Aliases. This holds true whether you make changes to the original,
or the "copies". In fact, there is no effective difference between an Alias and its
original. A small circle appearing at the left of the Line Block indicates the Alias
status.

DELETING LINE BLOCKS

Method 1:

Select the Eraser tool at the top of the Document Window and simply click on a
Line Block to delete it. With the Eraser tool, clicking and holding your mouse
button down at an empty location in the Line Area and dragging the Eraser over
desired Line Blocks allows you to delete multiple Line Blocks in one quick
operation.

Method 2:

Right-click a Line Block and choose Clear Line Block to delete a Line Block.
Alternatively, click desired Line Block and choose Clear Line Block from the Edit
menu. Using the Ctrl (or Shift) key while selecting allows you to Clear multiple Line
Blocks in one operation.

 

See also:

Understanding Takes
Adjusting the Grid display

 



Using the Line Area  
Description of this Area

Items in this Area

  

Understanding
Takes

Take CAMPS allows you to store different Takes within each Line Block. Takes are different
versions of a given Line Block. Except for Notes in the Line data, Length and other
attributes are the same as the original. This allows you to store and choose between
alternate performances of a particular Line Block.

For basic "Take" operations, open the Take List dialog box using one of the following
methods.

Method 1:

Right-click a Line Block and then choose Take List... from the Take submenu.
Alternatively, select a Line Block and then choose Take List.... from the Take
submenu of the Line menu.

Method 2:

Double-click a Line Block while holding the Ctrl key down.

 Using the above methods with multiple Line Blocks opens the same number of
Take List dialog boxes as the selected Line Blocks. As you close the Take List dialog
box for one Line Block, the Take List dialog box for the next selected Line Block
appears.

 

See also:

Manipulating Line Blocks
Adjusting the Grid display

 



Text Info Area of the Document Window  
Contents

Document Window

  

Description The Text Info Area displays general Text Information in a continuous row, parallel to the Bar
Area. It allows you to create/display Text Events such as "Rehearsal Letters" and "Markers".

 

Uses You can create, edit, copy, duplicate, move or delete Rehearsal Letters and Markers in the Text
Info Area as needed. These items can help you organize your composition Document to more
quickly locate a particular point in your music. These settings can then be saved with the
Document.

 

Items Rehearsal Letter event
Marker <From> event
Marker <To> event
Bar Grid
Beat Grid

 



Items in the Text Info Area  
Description of this Area

Using this Area

  

Creating
Text Events

Rehearsal Letter
event

Rehearsal Letters such as A or B, generally appearing at obvious
musical phrase boundaries, serve to provide Bar markings for
rehearsal. These Text Events can also be phrases such as "Verse",
"Chorus", "Head", Bridge", or anything you desire. You can create, edit,
copy, duplicate, move or delete Rehearsal Letters as needed.

Marker <From><To>
events

Markers serve to provide Cue markings for rehearsal or sequencing
work. You can use either <From> or <To> depending on your needs.
You can create, edit, copy, duplicate, move or delete Markers as
needed.

Adjusting the
Grid display

Bar Grid Vertical lines horizontally spaced across the Text Info Area indicating
the dividing points between Bars.

Beat Grid Vertical lines horizontally spaced across Bars indicating the dividing
points between Beats.

 



Using the Text Info Area  
Description of this Area

Items in this Area

  

 

Note:

After using any of the special Tool buttons at the top of the Document Window, be sure to
switch back to the standard Arrow Tool for regular manipulation operations.

Creating
and Manipulating
Text Events

Rehearsal Letter
event CREATING A REHEARSAL LETTER

Right-click a desired location in the Text Info Area and choose New
Rehearsal Letter to create a blank Rehearsal Letter. Enter desired text
data in the edit box. When you are finished entering Text, click outside
the edit box or press Enter on your computer's keyboard.

Alternatively, choose New Text Event... from the Edit menu to create a
blank Rehearsal Letter. The New Text Event dialog box will open
allowing you to choose a Rehearsal Letter, Marker <from> or Marker
<To> text event.

 When choosing New Text Event... from the Edit menu, you must
first have selected an empty Text Info Area, otherwise the New Text
Event... item won't be available.

Marker <From>
Marker <To>
events

CREATING A MARKER

Right-click a desired location in the Text Info Area and choose New
Marker <From> or New Marker <To> to create a blank Marker. Enter
desired text data in the edit box. When you are finished entering or
editing Text, click outside the edit box, or press Enter on your
computer's keyboard.

Alternatively, choose New Text Event... from the Edit menu to create a
blank Marker. The New Text Event dialog box will open allowing you to
choose a Rehearsal Letter, Marker <from> or Marker <To> text event.

 When choosing New Text Event... from the Edit menu, you must
first have selected an empty Text Info Area, otherwise the New Text
Event... item won't be available.



Rehearsal Letter
Marker <From>
Marker <To>
events

EDITING TEXT EVENTS

To edit a Text Event, double click it to open its edit box. After typing
your changes, hit the Enter key, or click someplace outside the edit box
to close it.

SELECTING TEXT EVENTS

Using the Arrow tool, you can select individual Text Events. You can
select multiple Text Events by holding the Ctrl (or Shift) key down as
you select. Alternatively, clicking and holding your mouse button down
at an empty location in the Text Info Area and dragging your mouse
over desired Text Events allows you to select multiple Text Events in
one quick operation. Once selected, you can then move, duplicate,
copy, paste or delete a group of Text Events at one time using the right
click, Menu Bar or click and drag method.

 Selecting multiple Text Events will not be possible if the Eraser tool
button at the top of the Document Window is currently active. In this
case, Text Events will be deleted.



MOVING TEXT EVENTS

Method 1:

Click and drag desired Text Events to a new location in the Text Info
Area.

Method 2:

Select desired Text Event with your mouse and use your computer
keyboard's left/right arrow keys to move Text Events a Division at a
time.

Method 3:

This method allows you to move Text Events between Documents.

Right-click a Text Event and choose Cut Text Event to remove a Text
Event from its current location. Alternatively, click desired Text Event
and choose Cut Text Event from the Edit menu. Using the Ctrl (or
Shift) key while selecting allows you to Cut multiple Text Events in one
operation.

Next, right-click a desired location in the Text Info Area of the desired
Document's Document Window or Pianoroll, Control Draw or Tempo
Draw Editor and choose Paste Text Event to Paste the Cut Text
Event(s). Alternatively, select a desired location in the Text Info Area
and choose Paste Text Event from the Edit menu.

 When Align To Grid is activated, the Text Event being moved will
be Pasted to the nearest Horizontal Grid Resolution point of the
selected Text Info Area location as defined in the Grid Setup dialog box.

DUPLICATING TEXT EVENTS

Right-click a Text Event and choose Duplicate Text Event to duplicate
a Text Event. Alternatively, click desired Text Events and choose
Duplicate Text Event from the Edit menu. Using the Ctrl (or Shift) key
while selecting allows you to Duplicate multiple Text Events in one
operation.

Unlike the Copy/Paste operation which allows you to choose the
location of the "copy" before it is created, Duplicating a Text Event
automatically places the "duplicate" on top of the original, offset slightly
to the right. You can then move the "duplicate" at any time.



COPYING / PASTING TEXT EVENTS

Right-click a Text Event and choose Copy Text Event to copy it.
Alternatively, click desired Text Event and choose Copy Text Event
from the Edit menu. Using the Ctrl (or Shift) key while selecting allows
you to copy multiple Text Events in one operation.

Next, right-click a desired location in the Text Info Area of the desired
Document's Document Window or Pianoroll, Control Draw or Tempo
Draw Editor and choose Paste Text Event to Paste the Copied Text
Event(s). Alternatively, select a desired location in the Text Info Area
and choose Paste Text Event from the Edit menu.

 When Align To Grid is activated, the Text Event being Copied will
be Pasted to the nearest Horizontal Grid Resolution point of the
selected Text Info Area location as defined in the Grid Setup dialog box.

DELETING TEXT EVENTS

Method 1:

Select the Eraser tool at the top of the Document Window and simply
click on a Text Event to delete it. With the Eraser tool, clicking and
holding your mouse button down at an empty location in the Text Info
Area and dragging the Eraser over desired Text Events allows you to
delete multiple Text Events in one quick operation.

Method 2:

Right-click a Text Event and choose Clear Text Event to delete a Text
Event. Alternatively, click desired Text Events and choose Clear Text
Event from the Edit menu. Using the Ctrl (or Shift) key while selecting
allows you to Clear multiple Text Events in one operation.

 

See also:

Adjusting the Grid display

 



Using the Text Info Area  
Description of this Area

Items in this Area

  

Adjusting the
Grid display

Bar Grid The Bar Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Bars (Measures) for visual reference. Choose Bar Grid from the
Grid View submenu of the View menu to show or hide the Bar Grid in the Text Info
Area, as well as the Chord and Line Areas.

Beat Grid The Beat Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Beats in each Bar for visual reference. (This is not necessarily
the same as the Alignment Grid.) Choose Beat Grid from the Grid View submenu
of the View menu to show or hide the Beat Grid in the Text Info Area, as well as the
Chord and Line Areas.

 

See also:

Creating and Manipulating Text Events

 



Track Area of the Document Window  
Contents

Document Window

  

Description The Track Area displays all a Document's MIDI Track Controls in separate rows, one for each
Track of Line data, allowing you to manage each Track independently. Each Track Control row
corresponds horizontally with its Line Blocks in the Line Area of the Document Window. You can
create as many Tracks as you like, limited only by the amount of memory installed in your
computer. However, there will always be only one Chord Track.

 

Uses Besides displaying various Track related information, the Track Area allows you to manage a
song's Tracks, including creating, duplicating, moving and deleting Tracks. The Track Area also
allows you to independently assign a Name, MIDI Driver or MIDI Channel, and temporary MIDI
Event values such as Program (Patch) number, Play Activate and Record Arm. Most importantly,
the Track Area allows you to assign an orchestration role to each Track, referred to in CAMPS as
a Category. At the upper portion of the Track Area is a special Chord Track in which settings
effect Chord Playback in all Editors and dialog boxes. All of these settings can be saved with the
Document.

 

Items Chord Track
Line Track
MIDI Event Type buttons/displays



Track
Items

Category button/display
Play button/display
Record button/display
Track Name button/display
MIDI Device button/display
MIDI Channel button/display
Transpose button/display
MIDI Event button/display
MIDI Event slider/display

 



Items in the Track Area  
Description of this Area

Using this Area

  

Adjusting the
Chord Track

Chord
Track

The Chord Track allows you to assign various settings for Chord
Playback in all Editors and dialog boxes. Unlike the Line Tracks, the
Chord Track controls can't be recreated, copied, duplicated, moved or
deleted. However, certain Chord Track parameters can be edited.

Manipulating
Line Tracks

Line
Track

A Line Track (or simply "Track") allows you to assign various settings for
MIDI Line data Playback in all Editors and dialog boxes. Besides editing,
you can create, copy, duplicate, move or delete Line Tracks as needed.

Assigning a
Category

Category
button/display

The Chord Track Category button (located on the left side the Chord
Track Area) allows you to choose one of six Chord Playback methods for
your musical reference.

A Line Track's Category button (located on the left side the Line Track
Area) displays its current setting, and opens a Track's Category
drop-down menu. This allows you to assign a Category (orchestration
role) such as Melody, Bass, etc., to the Track. This Category setting is
referred to by CAMPS during Auto Composing and Harmonizing.

Turning
Playback On/Off

Play
button/display

A Track's Play button displays its current setting and allows you to
activate or deactivate Playback for a Track. This setting is effective in all
Editors and dialog boxes.

Choosing a
Record Track

Record
button/display

A Track's Record button displays its current setting and allows you to
Arm a Track for recording. You can only choose one Track at a time.
This setting is only effective in the Document Window.

Assigning a
Track Name

Track Name
button/display

A Track's Track Name button displays the current Track name. Single
clicking this button allows you to select a Track for other operations, and
double clicking this button allows you to edit a Track's Name.

Assigning a
MIDI Output
Device

MIDI Device
button/display

A Track's MIDI Device button displays its current setting and allows you
to assign a MIDI Output Device to each Track by choosing a MIDI Driver
from its menu. All MIDI Drivers installed in your computer appear in this
menu, unless MIDI Mapper is selected in the MIDI menu. The assigned
MIDI Device also plays back during Recording (Cues) when a Track is
Armed for Recording. Choose Mute from this menu to temporarily mute
the Track.

Assigning a
MIDI Channel

MIDI Channel
button/display

A Track's MIDI Channel button displays its current setting and allows
you to assign a MIDI Output Channel to a Track by choosing a value
between 1 and 16. The assigned MIDI Channel is also used for Playback
during Recording (Cue) when a Track is Armed for Recording.

Transposing Transpose
button/display

A Track's Transpose button displays its current setting and allows you to
temporarily transpose a Track's Playback by choosing a value between
-72 and 72 Half Steps. The actual Track data is not changed. This
Transpose setting is also used for Playback during Recording (Cue)
when a Track is Armed for Recording.

Adjusting
MIDI Events

MIDI Event Type
buttons/displays

The MIDI Event Type buttons display their current settings and allow
you to choose a MIDI Event Type to edit or display in all Tracks, using a
Track's MIDI Event button or slider.



MIDI Event
button/display

The MIDI Event button allows you to temporarily assign a value for the
currently active MIDI Event Type. The actual Track data is not changed.
This MIDI Event setting is also used for Playback during Recording
(Cue) when a Track is Armed for Recording. As MIDI Events are
executed in a Track's Line data during Playback, this area displays the
corresponding MIDI Event values in real time.

MIDI Event
slider/display

The MIDI Event slider allows you to temporarily assign a value for the
currently active MIDI Event type in each Track. The actual Track data is
not changed. This MIDI Event setting is also used for Playback during
Recording (Cue) when a Track is Armed for Recording. As MIDI Events
are executed in a Track's Line data during Playback, the slider moves,
displaying the corresponding MIDI Event value as real time slider
position.

 

  



Using the Track Area  
Description of this Area

Items in this Area

  

Controlling
Chord Track
Playback

Chord
Track

Click the Category button (Speaker Icon) to open its drop-down menu. You can then
select one of six methods for Chord Playback: Guide Tones, Triad, 7th, Triad +
Tensions, 7th + Tensions or Scale Notes. ("7th + Tensions" is recommended.)

 Guide Tones: Chords using only Guide Tones

 Triad: Chords using Root, 3rd and 5th

 7th: Chords using Root, 3rd, 5th and 7th

 Triad + Tensions: Chords using Root, 3rd, 5th and Tensions

 7th + Tensions: Chords using Root, 3rd, 5th, 7th and Tensions

 Scale Notes: Scale Notes Arpeggiated from the Root

Click the Play button to activate or deactivate Chord Track Playback.

Click the MIDI Device button to open its drop-down menu. You can then choose one of
your computer's installed MIDI Output Devices for Chord Track Playback. These
Devices will not be individually selectable if MIDI Mapper is selected in the MIDI menu.

Click the MIDI Channel button to open the MIDI Channel edit box. You can then enter a
value between 1 and 16 to assign a desired MIDI Channel to the Chord Track for
Playback.

If necessary, Click the Transpose button to open the Transpose edit box. You can then
enter a value between -72 and 72 to Transpose the Chord Track for Playback. (1 = a
half step)

If you wish to edit a Chord Track MIDI Event numerically, click the MIDI Event Type at
the top of the MIDI Event button column and choose the MIDI Event type to edit from
the drop-down menu. Then click the Track's MIDI Event button to open its edit box. Use
the up/down buttons or directly enter a number between -1 and 127. A setting of -1
indicates "not specified" or "none".

To edit a MIDI Event with the slider, click the MIDI Event Type button at the top of the
MIDI Event slider column and choose the MIDI Event type to edit from the drop-down
menu. Then click and drag the Track's slider to make your adjustment.



 To hear Chord Playback anywhere in CAMPS, you must have adjusted the Volume
for the Chord Track to a value higher than 0.

 

See also:

Manipulating Line Tracks
Assigning a Track Category
Controlling Track Playback
Controlling Track Recording
Assigning a Track Name
Assigning a MIDI Device
Assigning a MIDI Channel
Transposing
Assigning MIDI Events
Adjusting MIDI Events
Selecting MIDI Events

 



Using the Track Area  
Description of this Area

Items in this Area

  

Assigning
MIDI Events

MIDI Event
button/display

This is the second column in from the right side of the Track Area. Unaltered, it
is typically set to a Program Change value.

Choose a MIDI Event you wish to edit from the MIDI Event Type button's
drop-down menu in the top row of this column. You can then change MIDI Event
values on a Track by Track basis using a Track's MIDI Event button to open its
edit box.

These MIDI Event settings only temporarily effect a Track's Playback, and the
actual Track Line data is not changed. The assigned MIDI Event settings are
also used for Playback during Recording (Cue) when a Track is Armed for
Recording.

As MIDI Events are executed in a Track's Line data during Playback, the MIDI
Event button displays the corresponding MIDI Event values in real time.

A Track's MIDI Event settings are effective for all the Line Blocks in that
Track.

 

See also:

Controlling Chord Track Playback
Manipulating Line Tracks
Assigning a Track Category
Controlling Track Playback
Controlling Track Recording
Assigning a Track Name
Assigning a MIDI Device
Assigning a MIDI Channel
Transposing
Adjusting MIDI Events
Selecting MIDI Events

 



Using the Track Area  
Description of this Area

Items in this Area

  

Adjusting
MIDI Events

MIDI Event
slider/display

Unaltered, this slider is typically set to control Volume data.

Choose a MIDI Event you wish to edit from the MIDI Event Type button's
drop-down menu at the top row of this column. You then can change MIDI Event
settings on a Track by Track basis by using a Track's MIDI Event slider.

These MIDI Event settings only temporarily effect a Track's Playback, and the
actual Track Line data is not changed. The assigned MIDI Event settings are also
used for Playback during Recording (Cue) when a Track is Armed for Recording.

As MIDI Events are executed in a Track's Line data during Playback, the MIDI
Event slider displays the corresponding MIDI Event values by moving in real
time.

 A Track's MIDI Event settings are effective for all the Line Blocks in that
Track.

 

See also:

Controlling Chord Track Playback
Manipulating Line Tracks
Assigning a Track Category
Controlling Track Playback
Controlling Track Recording
Assigning a Track Name
Assigning a MIDI Device
Assigning a MIDI Channel
Transposing
Assigning MIDI Events
Selecting MIDI Events

 



Using the Track Area  
Description of this Area

Items in this Area

  

Selecting
MIDI Events

MIDI Event Type
buttons/displays

These buttons are in the top row (above the Chord Track), in the two right
columns of the Track Area.

Unaltered, the left most MIDI Event Type button is typically set to Program
Change, and determines the Type of MIDI Event to be adjusted with the MIDI
Event buttons in the same column. The right most MIDI Event Type button is
typically set to Volume controller, and determines the Type of MIDI Event to
be adjusted with the MIDI Event sliders in the same column.

Choose a MIDI Event you wish to edit from either of these MIDI Event Type
buttons' drop-down menus, and then adjust the value of the selected MIDI
event for any Track using a Track's MIDI Event adjustment control in the
appropriate column. This allows you to change MIDI Event values on a Track
by Track basis using a Track's MIDI Event button or slider.

The resulting MIDI Event settings only temporarily effect a Track's Playback,
and the actual Track Line data is not changed. The assigned MIDI Event
settings are also used for Playback during Recording (Cue) when a Track is
Armed for Recording.

A Track's MIDI Event settings are effective for all the Line Blocks in that
Track.

 

See also:

Controlling Chord Track Playback
Manipulating Line Tracks
Assigning a Track Category
Controlling Track Playback
Controlling Track Recording
Assigning a Track Name
Assigning a MIDI Device
Assigning a MIDI Channel
Transposing
Assigning MIDI Events
Adjusting MIDI Events



 



Using the Track Area  
Description of this Area

Items in this Area

  

Manipulating
Line Tracks

Line
Track CREATING A NEW BLANK TRACK

Right-click in the Track Area and then choose New Track to create a blank Track.
Tracks are created in an additive fashion. It is not possible to place a Track freely in an
unused portion of the Track Area, rather, New Tracks are simply added underneath
existing Tracks as the next Track.

Alternatively, choose New Track from the Edit menu to create a blank Track.

 When choosing New Track from the Edit menu, you must have clicked in the Track
Area, otherwise the New Track item won't be available.

SELECTING TRACKS

Using the Arrow tool, you can select individual Tracks. You can select multiple Tracks
by holding the Ctrl (or Shift) key down as you select. Alternatively, Clicking and holding
your mouse button down on a Track, and then dragging your mouse up or down to other
Tracks allows you to select multiple Tracks in one operation. Once selected, you can
then move, duplicate, copy, paste and delete a group of Tracks at one time using the
right click, menu bar or click and drag method.

 Selecting multiple Tracks will not be possible if the Eraser tool button at the top of
the Document Window is currently active. In this case, Tracks will be deleted.



MOVING TRACKS

Method 1:

Click and drag desired Tracks to a new location in the Track Area. This can only be
done where Tracks already exist, in effect, reordering existing Tracks.

Method 2:

This method allows you to move Tracks between Documents.

Right-click a Track and then choose Cut Track to remove a Track from its current
location. Alternatively, select a Track and choose Cut Track from the Edit menu. Using
the Ctrl (or Shift) key while selecting allows you to Cut multiple Tracks in one operation.

Next, right-click a desired location in the Track Area of the desired Document and
choose Paste Track to Paste the Cut Track(s). Alternatively, select a location in the
Track Area and choose Paste Track from the Edit menu.

When Pasting a Track, clicking an existing Track will cause the Track being moved to be
Pasted above the selected Track. Pasting anywhere in the empty Track Area under
existing Tracks will cause the Track being moved to be Pasted as the next Track under
existing Tracks.

 When moving Tracks in the Track Area, all a Track's Line Blocks will be moved with
the Track.

DUPLICATING TRACKS

Right-click a Track and choose Duplicate Track to duplicate the selected Track.
Alternatively, choose Duplicate Track from the Edit menu. Using the Ctrl (or Shift) key
while selecting allows you to Duplicate multiple Tracks in one operation.

 When Duplicating Tracks in the Track Area, all a Track's Line Blocks will also be
Duplicated.



COPYING / PASTING TRACKS

Right-click a Track and then choose Copy Track to copy a Track. Alternatively, select a
Track and choose Copy Track from the Edit menu. Using the Ctrl (or Shift) key while
selecting allows you to copy multiple Tracks in one operation.

Next, right-click a desired location in the Track Area of the desired Document and
choose Paste Track to Paste the Copied Track(s). Alternatively, select a location in the
Track Area and choose Paste Track from the Edit menu.

When Pasting a Track, clicking an existing Track will cause the Track being Copied to
be Pasted above the selected Track. Pasting anywhere in the empty Track Area under
existing Tracks will cause the Track being Copied to be Pasted as the next Track under
existing Tracks.

 When copying Tracks in the Track Area, all a Track's Line Blocks will also be
copied.

DELETING TRACKS

Method 1:

Select the Eraser tool at the top of the Document Window and simply click on a Track to
delete it.

Method 2:

Right-click a Track and choose Clear Track to delete the selected Track. Alternatively,
choose Clear Track from the Edit menu. Using the Ctrl (or Shift) key while selecting
allows you to Clear multiple Tracks in one operation.

 When deleting Tracks in the Track Area, all a Track's Line Blocks are also deleted.

 



See also:

Controlling Chord Track Playback
Assigning a Track Category
Controlling Track Playback
Controlling Track Recording
Assigning a Track Name
Assigning a MIDI Device
Assigning a MIDI Channel
Transposing
Assigning MIDI Events
Adjusting MIDI Events
Selecting MIDI Events

 



Using the Track Area  
Description of this Area

Items in this Area

  

Assigning
Track Category

Category
button

Click a Track's Category button to open its Category drop-down menu. You can
then select one of six Category settings for Auto Composing and Harmonizing:
Melody, Comping, Obligato, Bass, Strings and Drums.

 Melody: For the main Melody line

 Comping: For accompaniments including a large number of harmonies

 Obligato: For additional accompaniments to the Melody line

 Bass: For the Bass line

 Strings: For Strings including sustained Chord progressions

 Drums: For Drums and Percussion

Because CAMPS is designed as a music composition tool, each Track (except
the Chord Track) will always have one of these attributes. This does not directly
effect MIDI line data Playback, but these attributes are referenced by the CAMPS
Composition Logic Engine during Auto Composition and Harmonization.
Depending on the Category assigned to a given Track, CAMPS automatically
adjusts its internal Composition Logic to the Track Category for appropriate
results. It is therefore important to assign the correct Category to each Line Track
in order to obtain correct results from various CAMPS features.

 A Track's Category setting is effective for all its Line Blocks.

 

See also:

Controlling Chord Track Playback
Manipulating Line Tracks
Controlling Track Playback
Controlling Track Recording
Assigning a Track Name
Assigning a MIDI Device
Assigning a MIDI Channel
Transposing
Assigning MIDI Events
Adjusting MIDI Events
Selecting MIDI Events

 



Using the Track Area  
Description of this Area

Items in this Area

  

Controlling Track
Playback

Play
button/display

Click the Play button to activate or deactivate a Track's Playback. When a
Track's Playback is active, the triangular "Play" Icon in this button turns blue
in color. This setting is effective in all Editors and dialog boxes for the
Track.

Other settings assigned to a Track including MIDI Device, MIDI Channel,
Transpose and MIDI Event will be in effect when the Play button for the
Track is turned on. However the Track's actual Line data is not changed.

 Clicking a Track's turned on Play button while holding the Ctrl key
down when no other Tracks are turned on results in all Tracks turning on.
Additionally, doing this when some other Tracks are turned on works as a
"Solo" function, turning all the other Tracks on or off except the Track
whose Play button you are clicking while holding the Ctrl key down.

 A Track's Play button setting is effective for all its Line Blocks.

 To hear Playback of a Track anywhere in CAMPS, you must have
adjusted the Volume for that Track to a value higher than 0, unless an
appropriate Volume Event value is assigned to each Line Block in that
Track.

 

See also:

Controlling Chord Track Playback
Manipulating Line Tracks
Assigning a Track Category
Controlling Track Recording
Assigning a Track Name
Assigning a MIDI Device
Assigning a MIDI Channel
Transposing
Assigning MIDI Events
Adjusting MIDI Events
Selecting MIDI Events

 



Using the Track Area  
Description of this Area

Items in this Area

  

Controlling
Track Recording

Record
button/display

Click a Track's Record button to Arm the Track for recording. When a Track
is Armed for Recording, the round "Record" Icon in this button turns
magenta in color, and any Punch In/Out regions inserted in the Bar area of
the Document Window change from dark gray to magenta, indicating that
CAMPS is ready for Recording. Click the Record button again to disArm
Recording for the Track. You can only select one Track at a time for
Recording. This setting is only effective in the Document Window.

Other settings assigned to a Track including MIDI Device, MIDI Channel,
Transpose and MIDI Event will be in effect for Playback during Recording
(Cue) when that Track is Armed for Recording. However, new Line data is
recorded exactly as you play it on your MIDI instrument.

 A Track's Record button setting is effective for all its Line Blocks.

 To hear Playback of the Track during Recording (Cue) in CAMPS, you
must have adjusted the Volume for that Track to a value higher than 0.

 

See also:

Controlling Chord Track Playback
Manipulating Line Tracks
Assigning a Track Category
Controlling Track Playback
Assigning a Track Name
Assigning a MIDI Device
Assigning a MIDI Channel
Transposing
Assigning MIDI Events
Adjusting MIDI Events
Selecting MIDI Events



Using the Track Area  
Description of this Area

Items in this Area

  

Assigning a
Track Name

Track Name
button

Click the Track Name button to select a Track for Copying, Duplicating, Moving
or other operations. Double click this button to open the Track Name edit box.
Name the Track by entering text data in the edit box.

The length of the Name you type is limited only by available computer memory,
but as it gets longer than the current size of the edit box, your typing will scroll out
of view. Click and drag the right side of the Name column with your mouse to
increase its size. When creating a new Track, it appears with the Track Name edit
box opened for editing.

The Track Name will be used when exporting your data as Standard MIDI File.

 

See also:

Controlling Chord Track Playback
Manipulating Line Tracks
Assigning a Track Category
Controlling Track Playback
Controlling Track Recording
Assigning a MIDI Device
Assigning a MIDI Channel
Transposing
Assigning MIDI Events
Adjusting MIDI Events
Selecting MIDI Events

 



Using the Track Area  
Description of this Area

Items in this Area

  

Assigning a
MIDI Device

MIDI Device
button/display

Click a Track's MIDI Device button to open the MIDI Device drop-down menu.
Here you can select any one of the MIDI Output Devices installed in your
computer, unless MIDI Mapper is selected in the MIDI menu. You can change
MIDI Device settings on a Track by Track basis using a Track's MIDI Device
button. This gives you the ability to assign different MIDI Devices to different
Tracks for Playback.

This can also be done for all Tracks at once by selecting all Track Names and
clicking a MIDI Device button for any one of the selected Tracks.

These features give you the ability to use the CAMPS multi-Document
environment to some of it's fullest potential. Multiple Documents can be opened
or saved, each with different MIDI Device configurations.

 A Track's MIDI Device setting is effective for all its Line Blocks.

 Virtual (Software) Synthesizers typically have a slower initial response time.
Therefore, using them while a Hardware MIDI Device is assigned to other
Tracks in the same Document may result in an unwanted offset of Playback time
between Instruments in your song.

 

See also:

Controlling Chord Track Playback
Manipulating Line Tracks
Assigning a Track Category
Controlling Track Playback
Controlling Track Recording
Assigning a Track Name
Assigning a MIDI Channel
Transposing
Assigning MIDI Events
Adjusting MIDI Events
Selecting MIDI Events

 



Using the Track Area  
Description of this Area

Items in this Area

  

Assigning a
MIDI Channel

MIDI Channel
button/display

Click a Track's MIDI Channel button to open its MIDI Channel edit box. Here,
you can enter a value between 1 and 16 to assign a MIDI Channel to the Track
for Playback.

You can change MIDI Channel settings on a Track by Track basis. This gives
you the ability to assign different MIDI Channels to different Tracks for
Playback. The assigned MIDI Channel is also used for Playback during
Recording (Cue) when the Track is Armed for Recording.

 A Track's MIDI Channel setting is effective for all its Line Blocks.

 

See also:

Controlling Chord Track Playback
Manipulating Line Tracks
Assigning a Track Category
Controlling Track Playback
Controlling Track Recording
Assigning a Track Name
Assigning a MIDI Device
Transposing
Assigning MIDI Events
Adjusting MIDI Events
Selecting MIDI Events

 



Using the Track Area  
Description of this Area

Items in this Area

  

Transposing Transpose
button/display

Click a Track's Transpose button to open it's Transpose edit box. Here you can
enter a value between -72 and 72 to assign a Transpose value to the Track for
Playback. (1= a Half Step.)

You can change Transpose settings on a Track by Track basis. Transpose
settings are temporary, and the actual Track data is not changed. These
Transpose settings are also used for Playback during Recording (Cue) when the
Track is Armed for Recording.

 A Track's Transpose settings are effective for all of its Line Blocks.

 

See also:

Controlling Chord Track Playback
Manipulating Line Tracks
Assigning a Track Category
Controlling Track Playback
Controlling Track Recording
Assigning a Track Name
Assigning a MIDI Device
Assigning a MIDI Channel
Assigning MIDI Events
Adjusting MIDI Events
Selecting MIDI Events



Pianoroll Editor  
Contents

Editors

  

Description The Pianoroll Editor is probably the most familiar Sequencing Editor in CAMPS.
The customary Pianoroll Grid allows you to quickly create and edit Notes using many methods,
and each Note's Velocity can be adjusted independently. Chords, general Text Events and Lyrics
can also be manipulated in their respective areas of the Pianoroll Editor. Finally, the same unique
Harmony and Composition Tools found in the Document Window are also accessible in the
Pianoroll Editor.

 

Items The Pianoroll Editor contains various Controls and Editing Areas for manipulating objects. You
can choose to Show or Hide the Controls with the Edit Buttons command in the View menu.
You can adjust the size of each Editing Area by clicking and dragging the horizontal separator
bar between Areas.

Edit Buttons The Edit Buttons give you quick access to viewing and manipulation tools for
the Pianoroll Editor, as well as the many Editors available in CAMPS.

Bar Area The Bar Area displays a range of Bar lines. Besides managing a song's Time
Grid, this area also allows you to manipulate Loop functions.

Text Info Area The Text Info Area allows you to create Text Events such as Rehearsal Letters
and Markers.

Chord Area Document Chord Blocks reside in the Chord Area. Each Chord Block in this row
contains Chord Containers to which you assign your song's Chords.

Lyric Area The Lyric Area displays Lyrics, allowing you to create or edit them.

Pianoroll Area The Pianoroll Area is the main MIDI Note Event editing area in the Pianoroll
Editor, offering graphical and menu-driven Note editing on individual and
Compositional levels.

Velocity Area The Velocity Area allows you to graphically edit Velocity values of Notes in the
Pianoroll Editor.



Bar Area of the Pianoroll Editor  
Contents

Pianoroll Editor

  

Description The Bar Area displays Measures or divisions of musical Time, known as Bars, in a continuous
row. This includes Bar Numbers, the Bar Grid and the Beat Grid.

 

Uses Besides displaying Bar related information, the Bar Area allows you to manage a song's Time
Signature setup, location of the Playback Pointer, and the Playback Loop and Punch In/Out
Recording settings.

 

Items Playback Pointer
Loop region
Punch In/Out region
Bar Number
Bar Grid
Beat Grid
Location Cursor

 



Items in the Bar Area  
Description of this Area

Using this Area

  

Positioning the
Playback Pointer

Playback Pointer The Playback Pointer resides in its own dark gray area at the top of the
bar area, displaying the current Playback location in the Pianoroll
Editor. It also allows you to change the current Playback point.

Inserting a
Playback Loop

Loop
region

Displays your current Loop region. Starting Playback repeats (Loops)
Playback in this region until you stop. This region is indicated by the
color blue in the upper portion of the Bar Area in the Pianoroll Editor.

Inserting a
Punch In/Out
Record region

Punch In/Out
region

Displays your current Punch In/Out region. This region is indicated by
the color magenta in the lower portion of the Bar Area.

Viewing
Bar related
items

Bar Number A series of numbers given to Bars, starting on the left side with 1.

Bar Grid Vertical lines evenly spaced across the Bar Area indicating Bar
divisions.

Beat Grid Vertical lines evenly spaced across Bars indicating Beat divisions.

Location Cursor A vertical Location Cursor line in the Bar Area represents the horizontal
position of your mouse as it relates to the time location in your
Document. Corresponding numerical information is also displayed in
the order of "Bar, Beat and Division" in the Interactive Information area
at the bottom of the Pianoroll Editor. The color of the Location Cursor
depends on your settings in the Microsoft Windows Control Panel
"Display" applet, under the heading "Selected Items" in the "Items" list
of the "Appearance" pane.

 

  



Using the Bar Area  
Description of this Area

Items in this Area

  

Positioning the
Playback Pointer

Playback Pointer
and area

You can use the Playback Pointer to change the Playback point in the
Pianoroll Editor in two ways: Clicking a desired location in the dark gray
Playback Pointer area at the top, or clicking and dragging the Playback
Pointer to a desired location. Choose Play from the MIDI menu (or click
the Play button in the Playback Control toolbar) to begin Playback. The
Playback Pointer displays the current Playback location as CAMPS
plays or records MIDI data.

Inserting a
Playback Loop

Loop
region

You can create a Loop region by clicking and dragging with your mouse
in the upper portion of the Bar Area, below the Playback Pointer Area.
As you drag your mouse, the Loop region appears blue in color,
displaying a new Loop region. A Punch In/Out region of the same size
is automatically inserted below the new Loop region. Click anywhere in
the upper portion of the Bar Area to delete a Loop region.

Choose Play from the MIDI menu (or click the Play button in the
Playback Control toolbar) to begin Playback. CAMPS repeats Loop
region Playback until you stop it. Click anywhere in the upper portion of
the Bar Area to delete a Loop region.

 The start and end points of the Loop region snap to the Grid
resolution set in the Grid Setup dialog box if Align to Grid is selected in
the Grid View submenu of the View menu.

Inserting a
Punch In/Out
Record region

Punch In/Out
region

You can create a Punch In/Out region by clicking and dragging your
mouse in the lower portion of the Bar Area (below the Loop region). As
you drag your mouse, this region appears magenta in color, displaying
a new Punch In/Out region. A Loop of the same size is automatically
inserted above the new Punch In/Out region. Click anywhere in the
lower portion of the Bar Area to delete a Punch In/Out region.

Choose Record from the MIDI menu (or click the Record button in the
Record Control toolbar) to begin recording.

If the automatically inserted Playback Loop is removed, CAMPS begins
Playback from the Playback Pointer's current position, but Recording is
only active as the Playback Pointer travels through the Punch In/Out
region. This provides a true Cued Punch In/Out environment.

 By combining with a Loop region beginning before the Punch
In/Out region, CAMPS provides a continuous Cued Punch In/Out
recording environment. Remove the automatically inserted Loop and
insert a new one starting before the Punch In/Out region, or remove the
Punch In/Out region and insert a new one starting after the Loop
region.

 The start and end points of the Punch In/Out region snap to the
Grid resolution set in the Grid Setup dialog box, if Align to Grid is
selected in the Grid View submenu of the View menu.



Assigning a
Time Signature

Time Signature
settings

CAMPS allows you to assign different Time Signatures to individual
Bars. Right-click a Bar to which you are assigning a new Time
Signature and then choose Time Signature Setup... to open the Time
Signature Setup dialog box. Set a Time Signature in the dialog box and
click OK. (Choosing Time Signature Setup... from the Edit menu
opens the same dialog box.)

 

  



Edit Buttons Area of the Pianoroll Editor  
Contents

Pianoroll Editor

  

Description The Edit Buttons are located at the top of the Pianoroll Editor. These Buttons give you quick
access to frequently used items like View Adjustments, Tools and Editors.

 

Uses The Edit Buttons in the Pianoroll Editor include most of the View and Editors menu commands.
The Tool buttons work in slightly different ways according to which Area of the Pianoroll Editor
you are working in. Choose Edit Buttons from the View menu to show or hide the Edit Buttons.

 

Items Auto Scroll button
Jump To Location button
Playback button
Playback with Others button
Zoom Out (V) button
Zoom In (V) button
Zoom Out (H) button
Zoom In (H) button
Align To Grid button
Grid Setup button
Arrow Tool button
I Beam Tool button
Pen Tool button
Magic Wand Tool button
Line Tool button
Oval Tool button
Stamp Tool button
Eraser Tool button
Razor Tool button
Event List Editor button
Pianoroll Editor button
Control Draw Editor button
Notation Editor button

 



Items in the Edit Buttons Area  Description of this Area

  

Adjusting
View

Auto Scroll
button

Sets the viewable area in the Bar, Text Info, Chord, Lyric, Pianoroll and
Velocity Areas to follow the Playback Pointer during Playback and
Recording.

Jump To Location
button

Opens the Jump To Location dialog box which allows you to move the
current viewpoint to a specified Bar in the Pianoroll Editor.

Zoom Out (V)
button

Incrementally decreases the Vertical size of the Pianoroll Area,
increasing its viewable area.

Zoom In (V)
button

Incrementally increases the Vertical size of the Pianoroll Area,
decreasing its viewable area.

Zoom Out (H)
button

Incrementally decreases the Horizontal size of the Bar, Text Info, Chord,
Lyric, Pianoroll and Velocity Areas, increasing their viewable area.

Zoom In (H)
button

Incrementally increases the Horizontal size of the Bar, Text Info, Chord,
Lyric, Pianoroll and Velocity Areas, decreasing their viewable area.

Align To Grid
button

Switches between Activate or Deactivate Align To Grid in the Text Info,
Chord, Lyric and Pianoroll Areas. Grid Alignment is specified in the Grid
Setup dialog box. Velocity Events automatically align with the starting
edge of Notes in the Pianoroll Area, so their Horizontal Grid Alignment is
not independently adjustable.

Grid Setup
button

Opens the Grid Setup dialog box, allowing you to adjust the Alignment
Grid Resolution for individual areas of the Pianoroll Editor and applicable
Editors. Depending on which Area of the Pianoroll Editor is active before
choosing this Menu Item, the corresponding pane in the Grid Setup
dialog box will be preselected.

Auditioning Playback
button

Starts Audition Playback of the currently selected Notes with an
automatically inserted Playback Loop. If no individual Notes are
selected, CAMPS begins Playback from the currently selected Line
Block with no Loop. 

Playback with Others
button

Starts Audition Playback of the currently selected Notes with an
automatically inserted Playback Loop along with all the other activated
Tracks in the same Bar region. If no individual Notes are selected,
CAMPS begins Playback from the currently selected Line Block with no
Loop.

Selecting
Tools

Arrow Tool
button

Selects the Arrow Tool, allowing you to select and manipulate objects in
the Pianoroll Editor. Objects need to be selected before related functions
become available.

I Beam Tool
button

Selects the I Beam Tool, allowing you to quickly select regions in the
Pianoroll and Velocity Areas.

Pen Tool
button

Selects the Pen Tool, allowing you to quickly create Notes of any desired
length, or create and edit Velocity Events with a unique freestyle drawing
method

Magic Wand Tool
button

Selects the Magic Wand Tool, allowing you to quickly create or recreate
Chord Blocks or Line regions with automatically filled-in data
(EZgenerate). In the Pianoroll Area, drag the Magic Wand Tool to create
a selection region around Notes you wish to be EZgenerated.



Line Tool
button

Selects the Line Tool, allowing you to quickly edit Velocity Events using
a straight line drawing method.

Oval Tool
button

Selects the Oval Tool, allowing you to quickly edit Velocity Events using
an automatic curve drawing method.

Stamp Tool
button

Selects the Stamp Tool, allowing you to quickly insert new Notes of a
fixed length in the Pianoroll Area with a click of your mouse. Use the
Note Stamp toolbar to adjust the length of Notes the Stamp tool creates.
The Length is also adjustable at any later time.

Eraser Tool
button

Selects the Eraser Tool, allowing you to quickly delete objects in the
Pianoroll Editor with a click of your mouse.

Razor Tool
button

Selects the Razor Tool, allowing you to quickly split a Chord Block at any
Chord boundary.

Opening
Editors

Event List Editor
button

Opens the Event List Editor, allowing you to edit individual Events of the
selected Line Block in vertical list format.

Pianoroll Editor
button

Opens a new Pianoroll Editor, allowing you to make alternate edits of the
selected Line Block in Pianoroll graph format.

Control Draw Editor
button

Opens the Control Draw Editor, allowing you to edit MIDI Control events
of a selected Line Block with a unique freestyle curve drawing method.

Notation Editor
button

Opens the Notation Editor, allowing you to edit Notes of a selected Line
Block in Musical Notation form.

 



Chord Area of the Pianoroll Editor  
Contents

Pianoroll Editor

  

Description A Document's Chord Blocks reside in the Chord Area. Each Chord Block in this row contains
Chord Containers to which you assign your song's Chords. These make up the Chord Track,
which is used by the CAMPS Composition Logic Engine during the use of Auto Composition and
other unique features in CAMPS. These are the same Chord Blocks as seen in the Chord Area
of the Document Window.

 

Uses The Chord Area is where you manage a song's Chords. Besides allowing you to create, resize,
duplicate, move and delete Chords and groups of Chords (Chord Blocks), you can display
Chords in various ways, such as by Chord Name, Roman Numeral or Scale Name.

You can assign a Chord Name, Key, Mode and several Functions to each Chord. These settings
allow CAMPS to help you create a composition which modulates to different Tonalities; following
Chords as they change. This resulting Chord Track can also be Played back in different voicing
styles, alone or with your song's main Tracks, allowing you to audibly compare these Chord
definitions with the Tonality of your Line data. See the Chord Track of the Document Window for
Chord Playback settings.

CAMPS provides a number of automated and manual methods of assigning Chord Names,
including Auto Harmonizing, Chord Generation and Chord Detection from your MIDI instrument.
All settings can then be saved with the Document.

 

Items Chord Block
Chord Container
Key and Mode button
Chord Function check list
Bar Grid
Beat Grid



 



Items in the Chord Area  
Description of this Area

Using this Area

  

Manipulating
Chord Blocks

Chord Block A Chord Block is an array containing a group of Chords, indicated and
manipulated by its Chord Block Selection Bar, a thin horizontal bar
across the top of each Chord Block.

Chord Blocks serve to enable quick musical arranging changes, as they
are referenced by CAMPS during Auto Composition and other functions.
They also help organize the Tonality of different Sections in your
composition, such as a Verse or Bridge.

When using CAMPS to Generate Chords, Tonality settings for the
current or potential Chord Block are referenced, allowing creation of
Chords that flow smoothly from one to the next within a Chord Block.
You can create, copy, duplicate, move or delete Chord Blocks as
needed.

Manipulating
Chords

Chord Container You can assign a Chord Name in a Key and Mode of your choice to
each Chord Container using various methods provided in CAMPS. A
Chord Name must be assigned to each Chord Container to get
appropriate results from musical tools in CAMPS, such as Compose...
and Voicing.... You can create, edit, resize, copy, duplicate, move or
delete Chord Containers as needed.

Assigning a
Key and Mode

Key and Mode
button

The Key and Mode button displays its current settings and opens a
Chord's Key and Mode drop-down menu. This allows you to assign a
Key and Mode (G major, D Mixolydian, etc.) to each Chord. This Key
and Mode setting is referred to by CAMPS during Auto Chord Detection,
Chord Progression Generation and Chord Construction.

Selecting
Chord Functions

Chord Function
check list

The Chord Function check list (visible below each Chord's Key and
Mode button when the Chord Area is extended downward) displays its
current settings and allows you to assign Chord Functions such as
Diatonic and Secondary Dominant. These settings are referred to by
CAMPS during Auto Chord Detection, Chord Progression Generation
and Chord Construction.

Auditioning
Chords

Chord
Track

The Chord Track controls in the Track Area of the Document Window
allow you to assign various settings for Chord Playback. See Track Area
of the Document Window documentation for more details.



Adjusting
Chord Display

Chord View
Menu Item

Choosing one of the five Chord Display Modes from the Chord View
submenu of the View menu changes the Chord's naming convention.
The current selection is indicated with a bullet. See Chord Menu
documentation for more details.

Depending on the amount of information being displayed and the
Pianoroll Editor's current horizontal Display resolution, Chord, Key and
Mode names may appear abbreviated. To see all of a Chord's Name,
Key or Mode, use the Zoom In/Out (horizontal) buttons at the top of the
Pianoroll Editor to adjust the horizontal Display resolution.

Adjusting the
Grid display

Bar Grid Vertical lines horizontally spaced across the Chord Area indicating the
dividing points between Bars.

Beat Grid Vertical lines horizontally spaced across Bars indicating the dividing
points between Beats.

 

 



Using the Chord Area  
Description of this Area

Items in this Area

  

Manipulating
Chord Blocks

Chord Block Note:

Many Chord Block related operations require selection of only the Chord Block
itself without highlighting any of its Chord Containers. To do this, click the Chord
Block Selection Bar across the top of a Chord Block.

After using any of the special Tool buttons at the top of the Pianoroll Editor, be
sure to switch back to the standard Arrow Tool for regular manipulation
operations.

CREATING A NEW BLANK CHORD BLOCK

Method 1:

Select the Pen tool at the top of the Pianoroll Editor and then click and drag
from left to right in the Chord Area to assign the starting and ending locations of
the Chord Block you are about to create. Settings for Chords in the new Chord
Block such as Key, Mode and Duration are adjustable at any later time.

Method 2:

Right-click an empty location in the Chord Area and choose New Chord
Block... to open the New Chord Block dialog box. Alternatively, select an empty
location in the Chord Area and choose New Chord Block... from the Edit
menu.

The New Chord Block dialog box allows you to set Quantity, Duration, Key and
Mode of Chords in the new Chord Block. To create a new empty Chord Block
without automatically assigned Chords, be sure the EZgenerate option is not
checkmarked. These settings will be automatically saved and used as defaults
for your next New Chord Block dialog box session. However, they can be
changed at any time.

 When choosing New Chord Block... from the Edit menu, you must have
clicked an empty location in the Chord Area, otherwise the New Chord Block...
item won't be available.



CREATING A NEW CHORD BLOCK WITH CHORDS

Method 1:

Select the Magic Wand tool at the top of the Pianoroll Editor and then click and
drag from left to right in the Chord Area to assign the starting and ending
locations of the Chord Block you are about to create. If executed where a Chord
Block already exists, this method will create a new Chord Block on top of the
original. Settings for Chords in the new Chord Block such as Chord Name, Key,
Mode and Duration are adjustable at any later time.

Method 2:

Right-click an empty location in the Chord Area and choose New Chord
Block... to open the New Chord Block dialog box. Alternatively, select an empty
location in the Chord Area and choose New Chord Block... from the Edit
menu.

The New Chord Block dialog box allows you to set Quantity, Duration, Key and
Mode of Chords in a new Chord Block. Be sure to checkmark the EZgenerate
Chords option in the dialog box if you want CAMPS to automatically generate a
Chord Progression in the New Chord Block. These settings will be automatically
saved and used as defaults for your next New Chord Block dialog box session.
However, they can be changed at any time.

 If any Line Blocks in Categories other than Drums exist in the same Bar
region as the New Chord Block being created with the Magic Wand tool or the
EZgenerate Chords option, CAMPS will generate Chords that Harmonize with
the existing Line data instead of arbitrarily creating a Chord Progression.

 When choosing New Chord Block... from the Edit menu, you must have
clicked an empty location in the Chord Area, otherwise the New Chord Block...
item won't be available.



EDITING CHORD BLOCKS

Select the Magic Wand tool at the top of the Document Window and click on
desired Chord Block's Selection Bar.

See also Manipulating Chords in the Chord Area of the Pianoroll Editor.

SELECTING CHORD BLOCKS

Using the Arrow tool, you can select individual Chord Blocks. You can select
multiple Chord Blocks by holding the Ctrl (or Shift) key down as you select.
Alternatively, Clicking and holding your mouse button at an empty location in
the Chord Area and dragging your mouse over desired Chord Blocks allows you
to select multiple Chord Blocks in one quick operation. Once selected, you can
then move, duplicate, make an Alias of, copy, paste or delete a group of Chord
Blocks at one time using the right click, menu bar or click and drag method.

Selecting Chords enables use of Chord related commands under the Chord
Menu bar item including Harmonize... and Detect from MIDI Instrument....

 Selecting multiple Chord Blocks will not be possible if the Magic Wand or
Eraser tool button at the top of the Pianoroll Editor is currently active. In these
cases, Chord Blocks will be EZgenerated or deleted one at a time (depending
on which of these buttons is active).



PLAYING BACK CHORD BLOCKS

Select desired Chord Blocks, right-click the Chord Blocks and then choose
Playback Chord Block from the drop-down menu to start Playback of the
selected Chord Blocks. A Loop region for the selected Chord Blocks will be
automatically created and CAMPS repeats (Loops) Playback in this region until
you stop. The Loop to be created may include empty sub-regions depending on
your Chord Block selections. Choose Playback with Line from the drop-down
menu to audition the selected Chord Blocks with Note Events in the Pianoroll
Area.

To stop Playback, choose Stop from the MIDI menu. Alternatively, click the
Stop button of the Playback Toolbar.

 Neither command effects the Play button settings for any Tracks.

MOVING CHORD BLOCKS

Method 1:

Click and drag desired Chord Block Selection Bar to a new location in the Chord
Area.

Method 2:

Select desired Chord Block with your mouse and use your computer keyboard's
left/right arrow keys to move Chord Blocks a Division at a time.

Method 3:

This method allows you to move Chord Blocks between Documents.

Right-click a Chord Block's Selection Bar and choose Cut Chord Block to
remove the Chord Block from its current location. Alternatively, click desired
Chord Block Selection Bar and choose Cut Chord Block from the Edit menu.
Using the Ctrl (or Shift) key while selecting allows you to Cut multiple Chord
Blocks in one operation.

Next, right-click a desired location in the Chord Area of the desired Document's
Pianoroll Editor or Document Window and choose Paste Chord Block to Paste
the Cut Chord Block(s). Alternatively, select a desired location in the Chord
Area and choose Paste Chord Block from the Edit menu.

 When Align To Grid is activated, the Chord Block being moved will be
Pasted to the nearest Horizontal Grid Resolution point of the selected Chord
Area location as defined in the Grid Setup dialog box.

 When one Chord Block overlaps another Chord Block, CAMPS always
refers to Chords appearing in front, ignoring the Chords in back. If only part of a
Chord Block overlaps, then only the Chords in the overlapping area will be
effected this way. Right-click a Chord Block's Selection Bar and use the Bring
to Front or Send to Back commands to activate the desired overlapping Chord



Block.

DUPLICATING CHORD BLOCKS

Right-click a Chord Block's Selection Bar and choose Duplicate Chord Block
to Duplicate the selected Chord Block. Alternatively, click desired Chord Block
Selection Bar and choose Duplicate Chord Block from the Edit menu. Using
the Ctrl (or Shift) key while selecting allows you to Duplicate multiple Chord
Blocks in one operation.

Unlike the Copy/Paste operation which allows you to choose the location of the
"copy" before it is created, Duplicating a Chord Block automatically places the
"duplicate" on top of the original, offset slightly to the right. You can then move it
at any time.

COPYING / PASTING CHORD BLOCKS

Right-click a Chord Block's Selection Bar and choose Copy Chord Block to
copy the selected Chord Block. Alternatively, click desired Chord Block
Selection Bar and choose Copy Chord Block from the Edit menu. Using the
Ctrl (or Shift) key while selecting allows you to copy multiple Chord Blocks in
one operation.

Next, right-click a desired location in the Chord Area of the desired Document's
Pianoroll Editor or Document Window and choose Paste Chord Block to Paste
the Copied Chord Block(s). Alternatively, select a desired location in the Chord
Area and choose Paste Chord Block from the Edit menu.

 When Align To Grid is activated, the Chord Block being Copied will be
Pasted to the nearest Horizontal Grid Resolution point of the selected Chord
Area location as defined in the Grid Setup dialog box.



CREATING AN ALIAS OF CHORD BLOCKS

Right-click Chord Block Selection Bar and choose Make Alias of Chord Block
to make an Alias of the selected Chord Block. Alternatively, select desired
Chord Block Selection Bar and choose Make Alias of Chord Block from the
Edit menu. Using the Ctrl (or Shift) key while selecting allows you to Make
Aliases of multiple Chord Blocks in one operation.

 An Alias is, in effect, an active copy of its original. Except for Copy/Paste,
Duplicate, Move and Delete operations, changes you make to one of the
Aliases effects all of its Aliases. This holds true whether you make changes to
the original, or the Aliases. In fact, there is no effective difference between an
Alias and its original. A small circle appearing in the left corner of the Chord
Block Selection Bar at the top of a Chord Block indicates the Alias status.

DELETING CHORD BLOCKS

Method 1:

Select the Eraser tool at the top of the Pianoroll Editor and simply click on a
Chord Block's Selection Bar to delete it. The Eraser tool can be used to delete
multiple Chord Blocks in one quick operation by clicking and holding your
mouse button at an empty location in the Chord Area and dragging the Eraser
over desired Chord Blocks.

Method 2:

Right-click a Chord Block Selection Bar and choose Clear Chord Block to
delete the selected Chord Block. Alternatively, click desired Chord Block
Selection Bar and choose Clear Chord Block from the Edit menu. Using the
Ctrl (or Shift) key while selecting allows you to Clear multiple Chord Blocks in
one operation.

 

See also:

Manipulating Chords
Assigning a Key and Mode
Assigning Chord Functions
Adjusting the Grid display



Using the Chord Area  
Description of this Area

Items in this Area

  

Manipulating
Chords

Chord Container Note:

Since Chord Containers reside in Chord Blocks, you'll first need to have
Chord Blocks in the Chord Area of your Document before you can
individually manipulate Chords.

Many of these operations will result in changes of Chord Block size. When
adding to a Chord Block, existing Chords get moved to the right. Keep in
mind that if another Chord Block already exists right after the Chord Block
which increases in size, Chords being moved to the right will slip behind the
next Chord Block, resulting in overlapping Chord Blocks. The visible Chords
in an overlapping area will become the active Chords in that area for all
Chord related CAMPS functions.

To choose which Chord Block is visible and active in an overlapping Chord
Area, right click the desired Chord Block Selection Bar and choose Bring to
Front or Send to Back.

CREATING NEW BLANK CHORD CONTAINERS

Right-click the Chord at a desired location and choose New Chord... to
open the New Chord dialog box. Alternatively, click the Chord at a desired
location and choose New Chord... from the Edit menu.

The New Chord dialog box allows you set Quantity, Duration, Key and Mode
of new Chords. To create a new empty Chord Container, be sure the
EZgenerate option is not checkmarked. These settings will be automatically
saved and used as defaults for your next New Chord dialog box session.
However, they can be changed at any time.

 When choosing New Chord... from the Edit menu, you must have
clicked a Chord, otherwise the New Chord... item won't be available.



CREATING NEW CHORD CONTAINERS WITH ASSIGNED CHORDS

Right-click a Chord and then choose New Chord... to open the New Chord
dialog box. Alternatively, select a Chord and choose New Chord... from the
Edit menu.

The New Chord dialog box allows you to set Quantity, Duration, Key and
Mode of new Chord Containers being created. Be sure to checkmark the
EZgenerate option in the dialog box to automatically generate a Chord.
These settings will be automatically saved and used as defaults for your
next New Chord dialog box session. However, they can be changed at any
later time.

 If any Line Blocks in Categories other than Drums exist in the same Bar
region as the New Chord being created with the EZgenerate Chords option
activated, CAMPS will generate Chords that Harmonize with the existing
Line data instead of arbitrarily creating a Chord Progression.

 When choosing New Chord... from the Edit menu, you must have
clicked a Chord, otherwise the New Chord... item won't be available.

ASSIGNING AND EDITING CHORDS

Method 1:

Select the Magic Wand tool at the top of the Pianoroll Editor and simply
click a Chord you wish to assign a Chord Name to. This can be done with
empty or filled-in Chord Containers. In the latter case, existing Chords will
be replaced. Settings for the new Chord such as Chord Name, Key, Mode
and Duration are adjustable at any later time. To assign or reassign Chords
to all Chord Containers in a Chord Block, click only the Chord Block
Selection Bar with the Magic Wand tool.

 If any Line Blocks in Categories other than Drums exist in the same Bar
region as the Chord being created with the Magic Wand tool, CAMPS will
generate Chords that Harmonize with the existing Line data instead of
arbitrarily creating new Chords.



Other Methods:

Select desired Chords and choose a Chord assignment method from the
Chord menu. Alternatively, right click desired Chord and choose a Chord
assignment method from the Actions submenu.

These options include Generate..., EZgenerate, Harmonize...,
EZharmonize, EZharmonize with Same Key, Detect from MIDI
Instrument... and Construct....
The EZharmonize All command references existing Line data to
Harmonize all Chords whether selected or not.

SELECTING CHORD CONTAINERS

Using the Arrow tool, you can select individual Chords. You can select
multiple Chords by holding the Ctrl (or Shift) key down as you select.
Alternatively, Clicking and holding your mouse button on a Chord, and then
dragging your mouse over other Chords allows you to select multiple
Chords in one operation. Once selected, you can then move, duplicate,
make an Alias of, copy, paste or delete a group of Chords at one time using
the right click, Menu Bar or click and drag method. This operation can be
used with most of the commands in the Chord Menu as well.

 Selecting multiple Chords will not be possible if the Magic Wand or
Eraser tool is currently selected from the top of the Pianoroll Editor. In these
cases, Chords will be created, generated or deleted one at a time
(depending on which of these buttons is active).

PLAYING BACK CHORD CONTAINERS

Select desired Chords, right-click the Chords and then choose Playback
Chord from the drop-down menu to start Playback of the selected Chords.
A Loop region for the selected Chords will be automatically created and
CAMPS repeats (Loops) Playback in this region until you stop. Choose
Playback with Lines from the drop-down menu to audition the selected
Chords with Note Events in the Pianoroll Area.

To stop Playback, choose Stop from the MIDI menu. Alternatively, click the
Stop button of the Playback Toolbar.

 Neither command effects the Play button settings for any Tracks.



PLAYING BACK CHORD CONTAINERS

Select desired Chords, right-click the Chords and then choose Playback
from the pull-down menu to start Playback of the selected Chords and Note
Events in the Line Block. A Loop and Punch In/POut regions for the
selected Chords will be automatically created and CAMPS repeats (Loops)
Playback in this region until you stop. Choose Playback with Others from
the pull-down menu to audition the selected Chords and Note Events in the
Line Block with Line Blocks on the other activated Tracks.

To stop Playback, choose Stop from the MIDI menu. Alternatively, click the
Stop button of the Playback toolbar.

MOVING CHORD CONTAINERS

Method 1:

Select desired Chords and drag them to a new location in a Chord Block.

 When moving Chords in this manner, a vertical indicator appears at the
boundary between Chords being moved and other existing Chords. Drag
the Chords being moved past this indicator to drop Chords in a new
location.

Method 2:

This method allows you to move Chord Containers between Documents.

Right-click a Chord Container and then choose Cut Chord to remove a
Chord Container from its current location. Alternatively, select a Chord
Container and choose Cut Chord from the Edit menu. Using the Ctrl (or
Shift) key while selecting allows you to Cut multiple Chord Containers in one
operation.

Next, right-click a desired location in a Chord Block of the desired
Document's Pianoroll Editor or Document Window and choose Paste Chord
to Paste the Cut Chord Container(s). Alternatively, select a location in a
Chord Block and choose Paste Chord from the Edit menu.

 When Pasting a Chord in an existing Chord Container's location, the
existing Chord will be moved to the right. When a Chord is being moved
from one Chord Block to another, the destination Chord Block will increase
in size, while the originating Chord Block will decrease in size.



RESIZING CHORD CONTAINERS

Using the Arrow Tool, position your mouse cursor over the right edge of a
desired Chord Container until the cursor changes to a double arrow. Then
click and drag the right edge of the Chord Container to the desired size.

Keep in mind that this effects the size of the Chord Block in which the Chord
Container is being resized, effecting its Playback time. Additionally,
enlarging a Chord may cause Chord Blocks to overlap.

 When Align To Grid is active in the Chord Area, the Chord size will
snap to the nearest Horizontal Resolution Grid point.

 When one Chord Block overlaps another Chord Block, CAMPS always
refers to Chords appearing in front, ignoring the Chords in back. If only part
of a Chord Block overlaps, then only the Chords in the overlapping area will
be effected this way. Right-click a Chord Block's Selection Bar and use the
Bring to Front or Send to Back commands to activate the desired
overlapping Chord Block.

DUPLICATING CHORD CONTAINERS

Right-click a Chord Container and choose Duplicate Chord to duplicate the
selected Chord Container. Alternatively, select a Chord and choose
Duplicate Chord from the Edit menu. Using the Ctrl (or Shift) key while
selecting allows you to Duplicate multiple Chord Containers in one
operation.

Unlike the Copy/Paste operation which allows you to choose the location of
the "copy" before it's actually created, Duplicating a Chord automatically
places the "duplicate" to the right of the original. You can then move it at
any time.



COPYING / PASTING CHORD CONTAINERS

Right-click a Chord and then choose Copy Chord to copy the selected
Chord. Alternatively, select a Chord and choose Copy Chord from the Edit
menu. Using the Ctrl (or Shift) key while selecting allows you to copy
multiple Chords in one operation.

Next, right-click a desired location in a Chord Block of the desired
Document's Pianoroll Editor or Document Window and choose Paste Chord
to Paste the Copied Chord Container(s). Alternatively, select a location in a
Chord Block and choose Paste Chord from the Edit menu.

 When Pasting a Chord in an existing Chord Container's location, the
existing Chord will be moved to the right, increasing the size of its Chord
Block.

DELETING CHORD CONTAINERS

Method 1:

Select the Eraser tool at the top of the Pianoroll Editor and simply click on a
Chord to delete it.

Method 2:

Right-click a Chord and choose Clear Chord to delete the selected Chord.
Alternatively, select a desired Chord and choose Clear Chord from the Edit
menu. Using the Ctrl (or Shift) key while selecting allows you to Clear
multiple Chords in one operation.

 

See also:

Manipulating Chord Blocks
Assigning a Key and Mode
Assigning Chord Functions
Adjusting the Grid display

 



Using the Chord Area  
Description of this Area

Items in this Area

  

Assigning a
Key and Mode

Key and Mode
button

The Key and Mode button, located right below each Chord Name, displays
its current settings and opens the Key and Mode drop-down menu. This
allows you to adjust Chord Container Tonality settings originally made in the
New Chord or New Chord Block dialog boxes. You can independently
choose a Key and Mode such as G major, D Mixolydian, etc., for each
Chord.

This Key and Mode setting is referred to by CAMPS during Auto Chord
Detection, Chord Progression Generation and Chord Construction.

If Chord Key and Mode buttons are not visible, click on the dividing line
between the Chord and Lyric Areas and drag your mouse downward,
extending the bottom of the Chord Area.

 

See also:

Manipulating Chord Blocks
Manipulating Chords
Assigning Chord Functions
Adjusting the Grid display

 



Using the Chord Area  
Description of this Area

Items in this Area

  

Assigning
Chord Functions

Chord Function
check list

The Chord Function check list, located right below each Chord's Key and
Mode button, displays its current settings with checkmarks and allows
you to turn individual Chord Functions on or off for each Chord. These
settings are referred to by CAMPS during Auto Chord Detection, Chord
Progression Generation and Chord Construction.

CAMPS comes with four "plug-in" Chord Functions for each Chord,
including Diatonic, Diminished, Sub V7 and Secondary Dominant. The
more Chord Functions you activate, the more types of Harmony CAMPS
deals with. For example, if you activate Sub V7 (appearing in a darker
shade of gray), you'll get more "Jazzy" Chords with the Auto Chord
Detection, Chord Progression Generation and Harmonize functions.

If the Chord Function check lists are not visible under existing Chords,
click on the dividing line between the Chord and Lyric Areas and drag it
downward, extending the bottom of the Chord Area.

 You must at least activate the Diatonic Chord Function for a Chord to
be effective in directing CAMPS Composition functions.

 



See also:

Manipulating Chord Blocks
Manipulating Chords
Assigning a Key and Mode
Adjusting the Grid display

 



Using the Chord Area  
Description of this Area

Items in this Area

  

Adjusting the
Grid display

Bar Grid The Bar Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Bars (Measures) for visual reference. Choose Bar Grid from the
Grid View submenu of the View menu to show or hide the Bar Grid in the Chord
Area, as well as the Text Info, Lyric, Pianoroll and Velocity Areas.

Beat Grid The Beat Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Beats in each Bar for visual reference. (This is not necessarily
the same as the Alignment Grid). Choose Beat Grid from the Grid View submenu
of the View menu to show or hide the Beat Grid in the Chord Area, as well as the
Text Info, Lyric, Pianoroll and Velocity Areas.

 

See also:

Manipulating Chord Blocks
Manipulating Chords
Assigning a Key and Mode
Assigning Chord Functions

 



Lyric Area of the Pianoroll Editor  
Contents

Pianoroll Editor

  

Description The Lyric Area displays a Line Block's Lyrics in a continuous row, parallel to the Chord and
Pianoroll Areas.

 

Uses You can create, edit, duplicate, move or delete Lyrics in the Lyric Area. These song Lyrics can
then be saved with the Document. Additionally, Lyrics are saved with your Composition when
exporting it to a Standard MIDI File.

 

Items Lyric Event
Bar Grid
Beat Grid

 



Items in the Lyric Area  
Description of this Area

Using this Area

  

Creating a
Lyric

Lyric
Event

Lyric Events allow you to include song Lyrics (sung words) in your Composition.
You can create, edit, copy, duplicate, move or delete Lyric Events as needed.
Lyrics can then be Saved and Exported with the rest of your Composition
Document. Unlike general Text Events which have a common location in a
Document, a different set of Lyrics can be saved with each Line Block.

Adjusting the
Grid display

Bar Grid Vertical lines horizontally spaced across the Lyric Area indicating Bar divisions.

Beat Grid Vertical lines horizontally spaced across Bars indicating Beat divisions.

 

  



Using the Lyric Area  
Description of this Area

Items in this Area

  

Creating and
Manipulating
Lyrics

Lyric
event CREATING LYRICS

Right-click a desired location in the Lyric Area and choose New Lyric to create a new
Lyric text box. Enter desired Lyric text data in the edit box. When you are finished
entering Lyrics, click outside the edit box or press Enter on your computer's keyboard.

Alternatively, choose New Lyric from the Edit menu to create a blank Lyric text box.

 When choosing New Lyric from the Edit menu, you must first have selected an
empty Lyric Area, otherwise the New Lyric item won't be available.

EDITING LYRICS

To edit a Lyric, double click it, opening its edit box. After typing your changes, hit the
Enter key, or click someplace outside the edit box to close it.



SELECTING LYRICS

Using the Arrow tool, you can select individual Lyrics. You can select multiple Lyrics by
holding the Ctrl (or Shift) key down as you select. Alternatively, clicking and holding your
mouse button down at an empty location in the Lyric Area and dragging your mouse
over desired Lyrics allows you to select multiple Lyrics in one quick operation. Once
selected, you can then move, duplicate, copy, paste or delete a group of Lyrics at one
time using the right click, menu bar or click and drag method.

 Selecting multiple Lyrics will not be possible if the Eraser tool button at the top of
the Pianoroll Editor is currently active. In this case, Lyrics will be deleted.

MOVING LYRICS

Method 1:

Click and drag desired Lyrics to a new location in the Lyric Area.

Method 2:

Select desired Lyric with your mouse and use your computer keyboard's left/right arrow
keys to move Lyrics a Division at a time.

Method 3:

This method allows you to move Lyrics between Documents.

Right-click a Lyric and choose Cut Lyric to remove a Lyric from its current location.
Alternatively, click desired Lyric and choose Cut Lyric from the Edit menu. Using the
Ctrl (or Shift) key while selecting allows you to Cut multiple Lyrics in one operation.

Next, right-click a desired location in the Lyric Area of the desired Document's Pianoroll
or Control Draw Editor and choose Paste Lyric to Paste the Cut Lyric(s). Alternatively,
select a desired location in the Lyric Area and choose Paste Lyric from the Edit menu.

 When Align To Grid is activated, the Lyric being moved will be Pasted to the
nearest Horizontal Grid Resolution point of the selected Lyric Area location as defined in
the Text Event tab of the Grid Setup dialog box.



DUPLICATING LYRICS

Right-click a Lyric and choose Duplicate Lyric to duplicate a Lyric. Alternatively, click
desired Lyrics and choose Duplicate Lyric from the Edit menu. Using the Ctrl (or Shift)
key while selecting allows you to Duplicate multiple Lyrics in one operation.

Unlike the Copy/Paste operation which allows you to choose the location of the "copy"
before it is created, Duplicating a Lyric automatically places the "duplicate" on top of the
original, offset slightly to the right. You can then move the "duplicate" at any time.

COPYING / PASTING LYRICS

Right-click a Lyric and choose Copy Lyric to copy a Lyric. Alternatively, click desired
Lyric and choose Copy Lyric from the Edit menu. Using the Ctrl (or Shift) key while
selecting allows you to copy multiple Lyrics in one operation.

Next, right-click a desired location in the Lyric Area of the desired Document's Pianoroll
or Control Draw Editor and choose Paste Lyric to Paste the Copied Lyric(s).
Alternatively, select a desired location in the Lyric Area and choose Paste Lyric from
the Edit menu.

 When Align To Grid is activated, the Lyric being Copied will be Pasted to the
nearest Horizontal Grid Resolution point of the selected Lyric Area location as defined in
the Text Event tab of the Grid Setup dialog box.

DELETING LYRICS

Method 1:

Select the Eraser tool at the top of the Pianoroll Editor and simply click on a Lyric to
delete it. With the Eraser tool, clicking and holding your mouse button down at an empty
location in the Lyric Area and dragging the Eraser over desired Lyrics allows you to
delete multiple Lyrics in one quick operation.

Method 2:

Right-click a Lyric and choose Clear Lyric to delete a Lyric. Alternatively, click desired
Lyrics and choose Clear Lyric from the Edit menu to delete the selected Lyrics. Using
the Ctrl (or Shift) key while selecting allows you to Clear multiple Lyrics in one operation.

 

See also:

Adjusting the Grid display

 



Using the Lyric Area  
Description of this Area

Items in this Area

  

Adjusting the
Grid display

Bar Grid The Bar Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Bars (Measures) for visual reference. Choose Bar Grid from the
Grid View submenu of the View menu to show or hide the Bar Grid in the Lyric
Area, as well as the Text Info, Chord, Pianoroll and Velocity Areas of the Pianoroll
Editor.

Beat Grid The Beat Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Beats in each Bar for visual reference. (This is not necessarily
the same as the Alignment Grid.) Choose Beat Grid from the Grid View submenu
of the View menu to show or hide the Beat Grid in the Lyric Area, as well as the
Text Info, Chord, Pianoroll and Velocity Areas of the Pianoroll Editor.

 

See also:

Creating and Manipulating Lyrics

 



Pianoroll Area of the Pianoroll Editor  
Contents

Pianoroll Editor

  

Description The Pianoroll Area is the main MIDI Note Event editing area in the Pianoroll Editor.

 

Uses Many editing tools facilitate a wide range of graphical editing and creation options for Notes in
the Pianoroll Area. As usual, Notes can also be individually or collectively manipulated using the
menu command system.

 

Items MIDI Note Event
Bar Grid
Beat Grid
Pitch Grid
Interactive Keyboard display



Items in the Pianoroll Area  
Description of this Area

Using this Area

  

Manipulating
MIDI Note Events

MIDI Note Event A MIDI Note Event is MIDI data which executes Note generation.
You can create, edit, copy, move or delete MIDI Note Events as
needed.

Viewing
MIDI Note Events

Bar Grid Vertical lines horizontally spaced across the Pianoroll Area
indicating the dividing points between Bars.

Beat Grid Vertical lines horizontally spaced across Bars indicating the
dividing points between Beats.

Pitch Grid Horizontal lines vertically spaced across the Pianoroll Area
indicating the dividing points between Note Pitch values.

Interactive Keyboard
display

The keys on this piano keyboard display are aligned with the
Pianoroll Area Pitch Grid, and display Pitch occurrences during
Playback in real time. Though it can't be used by itself as a
recording instrument, it's possible to "play" this keyboard with your
mouse for Pitch reference.

 

  



Using the Pianoroll Area  
Description of this Area

Items in this Area

  

Creating and
Manipulating
MIDI Note Events

MIDI Note Event Note:

After using any of the special Tool buttons at the top of the Pianoroll
Editor, be sure to switch back to the standard Arrow Tool for regular
manipulation operations.

CREATING NEW MIDI NOTE EVENTS

Method 1:

Click the Record button in the Record Control toolbar or choose the
desired Recording command from the Record submenu of the MIDI
menu and begin playing your MIDI Instrument. Loop and Punch In/Out
regions will be automatically assigned for the length of the currently
selected Line Block. If you prefer, you can assign a specific Punch
In/Out region before activating Record. Be aware that the Track Arming
buttons found in the Document Window have no effect in the Pianoroll
Editor. Once Record is activated and you begin playing, any existing
data in the currently selected Line Block will be replaced.

Method 2:

Select the Pen tool at the top of the Pianoroll Editor and then click and
drag from left to right in the Pianoroll Area to assign the starting and
ending locations of the Note Events you are about to create. Notes will
be created as you draw; their Pitch and Length following the Pen tool's
position.

Method 3:

Select the Stamp tool at the top of the Pianoroll Editor and then click
anywhere in the Pianoroll Area to assign Note Events. Notes will be
created as you click; their Pitch and Location following the Stamp tool's
position. Use the Note Stamp toolbar to adjust the length of Notes the
Stamp tool creates. The Length and other attributes can also be
adjusted at any later time.



EDITING MIDI NOTE EVENTS

Method 1:

Using the Arrow tool, click and drag desired Note Event to a new
vertical Pitch and/or horizontal time position in the Pianoroll Area. If a
tool other than the Arrow tool is active, it will change temporarily to the
Arrow tool when positioning your mouse cursor over a Note event in
the Pianoroll Area. See also MOVING MIDI NOTE EVENTS below.

 When Align To Grid is activated, the Note Event will snap to the
nearest Grid Resolution point of the selected Pianoroll Area location as
defined in the Grid Setup dialog box.

Hovering any tool except the Eraser tool over the starting or ending
edge of a Note Event turns the tool cursor into a double arrow, allowing
you to drag the edge of the Note Event to change its length. Changing a
Note's length from its starting edge also changes its start location, while
changing a Note's length from its ending edge also changes its ending
location.

Method 2:

Use the Magic Wand tool to reCompose a region of Notes. Click the
Magic Wand tool button at the top of the Pianoroll Editor. Then, click
and hold your mouse button down at an empty location in the Pianoroll
Area and drag your mouse over desired Note Events.

Method 3:

Right Click desired Note Event and choose any one of the many
commands available from the drop-down menu or submenus.
Alternatively, click desired Note Event and choose desired command
from the Edit or Line menus. Options include Compose...,
EZcompose, Voicing..., Detect Dissonant Intervals..., Quantize...,
Transpose..., Adjust Articulation..., Adjust Velocity... and Map
Pitches....

See also CREATING NEW MIDI NOTE EVENTS above.



SELECTING MIDI NOTE EVENTS

Method 1:

Using the Arrow tool, you can select individual Note Events. You can
select multiple Note Events by holding the Ctrl (or Shift) key down as
you select. Alternatively, Clicking and holding your mouse button down
at an empty location in the Pianoroll Area and dragging your mouse
over desired Note Events allows you to select multiple Note Events in
one quick operation.

Method 2:

Using the I Beam tool, you can select all Note Events in a horizontal
(time) region at once. After selecting the I Beam button at the top of the
Pianoroll Editor, click and hold your mouse button down at an empty
location in the Pianoroll Area and drag your the I Beam horizontally
over the desired Note Event region.

Selecting Note Events enables use of Note Event related commands
under the Edit and Line Menu bar items. Once selected, you can then
move, copy, paste or delete a group of Note Events at one time using
the right click, menu bar or click and drag method.

 Selecting entire Note regions will not be possible if the Pen, Line,
Oval or Eraser tool button at the top of the Pianoroll Editor is currently
active. In these cases, Note Events will be created or deleted
(depending on which of these buttons is active).



MOVING MIDI NOTE EVENTS

Method 1:

Using the Arrow tool, click and drag desired Note Events to a new
location in the Pianoroll Area. Any vertical motion during your dragging
operation will effect the Note's Pitch as well. See EDITING MIDI NOTE
EVENTS above.

 When Align To Grid is activated, the Note Event will snap to the
nearest Grid Resolution point of the selected Pianoroll Area location as
defined in the Grid Setup dialog box.

Method 2:

Select a Note Event with your mouse and use the arrow keys on your
computer's keyboard to move the selected Note with more precision.
The up/down arrow keys move a Note's Pitch by intervals (half steps),
and the left/right arrow keys move a Note's location in time by Divisions.

Method 3:

This method allows you to move Note Events between Documents.

Right-click a Note Event and choose Cut Note Event to remove a Note
Event from its current location. Alternatively, click desired Note Event
and choose Cut Note Event from the Edit menu. Using the Ctrl (or
Shift) key while selecting allows you to Cut multiple Note Events in one
operation.

Next, right-click a desired location in the Pianoroll Editor's Pianoroll
Area of the desired Document and choose Paste Note Event to Paste
the Cut Note Event(s). Alternatively, select a desired location in the
Pianoroll Area and choose Paste Note Event from the Edit menu.

 When Align To Grid is activated, the Note Event being moved will
be Pasted to the nearest Horizontal Grid Resolution point of the
selected Pianoroll Area location as defined in the Grid Setup dialog box.



COPYING / PASTING MIDI NOTE EVENTS

Right-click a Note Event and choose Copy Note Event to copy a Note
Event. Alternatively, click desired Note Event and choose Copy Note
Event from the Edit menu. Using the Ctrl (or Shift) key while selecting
allows you to copy multiple Note Events in one operation.

Next, right-click a desired location in the Pianoroll Editor's Pianoroll
Area of the desired Document and choose Paste Note Event to Paste
the Copied Note Event(s). Alternatively, select a desired location in the
Pianoroll Area and choose Paste Note Event from the Edit menu.

 When Align To Grid is activated, the Note Event being Copied will
be Pasted to the nearest Horizontal Grid Resolution point of the
selected Pianoroll Area location as defined in the Grid Setup dialog box.

DELETING MIDI NOTE EVENTS

Method 1:

Select the Eraser tool at the top of the Pianoroll Editor and simply click
on a Note Event to delete it. With the Eraser tool, clicking and holding
your mouse button down at an empty location in the Pianoroll Area and
dragging the Eraser over desired Note Events allows you to delete
multiple Note Events in one quick operation.

Method 2:

Right-click a Note Event and choose Clear Note Event to delete a Note
Event. Alternatively, click desired Note Event and choose Clear Note
Event from the Edit menu. Using the Ctrl (or Shift) key while selecting
allows you to Clear multiple Note Events in one operation.

 

See also:

Viewing MIDI Note Events

 



Using the Pianoroll Area  
Description of this Area

Items in this Area

  

Viewing
MIDI Note Events

Bar Grid The Bar Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Bars (Measures) for visual reference. Choose Bar Grid
from the Grid View submenu of the View menu to show or hide the Bar Grid
in the Pianoroll Area, as well as the Text Info, Chord, Lyric and Velocity Areas
of the Pianoroll Editor.

Beat Grid The Beat Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Beats in each Bar for visual reference. (This is not
necessarily the same as the Alignment Grid.) Choose Beat Grid from the Grid
View submenu of the View menu to show or hide the Beat Grid in the
Pianoroll Area, as well as the Text Info, Chord, Lyric and Velocity Areas of the
Pianoroll Editor.

Pitch Grid The Pitch Grid is a pattern of evenly spaced horizontal lines marking vertical
divisions between Note Pitches for visual reference. (This is not necessarily
the same as the Alignment Grid.) Choose Pitch Grid from the Grid View
submenu of the View menu to show or hide the Pitch Grid in the Pianoroll
Area.

 

See also:

Creating and Manipulating MIDI Note Events

 



Text Info Area of the Pianoroll Editor  
Contents

Pianoroll Editor

  

Description The Text Info Area displays general Text Information in a continuous row, parallel to the Bar
Area. It allows you to create/display Text Events such as Rehearsal Letters and Markers.

 

Uses You can create, edit, copy, duplicate, move or delete Rehearsal Letters and Markers in the Text
Info Area as needed. These items can help you organize your composition Document to more
quickly locate a particular point in your music. These settings can then be saved with the
Document.

 

Items Rehearsal Letter event
Marker <From> event
Marker <To> event
Bar Grid
Beat Grid

 



Items in the Text Info Area  
Description of this Area

Using this Area

  

Creating
Text Events

Rehearsal Letter
event

Rehearsal Letters such as A or B, generally appearing at obvious
musical phrase boundaries, serve to provide Bar markings for
rehearsal. These Text Events can also be phrases such as "Verse",
"Chorus", "Head", Bridge", or anything you desire. You can create, edit,
copy, duplicate, move or delete Rehearsal Letters as needed.

Marker <From><To>
events

Markers serve to provide Cue markings for rehearsal or sequencing
work. You can use either <From> or <To> depending on your needs.
You can create, edit, copy, duplicate, move or delete Markers as
needed.

Adjusting the
Grid display

Bar Grid Vertical lines horizontally spaced across the Text Info Area indicating
the dividing points between Bars.

Beat Grid Vertical lines horizontally spaced across Bars indicating the dividing
points between Beats.

 



Using the Text Info Area  
Description of this Area

Items in this Area

  

Creating
and Manipulating
Text Events

Rehearsal Letter
event CREATING A REHEARSAL LETTER

Right-click a desired location in the Text Info Area and choose New
Rehearsal Letter to create a blank Rehearsal Letter. Enter desired text
data in the edit box. When you are finished entering Text, click outside
the edit box or press Enter on your computer's keyboard.

Alternatively, choose New Text Event... from the Edit menu to create a
blank Rehearsal Letter. The New Text Event dialog box will open
allowing you to choose a Rehearsal Letter, Marker <from> or Marker
<To> text event.

 When choosing New Text Event... from the Edit menu, you must
first have selected an empty Text Info Area, otherwise the New Text
Event... item won't be available.

Marker <From>
Marker <To>
events

CREATING A MARKER

Right-click a desired location in the Text Info Area and choose New
Marker <From> or New Marker <To> to create a blank Marker. Enter
desired text data in the edit box. When you are finished entering or
editing Text, click outside the edit box, or press Enter on your
computer's keyboard.

Alternatively, choose New Text Event... from the Edit menu to create a
blank Marker. The New Text Event dialog box will open allowing you to
choose a Rehearsal Letter, Marker <from> or Marker <To> text event.

 When choosing New Text Event... from the Edit menu, you must
first have selected an empty Text Info Area, otherwise the New Text
Event... item won't be available.

 

EDITING TEXT EVENTS

To edit a Text Event, double click it to open its edit box. After typing
your changes, hit the Enter key, or click someplace outside the edit box
to close it.



SELECTING TEXT EVENTS

Using the Arrow tool, you can select individual Text Events. You can
select multiple Text Events by holding the Ctrl (or Shift) key down as
you select. Alternatively, clicking and holding your mouse button down
at an empty location in the Text Info Area and dragging your mouse
over desired Text Events allows you to select multiple Text Events in
one quick operation. Once selected, you can then move, duplicate,
copy, paste or delete a group of Text Events at one time using the right
click, Menu Bar or click and drag method.

 Selecting multiple Text Events will not be possible if the Eraser tool
button at the top of the Pianoroll Editor is currently active. In this case,
Text Events will be deleted one at a time; each with a click of your
mouse.

MOVING TEXT EVENTS

Method 1:

Click and drag desired Text Events to a new location in the Text Info
Area.

Method 2:

Select desired Text Event with your mouse and use your computer
keyboard's left/right arrow keys to move Text Events a Division at a
time.

Method 3:

This method allows you to move Text Events between Documents.

Right-click a Text Event and choose Cut Text Event to remove a Text
Event from its current location. Alternatively, click desired Text Event
and choose Cut Text Event from the Edit menu. Using the Ctrl (or
Shift) key while selecting allows you to Cut multiple Text Events in one
operation.

Next, right-click a desired location in the Text Info Area of the desired
Document's Pianoroll, Control Draw or Tempo Draw Editor or Document
Window and choose Paste Text Event to Paste the Cut Text Event(s).
Alternatively, select a desired location in the Text Info Area and choose
Paste Text Event from the Edit menu.

 When Align To Grid is activated, the Text Event being moved will
be Pasted to the nearest Horizontal Grid Resolution point of the



selected Text Info Area location as defined in the Grid Setup dialog box.

DUPLICATING TEXT EVENTS

Right-click a Text Event and choose Duplicate Text Event to duplicate
a Text Event. Alternatively, click desired Text Events and choose
Duplicate Text Event from the Edit menu. Using the Ctrl (or Shift) key
while selecting allows you to Duplicate multiple Text Events in one
operation.

Unlike the Copy/Paste operation which allows you to choose the
location of the "copy" before it is created, Duplicating a Text Event
automatically places the "duplicate" on top of the original, offset slightly
to the right. You can then move the "duplicate" at any time.

COPYING / PASTING TEXT EVENTS

Right-click a Text Event and choose Copy Text Event to copy a Text
Event. Alternatively, click desired Text Event and choose Copy Text
Event from the Edit menu. Using the Ctrl (or Shift) key while selecting
allows you to copy multiple Text Events in one operation.

Next, right-click a desired location in the Text Info Area of the desired
Document's Pianoroll, Control Draw or Tempo Draw Editor or Document
Window and choose Paste Text Event to Paste the Copied Text
Event(s). Alternatively, select a desired location in the Text Info Area
and choose Paste Text Event from the Edit menu.

 When Align To Grid is activated, the Text Event being Copied will
be Pasted to the nearest Horizontal Grid Resolution point of the
selected Text Info Area location as defined in the Grid Setup dialog box.

DELETING TEXT EVENTS

Method 1:

Select the Eraser tool at the top of the Pianoroll Editor and simply click
on a Text Event to delete it. With the Eraser tool, clicking and holding
your mouse button down at an empty location in the Text Info Area and
dragging the Eraser over desired Text Events allows you to delete
multiple Text Events in one quick operation.

Method 2:

Right-click a Text Event and choose Clear Text Event to delete a Text
Event. Alternatively, click desired Text Events and choose Clear Text
Event from the Edit menu. Using the Ctrl (or Shift) key while selecting
allows you to Clear multiple Text Events in one operation.



 

See also:

Adjusting the Grid display

 



Using the Text Info Area  
Description of this Area

Items in this Area

  

Adjusting the
Grid display

Bar Grid The Bar Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Bars (Measures) for visual reference. Choose Bar Grid from the
Grid View submenu of the View menu to show or hide the Bar Grid in the Text Info
Area, as well as the Chord, Lyric, Pianoroll and Velocity Areas.

Beat Grid The Beat Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Beats in each Bar for visual reference. (This is not necessarily
the same as the Alignment Grid.) Choose Beat Grid from the Grid View submenu
of the View menu to show or hide the Beat Grid in the Text Info Area, as well as the
Chord, Lyric, Pianoroll and Velocity Areas.

See also:

Creating and Manipulating Text Events

 



Velocity Area of the Pianoroll Editor  
Contents

Pianoroll Editor

  

Description The Velocity Area allows you to graphically edit Velocity values of Notes in the Pianoroll Editor.

 

Uses Choose the desired editing tool and simply draw desired changes in the Velocity Area with your
mouse.

 

Items MIDI Velocity Event
Bar Grid
Beat Grid
Velocity Grid
Velocity Scale
Location Cursor

 



Items in the Velocity Area  
Description of this Area

Using this Area

  

Manipulating
MIDI Velocity Events

MIDI Velocity Event A MIDI Velocity Event is MIDI data which executes a MIDI
Volume (or attack) command at the beginning of each Note. As
such, it is a component of Note data for most practical purposes.
You can create, edit, copy, move or delete MIDI Velocity Events,
but in reality it is mostly the Note being manipulated. Except for
editing actual Velocity values, perform most of these operations
on Notes in the Pianoroll Area of the Pianoroll Editor or other
Note related Editors.

Adjusting the
Grid display

Bar Grid Vertical lines horizontally spaced across the Velocity Area
indicating the horizontal dividing points between Bars.

Beat Grid Vertical lines horizontally spaced across Bars indicating the
dividing points between Beats.

Velocity Grid Horizontal lines vertically spaced across the Velocity Area
indicating the vertical dividing points between Velocity data
values.

Velocity Scale Located on the left side of the Velocity Area, this Scale displays
the Velocity range of the vertical Velocity Grid in the Velocity
Area of the Pianoroll Editor.

Location Cursor A horizontal Location Cursor line in the Velocity Scale represents
the vertical position of your mouse as it relates to Velocity in the
Draw Area of the Control Draw Editor. Corresponding numerical
information is also displayed in the Interactive Information area at
the bottom of the Pianoroll Editor. The color of the Location
Cursor depends on your settings in the Microsoft Windows
Control Panel "Display" applet, under the heading "Selected
Items" in the "Items" list of the "Appearance" pane.



 

  



Using the Velocity Area  
Description of this Area

Items in this Area

  

Manipulating
MIDI Velocity Events

MIDI Velocity Event Note:

While Velocity data can be manipulated separately, it exists
as a component of Notes. For example, when you create a
Note Event, there is "NOTE ON", "VELOCITY", "PITCH" and
"NOTE OFF" data involved. As a result, performing operations
like Cut/Paste on a Velocity Event actually acts upon its
related Note. For this reason, most of the Velocity commands
listed here are deferred to the Pianoroll Area of the Pianoroll
Editor. Other note related Editors such as the Event List and
Notation Editors are also good alternatives.

Draw operations require use of special Tools. After using any
of the special Tool buttons at the top of the Pianoroll Editor,
be sure to switch back to the standard Arrow Tool for regular
manipulation operations.

CREATING NEW MIDI VELOCITY EVENTS

There are many ways to create Notes in CAMPS. To create
Notes and their associated Velocity Events in the Pianoroll
Editor, see CREATING NEW MIDI NOTE EVENTS in the
Pianoroll Area.

EDITING MIDI VELOCITY EVENTS

Method 1:

Using the Arrow tool, click and drag desired Velocity Event to
a new vertical value position the Velocity Area..

 When Align To Grid is activated, the Velocity Event will
snap to the nearest Grid Resolution point of the selected
Velocity Area location as defined in the Grid Setup dialog box.

Method 2:



Three Drawing tools are provided for various drawing results:

Select the Pen tool button at the top of the Pianoroll Editor to
edit Velocity Events by freely drawing their vertical position.

Select the Line tool button at the top of the Pianoroll Editor to
edit Velocity Events by directing them with an automatic
straight line from the point you start dragging to your present
cursor location.

Select the Oval tool button at the top of the Pianoroll Editor to
edit Velocity Events by directing them with an automatic
curved line from the point you start dragging to your present
cursor location.

Using one of these tools, click and hold your mouse button
down at the desired location in the Velocity Area and drag
your mouse horizontally over Velocity Events while defining
Velocity level with vertical cursor control.

Method 3:

Select a Velocity Event with your mouse and use the arrow
keys on your computer's keyboard to move the selected Event
with more precision. The up/down arrow keys move a Velocity
Event's value by single increments.

Method 4:

Right Click desired Velocity Event and choose Adjust
Velocity... from the Actions submenu. Alternatively, click
desired Velocity Event and choose Adjust Velocity from the
Line menu.

SELECTING MIDI VELOCITY EVENTS

Method 1:

Using the Arrow tool, you can select individual Velocity
Events. You can select multiple Velocity Events by holding the
Ctrl (or Shift) key down as you select. Alternatively, Clicking
and holding your mouse button down at an empty location in
the Velocity Area and dragging your mouse over desired
Velocity Events allows you to select multiple Velocity Events
in one quick operation.

Method 2:

Using the I Beam tool, you can select all Velocity Events in a
horizontal (time) region at once. After clicking the I Beam
button at the top of the Pianoroll Editor, click and hold your
mouse button down at an empty location in the Velocity Area
and drag your mouse horizontally over the desired Velocity
Event region.



Selecting Velocity Events enables use of Velocity Event
related commands under the Edit and Line Menu bar items.
Once selected, you can then move, copy, paste or delete a
group of Velocity Events at one time using the right click,
menu bar or click and drag method.

 Selecting entire Velocity regions will not be possible if the
Pen, Line, Oval or Eraser tool button at the top of the
Pianoroll Editor is currently active. In these cases, Velocity
Events will be moved or deleted (depending on which of these
buttons is active).

MOVING MIDI VELOCITY EVENTS

It is possible to move Velocity Events and their accompanying
Pitch data using the same kind of MOVE options provided in
similar editing areas of CAMPS. However, since moving
Velocity Events is in reality moving Note Events, we suggest
you see MOVING MIDI NOTE EVENTS in the Pianoroll Area
of the Pianoroll Editor.

COPYING / PASTING MIDI VELOCITY EVENTS

This operation is basically the same as Copying/Pasting Note
Events. Since this operation is readily executable in the
Velocity Area of the Pianoroll Editor, it is included here for
completeness. However, we recommend you refer to
COPYING / PASTING MIDI NOTE EVENTS in the Pianoroll
Area.

Right-click a Velocity Event and choose Copy Note Event to
copy a Velocity Event. Alternatively, click desired Velocity
Event and choose Copy Note Event from the Edit menu.
Using the Ctrl (or Shift) key while selecting allows you to copy
multiple Velocity Events in one operation.

Next, right-click a desired location in the Pianoroll Editor's
Velocity Area of the desired Document and choose Paste
Note Event to Paste the Copied Velocity Event(s).
Alternatively, select a desired location in the Velocity Area and



choose Paste Note Event from the Edit menu.

DELETING MIDI VELOCITY EVENTS

Once again, these operations are actually acting upon Note
Events. Since this operation is readily executable in the
Velocity Area of the Pianoroll Editor, it is included here for
completeness.

Method 1:

Select the Eraser tool at the top of the Pianoroll Editor and
simply click on a Velocity Event to delete it. With the Eraser
tool, clicking and holding your mouse button down at an
empty location in the Velocity Area and dragging the Eraser
over desired Velocity Events allows you to delete multiple
Velocity Events in one quick operation.

Method 2:

Right-click a Velocity Event and choose Clear Note Event to
delete a Velocity Event. Alternatively, click desired Velocity
Event and choose Clear Note Event from the Edit menu.
Using the Ctrl (or Shift) key while selecting allows you to Clear
multiple Velocity Events in one operation.

 

See also:

Adjusting the Grid display

 



Using the Velocity Area  
Description of this Area

Items in this Area

  

Adjusting the
Grid display

Bar Grid The Bar Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Bars (Measures) for visual reference. Choose Bar Grid from
the Grid View submenu of the View menu to show or hide the Bar Grid in the
Velocity Area, as well as the Text Info, Chord, Lyric and Pianoroll Areas of the
Pianoroll Editor.

Beat Grid The Beat Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Beats in each Bar for visual reference. (This is not
necessarily the same as the Alignment Grid.) Choose Beat Grid from the Grid
View submenu of the View menu to show or hide the Beat Grid in the Velocity
Area, as well as the Text Info, Chord, Lyric and Pianoroll Areas of the Pianoroll
Editor.

Velocity Grid The Velocity Grid is a pattern of evenly spaced horizontal lines marking vertical
divisions between Velocity values for visual reference. (This is not necessarily
the same as the Alignment Grid.) Choose Velocity Grid from the Grid View
submenu of the View menu to show or hide the Velocity Grid in the Velocity
Area.

See also:

Manipulating MIDI Velocity Events

 



 

Opening From the
Document Window

First, select a desired Line Block. Then, either choose Pianoroll Editor
from the Editors menu, or simply click the Pianoroll Editor button at the
top of the Document Window.

From the...
Event List Editor
Pianoroll Editor
Control Draw Editor
Notation Editor

Choose Pianoroll Editor from the Editors menu, or simply click the
Pianoroll Editor button at the top of the Editor Window.

 



Opening Opening a Document Choose Open... from the File menu to open previously saved
CAMPS v4 Documents, as well as CAMPS v3 ( for Mac )
Documents and Standard MIDI Files ( S.M.F.).

 When opening a Standard MIDI File, CAMPS automatically
analyzes Line data and assigns appropriate Line Blocks and one of
six Category settings to each Track. You can alter these settings at
any time.

Creating a new Document Choose New from the File menu to create a new blank Document
Window. To set defaults for new Documents, choose New Setup...
from the File menu, opening the New Document Setup dialog box.

 



Event List Editor  
Contents

Editors

  

Description The Event List Editor allows you to directly edit a Line Block's MIDI Note, Control and Lyric Event
data values. Events are listed vertically from the top down.

 

Items The Event List Editor contains several Buttons and Data columns for manipulating MIDI Control
Events. You can choose to Show or Hide the Buttons with the Edit Buttons command in the
View menu. You can adjust the horizontal size of each Column by clicking and dragging the
vertical separator bar between column headers at the top.

Edit Buttons The Edit Buttons give you quick access to manipulation tools for the
Event List Editor, as well as many of the Editors available in CAMPS.

Playback Pointer Area The Playback Pointer Area displays the Playback Pointer, and allows
you to manipulate Loop and Punch In/Out functions.

List Area The List Area displays MIDI Note and Control Event data in the
currently selected Line Block, listed vertically from the top down. Each
Event's data appears in a horizontal row, and all data fields can be
directly edited.

 



Opening From the
Document Window

First, select a desired Line Block. Then, either choose Event List Editor
from the Editors menu, or simply click the Event List Editor button at the
top of the Document Window.

From the...
Event List Editor
Pianoroll Editor
Control Draw Editor
Notation Editor

Choose Event List Editor from the Editors menu, or simply click the
Event List Editor button at the top of the Editor Window.

 



Edit Buttons Area of the Event List Editor  
Contents

Event List Editor

  

Description The Edit Buttons at the top of the Event List Editor give you quick access to frequently used
items, such as View settings and Editors.

 

Uses The Edit Buttons include many of the View and Editors menu commands. Choose Edit Buttons
from the View menu to show or hide the Edit Buttons.

 

Items Auto Scroll button
Jump To Location button
Playback button
Playback with Others button
Event List Editor button
Pianoroll Editor button
Control Draw Editor button
Notation Editor button

 



Items in the Edit Buttons Area  Description of this Area

  

Adjusting
View

Auto Scroll
button

Sets the viewable area in the List Area to follow the Playback Pointer
during Playback and Recording.

Jump To Location
button

Opens the Jump To Location dialog box which allows you to move the
current viewpoint to a specified Bar in the Event List Editor.

Playback
button

Starts Audition Playback of the currently selected MIDI Events with an
automatically inserted Playback Loop. If no Control Events are selected,
CAMPS begins Playback from the currently selected Line Block with no
Loop.

Playback with Others
button

Starts Audition Playback of the currently selected MIDI Events with an
automatically inserted Playback Loop along with all the other activated
Tracks in the same Bar region. If no Control Events are selected, CAMPS
begins Playback from the currently selected Line Block with no Loop.

Opening
Editors

Event List Editor
button

Opens a new Event List Editor window, allowing you to make alternate
MIDI Event edits of the selected Line Block.

Pianoroll Editor
button

Opens the Pianoroll Editor, allowing you to edit Notes of the selected Line
Block in Pianoroll graph format.

Control Draw Editor
button

Opens the Control Draw Editor, allowing you to edit a Line Block's MIDI
Event data with a unique freestyle curve drawing method.

Notation Editor
button

Opens the Notation Editor, allowing you to edit Notes of the selected Line
Block in Musical Notation form.

 

 



List Area of the Event List Editor  
Contents

Event List Editor

  

Description The List Area is the main MIDI Event editing area of the Event List Editor.

 

Uses The List Area allows you to quickly create and edit MIDI data one Event at a time. The Event
data can be displayed in Hexadecimal or Decimal format, and the End Location (Event ending
point) can be displayed using Bars, Beats and Divisions, or as a duration value expressed in
MIDI time Divisions. To edit an Event value, double click the desired data field and make your
changes in the edit or dialog box which opens.

 

Items MIDI Event
Event Icon column
Start Location column
Data column
End Location column
Event Selector button
Display Mode Selector buttons

 



Items in the List Area  
Description of this Area

Using this Area

  

Manipulating
Events

MIDI Event A MIDI Event is MIDI data which executes MIDI commands, including
Note generation, Control changes and Lyrics. You can create, edit,
copy, move or delete MIDI Events as needed.

Event Icon
column

This column displays any applicable Event Icons for MIDI Events, and
allows you to select an Event. Click on an Event's Icon in the far left
column of the List Area, or in an Event's data row between any of the
data fields to select an Event and all its data.

Start Location
column

This column displays the Playback Start Location of MIDI Events in
the format [Bar:Beat:Divisions].

Data
column

This column displays MIDI Event Data in the format [Value Name
Velocity]. While the data in the Value field is always an absolute MIDI
Value, the data in the Name field changes depending on the type of
MIDI Event. The Velocity field only displays a value for Events
containing Velocity data. Additionally, the value display format
depends on your settings with this column's Display Mode Selector
button.

End Location
column

This column displays the Playback End point of MIDI Events. The
display format depends on your settings with this column's Display
Mode Selector button.

Adjusting
Event
Display

Event Selector
button

The Event Selector button resides at the top of the Event Icon
column. Clicking this button opens the Event menu which allows you
to either change individual Events' show/hide status or open the
Displayed Events dialog box.

Display Mode Selector
buttons

These buttons reside at the top of the Data and End Location
columns.

The Data column's Display Mode Selector button allows you to
choose between Hexadecimal (base 16) or Decimal (base 10)
rendering of the data in an Event's Value and Velocity fields.

The End Location column's Display Mode Selector button allows you
to choose between an Event's End point expressed as
[Bar:Beat:Divisions], or an Event's duration expressed in Divisions.



 

  



Using the List Area  
Description of this Area

Items in this Area

  

Adjusting the
List display

Event Selector
button

Click the Event Selector button to open the Event menu. You can then
select whether to show or hide individual Events. A checkmark appears
next to Event names set to Show. The bottom choice in the Event menu
opens the Displayed Events dialog box. The Displayed Events dialog
box allows you to set all desired Event Types to be displayed, while the
rest of the Event menu only allows selection one at a time.

Display Mode
Selector
buttons

Click the Data column's Display Mode Selector button to open the Data
column's Display Mode menu. You can then choose between
Hexadecimal (base 16) or Decimal (base 10) rendering of the data
values in an Event's Value and Velocity fields. A checkmark appears
next to the currently selected option. MIDI equipment documentation
may describe values in either form, or you may be more familiar with
one of them. This adjustment is intended to ease your interpretation of
the data. It effects display of the data column for an entire Event List.

Click the End Location column's Display Mode Selector button to open
the End Location's Display Mode menu. You can then choose between
Event end point expressed as [Bar:Beat:Divisions], or Event duration
expressed in Divisions. A checkmark appears next to the currently
selected option. This effects display of the End Location column for an
entire Event List.

 



See also:

Creating and Manipulating MIDI Events

 



Using the List Area  
Description of this Area

Items in this Area

  

Creating and
Manipulating
MIDI Events

MIDI Event
CREATING NEW MIDI EVENTS

Method 1:

Click the Record button in the Record Control toolbar or choose the desired
Recording command from the Record submenu of the MIDI menu and begin
playing your MIDI Instrument. Loop and Punch In/Out regions will be automatically
assigned for the length of the currently selected Line Block. If you prefer, you can
assign a specific Punch In/Out region before activating Record. Be aware that the
Track Arming buttons found in the Document Window have no effect in the Event
List Editor. Once Record is activated and you begin playing, any existing data in
the currently selected Line Block will be replaced.

Method 2:

Right click a desired location in the List Area and choose the desired Event Type
to be inserted. Alternatively, click the desired location in the List Area and choose
New Event... from the Edit menu to open the New Event dialog box.



EDITING MIDI EVENTS

Method 1:

Double click the desired data field to open its edit or dialog box, depending on the
Event Type. With edit boxes, you can use the up/down buttons or directly edit the
values with your computer's keyboard. In dialog boxes, edit the data field as
desired and click OK.

Method 2:

Click the desired Event and choose desired command from the Line menu.
Available commands will vary depending on the Type of Event selected.

See also CREATING NEW MIDI EVENTS above.

SELECTING MIDI EVENTS

Using the Arrow tool, you can select individual MIDI Events. You can select
multiple MIDI Events by holding the Ctrl (or Shift) key down as you select. Once
selected, you can then move, copy, paste or delete a group of MIDI Events at one
time using the right click, menu bar or click and drag method.

Selecting MIDI Events enables use of MIDI Event related commands under the
Edit and Line menu bar items.



MOVING MIDI EVENTS

Method 1:

Click and drag desired MIDI Events to a new location in the Event List Area. As
you drag an Event through the Event List, a black horizontal bar appears between
existing Events indicating possible destinations. When this bar appears at the
desired location, release your mouse button to drop the Event being moved to the
new location.

Method 2:

This method allows you to move MIDI Events between Documents.

Right-click a MIDI Event and choose Cut Event to remove a MIDI Event from its
current location. Alternatively, click desired MIDI Event and choose Cut Event
from the Edit menu. Using the Ctrl (or Shift) key while selecting allows you to Cut
multiple MIDI Events in one operation.

Next, right-click a desired location in the desired Document's Event List Editor and
choose Paste Event to Paste the Cut MIDI Event(s). Alternatively, select a
desired location in the List Area and choose Paste Event from the Edit menu.

 The MIDI Event being moved will be Pasted immediately after the selected
destination Event's location in the List.



COPYING / PASTING MIDI EVENTS

Right-click a MIDI Event and choose Copy Event to copy it. Alternatively, click
desired MIDI Event and choose Copy Event from the Edit menu. Using the Ctrl
(or Shift) key while selecting allows you to copy multiple MIDI Events in one
operation.

Then, right-click a desired location in the desired Document's Event List Editor and
choose Paste Event to Paste the Copied MIDI Event(s). Alternatively, select a
desired location in the List Area and choose Paste Event from the Edit menu.

 The MIDI Event being copied will be Pasted immediately after the selected
destination Event's location in the List.



DELETING MIDI EVENTS

Right-click a MIDI Event and choose Clear Event to delete it. Alternatively, click
desired MIDI Event and choose Clear Event from the Edit menu. Using the Ctrl
(or Shift) key while selecting allows you to Clear multiple MIDI Events in one
operation.

 

See also:

Adjusting the List display

 



Playback Pointer Area of the Event List Editor  
Contents

Event List Editor

  

Description The Playback Pointer Area displays the current Playback location as well as Loop and Punch
In/Out regions.

 

Uses The Playback Pointer Area allows you to manage the location of the Playback Pointer, as well as
the Playback Loop and Punch In/Out Recording settings.

 

Items Playback Pointer
Loop region
Punch In/Out region

 



Items in the Playback Pointer Area  
Description of this Area

Using this Area

  

Positioning the
Playback Pointer

Playback Pointer The Playback Pointer resides in its own dark gray column in the far left
side of the Event List Editor window. It displays the current Playback
location in the Event List Editor and allows you to change the current
Playback point.

Inserting a
Playback Loop

Loop
region

Displays your current Loop region. Starting Playback repeats (Loops)
Playback in this region until you stop. A Loop region is indicated
vertically by the color blue to the right of the dark gray Playback Pointer
column.

Inserting a
Punch In/Out
Record region

Punch In/Out
region

Displays your current Punch In/Out region. Recording becomes active
in this region of the currently selected Line Block as the Playback
Pointer travels through it. A Punch In/Out region is indicated vertically
by the color magenta between the Loop region and the Event Icon
column.

 

  



Using the Playback Pointer Area  
Description of this Area

Items in this Area

  

Positioning the
Playback Pointer

Playback Pointer
and area

Unlike most of the other Editors in CAMPS, the Event List Editor's
Playback displays vertically instead of horizontally. Since data is listed
in actual sequence without respect to musical Bars, Playback display
movement is not linear. For example, a large group of Pitch Bend data
assigned to the same Note Event will cause the vertical Playback
Pointer motion to accelerate through those Events as it stays
synchronized with a song's Bar location during Playback.

You can use the Playback Pointer to change the Playback point in the
Event List Editor in two ways: Clicking a desired location in the dark
gray Playback Pointer area on the left, or clicking and dragging the
Playback Pointer vertically to a desired location. Choose Play from the
MIDI menu (or click the Play button in the Playback Control toolbar) to
begin Playback. The Playback Pointer displays the current Playback
location as CAMPS plays or records MIDI data.

Inserting a
Playback Loop

Loop
region

You can create a Loop region by clicking and dragging with your mouse
vertically in the Loop Area, to the right of the Playback Pointer Area. As
you drag your mouse, the Loop region appears blue in color, displaying
a new Loop region. A Punch In/Out region of the same size is
automatically inserted to the right of the new Loop region.

Choose Play from the MIDI menu (or click the Play button in the
Playback Control toolbar) to begin Playback. CAMPS repeats Loop
region Playback until you stop it.

 The start and end points of the Loop region snap to the nearest
vertical Event boundary. Click anywhere in the Loop Area to delete a
Loop region.

Inserting a
Punch In/Out
Record region

Punch In/Out
region

You can create a Punch In/Out region by clicking and dragging your
mouse vertically in the Punch In/Out Area to the right of the Loop Area.
As you drag your mouse, this region appears magenta, displaying a
new Punch In/Out region. A Loop of the same size is automatically
inserted to the left of the new Punch In/Out region.

 The start and end points of the Punch In/Out region snap to the
nearest vertical Event boundary. Click anywhere in the Punch In/Out
Area to delete a Punch In/Out region.

Choose Record from the MIDI menu (or click the Record button in the
Record Control toolbar) to begin recording.

If the automatically inserted Playback Loop is removed, CAMPS begins
Playback from the Playback Pointer's current position, but Recording is
only active as the Playback Pointer travels through the Punch In/Out
region. This provides a true Cued Punch In/Out environment.

 By combining with a Loop region beginning before the Punch
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In/Out region, CAMPS provides a continuous Cued Punch In/Out
recording environment. Remove the automatically inserted Loop and
insert a new one starting before the Punch In/Out region, or remove the
Punch In/Out region and insert a new one starting after the Loop
region.

 

  



Displayed Events dialog box  
Contents

Dialog Boxes

  

Description The Displayed Events dialog box allows you to choose which MIDI Events appear in the Event
List Editor.

Uses Simply click the corresponding buttons to enable display of desired MIDI Event Types. Clicking a
button again disables its corresponding Event Type display. This allows you to choose a "set" of
Events to work on without repeatedly clicking the Event Selector button in the Event List Editor
to set each Event Type's show/hide status individually. The Displayed Events dialog box does
not deactivate or delete any actual Events.

  

Items Note
button

Click this button to enable display of MIDI Note data Events in the Event
List Editor. For Tonal (Melodic and Chordal) Instrument Programs, these
Events represent Pitch and duration. For Drum Programs, these Events
usually translate to different different Drum Sounds (Instruments).

Control Change
button

Click this button to enable display of MIDI Control Change data Events in
the Event List Editor. Typical Control Change Events are Volume and
Pan settings.

Poly After Touch
button

Click this button to enable display of MIDI Poly After Touch data Events
in the Event List Editor. These Events represent a change in MIDI
Instrument key pressure after initial attack on an individual key basis,
which can be used to trigger modulation (vibrato) or a second sound, for
example.

Channel After Touch
button

Click this button to enable display of MIDI Poly After Touch data Events
in the Event List Editor. These Events represent a change in MIDI
Instrument key pressure after initial attack on a MIDI channel-wide basis
(all keys), which can be used to trigger modulation (vibrato) or a second
sound, for example.

Program Change
button

Click this button to enable display of MIDI Program Change data Events
in the Event List Editor. These Events control Synth Module Program
(Patch) selection, representing different sounds (Musical Instruments).

Pitch Bend
button

Click this button to enable display of MIDI Pitch Bend data Events in the
Event List Editor. These Events represent the position of a Pitch Bending
control on your MIDI Instrument, such as a control wheel or joystick.

Lyric
button

Click this button to enable display of MIDI Lyric data Events in the Event
List Editor. These Events represent Song Lyric Text embedded in a MIDI
Document.

System Exclusive
button

Click this button to enable display of MIDI System Exclusive data Events
in the Event List Editor. These are typically proprietary Events used
differently by each MIDI Device for special functions such as Mode
Change or Data Loading.

OK
button Closes the Displayed Events dialog box and commits changes.

Cancel
button Closes the New Text Event dialog box without committing changes.

Help
button Opens this Help document.



 

  

Opening From the
Event List Editor

Choose Select Event Types... from the List View submenu of the View
menu.
Alternatively, click the Displayed Events (Checkmark) button at the top of
the event column on the left side of the Event List Editor window and choose
Select Event Types....

  



New Event dialog box  
Contents

Dialog Boxes

  

Description The New Event dialog box allows you to add a new MIDI Event to your Line data.

Uses After selecting desired location in the Event List and opening the New Event dialog box, click the
corresponding Event type button for the New Event you wish to create. This closes the New
Event dialog box and inserts your New Event immediately following the Event selected when
opening the New Event dialog box.

  

Items Note
button

The Note button inserts a new MIDI Note Event and closes the New
Event dialog box.

Control Change
button

The Control Change button inserts a new MIDI Control Change Event
and closes the New Event dialog box.

Poly After Touch
button

The Poly After Touch button inserts a new MIDI Poly After Touch Event
and closes the New Event dialog box.

Channel After Touch
button

The Channel After Touch button inserts a new MIDI Channel After Touch
Event and closes the New Event dialog box.

Program Change
button

The Program Change button inserts a new MIDI Program Change Event
and closes the New Event dialog box.

Pitch Bend
button

The Pitch Bend button inserts a new MIDI Pitch Bend Event and closes
the New Event dialog box.

Lyric
button

The Lyric button inserts a new MIDI Lyric Event and closes the New
Event dialog box.

System Exclusive
button

The System Exclusive button inserts a new MIDI System Exclusive Event
and closes the New Event dialog box.

Cancel
button Closes the New Event dialog box without making changes.

Help
button Opens this Help document.

 



  

Opening From the
Event List Editor

Click the Event after which a New Event is desired, and choose New Event...
from the Edit menu.

  



Select a Control dialog box  
Contents

Dialog Boxes

  

Description The Select a Control dialog box is used to assign a MIDI Control Event Type to a MIDI Control
Change Event.

Uses After opening the Select a Control dialog box, select a Control Event Type from the Control Event
scroll area and click OK to assign the Control Event Type and close the Select a Control dialog
box.

  

Items Control Event
scroll area

Select the desired Control Event Type you wish to assign to the currently
selected Control Change Event.

OK
button Closes the Select a Control dialog box and commits changes.

Cancel
button Closes the Select a Control dialog box without committing changes.

Help
button Opens this Help document.

 

  

Opening From the
Event List Editor

Double-click a Control Event's Name in the Data column.

  



Select a Drum Key dialog box  
Contents

Dialog Boxes

  

Description The Select a Drum Key dialog box is used to assign a MIDI Instrument Key (Pitch value which
translates to a Drum sound in the current Drum Program) to a MIDI Note Event in Percussion
Line data.

 This dialog box is available only when the selected Track is assigned to the Drums Category
and also a MIDI Synth Program (Patch) name is selected in the Program Set selection box of the
Output Device pane in the MIDI Setup dialog box.

Uses After opening the Select a Drum Key dialog box, select a Drum Key from the Drum Key scroll
area and click OK to assign the Drum Key and close the Select a Drum Key dialog box.

  

Items Drum Key
scroll area

Select the desired Drum Key you wish to assign to the currently selected Drum Key.

OK
button Closes the Select a Drum Key dialog box and commits changes.

Cancel
button Closes the Select a Drum Key dialog box without committing changes.

Help
button Opens this Help document.

 

  

Opening From the
Event List Editor

Double-click a Drum Note Event's Name in the Data column.

  



Select a Key dialog box  
Contents

Dialog Boxes

  

Description The Select a Key dialog box is used to assign a MIDI Instrument Key (Pitch value) for MIDI Poly
After Touch Events in Tonal Line data.

Uses After opening the Select a Key dialog box, select a Key from the Key scroll area and then click
OK to assign Poly After Touch Events to the Key.

  

Items Key
scroll area

Select MIDI Instrument Key (Pitch value) you wish to assign Poly After Touch Events
to.

OK
button Closes the Select a Key dialog box and commits changes.

Cancel
button Closes the Select a Key dialog box without committing changes.

Help
button Opens this Help document.

 

  

Opening From the
Event List Editor

Double-click a Poly After Touch Event's Name in the Data column.

  



Select a Program dialog box  
Contents

Dialog Boxes

  

Description The Select a Program dialog box allows you to assign a MIDI Program (Patch) to a MIDI
Program Change Event.

Uses After opening the Select a Program dialog box, select a Program (Patch) number from the
Program scroll area and click OK to assign the MIDI Program and close the Select a Program
dialog box.

  

Items Program
scroll area

Select the desired Control Event Type you wish to assign to the currently selected
Control Change Event.

OK
button Closes the Select a Program dialog box and commits changes.

Cancel
button Closes the Select a Program dialog box without committing changes.

Help
button Opens this Help document.

 

  

Opening From the
Event List Editor

Double-click a Program Change Event's Name in the Data column.

  



Edit a System Exclusive Event dialog box  
Contents

Dialog Boxes

  

Description The Edit a System Exclusive Event dialog box allows you to Edit MIDI System Exclusive
messages. System Exclusive data is proprietary command information for your MIDI Device, and
varies from manufacturer to manufacturer.

Uses After double-clicking a MIDI System Exclusive Event in the Event List Editor, the Edit a System
Exclusive Event dialog box appears. You can then Edit, Save or Delete System Exclusive MIDI
messages, as well as send them directly to your outboard MIDI equipment for immediate
processing, such as Synth Module Mode Change, etc.

  

Items Event
scroll area

The Event scroll area allows you to freely Edit MIDI System Exclusive Events.
Be aware that you need to have knowledge of MIDI System Exclusive message
Implementation for the intended MIDI Device to effectively manipulate System
Exclusive Events. This information is usually provided in your MIDI Equipment
(Synth Module, etc.) Instruction Manual. Raw Event data appears in the
Hexadecimal (Base 16) numbering system.

Saved Events
selection box

The Saved Events selection box is where MIDI System Exclusive events are
stored and recalled using this dialog box's Save and Delete buttons.

Save
button

The Save button allows you to Save a MIDI System Exclusive Event while
Editing another one. Saved Events appear in the Saved Events selection box,
and are stored independently of Document data. These Events can then be
recalled while working in different Documents and later CAMPS sessions.

Delete
button

The Delete button allows you to Delete MIDI System Exclusive Events from the
Saved Events list in the Saved Events selection box.

Send
button

The Send button allows you to Send the MIDI System Exclusive Event
highlighted in the Event scroll area directly to the currently selected MIDI Output
Device. This serves as a manual System Exclusive command processor as well
as a means of testing your Editing work.

OK
button Closes the Edit a System Exclusive Event dialog box and commits changes.

Cancel
button

Closes the Edit a System Exclusive Event dialog box without committing
changes.

Help
button Opens this Help document.

 

  



Opening From the
Event List Editor

Double-click the System exclusive Event to be Edited.

  



Notation Editor  
Contents

Editors

  

Description The Notation Editor allows you to view and edit a Line Block's MIDI Note data in a musical
notation environment. Though provided more as a viewing tool, it is also a Line editor, and all
Line related commands including CAMPS Compose features are available here. The CAMPS
Notation Editor is not intended to be a sheet music preparation tool, so printing is not supported.

 

Items The Notation Editor contains various Controls for viewing and manipulating Notes. You can
choose to Show or Hide the Controls with the Edit Buttons command in the View menu.

Edit Buttons The Edit Buttons give you quick access to viewing and manipulation tools for
the Notation Editor, as well as many other Editors available in CAMPS.

Bar Area The Bar Area displays a range of Bar lines. Besides managing a song's Time
Grid, this area also allows you to manipulate Loop and Punch In/Out recording
functions.

Text Info Area The Text Info Area displays a Document's general Text Events

Chord Area The Chord Area displays a Document's Chords and Key Signatures.

Notation Area The Notation Area is the MIDI Note Event editing area in the Notation Editor,
offering individual or collective graphical and menu-driven Note editing.

Lyric Area The Lyric Area displays Line Block Lyrics.



 

Opening From the
Document Window

First, select a desired Line Block. Then, either choose Notation Editor
from the Editors menu, or simply click the Notation Editor button at the
top of the Document Window.

From the...
Event List Editor
Pianoroll Editor
Control Draw Editor
Notation Editor

Choose Notation Editor from the Editors menu, or simply click the
Notation Editor button at the top of the Editor Window.

 



Bar Area of the Notation Editor  
Contents

Notation Editor

  

Description The Bar Area displays Measures or divisions of musical Time, known as Bars, in a continuous
row. This includes Bar Numbers and Beat divisions.

 

Uses Besides displaying Bar related information, the Bar Area allows you to manage a song's Time
Signature setup, location of the Playback Pointer, and the Playback Loop and Punch In/Out
Recording settings.

 

Items Playback Pointer
Loop region
Punch In/Out region
Bar Number
Bar Grid
Beat Grid
Location Cursor

 



Items in the Bar Area  
Description of this Area

Using this Area

  

Positioning the
Playback Pointer

Playback Pointer The Playback Pointer resides in its own dark gray area at the top of the
bar area, displaying the current Playback location in the Notation Editor.
It also allows you to change the current Playback point.

Inserting a
Playback Loop

Loop
region

Displays your current Loop region. Starting Playback repeats (Loops)
Playback in this region until you stop. This region is indicated by the
color blue in the upper portion of the Bar Area in the Notation Editor.

Inserting a
Punch In/Out
Record region

Punch In/Out
region

Displays your current Punch In/Out region. This region is indicated by
the color magenta in the lower portion of the Bar Area.

Viewing
Bar related
items

Bar Number A series of numbers given to Bars, starting on the left side with 1.

Bar Grid

Vertical lines across the Bar Area indicating Bar divisions. Because of
the complexity of generating Notation display, the Bar Grid won't always
be evenly spaced, but will always align with Bar Lines on the Staff in
the Notation Area.

Beat Grid Vertical lines evenly spaced across Bars indicating Beat divisions.

Location Cursor A vertical Location Cursor line extends downward from the Bar Area
through the Text Info, Chord and Lyric Areas. This cursor represents
the horizontal position of your mouse as it relates to the time location in
your Document. Corresponding numerical information is also displayed
in the order of "Bar, Beat and Division" in the Interactive Information
area at the bottom of the Notation Editor. The color of the Location
Cursor depends on your settings in the Microsoft Windows Control
Panel "Display" applet, under the heading "Selected Items" in the
"Items" list of the "Appearance" pane.

 

  



Using the Bar Area  
Description of this Area

Items in this Area

  

Positioning the
Playback Pointer

Playback Pointer
and area

You can use the Playback Pointer to change the Playback point in the
Notation Editor in two ways: Clicking a desired location in the dark gray
Playback Pointer area at the top, or clicking and dragging the Playback
Pointer to a desired location. Choose Play from the MIDI menu (or click
the Play button in the Playback Control toolbar) to begin Playback. The
Playback Pointer displays the current Playback location as CAMPS
plays or records MIDI data.

Inserting a
Playback Loop

Loop
region

You can create a Loop region by clicking and dragging with your mouse
in the upper portion of the Bar Area, below the Playback Pointer Area.
As you drag your mouse, the Loop region appears blue in color,
displaying a new Loop region. A Punch In/Out region of the same size
is automatically inserted below the new Loop region. Click anywhere in
the upper portion of the Bar Area to delete a Loop region.

Choose Play from the MIDI menu (or click the Play button in the
Playback Control toolbar) to begin Playback. CAMPS repeats Loop
region Playback until you stop it. Click anywhere in the upper portion of
the Bar Area to delete a Loop region.

 The start and end points of the Loop region snap to the resolution
set with the Resolution buttons or the Resolution submenu of the
View menu.

Inserting a
Punch In/Out
Record region

Punch In/Out
region

You can create a Punch In/Out region by clicking and dragging your
mouse in the lower portion of the Bar Area (below the Loop region). As
you drag your mouse, this region appears magenta in color, displaying
a new Punch In/Out region. A Loop of the same size is automatically
inserted above the new Punch In/Out region. Click anywhere in the
lower portion of the Bar Area to delete a Punch In/Out region.

Choose Record from the MIDI menu (or click the Record button in the
Record Control toolbar) to begin recording.

If the automatically inserted Playback Loop is removed, CAMPS begins
Playback from the Playback Pointer's current position, but Recording is
only active as the Playback Pointer travels through the Punch In/Out
region. This provides a true Cued Punch In/Out environment.

 By combining with a Loop region beginning before the Punch
In/Out region, CAMPS provides a continuous Cued Punch In/Out
recording environment. Remove the automatically inserted Loop and
insert a new one starting before the Punch In/Out region, or remove the
Punch In/Out region and insert a new one starting after the Loop
region.

 The start and end points of the Loop region snap to the resolution
set with the Resolution buttons or the Resolution submenu of the
View menu.



Assigning a
Time Signature

Time Signature
settings

CAMPS allows you to assign different Time Signatures to individual
Bars. Right-click a Bar to which you are assigning a new Time
Signature and then choose Time Signature Setup... to open the Time
Signature Setup dialog box. Set a Time Signature in the dialog box and
click OK. Choosing Time Signature Setup... from the Edit menu
opens the same dialog box.

 

  



Edit Buttons Area of the Notation Editor  
Contents

Notation Editor

  

Description The Edit Buttons are located at the top of the Notation Editor. These Buttons give you quick
access to frequently used items like View Adjustments, Tools and Editors.

 

Uses The Edit Buttons in the Notation Editor include most of the View and Editors menu commands,
including Notation-specific time display resolution and Note editing tools. Choose Edit Buttons
from the View menu to show or hide the Edit Buttons.

 

Items Auto Scroll button
Jump To Location button
Playback button
Playback with Others button
Clef button
Align To Grid button
Grid Setup button
Smart Notation button
Quarter Note Resolution button
Eighth Note Resolution button
Sixteenth Note Resolution button
32nd Note Resolution button
Triplet Resolution button
Quintuplet Resolution button
Arrow Tool button
I Beam Tool button
Magic Wand Tool button
Stamp Tool button
Eraser Tool button
Event List Editor button
Pianoroll Editor button
Control Draw Editor button
Notation Editor button



 



Items in the Edit Buttons Area  Description of this Area

  

Adjusting
View

Auto Scroll
button

Sets the viewable area in the Bar, Text Info, Chord, Notation and
Lyric Areas to follow the Playback Pointer during Playback and
Recording.

Jump To Location
button

Opens the Jump To Location dialog box which allows you to move
the current viewpoint to a specified Bar in the Notation Editor.

Clef
button

Click the Clef drop-down button to open a list of Clef choices for the
Notation display Staff, or click the main Clef button to switch to the
next Clef in the list. Changing this setting effects how Notes are
displayed on the Notation Staff with respect to Line data's musical
register (Pitch range). There is no actual change to Note Event
data.

Align To Grid
button

Switches between Activate or Deactivate Align To Grid in the Bar
and Notation Areas. Grid Alignment is specified in the Grid Setup
dialog box.

Grid Setup
button

Opens the Grid Setup dialog box, allowing you to adjust the
Alignment Grid Resolution for individual areas of the Notation
Editor and applicable Editors. Depending on which Area of the
Notation Editor is active before choosing this Menu Item, the
corresponding pane in the Grid Setup dialog box will be
preselected.

Smart Notation
button

This function "filters" the exact Notation display of Rests (spaces)
between Note Events to "clean up" the Notation display. Time
between Notes is added to those Notes with respect to Note and
Beat proximity. There is no actual change to Note Event data.

Quarter Note Resolution
button

Sets the Note duration display in the Notation Area to resolve to the
nearest Quarter Note. This does not change actual Note Event
data.

Eighth Note Resolution
button

Sets the Note duration display in the Notation Area to resolve to the
nearest Eighth Note. This does not change actual Note Event data.

Sixteenth Note Resolution
button

Sets the Note duration display in the Notation Area to resolve to the
nearest Sixteenth Note. This does not change actual Note Event
data. Results with this option may not be evident when Smart
Notation is active.

32nd Note Resolution
button

Sets the Note duration display in the Notation Area to resolve to the
nearest 32nd Note. This does not change actual Note Event data.
Results with this option may not be evident when Smart Notation
is active.

Triplet Resolution
button

Sets the Note duration display in the Notation Area to resolve to the
nearest Note Resolution selected from Quarter, 8th, 16th, 32nd
Note or corresponding Triplet. This does not change actual Note
Event data. Results with this option may not be evident when
Smart Notation is active.



Quintuplet Resolution
button

Sets the Note duration display in the Notation Area to resolve to the
nearest Note Resolution selected from Quarter, 8th, 16th, 32nd
Note or corresponding Quintuplet. This does not change actual
Note Event data. Results with this option may not be evident when
Smart Notation is active.

Auditioning Playback
button

Starts Audition Playback of the currently selected Notes with an
automatically inserted Playback Loop. If no individual Notes are
selected, CAMPS begins Playback from the currently selected Line
Block with no Loop. 

Playback with Others
button

Starts Audition Playback of the currently selected Notes with an
automatically inserted Playback Loop along with all the other
activated Tracks in the same Bar region. If no individual Notes are
selected, CAMPS begins Playback from the currently selected Line
Block with no Loop.

Selecting
Tools

Arrow Tool
button

Selects the Arrow Tool, allowing you to select and manipulate
Notes in the Notation Editor. Notes need to be selected before
related functions become available.

I Beam Tool
button

Selects the I Beam Tool, allowing you to quickly select regions in
the Notation Area.

Magic Wand Tool
button

Selects the Magic Wand Tool, allowing you to quickly recreate
individual Notes or regions of Notes with automatically assigned
Pitches (EZgenerate). In the Notation Area, drag the Magic Wand
Tool to create a selection region around Notes you wish to be
EZgenerated.

Stamp Tool
button

Selects the Stamp Tool, allowing you to quickly insert new Notes of
a fixed length in the Pianoroll Area with a click of your mouse. Use
the Note Stamp toolbar to adjust the length of Notes that the
Stamp tool creates. The Length is also adjustable at any later time
in the Pianoroll Editor.

Eraser Tool
button

Selects the Eraser Tool, allowing you to quickly delete Notes in the
Notation Area with a click of your mouse. Note that Rests can not
be deleted; instead they are automatically adjusted to indicate the
absence of Notes.

Opening
Editors

Event List Editor
button

Opens the Event List Editor, allowing you to edit individual MIDI
Events of the selected Line Block in vertical list format.

Pianoroll Editor
button

Opens the Pianoroll Editor, allowing you to edit Notes of the
selected Line Block in Pianoroll graph format.

Control Draw Editor
button

Opens the Control Draw Editor, allowing you to edit MIDI Control
Events of a selected Line Block with a unique freestyle curve
drawing method.

Notation Editor
button

Opens a new Notation Editor, allowing you to make alternate edits
of the selected Line Block in Musical Notation form.



 



Chord Area of the Notation Editor  
Contents

Notation Editor

  

Description The Chord Area displays a Document's Chords. It is provided as a visual reference in the
Notation Editor.

 

Uses Reference the Chord Area for Key Signature and Chord display. To edit Chords, use the
Document Window or Pianoroll Editor.

 

Items Key and Mode
display

This display is Located in its own row below the Text Info Area and just before
each Bar which contains a change of Key and Mode. It displays the Key and
Mode of the first Chord Container in every Bar. Corresponding Key Signature
Notation appears on the Staff in the Notation Area.

Chord
display

This display is Located in its own row just below the Key and Mode display. It
displays the Chord Names of each Bar's Chord Containers.

 



Lyric Area of the Notation Editor  
Contents

Notation Editor

  

Description The Lyric Area displays a Line Block's Lyrics in a continuous row at the bottom of the Notation
Editor window. It is provided as a visual reference in the Notation Editor.

 

Uses Reference the Lyric Area as synchronizing Lyrics with your composition. To edit Lyric Events,
use the Pianoroll Editor or Control Draw Editor.

 

 

 



Notation Area of the Notation Editor  
Contents

Notation Editor

  

Description The Notation Area is the MIDI Note Event editing area in the Notation Editor, offering a musical
Notation environment for editing individual Notes, groups of Notes or an entire Line Block at
once.

 

Uses Many editing tools facilitate a wide range of editing and creation options for Notes in the Notation
Area. As usual, Notes can also be individually or collectively manipulated using the menu
command system.

 

Items MIDI Note Event
Staff

 



Items in the Notation Area  
Description of this Area

Using this Area

  

Creating and
Manipulating
MIDI Note Events

MIDI Note Event A MIDI Note Event is MIDI data which executes Note generation. In the
Notation Editor, MIDI Note Events are displayed in Notated form such
as Whole Note, Half Note, etc. You can create, edit, copy, move or
delete MIDI Note Events as needed.

Adjusting the
View of the
Notation Area

Staff
In most cases, Notes are displayed on a standard 5-line musical Staff.
The Staff display also includes Clef, Bar Lines, Rests, Dots and Ties, as
well as initial and subsequent Key Signatures and Time Signatures.

 

  



Using the Notation Area  
Description of this Area

Items in this Area

  

Adjusting the
View of the
Notation Area

Staff Tonal (Melodic) Notes are displayed on a standard 5-line musical Staff. The
Staff's Clef is adjustable, but the rest of the symbols displayed on the Staff in
the Notation Area are automatically prepared from your Line data using your
Smart Notation and Resolution settings as guides.

By default, the Staff display differs for Notes in the Drums Category, and its
appearance for Percussion data is adjustable using the Drums Notation
Setup dialog box. In this dialog box the Percussion Notation Staff may be
changed from five lines to one, and various Note symbols can be selected
for each MIDI Pitch value to accommodate different arrangements of Drum
sounds in MIDI Synth Programs. Additionally, Percussion Note Stems are
drawn in different directions than usual, and Accidentals are not included
when using a [Drums Notation Set] in your Clef settings. The default
[Drums Notation Set] in CAMPS is "GM 5 Lines".

The Staff display includes the following Items for Tonal or Percussion Notes:

Clef The Clef defines how Notes are displayed on the Notation Staff with respect
to Line data's musical register (Pitch range). Use the Clef button or the Clef
submenu of the View menu to change the Clef on the Staff of the Notation
Area. Actual Note Event data Pitch range is unaffected by this Notation
display setting.

Key Signature Defined in the Chord Area of the Document Window or Pianoroll Editor, the
initial Key Signature is Notated on the Staff with Sharps or Flats immediately
following the Clef. Subsequent Key changes are Notated immediately
following their first Bar Line.

Time Signature Defined in the Bar Area of various Editors, the initial Time Signature is
Notated on the Staff with the customary numerical fraction display
immediately following the Key Signature. Subsequent Time Signature
changes are Notated immediately following their first Bar Line, after any Key
Signature changes that may be present.

Note Note durations in the Notation Editor are represented by their customary
symbols such as Whole, Half, Quarter, Eighth, Sixteenth, 32nd and 64th
Notes, including Dots and Ties. These designations are for viewing
purposes, interpreting actual MIDI Note Event duration into Notated form
under conditions you set with the Smart Notation and Resolution buttons
or View menu commands.

Rest Rests are automatically prepared by the Notation Editor according to the
"spaces" between Note Events. Any changes made to Notes in the Notation
or other Editors causes recalculation of Rest values and locations in the
Notation Editor. The display of Rests is further controlled by your settings of
the Smart Notation and Resolution buttons or View menu commands.
Actual Note Event data is unaffected by these Notation display settings.



Dot A Dot is added to the right side of a Note to increase its duration by half its
original time value. Any changes made to Notes in the Notation Editor
causes recalculation of Notes' possible Dotted status. The display of Dots is
further controlled by your settings of the Smart Notation and Resolution
buttons or View menu commands. Actual Note Event data is unaffected by
these Notation display settings.

Tie Ties are displayed between Note Events that actually overlap in your Line
data, and therefore sound as one. Any changes made to Notes in the
Notation Editor causes recalculation of Notes' possible Tied status. The
display of Ties is further controlled by your settings of the Smart Notation
and Resolution buttons or View menu commands. Actual Note Event data
is unaffected by these Notation display settings.

Bar Line Bar Lines always represent actual Bars, but to conserve Editor window
space, their positions are adjusted according to how many Notes are
present.

 

See also:

Creating and Manipulating MIDI Note Events

 



Using the Notation Area  
Description of this Area

Items in this Area

  

Creating and
Manipulating
MIDI Note Events

MIDI Note Event Note:

The Notation Editor "rounds off" Note Event duration values to facilitate
legitimate music Notation display. Note Event data is not changed by
this process, it's just part of the Notation display process. The Notation
Editor is a very handy tool, but you may find the Pianoroll Editor better
suited for certain detailed MIDI Note editing tasks.

After using any of the special Tool buttons at the top of the Notation
Editor, be sure to switch back to the standard Arrow Tool for regular
manipulation operations.

CREATING NEW MIDI NOTE EVENTS

Method 1:

Click the Record button in the Record Control toolbar or choose the
desired Recording command from the Record submenu of the MIDI
menu and begin playing your MIDI Instrument. Loop and Punch In/Out
regions will be automatically assigned for the length of the currently
selected Line Block. If you prefer, you can assign a specific Punch
In/Out region before activating Record. Be aware that the Track Arming
buttons found in the Document Window have no effect in the Notation
Editor. Once Record is activated and you begin playing, any existing
data in the currently selected Line Block will be replaced.

Method 2:

Select the Stamp tool at the top of the Notation Editor and then click
anywhere in the Notation Area to assign Note Events. Notes will be
created as you click; their Pitch and Location following the Stamp tool's
position. Length and other attributes can be modified later.

 Note Events will snap to the nearest horizontal (time) resolution
point as you create them. This resolution depends on your settings with
the Resolution buttons at the top of the Notation Editor or in the Note
View submenu of the View menu.

 Since the Notation Editor interprets Note duration for Notation



display, the Pianoroll Editor provides a more exact environment for
creating Notes with your mouse.

EDITING MIDI NOTE EVENTS

Method 1:

Using the Arrow tool, click and drag desired Note Event to a new
vertical Pitch and/or horizontal time position in the Notation Area. See
also MOVING MIDI NOTE EVENTS below.

 Note Events will snap to the nearest horizontal (time) resolution
point as you drag them. This resolution depends on your settings with
the Resolution buttons at the top of the Notation Editor or in the Note
View submenu of the View menu.

Method 2:

Use the Magic Wand tool to reCompose a region of Notes. Click the
Magic Wand tool button at the top of the Notation Editor. Then, click
and hold your mouse button down at an empty location in the Velocity
Area and drag the Magic Wand over desired Note Events, or click each
Note individually.

Method 3:

Right Click desired Note Event and choose any one of the many
commands available from the pop-up menu or submenus. Alternatively,
click desired Note Event and choose desired command from the Edit or
Line menus. See also CREATING NEW MIDI NOTE EVENTS above.



SELECTING MIDI NOTE EVENTS

Method 1:

Using the Arrow tool, you can select individual Note Events. You can
select multiple Note Events by holding the Ctrl (or Shift) key down as
you select. Alternatively, Clicking and holding your mouse button down
at an empty location in the Notation Area and dragging the cursor over
desired Note Events allows you to select multiple Note Events in one
quick operation.

Method 2:

Using the I Beam tool, you can select all Note Events in a horizontal
(time) region at once. After selecting the I Beam tool at the top of the
Notation Editor, click and hold your mouse button down at an empty
location in the Notation Area and drag the I Beam horizontally over the
desired Note Event region.

Selecting Note Events enables use of Note Event related commands
under the Edit and Line Menu bar items. Once selected, you can then
move, copy, paste or delete a group of Note Events at one time using
the right click, menu bar or click and drag method.

 Selecting entire Note regions will not be possible if the Magic
Wand, Stamp or Eraser tool button at the top of the Notation Editor is
currently active. In these cases, Note Events will be changed, created
or deleted (depending on which of these buttons is active).



MOVING MIDI NOTE EVENTS

Method 1:

Using the Arrow tool, click and drag desired Note Events to a new
location in the Notation Area. Any vertical motion during your dragging
operation will effect the Note's Pitch as well. See EDITING MIDI NOTE
EVENTS above.

Method 2:

Select a Note Event with your mouse and use the arrow keys on your
computer's keyboard to move the selected Note with more precision.
The up/down arrow keys move a Note's Pitch by intervals (half steps),
and the left/right arrow keys move a Note's location in time by Divisions.

Method 3:

This method allows you to move Note Events between Documents.

Right-click a Note Event and choose Cut Note Event to remove a Note
Event from its current location. Alternatively, click desired Note Event
and choose Cut Note Event from the Edit menu. Using the Ctrl (or
Shift) key while selecting allows you to Cut multiple Note Events in one
operation.

Next, right-click a desired location in the Notation Editor's Notation Area
of the desired Document and choose Paste Note Event to Paste the
Cut Note Event(s). Alternatively, select a desired location in the
Notation Area and choose Paste Note Event from the Edit menu.

 Note Events will snap to the nearest horizontal (time) resolution
point as you paste them. This resolution depends on your settings with
the Resolution buttons at the top of the Notation Editor or in the Note
View submenu of the View menu.

COPYING / PASTING MIDI NOTE EVENTS

Right-click a Note Event and choose Copy Note Event to copy it.
Alternatively, click desired Note Event and choose Copy Note Event
from the Edit menu. Using the Ctrl (or Shift) key while selecting allows
you to copy multiple Note Events in one operation.

Next, right-click a desired location in the Notation Editor's Notation Area
of the desired Document and choose Paste Note Event to Paste the
Copied Note Event(s). Alternatively, select a desired location in the
Notation Area and choose Paste Note Event from the Edit menu.

 Note Events will snap to the nearest horizontal (time) resolution
point as you paste them. This resolution depends on your settings with
the Resolution buttons at the top of the Notation Editor or in the Note
View submenu of the View menu.



DELETING MIDI NOTE EVENTS

Method 1:

Select the Eraser tool at the top of the Notation Editor and simply click
on a Note Event to delete it. With the Eraser tool, clicking and holding
your mouse button down at an empty location in the Notation Area and
dragging the Eraser over desired Note Events allows you to delete
multiple Note Events in one quick operation.

Method 2:

Right-click a Note Event and choose Clear Note Event to delete it.
Alternatively, click desired Note Event and choose Clear Note Event
from the Edit menu. Using the Ctrl (or Shift) key while selecting allows
you to Clear multiple Note Events in one operation.

 

See also:

Adjusting the View of the Notation Area

 



Text Info Area of the Notation Editor  
Contents

Notation Editor

  

Description The Text Info Area displays a Document's general Text Information in a continuous row under
the Bar Area. It is provided as a visual reference in the Notation Editor.

 

Uses Reference the Text Info Area to more quickly locate a particular point in your music. To edit Text
Events, use the Document Window, Pianoroll Editor, Control Draw Editor, Tempo Draw Editor or
Text List Editor.

 

 

 



Control Draw Editor  
Contents

Editors

  

Description The Control Draw Editor allows you to edit a Line Block's MIDI Control data with a unique
freestyle curve drawing method.

 

Items The Control Draw Editor contains various Controls and Editing Areas for manipulating MIDI
Control Events and other objects. You can choose to Show or Hide the Controls with the Edit
Buttons command in the View menu. You can adjust the vertical size of each Editing Area by
clicking and dragging the horizontal or vertical separator bar between Areas.

Edit Buttons The Edit Buttons give you quick access to Viewing and Manipulation Tools for
the Control Draw Editor, as well as many of the Editors available in CAMPS.

Note Data Area The Note Data Area displays the currently selected Line Block's Note data in
Pianoroll form for you reference.

Bar Area The Bar Area displays a range of Bar lines. Besides managing a song's Time
Grid, this area also allows you to manipulate Loop and Punch In/Out functions.

Text Info Area The Text Info Area displays Text Events such as Rehearsal Letters and
Markers, allowing you to create or edit them.

Lyric Area The Lyric Area displays Lyrics, allowing you to create or edit them.

Draw Area The Draw Area allows you to edit MIDI Control Event data with a unique
drawing method.

 



Opening From the
Document Window

First, select a desired Line Block. Then, either choose Control Draw
Editor from the Editors menu, or simply click the Control Draw Editor
button at the top of the Document Window.

From the...
Event List Editor
Pianoroll Editor
Control Draw Editor
Notation Editor

Choose Control Draw Editor from the Editors menu, or simply click the
Control Draw Editor button at the top of the Editor Window.

 



Bar Area of the Control Draw Editor  
Contents

Control Draw Editor

  

Description The Bar Area displays Measures or divisions of musical Time, known as Bars, in a continuous
row. This includes Bar Numbers, the Bar Grid and Beat Grid.

 

Uses Besides displaying Bar related information, the Bar Area allows you to manage a song's Time
Signature setup, location of the Playback Pointer, and the Playback Loop and Punch In/Out
Recording settings.

 

Items Playback Pointer
Loop region
Punch In/Out region
Bar Number
Bar Grid
Beat Grid
Location Cursor

 



Items in the Bar Area  
Description of this Area

Using this Area

  

Positioning the
Playback Pointer

Playback Pointer The Playback Pointer resides in its own dark gray area at the top of the
bar area, displaying the current Playback location in the Control Draw
Editor. It also allows you to change the current Playback point.

Inserting a
Playback Loop

Loop
region

Displays your current Loop region. Starting Playback repeats (Loops)
Playback in this region until you stop. This region is indicated by the
color blue in the upper portion of the Bar Area in the Control Draw
Editor.

Inserting a
Punch In/Out
Record region

Punch In/Out
region

Displays your current Punch In/Out region. This region is indicated by
the color magenta in the lower portion of the Bar Area.

Viewing
Bar related
items

Bar Number A series of numbers given to Bars, starting on the left side with 1.

Bar Grid Vertical lines horizontally spaced across the Bar Area indicating Bar
divisions.

Beat Grid Vertical lines horizontally spaced across Bars indicating Beat divisions.

Location Cursor A vertical Location Cursor line in the Bar Area represents the horizontal
position of your mouse as it relates to the time location in your
Document. Corresponding numerical information is also displayed in
the order of "Bar, Beat and Division" in the Interactive Information area
at the bottom of the Control Draw Editor. The color of the Location
Cursor depends on your settings in the Microsoft Windows Control
Panel "Display" applet, under the heading "Selected Items" in the
"Items" list of the "Appearance" pane.

 

  



Using the Bar Area  
Description of this Area

Items in this Area

  

Positioning the
Playback Pointer

Playback Pointer
and area

You can use the Playback Pointer to change the Playback point in the
Control Draw Editor in two ways: Clicking a desired location in the dark
gray Playback Pointer area at the top, or clicking and dragging the
Playback Pointer to a desired location. Choose Play from the MIDI
menu (or click the Play button in the Playback Control toolbar) to begin
Playback. The Playback Pointer displays the current Playback location
as CAMPS plays or records MIDI data.

Inserting a
Playback Loop

Loop
region

You can create a Loop region by clicking and dragging with your mouse
in the upper portion of the Bar Area, below the Playback Pointer Area.
As you drag your mouse, the Loop region appears blue in color,
displaying a new Loop region. A Punch In/Out region of the same size
is automatically inserted below the new Loop region. Click anywhere in
the upper portion of the Bar Area to delete a Loop region.

Choose Play from the MIDI menu (or click the Play button in the
Playback Control toolbar) to begin Playback. CAMPS repeats Loop
region Playback until you stop it. Click anywhere in the upper portion of
the Bar Area to delete a Loop region.

 The start and end points of the Loop region snap to the Grid
resolution set in the Grid Setup dialog box, if Align to Grid is selected
in the Grid View submenu of the View menu.

Inserting a
Punch In/Out
Record region

Punch In/Out
region

You can create a Punch In/Out region by clicking and dragging your
mouse in the lower portion of the Bar Area (below the Loop region). As
you drag your mouse, this region appears magenta in color, displaying
a new Punch In/Out region. A Loop of the same size is automatically
inserted above the new Punch In/Out region. Click anywhere in the
lower portion of the Bar Area to delete a Punch In/Out region.

Choose Record from the MIDI menu (or click the Record button in the
Record Control toolbar) to begin recording.

If the automatically inserted Playback Loop is removed, CAMPS begins
Playback from the Playback Pointer's current position, but Recording is
only active as the Playback Pointer travels through the Punch In/Out
region. This provides a true Cued Punch In/Out environment.

 By combining with a Loop region beginning before the Punch
In/Out region, CAMPS provides a continuous Cued Punch In/Out
recording environment. Remove the automatically inserted Loop and
insert a new one starting before the Punch In/Out region, or remove the
Punch In/Out region and insert a new one starting after the Loop
region.

 The start and end points of the Punch In/Out region align to the
Grid resolution set in the Grid Setup dialog box, if Align to Grid is
selected in the Grid View submenu of the View menu.



Assigning a
Time Signature

Time Signature
settings

CAMPS allows you to assign different Time Signatures to individual
Bars. Right-click a Bar to which you are assigning a new Time
Signature and then choose Time Signature Setup... to open the Time
Signature Setup dialog box. Set a Time Signature in the dialog box and
click OK. (Choosing Time Signature Setup... from the Edit menu
opens the same dialog box.)

 

  



Edit Buttons Area of the Control Draw Editor  
Contents

Control Draw Editor

  

Description The Edit Buttons are located at the top of the Control Draw Editor. These Buttons give you quick
access to frequently used items like View Adjustments, Tools and Editors.

 

Uses The selection boxes in the left side of the Edit Buttons Area determine which MIDI Control Events
are displayed in the Draw Area of the Control Draw Editor. The rest of the Edit Buttons include
most of the View and Editors menu commands. The Tool buttons work in slightly different ways
depending on which Area of the Control Draw Editor you are working in. Choose Edit Buttons
from the View menu to show or hide the Edit Buttons.

 

Items Control Event Type selection box
Control Event selection box
Auto Scroll button
Jump To Location button
Playback button
Playback with Others button
Zoom Out (H) button
Zoom In (H) button
Align To Grid button
Grid Setup button
Arrow Tool button
I Beam Tool button
Pen Tool button
Line Tool button
Oval Tool button
Eraser Tool button
Event List Editor button
Pianoroll Editor button
Control Draw Editor button
Notation Editor button

 



Items in the Edit Buttons Area  Description of this Area

  

Selecting
Control Events

Control Event Type
selection box

This is where you select which Type of Control Events appear in the
Draw Area of the Control Draw Editor. While any given location in a
Line Block may contain several different types of MIDI Control
Events, the Control Draw Editor is designed to deal with only one
type at a time. Depending on the type of Control Event selected, the
Control Event selection box will appear next to the Control Event
Type selection box, allowing you to select exactly which type of
Events to work with.

Control Event
selection box

This selection box appears only when the Control Event Type is set
to either Control Change or Poly After Touch. For the Control
Change setting, the Control Event selection box allows you to
choose which kind of Control Change Events, such as Volume or
Pan, are displayed in the Draw Area. For the Poly After Touch
setting, the Control Event selection box allows you to choose which
Note's Poly After Touch Events are displayed.

Adjusting
View

Auto Scroll
button

Sets the viewable area in the Bar, Text Info, Note Data, Lyric and
Draw Areas to follow the Playback Pointer during Playback and
Recording.

Jump To Location
button

Opens the Jump To Location dialog box which allows you to move
the current viewpoint to a specified Bar in the Control Draw Editor.

Zoom Out (H)
button

Incrementally decreases the Horizontal size of the Bar, Text Info,
Note Data, Lyric and Draw Areas, increasing their viewable area.

Zoom In (H)
button

Incrementally increases the Horizontal size of the Bar, Text Info,
Note Data, Lyric and Draw Areas, decreasing their viewable area.

Align To Grid
button

Switches between Activate or Deactivate Align To Grid in the Text
Info, Lyric and Draw Areas. Grid Alignment is specified in the Grid
Setup dialog box.

Grid Setup
button

Opens the Grid Setup dialog box, allowing you to adjust the
Alignment Grid Resolution for individual areas of the Control Draw
Editor and applicable Editors. Depending on which Area of the
Control Draw Editor is active before choosing this Menu Item, the
corresponding pane in the Grid Setup dialog box will be preselected.

Auditioning Playback
button

Starts Audition Playback of the currently selected Control Events with
an automatically inserted Playback Loop. If no individual Control
Events are selected, CAMPS begins Playback from the currently
selected Line Block with no Loop. 

Playback with Others
button

Starts Audition Playback of the currently selected Control Events with
an automatically inserted Playback Loop along with all the other
activated Tracks in the same Bar region. If no individual Control
Events are selected, CAMPS begins Playback from the currently
selected Line Block with no Loop.

Selecting
Tools

Arrow Tool
button

Selects the Arrow Tool, allowing you to select and manipulate
objects in the Control Draw Editor. Objects need to be selected
before related functions become available.



I Beam Tool
button

Selects the I Beam Tool, allowing you to quickly select regions in the
Draw Area. 

Pen Tool
button

Selects the Pen Tool, allowing you to quickly create or define values
of MIDI Control Events in the Draw Area with a unique freestyle
drawing method.

Line Tool
button

Selects the Line Tool, allowing you to quickly create and edit Control
Events using a straight line drawing method.

Oval Tool
button

Selects the Oval Tool, allowing you to quickly create and edit Control
Events using an automatic curve drawing method. 

Eraser Tool
button

Selects the Eraser Tool, allowing you to quickly delete objects in the
Control Draw Editor.

Opening
Editors

Event List Editor
button

Opens the Event List Editor, allowing you to edit individual Events of
the selected Line Block in vertical list format.

Pianoroll Editor
button

Opens the Pianoroll Editor, allowing you to edit Notes of the selected
Line Block in Pianoroll graph format.

Control Draw Editor
button

Opens a new Control Draw Editor window, allowing you to make
alternate MIDI Control Event edits of the selected Line Block.

Notation Editor
button

Opens the Notation Editor, allowing you to edit Notes of the selected
Line Block in Musical Notation form.

 

 



Draw Area of the Control Draw Editor  
Contents

Control Draw Editor

  

Description The Draw Area is the main MIDI Control Event editing area of the Control Draw Editor.

 

Uses The Draw Area allows you to quickly create and edit Control Events using a freestyle drawing
method. Choose the Control Event Type you wish to create or edit from the selection boxes in
the upper left-hand corner of the Control Draw Editor, choose the desired editing tool and simply
draw desired changes in the Draw Area with your mouse.

 

Items MIDI Control Event
Bar Grid
Beat Grid
Value Grid
Value Scale
Location Cursor



Items in the Draw Area  
Description of this Area

Using this Area

  

Manipulating
MIDI Control Events

MIDI Control Event A MIDI Control Event is MIDI data which executes a specific MIDI
controller task other than Note generation. Such tasks include
Volume changes, Pitch Bend, Synth Program (Patch) changes
and Poly After Touch to name a few. Events displayed in the Draw
Area depend on your selections in the Control Event Type and
Control Event selection boxes. You can create, edit, copy, move
or delete MIDI Control Events as needed.

Adjusting the
Grid display

Bar Grid Vertical lines horizontally spaced across the Draw Area indicating
the dividing points between Bars.

Beat Grid Vertical lines horizontally spaced across Bars indicating the
dividing points between Beats.

Value Grid Horizontal lines vertically spaced across the Draw Area indicating
the vertical dividing points between data Values.

Value Scale Located on the left side of the Draw Area, this Scale displays the
Value range of the vertical Value Grid in the Draw Area of the
Control Draw Editor.

Location Cursor A horizontal Location Cursor line in the Value Scale represents
the vertical position of your mouse as it relates to Event Value in
the Draw Area of the Control Draw Editor. Corresponding
numerical information is also displayed in the Interactive
Information area at the bottom of the Control Draw Editor. The
color of the Location Cursor depends on your settings in the
Microsoft Windows Control Panel "Display" applet, under the
heading "Selected Items" in the "Items" list of the "Appearance"
pane.



 

  



Using the Draw Area  
Description of this Area

Items in this Area

  

Adjusting the
Grid display

Bar Grid The Bar Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Bars (Measures) for visual reference. Choose Bar Grid from
the Grid View submenu of the View menu to show or hide the Bar Grid in the
Draw Area, as well as the Text Info and Lyric Areas of the Control Draw Editor.

Beat Grid The Beat Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Beats in each Bar for visual reference. (This is not necessarily
the same as the Alignment Grid.) Choose Beat Grid from the Grid View submenu
of the View menu to show or hide the Beat Grid in the Draw Area, as well as the
Text Info and Lyric Areas of the Control Draw Editor.

Value Grid The Value Grid is a pattern of evenly spaced horizontal lines marking vertical
divisions between data Values for visual reference. (This is not necessarily the
same as the Alignment Grid.) Choose Value Grid from the Grid View submenu of
the View menu to show or hide the Value Grid in the Draw Area.

 

See also:

Creating and Manipulating MIDI Control Events

 



Using the Draw Area  
Description of this Area

Items in this Area

  

Creating and
Manipulating
MIDI Control Events

MIDI Control Event Note:

Before any actions are taken in the Draw Area, you must first
select the Control Event Type and Event you wish to work with.
Once these selections are made, any corresponding Events will
be displayed in the Draw Area.

After using any of the special Tool buttons at the top of the Control
Draw Editor, be sure to switch back to the standard Arrow Tool
for regular manipulation operations.

CREATING NEW MIDI CONTROL EVENTS

Method 1:

This method replaces all existing Line Block data, including Notes.

Click the Record button in the Record Control toolbar or choose
the desired Recording command from the Record submenu of the
MIDI menu and begin playing your MIDI Instrument. Loop and
Punch In/Out regions will be automatically assigned for the length
of the currently selected Line Block. If you prefer, you can assign
a specific Punch In/Out region before activating Record. Be aware
that the Track Arming buttons found in the Document Window
have no effect in the Control Draw Editor. Once Record is
activated and you begin playing, any existing data in the currently
selected Line Block will be replaced.

Method 2:

Select the Pen tool at the top of the Control Draw Editor and then
click and drag horizontally in the Draw Area to assign Control



Events. Events will be created as you draw; their value (vertical
position) following the Pen tool's position.

Method 3:

Select the Line tool at the top of the Control Draw Editor and then
click and drag horizontally in the Draw Area to assign Control
Events. Events will be created as you draw; their value (vertical
position) following the straight line that results from your drawing
action.

Method 4:

Select the Oval tool at the top of the Control Draw Editor and then
click and drag horizontally in the Draw Area to assign Control



Events. Events will be created as you draw; their value (vertical
position) following the curved line that results from your drawing
action.

 Besides creating new Event data, all of these methods can be
used to edit existing Events as well. The horizontal (time) density
of Events created or edited depends on your settings in the Grid
Setup dialog box. Other settings for Control Events such as
Location, Color and Value are adjustable at any later time.

EDITING MIDI CONTROL EVENTS

Method 1:

Using the Arrow tool, click and drag desired Control Event to a
new vertical value position the Draw Area. Any horizontal motion
during your dragging operation will effect the Event's location in
time. See MOVING MIDI CONTROL EVENTS below.

 When Align To Grid is activated, the Control Event will snap
to the nearest Grid Resolution point of the selected Draw Area
location as defined in the Grid Setup dialog box.

Method 2:

Right Click desired Control Event and choose Adjust Value...
from the Actions submenu. Alternatively, click desired Control
Event and choose Adjust Value from the Line menu.

See also CREATING NEW MIDI CONTROL EVENTS above.



SELECTING MIDI CONTROL EVENTS

Method 1:

Using the Arrow tool, you can select individual Control Events.
You can select multiple Control Events by holding the Ctrl (or
Shift) key down as you select. Alternatively, Clicking and holding
your mouse button down at an empty location in the Draw Area
and dragging your mouse over desired Control Events allows you
to select multiple Control Events in one quick operation.

Method 2:

Using the I Beam tool, you can select all Control Events in a
horizontal (time) region at once. After clicking the I Beam button at
the top of the Pianoroll Editor, click and hold your mouse button
down in an empty location of the Draw Area and drag the I Beam
horizontally over the desired Control Event region.



Selecting Control Events enables use of Control Event related
commands under the Edit and Line Menu bar items. Once
selected, you can then move, copy, paste or delete a group of
Control Events at one time using the right click, menu bar or click
and drag method.

 Selecting entire Control Event regions will not be possible if
the Pen, Line, Oval or Eraser tool button at the top of the Control
Draw Editor is currently active. In these cases, Control Events will
be created, edited or deleted (depending on which of these
buttons is active).

MOVING MIDI CONTROL EVENTS

Method 1:

Using the Arrow tool, click and drag desired Control Events to a
new location in the Draw Area. Any vertical motion during your
dragging operation will effect the Event's value. See EDITING
MIDI CONTROL EVENTS above.

Method 2:

Select a Control Event with your mouse and use the arrow keys
on your computer's keyboard to move the selected Event with
more precision. The up/down arrow keys move an Event's value
by single increments, and the left/right arrow keys move an
Event's location in time by Divisions.

Method 3:

This method allows you to move Control Events between
Documents.



Right-click a Control Event and choose Cut Event to remove a
Control Event from its current location. Alternatively, click desired
Control Event and choose Cut Event from the Edit menu. Using
the Ctrl (or Shift) key while selecting allows you to Cut multiple
Control Events in one operation.

Next, right-click a desired location in the Control Draw Editor's
Draw Area of the desired Document and choose Paste Event to
Paste the Cut Control Event(s). Alternatively, select a desired
location in the Draw Area and choose Paste Event from the Edit
menu.

 When Align To Grid is activated, the Control Event being
moved will snap to the nearest Grid Resolution point of the
selected Draw Area location as defined in the Grid Setup dialog
box.

COPYING / PASTING MIDI CONTROL EVENTS

Right-click a Control Event and choose Copy Event to copy a
Control Event. Alternatively, click desired Control Event and
choose Copy Event from the Edit menu. Using the Ctrl (or Shift)
key while selecting allows you to copy multiple Control Events in
one operation.

Then, right-click a desired location in the Control Draw Editor's
Draw Area of the desired Document and choose Paste Event to
Paste the Copied Control Event(s). Alternatively, select a desired
location in the Draw Area and choose Paste Event from the Edit
menu.

 When Align To Grid is activated, the Control Event being
Copied will be Pasted to the nearest Horizontal Grid Resolution
point of the selected Draw Area location as defined in the Grid
Setup dialog box.

DELETING MIDI CONTROL EVENTS

Method 1:

Select the Eraser tool at the top of the Control Draw Editor and
simply click on a Control Event to delete it. With the Eraser tool,
clicking and holding your mouse button down at an empty location
in the Draw Area and dragging the Eraser over desired Control
Events allows you to delete multiple Control Events in one quick
operation.

Method 2:

Right-click a Control Event and choose Clear Event to delete it.
Alternatively, click desired Control Event and choose Clear Event
from the Edit menu. Using the Ctrl (or Shift) key while selecting



allows you to Clear multiple Control Events in one operation.

 

See also:

Adjusting the Grid display

 



Lyric Area of the Control Draw Editor  
Contents

Control Draw Editor

  

Description The Lyric Area displays a Line Block's Lyrics in a continuous row, parallel to the Note Data Area.

 

Uses You can create, edit, duplicate, move or delete Lyrics in the Lyric Area. These song Lyrics can
then be saved with a Document. Additionally, Lyrics are saved with your Composition when
exporting it to a Standard MIDI File.

 

Items Lyric Event
Bar Grid
Beat Grid

 



Items in the Lyric Area  
Description of this Area

Using this Area

  

Creating a
Lyric

Lyric
Event

Lyric Events allow you to include song Lyrics (sung words) in your Composition.
You can create, edit, copy, duplicate, move or delete Lyric Events as needed.
Lyrics can then be Saved and Exported with the rest of your Composition
Document. Unlike general Text Events which have a common location in a
Document, a different set of Lyrics can be saved with each Line Block.

Adjusting the
Grid display

Bar Grid Vertical lines horizontally spaced across the Lyric Area indicating Bar divisions.

Beat Grid Vertical lines horizontally spaced across Bars indicating Beat divisions.

 

  



Using the Lyric Area  
Description of this Area

Items in this Area

  

Adjusting the
Grid display

Bar Grid The Bar Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Bars (Measures) for visual reference. Choose Bar Grid from the
Grid View submenu of the View menu to show or hide the Bar Grid in the Lyric
Area, as well as the Text Info and Draw Areas of the Control Draw Editor.

Beat Grid The Beat Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Beats in each Bar for visual reference. (This is not necessarily
the same as the Alignment Grid.) Choose Beat Grid from the Grid View submenu
of the View menu to show or hide the Beat Grid in the Lyric Area, as well as the
Text Info and Draw Areas of the Control Draw Editor.

 

See also:

Creating and Manipulating Lyrics

 



Using the Lyric Area  
Description of this Area

Items in this Area

  

Creating and
Manipulating
Lyrics

Lyric
event CREATING LYRICS

Right-click a desired location in the Lyric Area and choose New Lyric to create a new
Lyric text box. Enter desired Lyric text data in the edit box. When you are finished
entering Lyrics, click outside the edit box or press Enter on your computer's keyboard.

Alternatively, choose New Lyric from the Edit menu to create a blank Lyric text box.

 When choosing New Lyric from the Edit menu, you must first have selected an
empty Lyric Area, otherwise the New Lyric item won't be available.

EDITING LYRICS

To edit a Lyric, double click it, opening its edit box. After typing your changes, hit the
Enter key, or click someplace outside the edit box to close it.



SELECTING LYRICS

Using the Arrow tool, you can select individual Lyrics. You can select multiple Lyrics by
holding the Ctrl (or Shift) key down as you select. Alternatively, clicking and holding your
mouse button down at an empty location in the Lyric Area and dragging your mouse
over desired Lyrics allows you to select multiple Lyrics in one quick operation. Once
selected, you can then move, duplicate, copy, paste or delete a group of Lyrics at one
time using the right click, menu bar or click and drag method.

 Selecting multiple Lyrics will not be possible if the Eraser tool button at the top of
the Control Draw Editor is currently active. In this case, Lyrics will be deleted one at a
time; each with a click of your mouse.

MOVING LYRICS

Method 1:

Click and drag desired Lyrics to a new location in the Lyric Area.

Method 2:

Select desired Lyric with your mouse and use your computer keyboard's left/right arrow
keys to move Lyrics a Division at a time.

Method 3:

This method allows you to move Lyrics between Documents.

Right-click a Lyric and choose Cut Lyric to remove a Lyric from its current location.
Alternatively, click desired Lyric and choose Cut Lyric from the Edit menu. Using the
Ctrl (or Shift) key while selecting allows you to Cut multiple Lyrics in one operation.

Next, right-click a desired location in the Lyric Area of the desired Document's Control
Draw or Pianoroll Editor and choose Paste Lyric to Paste the Cut Lyric(s). Alternatively,
select a desired location in the Lyric Area and choose Paste Lyric from the Edit menu.

 When Align To Grid is activated, the Lyric being moved will be Pasted to the
nearest Horizontal Grid Resolution point of the selected Lyric Area location as defined in
the Text Event tab of the Grid Setup dialog box.



DUPLICATING LYRICS

Right-click a Lyric and choose Duplicate Lyric to duplicate a Lyric. Alternatively, click
desired Lyrics and choose Duplicate Lyric from the Edit menu. Using the Ctrl (or Shift)
key while selecting allows you to Duplicate multiple Lyrics in one operation.

Unlike the Copy/Paste operation which allows you to choose the location of the "copy"
before it is created, Duplicating a Lyric automatically places the "duplicate" on top of the
original, offset slightly to the right. You can then move the "duplicate" at any time.

COPYING / PASTING LYRICS

Right-click a Lyric and choose Copy Lyric to copy a Lyric. Alternatively, click desired
Lyric and choose Copy Lyric from the Edit menu. Using the Ctrl (or Shift) key while
selecting allows you to copy multiple Lyrics in one operation.

Next, right-click a desired location in the Lyric Area of the desired Document's Control
Draw or Pianoroll Editor and choose Paste Lyric to Paste the Copied Lyric(s).
Alternatively, select a desired location in the Lyric Area and choose Paste Lyric from
the Edit menu.

 When Align To Grid is activated, the Lyric being Copied will be Pasted to the
nearest Horizontal Grid Resolution point of the selected Lyric Area location as defined in
the Text Event tab of the Grid Setup dialog box.

DELETING LYRICS

Method 1:

Select the Eraser tool at the top of the Control Draw Editor and simply click on a Lyric to
delete it. With the Eraser tool, clicking and holding your mouse button down at an empty
location in the Lyric Area and dragging the Eraser over desired Lyrics allows you to
delete multiple Lyrics in one quick operation.

Method 2:

Right-click a Lyric and choose Clear Lyric to delete a Lyric. Alternatively, click desired
Lyrics and choose Clear Lyric from the Edit menu to delete the selected Lyrics. Using
the Ctrl (or Shift) key while selecting allows you to Clear multiple Lyrics in one operation.

 

See also:

Adjusting the Grid display

 



Note Data Area of the Control Draw Editor  
Contents

Control Draw Editor

  

Description Located between the Text Info and Lyric Areas of the Control Draw Editor, the Note Data Area
displays the currently selected Line Block's Note Data in Pianoroll form. This Area is for visual
reference only, and does not provide any editing functions.

 

Uses Refer to the Note Data Area as editing Text, Lyric or MIDI Control Events in the Control Draw
Editor. This will help you keep track of your current location within the Line Block you are editing.

 

Items Note Data
display

This Area displays the Note Data contained in the currently selected Line Block. The
Notes are displayed in horizontal (time) alignment with other objects in the Control
Draw Editor.

 

  



Text Info Area of the Control Draw Editor  
Contents

Control Draw Editor

  

Description The Text Info Area displays general Text Information in a continuous row, parallel to the Bar
Area. It allows you to create/display Text Events such as Rehearsal Letters and Markers.

 

Uses You can create, edit, copy, duplicate, move or delete Rehearsal Letters and Markers in the Text
Info Area as needed. These items can help you organize your composition Document to more
quickly locate a particular point in your music. These settings can then be saved with the
Document.

 

Items Rehearsal Letter event
Marker <From> event
Marker <To> event
Bar Grid
Beat Grid

 



Items in the Text Info Area  
Description of this Area

Using this Area

  

Creating
Text Events

Rehearsal Letter
event

Rehearsal Letters such as A or B, generally appearing at obvious
musical phrase boundaries, serve to provide Bar markings for
rehearsal. These Text Events can also be phrases such as "Verse",
"Chorus", "Intro.", Bridge", or anything you desire. You can create, edit,
copy, duplicate, move or delete Rehearsal Letters as needed.

Marker <From><To>
events

Markers serve to provide Cue markings for rehearsal or sequencing
work. You can use either <From> or <To> depending on your needs.
You can create, edit, copy, duplicate, move or delete Markers as
needed.

Adjusting the
Grid display

Bar Grid Vertical lines horizontally spaced across the Text Info Area indicating
Bar divisions.

Beat Grid Vertical lines horizontally spaced across Bars indicating Beat divisions.

 

  



Using the Text Info Area  
Description of this Area

Items in this Area

  

Adjusting the
Grid display

Bar Grid The Bar Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Bars (Measures) for visual reference. Choose Bar Grid from the
Grid View submenu of the View menu to show or hide the Bar Grid in the Text Info
Area, as well as the Lyric and Draw Areas of the Control Draw Editor.

Beat Grid The Beat Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Beats in each Bar for visual reference. (This is not necessarily
the same as the Alignment Grid.) Choose Beat Grid from the Grid View submenu
of the View menu to show or hide the Beat Grid in the Text Info Area, as well as the
Lyric and Draw Areas of the Control Draw Editor.

 

See also:

Creating and Manipulating Text Events

 



Using the Text Info Area  
Description of this Area

Items in this Area

  

Creating and
Manipulating
Text Events

Rehearsal Letter
event CREATING A REHEARSAL LETTER

Right-click a desired location in the Text Info Area and choose New
Rehearsal Letter to create a blank Rehearsal Letter. Enter desired text
data in the edit box. When you are finished entering, click outside the edit
box or press Enter on your computer's keyboard.

Alternatively, choose New Text Event... from the Edit menu to create a
blank Rehearsal Letter. The New Text Event dialog box will open allowing
you to choose a Rehearsal Letter, Marker <from> or Marker <To> text
event.

 When choosing New Text Event... from the Edit menu, you must first
have selected an empty Text Info Area, otherwise the New Text Event...
item won't be available.

Marker <From>
Marker <To>
events

CREATING A MARKER

Right-click a desired location in the Text Info Area and choose New Marker
<From> or New Marker <To> to create a blank Marker. Enter desired text
data in the edit box. When you are finished entering, click outside the edit
box or press Enter on your computer's keyboard.

Alternatively, choose New Text Event... from the Edit menu to create a
blank Marker. The New Text Event dialog box will open allowing you to
choose a Rehearsal Letter, Marker <from> or Marker <To> text event.

 When choosing New Text Event... from the Edit menu, you must first
have selected an empty Text Info Area, otherwise the New Text Event...
item won't be available.



EDITING TEXT EVENTS

To edit a Text Event, double click it, opening its edit box. After typing your
changes, hit the Enter key, or click someplace outside the edit box to close
it.

 
SELECTING TEXT EVENTS

Using the Arrow tool, you can select individual Text Events. You can select
multiple Text Events by holding the Ctrl (or Shift) key down as you select.
Alternatively, clicking and holding your mouse button down at an empty
location in the Text Info Area and dragging your mouse over desired Text
Events allows you to select multiple Text Events in one quick operation.
Once selected, you can then move, duplicate, copy, paste or delete a group
of Text Events at one time using the right click, menu bar or click and drag
method.

 Selecting multiple Text Events will not be possible if the Eraser tool
button at the top of the Control Draw Editor is currently active. In this case,
Text Events will be deleted one at a time; each with a click of your mouse.

MOVING TEXT EVENTS

Method 1:

Click and drag desired Text Events to a new location in the Text Info Area.

Method 2:

Select desired Text Event with your mouse and use your computer
keyboard's left/right arrow keys to move Text Events a Division at a time.

Method 3:

This method allows you to move Text Events between Documents.

Right-click a Text Event and choose Cut Text Event to remove a Text
Event from its current location. Alternatively, click desired Text Event and
choose Cut Text Event from the Edit menu. Using the Ctrl (or Shift) key
while selecting allows you to Cut multiple Text Events in one operation.

Next, right-click a desired location in the Text Info Area of the desired
Document's Control Draw, Tempo Draw or Pianoroll Editor, or Document
Window and choose Paste Text Event to Paste the Cut Text Event(s).
Alternatively, select a desired location in the Text Info Area and choose
Paste Text Event from the Edit menu.



 When Align To Grid is activated, the Text Event being moved will be
Pasted to the nearest Horizontal Grid Resolution point of the selected Text
Info Area location as defined in the Grid Setup dialog box.

DUPLICATING TEXT EVENTS

Right-click a Text Event and choose Duplicate Text Event to duplicate a
Text Event. Alternatively, click desired Text Events and choose Duplicate
Text Event from the Edit menu. Using the Ctrl (or Shift) key while selecting
allows you to Duplicate multiple Text Events in one operation.

Unlike the Copy/Paste operation which allows you to choose the location of
the "copy" before it is created, Duplicating a Text Event automatically places
the "duplicate" on top of the original, offset slightly to the right. You can then
move the "duplicate" at any time.

COPYING / PASTING TEXT EVENTS

Right-click a Text Event and choose Copy Text Event to copy a Text Event.
Alternatively, click desired Text Event and choose Copy Text Event from
the Edit menu. Using the Ctrl (or Shift) key while selecting allows you to
copy multiple Text Events in one operation.

Next, right-click a desired location in the Text Info Area of the desired
Document's Control Draw, Tempo Draw or Pianoroll Editor, or Document
Window and choose Paste Text Event to Paste the Copied Text Event(s).
Alternatively, select a desired location in the Text Info Area and choose
Paste Text Event from the Edit menu.

 When Align To Grid is activated, the Text Event being Copied will be
Pasted to the nearest Horizontal Grid Resolution point of the selected Text
Info Area location as defined in the Grid Setup dialog box.

DELETING TEXT EVENTS

Method 1:

Select the Eraser tool at the top of the Control Draw Editor and simply click
on a Text Event to delete it. With the Eraser tool, clicking and holding your
mouse button down at an empty location in the Text Info Area and dragging
the Eraser over desired Text Events allows you to delete multiple Text
Events in one quick operation.

Method 2:

Right-click a Text Event and choose Clear Text Event to delete it.
Alternatively, click desired Text Events and choose Clear Text Event from
the Edit menu to delete the selected Text Events. Using the Ctrl (or Shift)
key while selecting allows you to Clear multiple Text Events in one
operation.



 

See also:

Adjusting the Grid display

 



Select a Key dialog box  
Contents

Dialog Boxes

  

Description The Select a Key dialog box is used to assign a MIDI Instrument Key (Pitch value) for Poly After
Touch Events in Tonal Line data.

Uses After opening the Select a Key dialog box, select a Key from the Key scroll area and then click
OK to assign Poly After Touch Events to the Key.

  

Items Key
scroll area

Select MIDI Instrument Key (Pitch value) you wish to assign Poly After Touch Events
to.

OK
button Closes the Select a Key dialog box and commits changes.

Cancel
button Closes the Select a Key dialog box without committing changes.

Help
button Opens this Help document.

 

  

Opening From the
Control Draw Editor

Choose Poly After Touch... from the Control View submenu of the View
menu.

  



Select a Control dialog box  
Contents

Dialog Boxes

  

Description The Select a Control dialog box is used to assign a MIDI Control Event Type to a MIDI Control
Change Event.

Uses After opening the Select a Control dialog box, select a Control Event Type from the Control Event
scroll area and click OK to assign the Control Event Type and close the Select a Control dialog
box.

  

Items Control Event
scroll area

Select the desired Control Event Type you wish to assign to the currently
selected Control Change Event.

OK
button Closes the Select a Control dialog box and commits changes.

Cancel
button Closes the Select a Control dialog box without committing changes.

Help
button Opens this Help document.

 

  

Opening From the
Control Draw Editor

Choose Control Change... from the Control View submenu of the View
menu.

  



Tempo Draw Editor  
Contents

Editors

  

Description The Tempo Draw Editor allows you to edit a Line Block's MIDI Tempo data with a unique
freestyle drawing method.

 

Items The Tempo Draw Editor contains various Buttons and Editing Areas for manipulating MIDI
Tempo Events and other objects. You can choose to Show or Hide the Buttons with the Edit
Buttons command in the View menu. You can adjust the vertical size of each Editing Area by
clicking and dragging the horizontal or vertical separator bar between Areas.

Edit Buttons The Edit Buttons give you quick access to viewing and manipulation tools for
the Tempo Draw Editor.

Bar Area The Bar Area displays a range of Bar lines. Besides managing a song's Time
Grid, this area also allows you to manipulate Loop functions.

Text Info Area The Text Info Area displays Text Events such as Rehearsal Letters and
Markers, allowing you to create or edit them.

Draw Area The Draw Area allows you to edit MIDI Tempo Event data with a unique
drawing method.

 

Opening From the
Document Window

First, select a desired Line Block. Then, either choose Tempo Draw
Editor from the Editors menu, or simply click the Tempo Draw Editor
button at the top of the Document Window.

From the...
Tempo List Editor
Tempo Draw Editor

Choose Tempo Draw Editor from the Editors menu, or simply click the
Tempo Draw Editor button at the top of the Editor Window.
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Bar Area of the Tempo Draw Editor  
Contents

Tempo Draw Editor

  

Description The Bar Area displays Measures or divisions of musical Time, known as Bars, in a continuous
row. This includes Bar Numbers, The Bar Grid and Beat Grid.

 

Uses Besides displaying Bar related information, the Bar Area allows you to manage a song's Time
Signature setup, location of the Playback Pointer, and the Playback Loop settings.

 

Items Playback Pointer
Loop region
Bar Number
Bar Grid
Beat Grid
Location Cursor

 



Items in the Bar Area  
Description of this Area

Using this Area

  

Positioning the
Playback Pointer

Playback Pointer The Playback Pointer resides in its own dark gray area at the top of the
bar area, displaying the current Playback location in the Tempo Draw
Editor. It also allows you to change the current Playback point.

Inserting a
Playback Loop

Loop
region

Displays your current Loop region. Starting Playback repeats (Loops)
Playback in this region until you stop. This region is indicated by the
color blue in the upper portion of the Bar Area in the Tempo Draw
Editor.

Viewing
Bar related
items

Bar Number A series of numbers given to Bars, starting on the left side with 1.

Bar Grid Vertical lines horizontally spaced across the Bar Area indicating Bar
divisions.

Beat Grid Vertical lines horizontally spaced across Bars indicating Beat divisions.

Location Cursor A vertical Location Cursor line in the Bar Area represents the horizontal
position of your mouse as it relates to the time location in your
Document. Corresponding numerical information is also displayed in
the order of "Bar, Beat and Division" in the Interactive Information area
at the bottom of the Tempo Draw Editor. The color of the Location
Cursor depends on your settings in the Microsoft Windows Control
Panel "Display" applet, under the heading "Selected Items" in the
"Items" list of the "Appearance" pane.

 

  



Using the Bar Area  
Description of this Area

Items in this Area

  

Positioning the
Playback Pointer

Playback Pointer
and area

You can use the Playback Pointer to change the Playback point in the
Tempo Draw Editor in two ways: Clicking a desired location in the dark
gray Playback Pointer area at the top, or clicking and dragging the
Playback Pointer to a desired location. Choose Play from the MIDI
menu (or click the Play button in the Playback Control toolbar) to begin
Playback. The Playback Pointer displays the current Playback location
as CAMPS plays MIDI data.

Inserting a
Playback Loop

Loop
region

You can create a Loop region by clicking and dragging with your mouse
in the upper portion of the Bar Area, below the Playback Pointer Area.
As you drag your mouse, the Loop region appears blue in color,
displaying a new Loop region.

Choose Play from the MIDI menu (or click the Play button in the
Playback Control toolbar) to begin Playback. CAMPS repeats Loop
region Playback until you stop it. Click anywhere in the upper portion of
the Bar Area to delete a Loop region.

 The start and end points of the Loop region snap to the Grid
resolution set in the Grid Setup dialog box, if Align to Grid is selected
in the Grid View submenu of the View menu.

Assigning a
Time Signature

Time Signature
settings

CAMPS allows you to assign different Time Signatures to individual
Bars. Right-click a Bar to which you are assigning a new Time
Signature and then choose Time Signature Setup... to open the Time
Signature Setup dialog box. Set a Time Signature in the dialog box and
click OK. (Choosing Time Signature Setup... from the Edit menu
opens the same dialog box.)

 

  



Edit Buttons Area of the Tempo Draw Editor  
Contents

Tempo Draw Editor

  

Description The Edit Buttons are located at the top of the Tempo Draw Editor. These Buttons give you quick
access to frequently used items like View Adjustments, Tools and Editors.

 

Uses The Edit Buttons include most of the View and Editors menu commands. The Tool buttons work
in slightly different ways depending on which Area of the Tempo Draw Editor you are working in.
Choose Edit Buttons from the View menu to show or hide the Edit Buttons.

 

Items Auto Scroll button
Jump To Location button
Zoom Out (H) button
Zoom In (H) button
Align To Grid button
Grid Setup button
Half Note Tempo View button
Quarter Note Tempo View button
8th Note Tempo View button
16th Note Tempo View button
Arrow Tool button
I Beam Tool button
Pen Tool button
Line Tool button
Oval Tool button
Eraser Tool button
Tempo List Editor button
Tempo Draw Editor button
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Items in the Edit Buttons Area  Description of this Area

  

Adjusting
View

Auto Scroll
button

Sets the viewable area in the Bar, Text Info and Draw Areas to follow
the Playback Pointer during Playback and Recording.

Jump To Location
button

Opens the Jump To Location dialog box which allows you to move the
current viewpoint to a specified Bar in the Tempo Draw Editor.

Zoom Out (H)
button

Incrementally decreases the Horizontal size of the Bar, Text Info and
Draw Areas, increasing their viewable area.

Zoom In (H)
button

Incrementally increases the Horizontal size of the Bar, Text Info and
Draw Areas, decreasing their viewable area.

Align To Grid
button

Switches between Activate or Deactivate Align To Grid in the Text
Info and Draw Areas. Grid Alignment is specified in the Grid Setup
dialog box.

Grid Setup
button

Opens the Grid Setup dialog box, allowing you to adjust the
Alignment Grid Resolution for individual areas of the Tempo Draw
Editor and applicable Editors. Depending on which Area of the Tempo
Draw Editor is active before choosing this Menu Item, the
corresponding pane in the Grid Setup dialog box will be preselected.

Half Note Tempo View
button

Sets the vertical Tempo scale in the Draw Area of the Tempo Draw
Editor to use a Half Note time value as a basis, i.e. Half Note = 75
Beats Per Minute.

Quarter Note Tempo View
button

Sets the vertical Tempo scale in the Draw Area of the Tempo Draw
Editor to use a Quarter Note time value as a basis (standard
Metronome scale), i.e. Quarter Note = 150 Beats Per Minute.

8th Note Tempo View
button

Sets the vertical Tempo scale in the Draw Area of the Tempo Draw
Editor to use an 8th Note time value as a basis, i.e. 8th Note = 300
Beats Per Minute.

16th Note Tempo View
button

Sets the vertical Tempo scale in the Draw Area of the Tempo Draw
Editor to use a 16th Note time value as a basis, i.e. 16th Note = 600
Beats Per Minute.

Selecting
Tools

Arrow Tool
button

Selects the Arrow Tool, allowing you to select and manipulate objects
in the Tempo Draw Editor. Objects need to be selected before related
functions become available.

I Beam Tool
button

Selects the I Beam Tool, Allowing you to quickly select regions in the
Draw Area. 

Pen Tool
button

Selects the Pen Tool, allowing you to quickly create or edit MIDI
Tempo Events in the Draw Area with a unique freestyle drawing
method.

Line Tool
button

Selects the Line Tool, allowing you to quickly create and edit Tempo
Events using a straight line drawing method.

Oval Tool
button

Selects the Oval Tool, allowing you to quickly create and edit Tempo
Events using an automatic curve drawing method. 

Eraser Tool
button

Selects the Eraser Tool, allowing you to quickly delete objects in the
Tempo Draw Editor.



Opening
Editors

Tempo List Editor
button

Opens the Tempo List Editor, allowing you to edit individual Tempo
Events of the selected Line Block in vertical list format.

Tempo Draw Editor
button

Opens a new Tempo Draw Editor window, allowing you to make
alternate MIDI Tempo Event edits of the selected Line Block.

 

 

file:///C|/My Documents/Camps/CampsHelp/Editors/TempoDraw/Main.htm


Draw Area of the Tempo Draw Editor  
Contents

Tempo Draw Editor

  

Description The Draw Area is the main MIDI Tempo Event editing area of the Tempo Draw Editor.

 

Uses The Draw Area allows you to quickly create and edit Tempo Events using a freestyle drawing
method. Choose the desired editing tool and simply draw desired changes in the Draw Area with
your mouse.

 

Items MIDI Tempo Event
Bar Grid
Beat Grid
Value Grid
Value Scale
Location Cursor
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Items in the Draw Area  
Description of this Area

Using this Area

  

Manipulating
MIDI Tempo Events

MIDI Tempo Event A MIDI Tempo Event is MIDI data which executes MIDI Tempo
commands. This data effects Playback Tempo of all MIDI devices
connected to the output of CAMPS, including Sync output. You can
create, edit, copy, duplicate, move or delete MIDI Tempo Events as
needed.

Adjusting the
Grid display

Bar Grid Vertical lines horizontally spaced across the Draw Area indicating
the dividing points between Bars.

Beat Grid Vertical lines horizontally spaced across Bars indicating the
dividing points between Beats.

Value Grid Horizontal lines vertically spaced across the Draw Area indicating
the vertical dividing points between Tempo data values.

Value Scale Located on the left side of the Draw Area, this Scale displays the
Value range of the vertical Value Grid in the Draw Area of the
Tempo Draw Editor.

Location Cursor A horizontal Location Cursor line in the Value Scale represents the
vertical position of your mouse as it relates to Tempo Event Value
in the Draw Area of the Tempo Draw Editor. Corresponding
numerical information is also displayed in the Interactive
Information area at the bottom of the Tempo Draw Editor. The color
of the Location Cursor depends on your settings in the Microsoft
Windows Control Panel "Display" applet, under the heading
"Selected Items" in the "Items" list of the "Appearance" pane.
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Using the Draw Area  
Description of this Area

Items in this Area

  

Creating and
Manipulating
MIDI Tempo Events

MIDI Tempo Event Note:

After using any of the special Tool buttons at the top of the Tempo
Draw Editor, be sure to switch back to the standard Arrow Tool for
regular manipulation operations.

CREATING NEW MIDI TEMPO EVENTS

Method 1:

Select the Pen tool at the top of the Tempo Draw Editor and then
click and drag horizontally in the Draw Area to assign Tempo
Events. Events will be created as you draw; their value (vertical
position) following the Pen tool's position.

Method 2:

Select the Line tool at the top of the Tempo Draw Editor and then
click and drag horizontally in the Draw Area to assign Tempo
Events. Events will be created as you draw; their value (vertical
position) following the straight line that results from your drawing
action.



Method 3:

Select the Oval tool at the top of the Tempo Draw Editor and then
click and drag horizontally in the Draw Area to assign Tempo
Events. Events will be created as you draw; their value (vertical
position) following the curved line that results from your drawing
action.

 Besides creating new Event data, all of these methods can
also be used to edit existing Events. The horizontal (time) density
of Events created or edited depends on your settings in the Grid
Setup dialog box. Other settings for Tempo Events such as
Location, Color and Value are adjustable at any later time.



EDITING MIDI TEMPO EVENTS

Method 1:

Using the Arrow tool, click and drag desired Tempo Event to a
new vertical value position the Draw Area. Any horizontal motion
during your dragging operation will effect the Event's location in
time. See MOVING MIDI TEMPO EVENTS below.

 When Align To Grid is activated, the Tempo Event will snap
to the nearest Grid Resolution points of the selected Draw Area
location as defined in the Grid Setup dialog box.

Method 2:

Right Click desired Tempo Event and choose Adjust Value... from
the Actions submenu. Alternatively, click desired Tempo Event
and choose Adjust Value from the Line menu.

Besides these editing methods, see CREATING NEW MIDI
TEMPO EVENTS above.

SELECTING MIDI TEMPO EVENTS

Method 1:

Using the Arrow tool, you can select individual Tempo Events. You
can select multiple Tempo Events by holding the Ctrl (or Shift) key
down as you select. Alternatively, Clicking and holding your mouse
button down at an empty location in the Draw Area and dragging
your mouse over desired Tempo Events allows you to select
multiple Tempo Events in one quick operation.

Method 2:

Using the I Beam tool, you can select all Tempo Events in a



horizontal (time) region at once. After clicking the I Beam button at
the top of the Tempo Draw Editor, click and hold your mouse
button down in an empty location of the Draw Area and drag your
mouse horizontally over the desired Tempo Event region.

Selecting Tempo Events enables use of Tempo Event related
commands under the Edit and Line Menu bar items. Once
selected, you can then move, copy, paste or delete a group of
Tempo Events at one time using the right click, menu bar or click
and drag method.

 Selecting entire Tempo Event regions will not be possible if the
Pen, Line, Oval or Eraser tool button at the top of the Tempo
Draw Editor is currently active. In these cases, Tempo Events will
be created or deleted (depending on which of these buttons is
active).

MOVING MIDI TEMPO EVENTS

Method 1:

Using the Arrow Tool, click and drag desired Tempo Events to a
new location in the Draw Area. Any vertical motion during your
dragging operation will effect the Event's value. See EDITING MIDI
TEMPO EVENTS above.

Method 2:

Select a Tempo Event with your mouse and use the arrow keys on
your computer's keyboard to move Events with more precision. The
up/down arrow keys move a Tempo Event's value in single
increments, and the left/right arrow keys move a Tempo Event's
location by Divisions.

Method 3:



This method allows you to move Tempo Events between
Documents.

Right-click a Tempo Event and choose Cut Tempo Event to
remove a Tempo Event from its current location. Alternatively, click
desired Tempo Event and choose Cut Tempo Event from the Edit
menu. Using the Ctrl (or Shift) key while selecting allows you to Cut
multiple Tempo Events in one operation.

Next, right-click a desired location in the Tempo Draw Editor's
Draw Area of the desired Document and choose Paste Tempo
Event to Paste the Cut Tempo Event(s). Alternatively, select a
desired location in the Draw Area and choose Paste Tempo Event
from the Edit menu.

 When Align To Grid is activated, the Tempo Event being
moved will be Pasted to the nearest Horizontal Grid Resolution
point of the selected Draw Area location as defined in the Grid
Setup dialog box.

DUPLICATING TEMPO EVENTS

Right-click a Tempo Event and choose Duplicate Tempo Event to
duplicate a Tempo Event. Alternatively, click desired Tempo
Events and choose Duplicate Tempo Event from the Edit menu.
Using the Ctrl (or Shift) key while selecting allows you to Duplicate
multiple Tempo Events in one operation.

Unlike the Copy/Paste operation which allows you to choose the
location of the "copy" before it is created, Duplicating a Tempo
Event automatically places the "duplicate" on top of the original.
You can then move the "duplicate" at any time.

COPYING / PASTING MIDI TEMPO EVENTS

Right-click a Tempo Event and choose Copy Tempo Event to
copy a Tempo Event. Alternatively, click desired Tempo Event and
choose Copy Tempo Event from the Edit menu. Using the Ctrl (or
Shift) key while selecting allows you to copy multiple Tempo
Events in one operation.

Then, right-click a desired location in the Tempo Draw Editor's
Draw Area of the desired Document and choose Paste Tempo
Event to Paste the Copied Tempo Event(s). Alternatively, select a
desired location in the Draw Area and choose Paste Tempo Event
from the Edit menu.

 When Align To Grid is activated, the Tempo Event being
Copied will be Pasted to the nearest Horizontal Grid Resolution
point of the selected Draw Area location as defined in the Grid
Setup dialog box.



DELETING MIDI TEMPO EVENTS

Method 1:

Select the Eraser tool at the top of the Tempo Draw Editor and
simply click on a Tempo Event to delete it. With the Eraser tool,
clicking and holding your mouse button down at an empty location
in the Draw Area and dragging the Eraser over desired Tempo
Events allows you to delete multiple Tempo Events in one quick
operation.

Method 2:

Right-click a Tempo Event and choose Clear Tempo Event to
delete a Tempo Event. Alternatively, click desired Tempo Event
and choose Clear Tempo Event from the Edit menu. Using the
Ctrl (or Shift) key while selecting allows you to Clear multiple
Tempo Events in one operation.

 

See also:

Adjusting the Grid display

 



Using the Draw Area  
Description of this Area

Items in this Area

  

Adjusting the
Grid display

Bar Grid The Bar Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Bars (Measures) for visual reference. Choose Bar Grid from
the Grid View submenu of the View menu to show or hide the Bar Grid in the
Draw and Text Info Areas of the Tempo Draw Editor.

Beat Grid The Beat Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Beats in each Bar for visual reference. (This is not necessarily
the same as the Alignment Grid.) Choose Beat Grid from the Grid View submenu
of the View menu to show or hide the Beat Grid in the Draw and Text Info Areas of
the Tempo Draw Editor.

Value Grid The Value Grid is a pattern of evenly spaced horizontal lines marking vertical
divisions between Tempo data Values for visual reference. (This is not necessarily
the same as the Alignment Grid.) Choose Value Grid from the Grid View
submenu of the View menu to show or hide the Value Grid in the Draw Area.

 

See also:

Creating and Manipulating MIDI Tempo Events

 



Text Info Area of the Tempo Draw Editor  
Contents

Tempo Draw Editor

  

Description The Text Info Area displays general Text Information in a continuous row, parallel to the Bar
Area. It allows you to create and display Text Events such as Rehearsal Letters and Markers.

 

Uses Text Events serve to help you organize your composition Document to more quickly locate a
particular point in your music. These settings can then be saved with the Document.

 

Items Rehearsal Letter event
Marker <From> event
Marker <To> event
Bar Grid
Beat Grid

 



Items in the Text Info Area  
Description of this Area

Using this Area

  

Creating
Text Events

Rehearsal Letter
event

Rehearsal Letters such as A or B, generally appearing at obvious
musical phrase boundaries, serve to provide Bar markings for
rehearsal. These Text Events can also be phrases such as "Verse",
"Chorus", "Head", Bridge", or anything you desire. You can create, edit,
copy, duplicate, move or delete Rehearsal Letters as needed.

Marker <From><To>
events

Markers serve to provide Cue markings for rehearsal or sequencing
work. You can use either <From> or <To> depending on your needs.
You can create, edit, copy, duplicate, move or delete Markers as
needed.

Adjusting the
Grid display

Bar Grid Vertical lines horizontally spaced across the Text Info Area indicating
Bar divisions.

Beat Grid Vertical lines horizontally spaced across Bars indicating Beat divisions.

 

  



Using the Text Info Area  
Description of this Area

Items in this Area

  

Creating and
Manipulating
Text Events

Rehearsal Letter
event CREATING A REHEARSAL LETTER

Right-click a desired location in the Text Info Area and choose New
Rehearsal Letter to create a blank Rehearsal Letter. Enter desired text
data in the edit box. When you are finished entering, click outside the edit
box or press Enter on your computer's keyboard.

Alternatively, choose New Text Event... from the Edit menu to create a
blank Rehearsal Letter. The New Text Event dialog box will open allowing
you to choose a Rehearsal Letter, Marker <from> or Marker <To> text
event.

 When choosing New Text Event... from the Edit menu, you must first
have selected an empty Text Info Area, otherwise the New Text Event...
item won't be available.

Marker <From>
Marker <To>
events

CREATING A MARKER

Right-click a desired location in the Text Info Area and choose New Marker
<From> or New Marker <To> to create a blank Marker. Enter desired text
data in the edit box. When you are finished entering, click outside the edit
box or press Enter on your computer's keyboard.

Alternatively, choose New Text Event... from the Edit menu to create a
blank Marker. The New Text Event dialog box will open allowing you to
choose a Rehearsal Letter, Marker <from> or Marker <To> text event.

 When choosing New Text Event... from the Edit menu, you must first
have selected an empty Text Info Area, otherwise the New Text Event...
item won't be available.



EDITING TEXT EVENTS

To edit a Text Event, double click it, opening its edit box. After typing your
changes, hit the Enter key or click someplace outside the edit box to close
it.

 
SELECTING TEXT EVENTS

Using the Arrow tool, you can select individual Text Events. You can select
multiple Text Events by holding the Ctrl (or Shift) key down as you select.
Alternatively, clicking and holding your mouse button down at an empty
location in the Text Info Area and dragging your mouse over desired Text
Events allows you to select multiple Text Events in one quick operation.
Once selected, you can then move, duplicate, copy, paste or delete a group
of Text Events at one time using the right click, menu bar or click and drag
method.

 Selecting multiple Text Events will not be possible if the Eraser tool
button at the top of the Tempo Draw Editor is currently active. In this case,
Text Events will be deleted.

MOVING TEXT EVENTS

Method 1:

Click and drag desired Text Events to a new location in the Text Info Area.

Method 2:

Select desired Text Event with your mouse and use your computer
keyboard's left/right arrow keys to move Text Events a Division at a time.

Method 3:

This method allows you to move Text Events between Documents.

Right-click a Text Event and choose Cut Text Event to remove a Text
Event from its current location. Alternatively, click desired Text Event and
choose Cut Text Event from the Edit menu. Using the Ctrl (or Shift) key
while selecting allows you to Cut multiple Text Events in one operation.

Next, right-click a desired location in the Text Info Area of the desired
Document's Tempo Draw, Control Draw or Pianoroll Editor, or Document
Window and choose Paste Text Event to Paste the Cut Text Event(s).
Alternatively, select a desired location in the Text Info Area and choose
Paste Text Event from the Edit menu.



 When Align To Grid is activated, the Text Event being moved will be
Pasted to the nearest Horizontal Grid Resolution point of the selected Text
Info Area location as defined in the Grid Setup dialog box.

DUPLICATING TEXT EVENTS

Right-click a Text Event and choose Duplicate Text Event to duplicate a
Text Event. Alternatively, click desired Text Events and choose Duplicate
Text Event from the Edit menu. Using the Ctrl (or Shift) key while selecting
allows you to Duplicate multiple Text Events in one operation.

Unlike the Copy/Paste operation which allows you to choose the location of
the "copy" before it is created, Duplicating a Text Event automatically places
the "duplicate" on top of the original, offset slightly to the right. You can then
move the "duplicate" at any time.

COPYING / PASTING TEXT EVENTS

Right-click a Text Event and choose Copy Text Event to copy a Text Event.
Alternatively, click desired Text Event and choose Copy Text Event from
the Edit menu. Using the Ctrl (or Shift) key while selecting allows you to
copy multiple Text Events in one operation.

Next, right-click a desired location in the Text Info Area of the desired
Document's Tempo Draw, Control Draw or Pianoroll Editor, or Document
Window and choose Paste Text Event to Paste the Copied Text Event(s).
Alternatively, select a desired location in the Text Info Area and choose
Paste Text Event from the Edit menu.

 When Align To Grid is activated, the Text Event being Copied will be
Pasted to the nearest Horizontal Grid Resolution point of the selected Text
Info Area location as defined in the Grid Setup dialog box.

DELETING TEXT EVENTS

Method 1:

Select the Eraser tool at the top of the Tempo Draw Editor and simply click
on a Text Event to delete it. With the Eraser tool, clicking and holding your
mouse button down at an empty location in the Text Info Area and dragging
your the Eraser over desired Text Events allows you to delete multiple Text
Events in one quick operation.

Method 2:

Right-click a Text Event and choose Clear Text Event to delete a Text
Event. Alternatively, click desired Text Events and choose Clear Text Event
from the Edit menu to delete the selected Text Events. Using the Ctrl (or
Shift) key while selecting allows you to Clear multiple Text Events in one
operation.



 

See also:

Adjusting the Grid display

 



Using the Text Info Area  
Description of this Area

Items in this Area

  

Adjusting the
Grid display

Bar Grid The Bar Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Bars (Measures) for visual reference. Choose Bar Grid from the
Grid View submenu of the View menu to show or hide the Bar Grid in the Text Info
and Draw Areas of the Tempo Draw Editor.

Beat Grid The Beat Grid is a pattern of evenly spaced vertical lines marking horizontal
divisions between Beats in each Bar for visual reference. (This is not necessarily
the same as the Alignment Grid.) Choose Beat Grid from the Grid View submenu
of the View menu to show or hide the Beat Grid in the Text Info and Draw Areas of
the Tempo Draw Editor.

 

See also:

Creating and Manipulating Text Events

 



Tempo List Editor  
Contents

Editors

  

Description The Tempo List Editor allows you to directly edit a Document's MIDI Tempo Event data values.
Events are listed vertically from the top down.

 

Items The Tempo List Editor contains several Buttons and Data columns for manipulating MIDI Tempo
Events. You can choose to Show or Hide the Buttons with the Edit Buttons command in the
View menu. You can adjust the horizontal size of each Column by clicking and dragging the
vertical separator bar between column headers at the top.

Edit Buttons The Edit Buttons give you quick access to viewing tools for the Tempo
List Editor, as well as Tempo related Editors available in CAMPS.

Playback Pointer Area The Playback Pointer Area displays the Playback Pointer and allows
you to manipulate Loop functions.

List Area The List Area displays MIDI Tempo Event data, listed vertically from the
top down. Each Event's data appears in a horizontal row, and all data
fields can be directly edited.

 



Opening From the
Document Window

First, select a desired Document. Then, either choose Event List Editor
from the Editors menu, or simply click the Tempo List Editor button at
the top of the Document Window.

From the...
Tempo List Editor
Tempo Draw Editor
Text List Editor

Choose Tempo List Editor from the Editors menu, or simply click the
Tempo List Editor button at the top of the Tempo List or Tempo Draw
Editor Window.

 



Edit Buttons Area of the Tempo List Editor  
Contents

Tempo List Editor

  

Description The Edit Buttons at the top of the Tempo List Editor give you quick access to frequently used
items, such as View settings and Editors.

 

Uses The Edit Buttons include many of the View and Editors menu commands. Choose Edit Buttons
from the View menu to show or hide the Edit Buttons.

 

Items Auto Scroll button
Jump To Location button
Tempo List Editor button
Tempo Draw Editor button

 



Items in the Edit Buttons Area  Description of this Area

  

Adjusting
View

Auto Scroll
button

Sets the viewable area in the List Area to follow the Playback Pointer during
Playback.

Jump To Location
button

Opens the Jump To Location dialog box which allows you to move the
current viewpoint to a specified Bar in the Tempo List Editor.

Opening
Editors

Tempo List Editor
button

Opens a new Tempo List Editor window, allowing you to make alternate
MIDI Tempo Event edits in the currently selected Document.

Tempo Draw Editor
button

Opens the Tempo Draw Editor, allowing you to edit a Document's MIDI
Tempo Event data with a unique freestyle drawing method.

 

 



Items in the List Area  
Description of this Area

Using this Area

  

Manipulating
MIDI Tempo Events

MIDI Tempo Event A MIDI Tempo Event is MIDI data which executes MIDI Tempo
commands. You can create, edit, copy, move or delete MIDI
Tempo Events as needed.

Basis Button
column

This column displays a Tempo Event data display button for each
MIDI Tempo Event, allowing you to select display time Basis for
each Tempo Event. Click on a Tempo Event's Basis button in the
left column of the List Area to open the Basis drop-down menu.

Start Location
column

This column displays the Playback Start Location of MIDI Tempo
Events in the format [Bar:Beat:Divisions].

Data
column

This column displays MIDI Tempo Event Data in a decimal value of
Beats Per Minute. Each Tempo Event's data display is in the
context of its Basis button setting.

 

  



List Area of the Tempo List Editor  
Contents

Tempo List Editor

  

Description The List Area is the main editing area of the Tempo List Editor.

 

Uses The List Area allows you to quickly create and edit MIDI Tempo Event data one Event at a time.
To edit an Event value, double click the desired data field and make your changes in the edit box
which opens.

 

Items MIDI Tempo Event
Basis Button column
Start Location column
Data column

 



Using the List Area  
Description of this Area

Items in this Area

  

Creating and
Manipulating
MIDI Tempo Events

MIDI Tempo Event
CREATING NEW MIDI TEMPO EVENTS

Right click desired location in the Tempo List and choose New
Tempo Event. Alternatively, click the desired location in the Event
List and choose New Tempo Event from the Edit menu.

EDITING MIDI TEMPO EVENTS

Method 1:

Double click the desired data field to open its edit box. Use the
up/down buttons or directly edit the values with your computer's
keyboard.

Method 2:

Click the desired Tempo Event and choose Adjust Value... from
the Line menu to open the Value Adjustment dialog box.



SELECTING MIDI TEMPO EVENTS

Using the Arrow tool, you can select individual Tempo Events. You
can select multiple Tempo Events by holding the Ctrl (or Shift) key
down as you select. Once selected, you can then move, copy,
paste or delete a group of Tempo Events at one time using the
right click, menu bar or click and drag method.

Selecting Tempo Events enables use of Tempo Event related
commands under the Edit and Line menu bar items.

MOVING MIDI TEMPO EVENTS

Method 1:

Click and drag desired Tempo Events to a new location in the
Event List Area. As you drag a Tempo Event through the Tempo
Event List, a black horizontal bar appears between existing Events
indicating possible destinations. When this bar appears at the
desired location, release your mouse button to drop the Tempo
Event being moved to the new location.

Method 2:

This method allows you to move Tempo Events between
Documents.

Right-click a Tempo Event and choose Cut Tempo Event to
remove a Tempo Event from its current location. Alternatively, click
desired Tempo Event and choose Cut Tempo Event from the Edit
menu. Using the Ctrl (or Shift) key while selecting allows you to Cut
multiple Tempo Events in one operation.

Next, right-click a desired location in the desired Document's
Tempo List Editor and choose Paste Tempo Event to Paste the
Cut Tempo Event(s). Alternatively, select a desired location in the
List Area and choose Paste Tempo Event from the Edit menu.

 The Tempo Event being moved will be pasted immediately
after the selected destination Tempo Event's location in the List.



COPYING / PASTING MIDI TEMPO EVENTS

Right-click a Tempo Event and choose Copy Tempo Event to
copy a Tempo Event. Alternatively, click desired Tempo Event and
choose Copy Tempo Event from the Edit menu. Using the Ctrl (or
Shift) key while selecting allows you to copy multiple Tempo
Events in one operation.

Next, right-click a desired location in the desired Document's
Tempo List Editor and choose Paste Tempo Event to Paste the
Copied Tempo Event(s). Alternatively, select a desired location in
the List Area and choose Paste Tempo Event from the Edit menu.

 The Tempo Event being copied will be Pasted immediately
after the selected destination Tempo Event's location in the List.

DELETING MIDI TEMPO EVENTS

Right-click a Tempo Event and choose Clear Tempo Event to
delete a Tempo Event. Alternatively, click desired Tempo Event
and choose Clear Tempo Event from the Edit menu. Using the
Ctrl (or Shift) key while selecting allows you to Clear multiple
Tempo Events in one operation.

 

See also:

Adjusting Tempo Data View

 



Using the List Area  
Description of this Area

Items in this Area

  

Adjusting
Tempo Data View

Basis
button/display

Click a Tempo Event's Basis button in the left column of the Tempo List
Editor to open its drop-down Basis menu. The current setting is indicated
with the appropriate Notation symbol in the button face, and a bullet next to
the corresponding item in the drop-down menu. Choices are as follows:

Half Note Sets the Tempo data display to use a Half Note time
value as a basis, i.e. Half Note = 75 Beats Per Minute.

Quarter Note Sets the Tempo data display to use a Quarter Note time
value as a basis (standard Metronome scale), i.e. Quarter
Note = 150 Beats Per Minute.

8th Note Sets the Tempo data display to use an 8th Note time
value as a basis, i.e. 8th Note = 300 Beats Per Minute.

16th Note Sets the Tempo data display to use a 16th Note time
value as a basis, i.e. 16th Note = 600 Beats Per Minute.

 

See also:

Creating and Manipulating MIDI Tempo Events

 



Playback Pointer Area of the Tempo List Editor  
Contents

Tempo List Editor

  

Description The Playback Pointer Area displays the current Playback location and Loop region.

 

Uses The Playback Pointer Area allows you to manage the location of the Playback Pointer, as well as
Playback Loop settings.

 

Items Playback Pointer
Loop region

 



Items in the Playback Pointer Area  
Description of this Area

Using this Area

  

Positioning the
Playback Pointer

Playback Pointer The Playback Pointer resides in its own dark gray column in the far left
side of the Tempo List Editor window. It displays the current Playback
location in the Tempo List Editor and allows you to change the current
Playback point.

Inserting a
Playback Loop

Loop
region

Displays your current Loop region. Starting Playback repeats (Loops)
Playback in this region until you stop. A Loop region is indicated
vertically by the color blue to the right of the dark gray Playback Pointer
column.

 

  



Using the Playback Pointer Area  
Description of this Area

Items in this Area

  

Positioning the
Playback Pointer

Playback Pointer
and area

Unlike most of the other Editors in CAMPS, the Tempo List Editor's
Playback displays vertically instead of horizontally.

You can use the Playback Pointer to change the Playback point in the
Tempo List Editor in two ways: Clicking a desired location in the dark
gray Playback Pointer area on the left, or clicking and dragging the
Playback Pointer vertically to a desired location. Choose Play from the
MIDI menu (or click the Play button in the Playback Control toolbar) to
begin Playback. The Playback Pointer displays the current Playback
location as CAMPS plays MIDI data.

Inserting a
Playback Loop

Loop
region

You can create a Loop region by clicking and dragging with your mouse
vertically in the Loop Area, to the right of the Playback Pointer Area. As
you drag your mouse, the Loop region appears blue in color, displaying
a new Loop region.

Choose Play from the MIDI menu (or click the Play button in the
Playback Control toolbar) to begin Playback. CAMPS repeats Loop
region Playback until you stop it.

 The start and end points of the Loop region snap to the nearest
vertical Event boundary. Click anywhere in the Loop Area to delete a
Loop region.

 

  



Text List Editor  
Contents

Editors

  

Description The Text List Editor allows you to directly edit a Document's general Text Event data values
(other than Lyrics). Events are listed vertically from the top down.

 

Items The Text List Editor contains several Buttons and Data columns for manipulating Text Events.
You can choose to Show or Hide the Buttons with the Edit Buttons command in the View menu.
You can adjust the horizontal size of each Column by clicking and dragging the vertical separator
bar between column headers at the top.

Edit Buttons The Edit Buttons give you quick access to viewing tools for the Text List
Editor, as well as Text related Editors available in CAMPS.

Playback Pointer Area The Playback Pointer Area displays the Playback Pointer, and allows
you to manipulate Loop functions.

List Area The List Area displays Text Event data in the currently selected
Document, listed vertically from the top down. Each Event's data
appears in a horizontal row, and all data fields can be directly edited.

 



Opening From the
Document Window

First, select a desired Document. Then, either choose Event List Editor
from the Editors menu, or simply click the Text List Editor button at the
top of the Document Window.

From the...
Tempo List Editor
Tempo Draw Editor
Text List Editor

Choose Text List Editor from the Editors menu, or simply click the Text
List Editor button at the top of the Text List Editor Window.

 



Edit Buttons Area of the Text List Editor  
Contents

Text List Editor

  

Description The Edit Buttons at the top of the Text List Editor give you quick access to frequently used items,
such as View settings and Editors.

 

Uses The Edit Buttons include two of the View and one of the Editors menu commands. Choose Edit
Buttons from the View menu to show or hide the Edit Buttons.

 

Items Auto Scroll button
Jump To Location button
Text List Editor button

 



Items in the Edit Buttons Area  Description of this Area

  

Adjusting
View

Auto Scroll
button

Sets the viewable portion of the List Area to follow the Playback Pointer
during Playback.

Jump To Location
button

Opens the Jump To Location dialog box which allows you to move the current
viewpoint to a specified Bar in the Text List Editor.

Opening
Editors

Text List Editor
button

Opens a new Text List Editor window, allowing you to make alternate Text
Event edits in the currently selected Document.

 

 



List Area of the Text List Editor  
Contents

Text List Editor

  

Description The List Area is the main editing area of the Text List Editor.

 

Uses The List Area allows you to quickly create and edit Text Event data one Event at a time. To edit
an Event value, double click the desired data field and make your changes in the edit or dialog
box which opens.

 

Items MIDI Text Event
Text Event Icon column
Start Location column
Data column

 



Items in the List Area  
Description of this Area

Using this Area

  

Manipulating
Text Events

MIDI Text Event A MIDI Text Event is MIDI data which containing Text used for general
purposes, such as Rehearsal Letters or Markers. You can create, edit, copy,
move or delete Text Events as needed.

Text Event Icon
column

This column displays any applicable Text Event Icons for Text Events, and
allows you to select a Text Event. Click on a Text Event's Icon in the far left
column of the List Area, or in an Event's data row between any of the data
fields to select an Event and all its data.

Start Location
column

This column displays the MIDI Location of Text Events in the format
[Bar:Beat:Divisions].

Data
column This column displays Text Event Data in its readable Text form.

 

  



Using the List Area  
Description of this Area

Items in this Area

  

Creating and
Manipulating
Text Events

Text Event
CREATING NEW TEXT EVENTS

Right click desired location in the Text List and choose New Text Event.
Alternatively, click the desired location in the Event List and choose New Text
Event from the Edit menu.

EDITING TEXT EVENTS

Double click the desired Position data field to open its edit box and use the
up/down buttons or directly edit the values with your computer's keyboard.

Double click the desired Text data field to open its dialog box and enter desired
changes in the dialog box with your computer's keyboard. Click OK when finished.



SELECTING TEXT EVENTS

Using the Arrow tool, you can select individual Text Events. You can select
multiple Text Events by holding the Ctrl (or Shift) key down as you select. Once
selected, you can then move, copy, paste or delete a group of Text Events at one
time using the right click, menu bar or click and drag method.

Selecting Text Events enables use of Text Event related commands in Edit menu.

MOVING TEXT EVENTS

Method 1:

Click and drag desired Text Events to a new location in the Event List Area. As
you drag a Text Event through the Text Event List, a black horizontal bar appears
between existing Events indicating possible destinations. When this bar appears
at the desired location, release your mouse button to drop the Event being moved
to the new location.

Method 2:

This method allows you to move Text Events between Documents.

Right-click a Text Event and choose Cut Text Event to remove a Text Event from
its current location. Alternatively, click desired Text Event and choose Cut Text
Event from the Edit menu. Using the Ctrl (or Shift) key while selecting allows you
to Cut multiple Text Events in one operation.

Next, right-click a desired location in the desired Document's Text List Editor List
Area and choose Paste Text Event to Paste the Cut Text Event(s). Alternatively,
select a desired location in the List Area and choose Paste Text Event from the
Edit menu.

 The Text Event being moved will be Pasted immediately after the selected
destination Text Event's location in the List.



COPYING / PASTING TEXT EVENTS

Right-click a Text Event and choose Copy Text Event to copy it. Alternatively,
click desired Text Event and choose Copy Text Event from the Edit menu. Using
the Ctrl (or Shift) key while selecting allows you to copy multiple Text Events in
one operation.

Then, right-click a desired location in the desired Document's Text List Editor and
choose Paste Text Event to Paste the Copied Text Event(s). Alternatively, select
a desired location in the List Area and choose Paste Text Event from the Edit
menu.

 The Text Event being copied will be Pasted immediately after the selected
destination Text Event's location in the List.

DELETING TEXT EVENTS

Right-click a Text Event and choose Clear Text Event to delete it. Alternatively,
click desired Text Event and choose Clear Text Event from the Edit menu. Using
the Ctrl (or Shift) key while selecting allows you to Clear multiple Text Events in
one operation.

 



Playback Pointer Area of the Text List Editor  
Contents

Text List Editor

  

Description The Playback Pointer Area displays the current Playback location and Loop region.

 

Uses The Playback Pointer Area allows you to manage the location of the Playback Pointer, as well as
Playback Loop settings.

 

Items Playback Pointer
Loop region

 



Items in the Playback Pointer Area  
Description of this Area

Using this Area

  

Positioning the
Playback Pointer

Playback Pointer The Playback Pointer resides in its own dark gray column in the far left
side of the Text List Editor window. It displays the current Playback
location in the Text List Editor and allows you to change the current
Playback point.

Inserting a
Playback Loop

Loop
region

Displays your current Loop region. Starting Playback repeats (Loops)
Playback in this region until you stop. A Loop region is indicated
vertically by the color blue to the right of the dark gray Playback Pointer
column.

 

  



Using the Playback Pointer Area  
Description of this Area

Items in this Area

  

Positioning the
Playback Pointer

Playback Pointer
and area

Unlike most of the other Editors in CAMPS, the Text List Editor's
Playback displays vertically instead of horizontally.

You can use the Playback Pointer to change the Playback point in the
Text List Editor in two ways: Clicking a desired location in the dark gray
Playback Pointer area on the left, or clicking and dragging the Playback
Pointer vertically to a desired location. Choose Play from the MIDI
menu (or click the Play button in the Playback Control toolbar) to begin
Playback. The Playback Pointer displays the current Playback location
as CAMPS plays MIDI data.

Inserting a
Playback Loop

Loop
region

You can create a Loop region by clicking and dragging with your mouse
vertically in the Loop Area, to the right of the Playback Pointer Area. As
you drag your mouse, the Loop region appears blue in color, displaying
a new Loop region.

Choose Play from the MIDI menu (or click the Play button in the
Playback Control toolbar) to begin Playback. CAMPS repeats Loop
region Playback until you stop it.

 The start and end points of the Loop region snap to the nearest
vertical Event boundary. Click anywhere in the Loop Area to delete a
Loop region.

 

  



Dialog Boxes  Contents

  

Dialog Boxes More than Forty Dialog Boxes are employed in CAMPS to assist in building your
Composition.

The following is a list of Dialog Boxes unique to CAMPS:

 

For Chords Generate Chord Progression Provides a selection of possible Chord substitutions or
Chord Progressions that can replace existing Chords or
fill in missing Chords.

Harmonize Generates numerous alternate Chord Progressions for
Melody harmonization.

Chord Detection Detects Chord Names, complete with Roman Numeral
Analysis, from an external MIDI instrument.

Chord Construction Allows you to manually construct a Chord by assigning its
Symbol, Quality and Tension.

New Chord Allows you to create and set defaults for new Chord
Containers in existing Chord Blocks.

New Chord Block Allows you to create and set defaults for new Chord
Blocks.

 

For Lines Compose Generates an infinite number of alternate Melodies to fit
your Chord Progressions, based on extensive analysis of
your original Melody and various parameters you can set,
including MelodyDraw.

Voicing Provides you with possible Voicings for a selected "Lead
Note".

Dissonant Intervals Detection Detects Dissonant Intervals in Line(s) and between
Line(s) for selected Note(s).

Quantize Allows you to correct the start time of Notes in selected
Line data.

Transpose Allows you to shift the Pitch of Notes in selected Line data
by half steps.

Articulation Adjustment Allows you to adjust the Length of Notes in selected Line
data.

Velocity Adjustment Allows you to adjust the Velocity of Notes in selected Line
data .

Map Pitches Allows you to reassign Line data MIDI Pitch Values,
primarily for remapping synth Drum Program sounds.

Drums Notation Setup Allows you to set up Percussion Notation for viewing
Drum Tracks in the Notation Editor.

 



New Line Block
(Edit Menu)

Opened from the Edit menu, this dialog box allows you to
create and insert new Line Blocks with or without
automatically generated Line data in any Track Category.

New Line Block Opened in the context of a Tonal Track, this dialog box
allows you to create and insert new Line Blocks with or
without automatically generated Tonal Line data.

New Line Block
(Drums)

Opened in the context of a Drum Track, this dialog box
allows you to create and insert new Line Blocks with or
without automatically generated Percussion Line data.

Take List Allows you to create, select and Audition New Takes for a
selected Line Block, with or without automatically
generated Line data.

New Take Opened in the context of a Tonal Line Block, this dialog
box allows you to create and select New Takes with or
without automatically generated Tonal Line data.

New Take
(Drums)

Opened in the context of a Line Block in the Drums
Category, this dialog box allows you to create and select
New Takes with or without automatically generated
Percussion Line data.

 

For MIDI Events New Event Allows you to create and edit specific MIDI Events in
selected Line data.

Select a Control
From Event List Editor

This dialog box is used to select a Control parameter
(Bank, Program, etc.) for Control Change Events.

Select a Control
From Control Draw Editor

This dialog box is used to select a Control parameter
(Bank, Program, etc.) for Control Change Events.

Select a Program This dialog box is used to select a Program Number
(sound; patch, etc.) for Program Change Events.

Select a Key
From Event List Editor

This dialog box is used to select a desired Drum Key
(Pitch value) you wish to assign to the currently selected
Drum Key

Select a Key
From Control Draw Editor

This dialog box is used to select a MIDI Instrument Key
(Pitch value) for Poly After Touch Events.

Select a Drum Key This dialog box is used to select a MIDI Instrument Key
(Pitch value which translates to a Drum sound in the
current Drum Program) to a MIDI Note Event in
Percussion Line data.

Edit a System Exclusive Event Allows you to selectively edit System Exclusive Event
data.

Value Adjustment Allows you to adjust the value of selected MIDI Events.

Displayed Events Allows you to choose which MIDI Events appear in the
Event List Editor.

 



For Text New Text Event Allows you to select a New Text Event, such as a
Rehearsal Letter or Marker, and insert it in the Text Info
Area of your Document.

Memo Allows you to insert and edit Memo text for selected
Documents, Line Blocks or Tracks.

 

Miscellaneous Jump To Location Lets you jump to a specified Bar in the Document and
Editor windows.

 

Preferences Allows you to set defaults for CAMPS general operation.

New Document Setup Allows you to set new blank Document Window defaults.

MIDI Setup Allows you to set defaults for MIDI Interfaces, MIDI
Record Filtering and MIDI synchronization.

Time Signature Setup Allows you to assign Time Signatures to individual Bars.

Grid Setup Allows you to set Alignment Grid resolution defaults for
various Editor areas.

SMPTE Offset Setup Allows you to offset SMPTE synchronization between
CAMPS in slave mode and a master SMPTE device
during Playback and Recording.

 

Export Standard MIDI File Allows save your composition as a Standard MIDI File.

Export Option Allows you to choose certain settings and information to
include when exporting Standard MIDI Files.

 



Articulation Adjustment dialog box  
Contents

Dialog Boxes

  

Description The Articulation Adjustment dialog box allows you to change the length of Notes on an individual
or Line Block basis.

Uses There are three ways to specify the length of Notes in the Articulation Adjustment dialog box;
Relative, Offset and Absolute. Which ever mode you use, setting the Note Length for more
Staccato results in shorter Notes, while setting it for more Tenuto results in longer Notes.

Using the Playback buttons, you can then audition Articulation Adjustments and select one that
sounds good to you.

  

Items Relative radio button
Offset radio button
Absolute radio button
Note Length edit box
Note Length slider
Playback button
Playback with Others button
Stop button
OK button
Cancel button
Help button

  

Opening From the...
Document Window
Event List Editor
Pianoroll Editor
Notation Editor

Choose Adjust Articulation... from the Line menu.
Alternatively, right-click desired Line data and choose Actions, Adjust
Articulation...

 When choosing Adjust Articulation... from the Line menu, Line data must first be selected,
otherwise the Adjust Articulation... item won't be available.



Items in the Articulation Adjustment dialog box  
Description of this dialog box

Using this dialog box

  

Selecting an
Adjustment
Mode

Relative
radio button

Sets the Note Length adjustment to render a relative percentage
of original Note Length.

Offset
radio button

Sets the Note Length adjustment to increase or decrease
divisions of the original Note Length.

Absolute
radio button

Sets the Note Length adjustment to use an absolute amount of
divisions for all Notes.

Adjusting
Articulation

Note Length
edit box

Use the left/right buttons or directly edit the number in this box to
change Note Length (Articulation).

Note Length
slider

Click and drag this slider to the left for shorter (more Staccato)
notes, or to the right for longer (more Tenuto) notes.

Auditioning  Playback Click the Playback (Single Speaker) button to listen to
Articulation Adjustments as you make them.

 Playback with Others Click the Playback with Others (Double Speaker) button to
listen to Articulation Adjustments you make along with all the
other activated Tracks.

 Stop Click the Stop (No Speaker) button to stop Playback.

Closing OK
button

Closes the Articulation Adjustment dialog box and commits
changes.

Cancel
button

Closes the Articulation Adjustment dialog box without committing
changes.

Help
button

Opens this Help document.

 

  



Using the Articulation Adjustment dialog box  
Description of this dialog box

Items in this dialog box

  

Adjusting
Articulation

Relative,
Offset,
Absolute,
radio buttons

After selecting Note data to adjust and opening the Articulation Adjustment dialog
box, choose an adjustment mode. There are three modes for specifying the length
of Notes in the Articulation Adjustment dialog box.

Relative ...Sets a relative percentage of the original Notes' length from 0% (none)
to 200% (double), while still retaining differences in Length from Note to Note.
Offset ...Increases or decreases divisions of the original Notes' length at a rate of
480 divisions per Quarter Note, while still retaining differences in Length from Note
to Note.
Absolute ...Increases or decreases divisions of the original Notes' length from .5
to 1.5 of the average divisions per Note in the currently selected region of Line
data, making the length of all selected Notes the same.

Note
Length
adjustment
area

Next, use the Note Length edit box or slider to adjust Articulation. Entering a
smaller number in the box or dragging the slider to the left results in shorter (more
Staccato) Notes, while entering a bigger number in the box or dragging the slider
to the right results in longer (more Tenuto) Notes.

 

See Also:

Getting Results

 



Using the Articulation Adjustment dialog box  
Description of this dialog box

Items in this dialog box

  

Getting
Results

Playback,
Playback with Others,
Stop
buttons

Each time you make Articulation Adjustments, the selected Line
data is temporarily replaced.

Click the Playback (Single Speaker) button to hear the results of
articulation processing in "Solo" mode. This Auditioning mode
will include any existing Chords if the Chord Track Play button in
the Track Area of the Document Window is activated.

Click the Playback with Others (Double Speaker) button to hear the

results of Articulation processing along with all the other activated
Tracks.

Once either Playback button is clicked, CAMPS will repeat (Loop) Playback
of selected Line data with current Articulation Adjustments as you make
them, until you click the Stop (No Speaker) button. With this feature, you
can change and listen to different Articulation Adjustments "on the fly" or
one by one.

OK
button

Click OK when you have achieved the desired results. This
closes the Articulation Adjustment dialog box and replaces the
selected Line data.

 Changing the length of Note data often causes Notes to overlap. As
always, when Notes overlap you may encounter some unexpected MIDI
performance.

 

See Also:

Adjusting Articulation

 



Chord Construction dialog box  
Contents

Dialog Boxes

  

Description The Chord Construction dialog box allows you to replace Chords in selected Chord Container(s)
with Chords you manually build by defining three elements: Symbol , Quality and Tension.

Uses In the Chord Construction dialog box, CAMPS automatically displays lists of Symbols, Qualities
and Tensions available in the chosen Key and Mode, allowing you to select one of each element
for constructing a Chord.

Using the Playback buttons, you can then audition Constructed Chords and select one that
sounds good to you.

  

Items Key and Mode scroll area

Symbol scroll area

Quality scroll area

Tension scroll area

Constructed Chord(s) scroll area
Key Signature display
Key and Mode display
Chord Name radio button
Roman Numeral radio button
Playback button
Playback with Others button
Stop button
OK button
Cancel button
Help button

  



Opening From the...
Document Window
Pianoroll Editor

Choose Construct... from the Chord menu.
Alternatively, right-click desired Chord(s) and choose Actions,
Construct....

 When choosing Construct... from the Chord menu, you must have selected Chord
Container(s) in the Chord Area, otherwise the Construct... item won't be available.

  



Items in the Chord Construction dialog box  
Description of this dialog box

Using this dialog box

  

Selecting
Chord
Components

Key and Mode
scroll area

The Mode and Key you select here determine the range of
Chords that can be built.

Symbol
scroll area

The Symbol scroll area displays all of the conceivable Chord
Symbols in the range specified by the Key and Mode scroll
area. This is where you select the Chord Symbols you want to
build.

Quality
scroll area

All of the conceivable chord Qualities for the Symbol selected
in the Symbol Scroll area appear in the Quality scroll area. This
is where you select the Quality for the Chord you want to build.

Tension
scroll area

The Tension scroll area displays all of the conceivable Tension
sets from the combination of selected Symbol and Quality. This
is where you select the Tension sets for the Chords you want
to build. 

Selecting a
Constructed
Chord

Constructed Chord(s)
scroll area

The Constructed Chord(s) scroll area displays a list of
Constructed Chords based on your selections in the Key and
Mode, Symbol, Quality and Tension scroll areas.

Key Signature
display

Displays the musical notation form of the Key Signature
selected in the Key and Mode scroll area.

Key and Mode
display

Displays the alphabetic form of Key and Mode selected from
the Key and Mode scroll area.

Appearance of
Constructed
Chord(s)

Chord Name
radio button

Sets the Chord display in the Constructed Chord(s) area to
Chord Name form.

Roman Numeral
radio button

Sets the Chord display in the Constructed Chord(s) area to
Roman Numeral form.

Auditioning  Playback Click the Playback (Single Speaker) button to listen to a
selected Constructed Chord.

 Playback with Others Click the Playback with Others (Double Speaker) button to
listen to a selected Constructed Chord along with all the other
activated Tracks.

 Stop Click the Stop (No Speaker) button to stop Playback.

Closing OK
button

Closes the Chord Construction dialog box and commits
changes.

Cancel
button

Closes the Chord Construction dialog box without committing
changes.

Help
button

Opens this Help document.



 

  



Using the Chord Construction dialog box  
Description of this dialog box

Items in this dialog box

  

Selecting
Chord
Components

Key and Mode
scroll area

Upon selecting Chord Containers whose Chords you want to construct and
opening the Chord Construction dialog box, CAMPS displays the Key and
Mode, Symbol, Quality and Tension for the selected Chord.
Use any desired combination of the following four steps to build Chords in the
Chord Construction dialog box:

1. Select a Key and Mode from the Key and Mode scroll area.

Symbol
scroll area

2. Select a Symbol from the Symbol scroll area. All of the conceivable
Qualities for the selected Symbol appear in the Quality scroll area.



Quality
scroll area

3. Select a Quality from the Quality Scroll Area. All of the conceivable Tension
combinations resulting from Symbol and Quality selections appear in the
Tension scroll area..

Tension
scroll area

4. Select a Tension set from the Tension scroll area. All of the Chords of the
same name that can logically be formed by combining the selected Symbol,
Quality, and Tension appear in the Constructed Chord(s) area.

 

See also:

Selecting a Chord
Getting Results

 



Using the Chord Construction dialog box  
Description of this dialog box

Items in this dialog box

  

Selecting a
Chord

Constructed
Chord(s)
scroll area

When there are a number of Chords of the same name (but different Roman
Numeral) in the Constructed Chord(s) scroll area, you can select any one you
want. You can also alter the selected Chord to Inverted Chords. Refer to the
Key Signature and Key and Mode Displays for the Chord when making your
selection.

Chord Name,
Roman Numeral
radio buttons

Click the Chord Name or Roman Numeral radio button to choose your
desired Chord display style in the Constructed Chord(s) area.

 

See also:

Selecting Chord Components
Getting Results

 



Using the Chord Construction dialog box  
Description of this dialog box

Items in this dialog box

  

Getting
Results

Playback,
Playback with Others,
Stop
buttons

Click the Playback (Single Speaker) button to listen to the Chord currently
selected in the Constructed Chord(s) scroll area. Click the Playback with
Others (Double Speaker) button to hear the Constructed Chord along with
all the other activated Tracks.

Once either Playback button is clicked, CAMPS will repeat (Loop) Playback
of a Constructed Chord, even while selecting different Chord components,
until you click the Stop (No Speaker) button. With this feature, you can
change and listen to different Chord Constructions "on the fly" or one by
one.

OK
button

Selecting a Chord in the Constructed Chord(s) scroll area and clicking OK
closes the Chord Construction dialog box and replaces the contents of the
selected Chord Container(s) with your newly Constructed Chord.

 

See also:

Selecting Chord Components
Selecting a Chord

 



Chord Detection dialog box  
Contents

Dialog Boxes

  

Description The Chord Detection dialog box allows you to replace Chords in selected Chord Containers with
Chords detected from your MIDI instrument.

Uses In the Chord Detection dialog box, CAMPS automatically displays detected MIDI Notes and
resulting Chords as you play Chords or Arpeggios on your MIDI instrument, based on your
selection of Key and Mode.

Using the Playback buttons, you can then audition the Detected Chords and select one that
sounds good to you.

  

Items Key and Mode scroll area
Key Signature display
Key and Mode display
MIDI Input scroll area
Detected Chord(s) scroll area
Chord Name radio button
Roman Numeral radio button
Playback button
Playback with Others button

Stop button

OK button
Cancel button
Help button

  

Opening From the...
Document Window
Pianoroll Editor

Choose Detect... from the Chord menu.
Alternatively, right-click desired Chord Container(s) and choose Actions,
Detect....

 When choosing Detect... from the Chord menu, you must have selected Chord Container(s)
in the Chord area, otherwise the Detect... item won't be available.



Items in the Chord Detection dialog box  
Description of this dialog box

Using this dialog box

  

Specifying
Chord Detection
Parameters

Key and Mode
scroll area

The Keys and Modes you select here determine the range of
Chords that can be detected. Multiple combinations can be
selected.

Key Signature
display

Displays the musical notation form of the Key Signature
selected in the Key and Mode scroll area.

Key and Mode
display

Displays the alphabetic form of Key and Mode you select
from the Key and Mode scroll area.

MIDI Input
scroll area

This scroll area displays Notes detected from your MIDI
instrument using the format
"Note Name:relative Chord Tone".

Selecting a
Chord

Detected Chord(s)
scroll area

The Detected Chord(s) scroll area displays all of the Chords
that can be built with the Notes input from your MIDI
instrument based on selections in the Key and Mode scroll
area.

Appearance of
Detected Chords

Chord Name
radio button

Sets the Chord display in the Detected Chord(s) scroll area
to Chord Name form.

Roman Numeral
radio button

Sets the Chord display in the Detected Chord(s) scroll area
to Roman Numeral form.

Auditioning  Playback Click the Playback (Single Speaker) button to listen to a
selected Detected Chord.

 Playback with Others Click the Playback with Others (Double Speaker) button to
listen to a selected Detected Chord along with all the other
activated Tracks.

 Stop Click the Stop (No Speaker) button to stop Playback.

Closing OK
button

Closes the Chord Detection dialog box and commits
changes.

Cancel
button

Closes the Chord Detection dialog box without committing
changes.

Help
button

Opens this Help document.

 



Using the Chord Detection dialog box  
Description of this dialog box

Items in this dialog box

  

Chord Detection
Parameters

Key and Mode
scroll area

After selecting Chord Containers and opening the Chord Detection dialog
box, CAMPS begins with the Key and Mode of the currently selected Chord
Container for your convenience.

Select a different Key or Mode as needed. Multiple combinations can be
selected simultaneously by holding the Control or Shift key down while
clicking. This gives CAMPS a wider Tonality base with which to detect
possible Chord spellings from your input.

As you change Key or Mode selections, CAMPS automatically adjusts the
range of available Chords for the Notes input from your MIDI instrument.

MIDI Input
Scroll area

The MIDI Input scroll area is where CAMPS displays information about the
Notes you input from a MIDI instrument. Displayed are the Note Names
and relative Chord Tones, based on the current Key and Mode selections.



 

See also:

Selecting a Chord
Getting Results

  



Using the Chord Detection dialog box  
Description of this dialog box

Items in this dialog box

  

Selecting a
Chord

Detected Chord(s)
scroll area

Basically, CAMPS compares the Notes you input with the current Key and
Mode selections to calculate a list of available Chords. Note order is
referenced to determine Inversion and Root possibilities. The results are
displayed in the Detected Chord(s) scroll area. Simply select one as
desired.

Chord Name,
Roman Numeral
radio buttons

Click the Chord Name or Roman Numeral radio button to choose your
desired Chord display style in the Detected Chord(s) scroll area.

 

See also:

Chord Detection Parameters
Getting Results

 



Using the Chord Detection dialog box  
Description of this dialog box

Items in this dialog box

  

Getting
Results

Playback,
Playback with Others,
Stop
buttons

Click the Playback (Single Speaker) button to listen to the Chord currently
selected in the Detected Chord(s) scroll area. Click the Playback with
Others (Double Speaker) button to hear the selected Detected Chord along
with all the other activated Tracks.

Once either Playback button is clicked, CAMPS will repeat (Loop) Playback
of Detected Chord(s) as you select them, even while inputting new notes
from your MIDI instrument, until you click the Stop (No Speaker) button.
With this feature, you can change and listen to different Chords "on the fly"
or one by one.

OK
button

Selecting a Chord in the Detected Chord(s) scroll area and clicking OK
closes the Chord Detection dialog box and replaces the contents of the
selected Chord Container(s) with your newly Detected Chord.

 

See also:

Chord Detection Parameters
Selecting a Chord

 



Generate Chord Progression dialog box  
Contents

Dialog Boxes

  

Description The Generate Chord Progression dialog box provides a selection of new or substitute Chords or
Chord Progressions for a selected Chord Block or Chord Containers.

Uses Upon opening the Generate Chord Progression dialog box, CAMPS automatically begins
generating new or alternate Chord Progressions based on existing Chord, Key and Mode data, if
any, without referencing any Line data.

Using the Playback buttons, you can then audition Generated Chord Progressions and select
one that sounds good to you.

  

Items Chord Progression(s) scroll area

Suspend/Continue button
Chord Name radio button
Roman Numeral radio button
Playback button
Playback with Others button
Stop button

Next button

Previous button
OK button
Cancel button
Help button

  



Opening From the...
Document Window
Pianoroll Editor

Choose Generate... from the Chord menu.
Alternatively, right-click desired Chord Container and choose Actions,
Generate....

 When choosing Generate from the Chord menu, you must first have selected Chord

Containers in the Chord Area, otherwise the Generate item won't be available.

  



Items in the Generate Chord Progression dialog box  
Description of this dialog box

Using this dialog box

  

Selecting a
Chord

Chord Progression(s)
scroll area

Displays a list of generated Chord Progressions in the Key and
Mode of each Chord in the currently selected Chord Block.

Suspend/Continue
button

Click the Suspend/Continue button to suspend or continue
generating Chord Progressions in the Chord Progression(s)
scroll area.

Appearance of
Chords

Chord Name
radio button

Sets the Chord display in the Chord Progression scroll area to
Chord Name form.

Roman Numeral
radio button

Sets the Chord display in the Chord Progression scroll area to
Roman Numeral form.

Auditioning  Playback Click the Playback (Single Speaker) button to listen to a
selected Chord Progression.

 Playback with Others Click the Playback with Others (Double Speaker) button to
listen to a selected Chord Progression along with all the other
activated Tracks.

 Stop Click the Stop (No Speaker) button to stop Playback.

Next
button

Click the Next button to hear the next Chord Progression you
have check marked in the Chord Progression(s) scroll area.

Previous
button

Click the Previous button to hear the previous Chord
Progression you have check marked in the Chord
Progression(s) scroll area.

Closing OK
button

Closes the Generate Chord Progression dialog box and
commits changes.

Cancel
button

Closes the Generate Chord Progression dialog box without
committing changes.

Help
button

Opens this Help document.

 

  



Using the Generate Chord Progression dialog box  
Description of this dialog box

Items in this dialog box

  

Generating
Chord
Progressions

In addition to its ability to generate alternatives for existing Chords like the contextual
(right-click) Alternatives menu item, the Generate Chord Progression dialog box can actually
generate a sequence of relative Chords (Progressions) at once. It can also generate Chords or
Progressions for empty Chord Containers. Neighboring Chords are referenced to provide
harmonic continuity.

One of the most powerful features of the Generate Chord Progression dialog box is its ability to
"fill in" missing Chords in a Chord Progression. To take advantage of this ability, select a range
of empty Chord Containers in between completed ones before choosing the Generate... menu
item.

 

See Also:

Selecting a Chord Progression
Getting Results

 



Using the Generate Chord Progression dialog box  
Description of this dialog box

Items in this dialog box

  

Selecting a
Chord
Progression

Chord
Progression(s)
scroll area

Choose a desired Chord Progression in the Chord Progression(s) scroll
area.

Suspend/Continue
button

During the Chord Generation process, you can always suspend and
continue generation by clicking the Suspend/Continue button. This
feature is especially useful when CAMPS is generating a vast number of
Chords or Chord Progressions. When CAMPS is finished generating
Chord Progressions, the label on this button changes to "Done".

Chord Name,
Roman Numeral
radio buttons

Click the Chord Name or Roman Numeral radio button to choose your
desired Chord display style in the Chord Progression(s) scroll area.

 

See Also:

Generating Chord Progressions
Getting Results

 



Using the Generate Chord Progression dialog box  
Description of this dialog box

Items in this dialog box

  

Getting
Results

Playback,
Playback with Others,
Stop
buttons

Click the Playback (Single Speaker) button to listen to the Chord
Progression currently selected in the Chord Progression(s) scroll area. Click
the Playback with Others (Double Speaker) button to hear the Chord
Progression along with all the other activated Tracks.

Once either Playback button is clicked, CAMPS will repeat (Loop) Playback
of Chord Progressions as you select them, until you click the Stop (No
Speaker) button. With this feature, you can change and listen to different
Chord Progressions "on the fly" or one by one.

Next,
Previous
buttons

When CAMPS generates a vast number of Chord Progressions, check
mark the ones that sound good to you as you listen. Use the Next and
Previous buttons to instantly switch between the check marked chords.

OK
button

Selecting a Chord Progression in the Chord Progression(s) scroll area and
clicking OK closes the Generate Chord Progression dialog box and
replaces the contents of the selected Chord Container(s) with the newly
generated Chord Progression.

 CAMPS will always generate Chord Progressions that flow smoothly
into each other within a Chord Block.

 

See also:

Generating Chord Progressions
Selecting a Chord Progression

 



New Chord Block dialog box  
Contents

Dialog Boxes

  

Description The New Chord Block dialog box allows you to create New Chord Blocks with automatically
assigned Chords, if desired.

Uses After selecting an empty Chord Area and opening the New Chord Block dialog box, select
whether or not to EZgenerate Chords and choose the Chord Quantity, Chord Duration, Mode and
Key for Chord Containers in the New Chord Block to be Generated.

Next, click the New button to save current settings and Generate a new Chord Block in the
selected Chord Area.

  

Items Chord Quantity edit box
Chord Duration radio buttons
Other divisions edit box
EZgenerate Chords check box
Mode selection box
Key selection box
New button
Cancel button
Help button

  

Opening From the...
Document Window
Pianoroll Editor

Choose New Chord Block... from the Edit menu.
Alternatively, right-click desired empty Chord Area and choose New Chord
Block....

 When choosing New Chord Block... from the Edit menu, you must first have selected an
empty Chord Area, otherwise the New Chord Block... item won't be available.

  



Items in the New Chord Block dialog box  
Description of this dialog box

Using this dialog box

  

Selecting
Time parameters

Chord Quantity
edit box

Use the up/down buttons or directly edit the number in this box to
change the desired quantity of Chord Containers for each New
Chord Block.

Chord Duration
radio buttons

Choose Chord Container time values of either a Quarter Note, Half
Note, Dotted Half Note, Whole Note, or Other specified amount of
divisions of a Chord Block.

Other divisions
edit box

Use the up/down buttons or directly edit the number in this box to
change how many Divisions the Chord Container size will be in
relation to the New Chord Block.

Selecting
Chord parameters

EZgenerate Chords
check box

Checkmark this item to have CAMPS automatically generate and
insert Chords in each Chord Container of the New Chord Block.

Mode
selection box

Click the drop-down list button on the right side of this box to
choose the New Chord Block's Chord Container Mode (Tonality).

Key
selection box

Click the drop-down list button on the right side of this box to
choose the New Chord Block's Chord Container Key (Key
Signature).

Key Signature
display

Displays the musical notation form of the Key Signature resulting
from your selections in the Key and Mode boxes.

Closing New
button

Clicking the New button closes the New Chord Block dialog box,
inserts a new Chord Block in the selected Chord Area and
automatically assigns Chords to the Chord Containers in the New
Chord Block if the EZgenerate Chords check box is checkmarked.

Cancel
button

Clicking the Cancel button closes the New Chord Block dialog box
without committing any changes.

Help
button

Opens this Help document.

 

  



Using the New Chord Block dialog box  
Description of this dialog box

Items in this dialog box

  

Selecting
Time Parameters

Getting Started If a new Chord Block is to span more than one Bar, be sure to select the
first Bar of the Chord Area where you want the new Chord Block before
opening the New Chord Block dialog box.

Chord Quantity
edit box

When setting time related parameters in the New Chord Block dialog
box, consider how many Chord Containers (Changes) per Beat or Bar
you want your song to have. These settings will directly impact how
many Beats or Bars long the new Chord Block will be.

Chord Duration
radio buttons

For example, in 4/4 time, selecting a Chord Quantity of 4 and a Chord
Duration of a Whole Note will result in a Chord Block spanning 4 Bars
with one Chord Container per Bar

Alternatively, selecting a Chord Quantity of 1 and a Chord Duration of a
Quarter Note will result in a Chord Block with only one Chord Container,
and only 1/4 of a Bar long.

A more typical example would be to select a Chord Quantity of 2 and a
Chord Duration of a Half Note, resulting in a Chord Block 1 Bar long with
2 Chord Containers having 2 Beats each.

 Grabbing and dragging the right edge of a Chord Container's Chord
box lets you freely change its Duration. Increasing a Chord's Duration
will alter the start time of any following Chord Containers in the same
Chord Block.

Other divisions
edit box

Specifying a Chord Container time value other than standard music
notation time values can be used for things like a more Human sounding
transition point, a "freeform" piece of music, or compensating for small
glitches when trying to synchronize with the outside world.

 Division ratio is 480 per Quarter Note.

 Using freeform sizes for Chord Containers can easily result in Chord

Blocks not lining up with standard Bars or the Quantize Grid.

 



See also:

Selecting Chord Parameters
Getting Results

 



Using the New Chord Block dialog box  
Description of this dialog box

Items in this dialog box

  

Selecting
Chord Parameters

Overview Since the function of Chord Containers in CAMPS is to determine
the harmonic flow of your music so that CAMPS can do its magic,
having the Chord Container structure match your song will yield the
best results. Using the EZgenerate Chords check box creates New
Chord Blocks whose Chord Containers will already be filled in with
CAMPS-generated Chords. Letting CAMPS EZgenerate Chords
without further Chord editing will actually define your song's
harmonic structure.

This may not always result in desired harmony. The more harmony
you define (either manually or via a song Imported into CAMPS),
the better your musical results will be. While "EZ" functions in
CAMPS can yield some interesting results, they are designed as a
quick starting point for novice users, not song "wizards".

Mode and Key Selections in the New Chord Block dialog box set
the Tonality for the Chord Containers in the New Chord Block being
created, which CAMPS in turn uses to generate the Chords in the
New Chord Block's Chord Containers.

EZgenerate Chords
check box

Checkmarking this item causes CAMPS to automatically generate
and insert Chords in each Chord Container of the New Chord
Block. EZgenerated Chords will follow settings made in the Mode
and Key selection boxes. If any of the EZgenerated Chords are not
to your liking, they can easily be edited later, using any one of
many methods available in CAMPS.

 If any Line Blocks in Categories other than Drums exist in the
same Bar region as the New Chord Block being created with the
EZgenerate Chords option activated, CAMPS will generate Chords
that Harmonize with the existing Line data instead of arbitrarily
creating a Chord Progression.

Mode
selection box

When you select a new Mode, CAMPS always compares the
previous Key setting to your Mode selection and changes the Key
setting to the Relative Major Key of the chosen Mode.

Key
selection box

Choosing a Key after selecting a Mode lets you completely define
the Tonality of the Chord Block being generated.

Key Signature
display

To keep the resulting musical Scale's Note Names in mind, refer to
the Key Signature display while making your selections.



 

See also:

Selecting Time Parameters
Getting Results

 



Using the New Chord Block dialog box  
Description of this dialog box

Items in this dialog box

  

Getting
Results

New
button

Clicking the New button inserts a New Chord Block starting at the Bar in the Chord Area
selected when opening the New Chord Block dialog box. If the EZgenerate Chords check
box was selected, CAMPS also inserts generated Chords in the Chord Containers of the
New Chord Block.

Keep in mind that if a New Chord Block exceeds the available space between your initial
Chord Area selection and the starting point of a following Chord Block, then the end of the
New Chord Block will overlap the beginning of the next Chord Block. The visible Chords in an
overlapping area will become the active Chords in that area for all Chord related CAMPS
functions.

To choose which Chord Block is visible and active in an overlapping Chord area, right click
the desired Chord Block's Selection Bar and choose Bring to Front or Send to Back.

 

See also:

Selecting Time Parameters
Selecting Chord Parameters

 



New Chord dialog box  
Contents

Dialog Boxes

  

Description The New Chord dialog box allows you to create new Chord Containers with automatically
assigned Chords, if desired.

Uses After selecting a Chord Block or Chord Container and opening the New Chord dialog box, select
whether or not to EZgenerate Chords and choose the Chord Quantity, Chord Duration, Mode and
Key for the New Chord(s).

Next, click the New button to create new Chord Containers in the selected Chord Block.

  

Items Chord Quantity edit box
Chord Duration radio buttons
Other divisions edit box
EZgenerate Chords check box
Mode selection box
Key selection box
New button
Cancel button
Help button

  

Opening From the...
Document Window
Pianoroll Editor

Choose New Chord... from the Edit menu.
Alternatively, right-click desired Chord and choose New Chord....

 When choosing New Chord... from the Edit menu, you must first have selected a Chord
Container, otherwise the New Chord... item won't be available.

  



Items in the New Chord dialog box  
Description of this dialog box

Using this dialog box

  

Selecting
Time Parameters

Chord Quantity
edit box

Use the up/down buttons or directly edit the number in this box to
change the desired quantity of Chord Containers to create.

Chord Duration
radio buttons

Choose Chord Container time values of either Quarter Note, Half
Note, Dotted Half Note, Whole Note, or Other specified amount of
divisions of the Chord Block where the New Chords will be created.

Other divisions
edit box

Use the up/down buttons or directly edit the number in this box to
change how many Divisions the Chord Container size will be in
relation to the Chord Block.

Selecting
Chord Parameters

EZgenerate Chords
check box

Checkmark this item to have CAMPS automatically generate and
insert Chords in each New Chord Container.

Mode
selection box

Click the drop-down list button on the right side of this box to
choose the Chord Container Mode (Tonality).

Key
selection box

Click the drop-down list button on the right side of this box to
choose the Chord Container Key (Key Signature).

Key Signature
display

Displays the musical notation form of the Key Signature resulting
from your selections in the Key and Mode boxes.

Closing New
button

Clicking the New button closes the New Chord dialog box, inserts
new Chord Containers in the selected Chord Block, and
automatically assigns Chords to the New Chord Containers if the
EZgenerate Chords check box is checkmarked.

Cancel
button

Clicking the Cancel button closes the New Chord dialog box
without committing any changes.

Help
button

Opens this Help document.

 

  



Using the New Chord dialog box  
Description of this dialog box

Items in this dialog box

  

Selecting
Time Parameters

Getting Started Before opening the New Chord dialog box, select a Chord Container at
the location where you want the new Chords inserted. When the New
Chord is inserted, the selected and following Chords will be moved to the
right. To insert new Chords at the end of a Chord Block, click only the
Chord Block Selection Bar without highlighting any existing Chord
Containers before opening the New Chord dialog box. In this case, you'll
need to select New Chord... from the Edit menu, as the contextual
(right-click) menu will only give Chord Block options.

Chord Quantity
edit box

When setting time related parameters in the New Chord dialog box,
consider how many Chord Containers (Changes) per Beat or Bar you
want your song to have. These settings will directly impact how many
Beats or Bars long the selected Chord Block will become.

Chord Duration
radio buttons

For example, in 4/4 time, selecting a Chord Quantity of 4 and a Chord
Duration of a Whole Note will result in a Chord Block spanning 4
additional Bars with one Chord Container per additional Bar

Alternatively, selecting a Chord Quantity of 1 and a Chord Duration of a
Quarter Note will result in a Chord Block with only one additional Chord
Container 1/4 of a Bar long.

 Grabbing and dragging the right edge of a Chord Container lets you
freely change its Duration. Increasing a Chord's Duration will alter the
start time of any following Chord Containers in the same Chord Block, as
well as the size of the current Chord Block.

Other divisions
edit box

Specifying a Chord Container time value other than standard music
notation time values can be used for things like a more Human sounding
transition point, a "freeform" piece of music, or compensating for small
glitches when trying to synchronize with the outside world.

 Division ratio is 480 per Quarter Note.

 Using freeform sizes for Chord Containers may result in Chord
Blocks not lining up with Bar Lines or the Quantize Grid.

 



See also:

Selecting Chord Parameters
Getting Results

 



Using the New Chord dialog box  
Description of this dialog box

Items in this dialog box

  

Selecting
Chord Parameters

Overview Since the function of Chord Containers in CAMPS is to determine
the harmonic flow of your music so that CAMPS can do its magic,
having the Chord Container structure match your song will yield the
best results. Using the EZgenerate Chords check box creates
Chord Containers already filled in with CAMPS-generated Chords.
Letting CAMPS EZgenerate Chords without further Chord editing
will actually define your song's harmonic structure.

This may not always result in desired harmony. The more harmony
you define (either manually or via a song Imported into CAMPS),
the better your musical results will be. While "EZ" functions in
CAMPS can yield some interesting results, they are designed as a
quick starting point for novice users, not a song "wizard".

Mode and Key Selections in the New Chord dialog box set the
Tonality for the Chord Containers being created, which CAMPS in
turn uses to generate the Chords in the New Chord Containers.
Upon opening the New Chord dialog box, Mode and Key settings
default to those in the Chord Block you are currently working in.

EZgenerate Chords
check box

Checkmarking this item causes CAMPS to automatically generate
and insert Chords in each New Chord Container. EZgenerated
Chords will follow settings made in the Mode and Key selection
boxes. If any of the EZgenerated Chords are not to your liking, they
can easily be edited later, using any one of many methods
available in CAMPS.

 If any Line Blocks in Categories other than Drums exist in the
same Bar region as the New Chord being created with the
EZgenerate Chords option activated, CAMPS will generate Chords
that Harmonize with the existing Line data instead of arbitrarily
creating a Chord Progression.

Mode
selection box

When you select a new Mode, CAMPS always compares the
previous Key setting to your Mode selection and changes the Key
setting to the Relative Major Key of the chosen Mode.

Key
selection box

Choosing a Key after selecting a Mode lets you completely define
the Tonality of the Chord Containers being generated.

Key Signature
display

To keep the resulting musical Scale's Note Names in mind, refer to
the Key Signature display while making your selections.



 

See also:

Selecting Time Parameters
Getting Results

 



Using the New Chord dialog box  
Description of this dialog box

Items in this dialog box

  

Getting
Results

New
button

Clicking the New button inserts new Chord Containers at the location of the selected Chord
in the selected Chord Block, moving existing Chord Containers to the right. If only the Chord
Block itself was selected without highlighting one of its Chord Containers before opening the
New Chord dialog box, the New Chords will be inserted at the end of the selected Chord
Block. Either way, the Chord Block will increase in Length.

Keep in mind that if another Chord Block already exists right after the Chord Block you are
adding to, Chords being moved to the right will slip behind the next Chord Block, resulting in
overlapping Chord Blocks. The visible Chords in an overlapping area will become the active
Chords in that area for all Chord related CAMPS functions.

To choose which Chord Block is visible and active in an overlapping Chord Area, right click
the desired Chord Block Selection Bar and choose Bring to Front or Send to Back.

If the EZgenerate Chords check box was selected before clicking New, CAMPS also inserts
automatically generated Chords in the new Chord Containers. These generated Chords will
follow the tonality of your Key and Mode settings in the New Chord dialog box.

 

See also:

Selecting Time Parameters
Selecting Chord Parameters

 



Compose dialog box  
Contents

Dialog Boxes

  

Description The Compose dialog box allows you to adjust guidelines for Auto Composing new Melodic,
Chordal or Rhythmic Line data, and allows you to Auto Compose these Lines with the click of a
button.

Uses This is, by far, one of the most powerful and complex dialog boxes in CAMPS. Here you can
adjust many subtleties and tendencies of projected results. Each time you click the Compose
button, CAMPS combines your finer settings with automatic analysis of the selected Line data
and it's assigned Chords to give you a different result.

Using the Playback buttons, you can then audition Compose results and select one that sounds
good to you.

  

Items Category selection box
Parameters pane
MelodyDraw pane
Rhythm Compose check box
Compose button
Remove button
Take scroll area
Name edit box
Playback button
Playback with Others button
Stop button
OK button
Cancel button
Help button

  



Opening From the...
Document Window
Pianoroll Editor
Notation Editor

Choose Compose... from the Line menu.
Alternatively, right-click desired Line data and choose Actions,
Compose....

 When choosing Compose... from the Line menu, you must first have selected Line data,
otherwise the Compose... item won't be available.

  



Items in the Compose dialog box  
Description of this dialog box

Using this dialog box

  

Adjusting
Compose
Parameters

Category
selection box

The Category box displays the Category of the Track you selected
before opening the Compose dialog box. Click the drop-down
button to select a different Category for the Line data being
Composed.

Parameters
pane

Click the Parameters tab to open the Parameters pane. The
Parameters pane has several subpanes which allow you to adjust
several types of musical Parameters for use by the CAMPS
Compose function.

MelodyDraw
pane

Click the MelodyDraw tab to open the MelodyDraw pane.
MelodyDraw is a unique freestyle drawing tool for "graphing"
desired Pitch occurrences of Auto Compose results.

Rhythm Compose
check box

The Rhythm Compose check box determines whether Rhythmic
Auto Composition is added to the Compose function.

Composing Compose
button

Clicking Compose in the Compose dialog box starts Auto
Composition of the selected Line data.

Remove
button

Click the Remove button to delete an undesired Auto Compose
result from the Take scroll area.

Take
scroll area

This is where CAMPS temporarily stores results from Auto
Composing. As Takes are generated, they can be Auditioned,
deleted or written over selected Track Line data.

Name
edit box

The Name edit box allows you to rename Takes in the Take scroll
area (except for the Original) to help you identify numerous Takes.

Auditioning  Playback Click the Playback (Single Speaker) button to listen to the
Compose results.

 Playback with Others Click the Playback with Others (Double Speaker) button to listen
to the Compose results along with all the other activated Tracks.

 Stop Click the Stop (No Speaker) button to stop Playback.

Closing OK
button

Closes the Compose dialog box and commits changes.

Cancel
button

Closes the Compose dialog box without committing changes.

Help
button

Opens this Help document.



 

  



Parameters pane  
Dialog boxes

Compose dialog box

  

Description  The Parameters pane has several subpanes which allow you to adjust
several types of musical Parameters for use by the CAMPS Compose
function.

 The content and availability of the Parameters subpanes change
depending on Track Category and Rhythm Compose selections.

After making many detailed Composition Parameter adjustments to your
liking, you can save them to a name of your choice for future use before
altering them again. Depending on your selections, repeatedly clicking
the Compose button will often give you slightly different results with the
same Set of Parameter adjustments.

Managing
Parameter Sets

Parameters Set
selection box

Here you can store and retrieve Sets of Compose Parameters settings
with desired names. The availability of Parameters Sets changes
depending on the currently selected Track Category. Use the drop-down
button on the right side of this box to open the list of previously saved
Sets for the currently selected Category. Parameter Sets get saved to
an external file, so you can recall them in subsequent Compose dialog
box sessions. CAMPS ships with some basic Sets for various Track
Categories.

Save
button

Saves the settings you made in the Parameters subpane to a
Parameters Set file.

Delete
button

Permanently deletes the currently selected Parameters Set without
confirmation.

Adjusting Tonality Register
subpane

Click the Register Tab to open the Register subpane. This subpane
allows you to set the Compose function's Pitch range in the Melody,
Comping, Obligato, Bass and Strings Track Categories.

 The Register subpane is not available for Drums Category.



Scale
subpane

Click the Scale Tab to open the Scale subpane. The Scale subpane
allows you to set the Scale Pitches to use during Auto Composition in
the Melody, Comping Obligato and Bass Track Categories.

 The Scale subpane is not available for the Strings or Drums
Categories.

Flavor
subpane

Click the Flavor Tab to open the Flavor subpane. This subpane allows
you to set the Pitch Interval Flavor for the Melody, Comping, Obligato
and Bass Track Categories. This translates to the degree of Harmony
with Chords created by the Compose function.

 The Flavor subpane is not available for the Drums Category.

Flavor
subpane
(for Strings)

Click the Flavor Tab to open the Flavor subpane. This subpane allows
you to set Pitch Interval Flavor for the Strings Track Category. This
translates to the degree of Harmony with Chords created by the
Compose function.

 The Flavor subpane is not available for the Drums Category.

Flat 2/9
subpane

Click the Flat 2/9 Tab to open the Flat 2/9 subpane. The Flat 2/9
subpane allows you to set whether or not the occurrence of Flat 9 and
Flat 2nd intervals, which tend to cause Dissonance, will be permitted
when Auto Composing in the Melody, Comping, Obligato, Bass and
Strings Track Categories.

 The Flat 2/9 subpane is not available for the Drums Category.

Activity
subpane

Click the Activity Tab to open the Activity subpane. This subpane allows
you to set the level of Pitch difference between Notes created by the
Compose function in the Melody, Comping, and Obligato Track
Categories.

 The Activity subpane is not available for the Strings or Drums
Categories.

Activity
subpane
(for Bass)

Click the Activity Tab to open the Activity subpane. This subpane allows
you to set the level of Pitch difference between Notes created by the
Compose function in the Bass Track Category.

 The Activity subpane is not available for the Strings or Drums
Categories.

Overlap
subpane

Click the Overlap Tab to open the Overlap subpane. The Overlap
subpane allows you to set a threshold value at which overlapping Notes
become recognized as Chordal Line data during Auto Composition in
the Melody, Comping, Obligato and Bass Track Categories.

The Overlap subpane is not available for the Strings or Drums
Categories.

Voices
subpane

Click the Voices Tab to open the Voices subpane. This subpane is only
available for the Strings Track Category.

file:///C|/My Documents/CampsHelp/Dialogboxes/compose/Leap.htm


 This subpane is not available in the Melody, Comping, Obligato,
Bass or Drums Categories. Additionally, Voices subpane settings will be
unavailable unless the Rhythm Compose check box is selected.

Adjusting Rhythm Rhythm
subpane

Click the Rhythm Tab to open the Rhythm subpane. This subpane
allows you to adjust Parameters for Rhythmic Auto Composition of
Melodic and Harmonic Line data in the Melody, Comping, Obligato and
Bass Track Categories.

 Rhythm subpane settings will not be available unless the Rhythm
Compose check box is selected. The Rhythm subpane is not available
for the Strings Category.

Rhythm
subpane
(for Drums)

Click the Rhythm Tab to open the Rhythm subpane. This subpane
allows you to adjust Parameters for Rhythmic Auto Composition of Line
data in the Drums Track Category.

 The Rhythm subpane is not available for the Strings Category.

 

 

See also:

Category selection box
MelodyDraw pane
Rhythm Compose check box
Compose button
Managing Takes
Getting Results

 



Using the Compose dialog box  
Compose dialog box

Parameters pane

  

Register
subpane

 The Register subpane is available for the Melody, Comping, Obligato, Bass
and Strings Track Categories.

Register Top,
Register Bottom
slider,
edit box,
Pitch display

Sets the highest and lowest allowed Pitches for the Compose function. The
results of the Compose function will always fall within this Pitch range.

Auto
button

Click the Auto button to automatically detect the Pitch range in the currently
selected Line Block. The results will be automatically entered in the
appropriate Register Top/Bottom edit boxes.

Lower Interval Limit
check box

Determines whether or not to set an additional lower Pitch range limit called
the Lower Interval limit (L.I.L.), to the Pitch range defined by the Register
Top/Bottom settings. If this is checkmarked, CAMPS will always perform
L.I.L.sensitive Auto Composing.

Middle C
edit box

In musical notation, a Staff combining the Bass Cleft and Treble Cleft known
as the Great Staff is used for instruments that can produce a wide range of
Notes such as the Piano or Organ. The center Note of the Great Staff is
called Middle C.

Depending on the selected Sound (Program/Patch number ) on your MIDI
Sound Module, there are instances when pressing a given key on your MIDI
instrument yields a Pitch one or two Octaves higher or lower than originally
intended for that key. The Middle C setting lets you compensate for this.

The Middle C setting defines the center of the Pitch range, which in turn
effects the value of the Lower Interval Limit (L.I.L.) and resulting Auto
Composition. CAMPS performs a variety of musical processes such as
Melody Auto Composition and Harmonization. Defining Middle C makes it
possible to get the most out of these features.

 

 



See also:

Scale subpane
Flavor subpane
Flavor subpane (for Strings)
Flat 2/9 subpane
Activity subpane
Activity subpane (for Bass)
Overlap subpane
Voices subpane
Rhythm subpane
Rhythm subpane (for Drums)
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Using the Compose dialog box  
Compose dialog box

Parameters pane

  

Scale
subpane

 The Scale subpane is available for the Melody, Comping, Obligato and
Bass Track Categories.

Scale
selection box

Settings in the Scale selection box determine the Scale Pitches used.
The Auto Composition result will be in the Scale you select here. The
scales available are Pentatonic, Chordal, Triadic, Bass Root, and
Pedal.

Selecting Bass Root for Line data in the Bass Track Category
associates Root motion to the Bass Line created by the Compose
function. Selecting Pedal for a Bass Line associates Pedal Tone use.

If you want to set your own Scale, select Custom. However, there
might be instances where your Scale settings will not be implemented
by the Compose function due to music theory adherence.

Interval
buttons

When you select Custom from the Scale box drop-down list, you can
select the Scale Notes you want to use. These choices are expressed
as Diatonic or Chord Tone Intervals: R (Root or 1), 3rd, 5th, 7th, 9th,
11th, & 13th.

8th Degree of Diminished
check box

Select this check box if you wish to use the 8 Note symmetrical
Diminished Scale in addition to 7 Note Scales.

Chromatic Notes
check box

Select this check box if you want to include Chromatic Notes (Half
Steps) more freely.



 

 

See also:

Register subpane
Flavor subpane
Flavor subpane (for Strings)
Flat 2/9 subpane
Activity subpane
Activity subpane (for Bass)
Overlap subpane
Voices subpane
Rhythm subpane
Rhythm subpane (for Drums)
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Using the Compose dialog box  
Compose dialog box

Parameters pane

  

Flavor
subpane

 This mode of the Flavor subpane is available for the Melody, Comping, Obligato and
Bass Track Categories.

Consonance
slider,
edit box

Consonance sets the degree of smooth, agreeable Harmony created by the
Compose function. Enter a value between 0 and 100%. Setting 100% results in
maximum Consonant Harmony with Chords. This is a relative adjustment. Even if
you set Consonance to 100%, the resulting Harmony will not be completely
Consonant with respect to Chords.

Fine
slider,
edit box

These controls allow you to finely adjust Consonance from 0 to 100%. Their main
use is controlling the degree to which Dissonant Harmony with Chords is avoided by
the Compose function. This is a relative adjustment. Even if you set Fine to 100%,
Dissonance will not be completely avoided with respect to Chords.

 

 

See also:

Register subpane
Scale subpane
Flavor subpane (for Strings)
Flat 2/9 subpane
Activity subpane
Activity subpane (for Bass)
Overlap subpane
Voices subpane
Rhythm subpane
Rhythm subpane (for Drums)
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Using the Compose dialog box  
Compose dialog box

Parameters pane

  

Flavor
subpane
(for Strings)

 This mode of the Flavor subpane is only available for the Strings Track
Category.

Harmonic Tension
check box

Selecting Harmonic Tension enables the Compose function to use
Harmonic Tensions when creating Chordal Line data in the Strings
Category. This may have the effect of producing less bland sounding
supporting Harmony in your music.

Common Tones
check box

Selecting Common Tones enables the Compose function to use Common
(connecting) Tones when creating Chordal Line data in the Strings
Category. Using some of the same Notes or Intervals as previous and
subsequent Chords keeps Harmonic motion close, promoting continuity
and smooth flow. This is typical of a String section's accompanying or
supporting role in music.

 

See also:

Register subpane
Scale subpane
Flavor subpane
Flat 2/9 subpane
Activity subpane
Activity subpane (for Bass)
Overlap subpane
Voices subpane
Rhythm subpane
Rhythm subpane (for Drums)
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Using the Compose dialog box  
Compose dialog box

Parameters pane

  

Flat 2/9
subpane

 The Flat 2/9 subpane is available for all Track Categories except Drums.

Flat 2nd and Flat 9 intervals are Dissonant sounding, but can add Tension to
Harmony, if desired. These check boxes allow you to permit or exclude them
from Auto Compose results.

Avoid
Within Track
check boxes

Select the Avoid b9 check box if you want to prevent the occurrence of Flat
9 intervals within the selected Track. Select the Avoid b2 check box if you
want to prevent the occurrence of Flat 2nd intervals.

Avoid
With Other Track(s)
check boxes

Select the Avoid b9 check box if you want to prevent the occurrence of Flat
9 intervals between the currently selected Track and other Tracks. Select the
Avoid b2 check box if you want to prevent the occurrence of Flat 2nd
intervals between Tracks.

 

 

See also:

Register subpane
Scale subpane
Flavor subpane
Flavor subpane (for Strings)
Activity subpane
Activity subpane (for Bass)
Overlap subpane
Voices subpane
Rhythm subpane
Rhythm subpane (for Drums)
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Using the Compose dialog box  
Compose dialog box

Parameters pane

  

Activity
subpane

 This mode of the Activity subpane is available for the Melody, Comping, and
Obligato Track Categories.

Pitch Repeat
slider,
edit box

These controls set how often a Pitch is reused by the Compose function. Use
the slider or enter a value from 0 to 100%. A setting of 100% yields a higher
incidence of Pitches being repeated in the Compose function's results. This is a
relative setting. Even if you set 100%, all of the Notes will not be the same
Pitch.

Leap Occurrence
slider,
edit box

These controls set how often Leaps (larger Intervals) occur between Note
Pitches. Setting 100% makes it easy for Leaps to occur. This is a relative
adjustment. Even if you set 100%, Leaps will not occur between all Notes.

Leap
edit box

When a Leap occurs between Notes, the Leap size will be as close as possible
to the value set here, expressed as 3 to 12 Half Steps.

 

 

See also:

Register subpane
Scale subpane
Flavor subpane
Flavor subpane (for Strings)
Flat 2/9 subpane
Activity subpane (for Bass)
Overlap subpane
Voices subpane
Rhythm subpane
Rhythm subpane (for Drums)

 



Using the Compose dialog box  
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Activity
subpane
(for Bass)

 This mode of the Activity subpane is only available for the Bass Track
Category.

Pitch Repeat
slider,
edit box

These controls set how often a Pitch is reused by the Compose function. Use
the slider or enter a value from 0 to 100%. A setting of 100% yields a higher
incidence of Pitches being repeated in the Compose function's results. This is
a relative setting. Even if you set 100%, all of the Notes will not be the same
Pitch.

Leap Occurrence
slider,
edit box

These controls set how often Leaps (larger Intervals) occur between Note
Pitches. Setting 100% makes it easy for Leaps to occur. This is a relative
adjustment. Even if you set 100%, Leaps will not occur between all Notes.

Leap
edit box

When a Leap occurs between Notes, the Leap size will be as close as
possible to the value set here, expressed as 3 to 12 Intervals.

Walking Bass
check box

The Walking Bass check box allows you to set the Compose function to create
Pitches in the style of Walking Bass Lines. Settings in the Scale and other
subpanes effect Bass Line Tonality.

 

 

See also:

Register subpane
Scale subpane
Flavor subpane
Flavor subpane (for Strings)
Flat 2/9 subpane
Activity subpane
Overlap subpane
Voices subpane
Rhythm subpane
Rhythm subpane (for Drums)
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Overlap
subpane

 The Overlap subpane is available for the Melody, Comping, Obligato and Bass
Track Categories.

Note Overlap
radio buttons

The CAMPS Compose function yields different results depending on whether Notes
in selected Line data are considered individual or Chordal. The Note Overlap radio
buttons allow you to set a Time threshold for determining whether overlapping
Notes will be recognized as Chord Tones by the CAMPS Composition Logic Engine.
Notes that Overlap for a longer time period than the value set here will be
recognized as forming a Chord during analysis.

Overlap Time limit values are expressed here as either a Quarter Note, Eighth Note,
Sixteenth Note, Thirty Second Note or Sixty Fourth Note. For example, after
selecting the 8th Note radio button, any Note Overlap of 8th Note duration or less
will not be considered Chordal during analysis by CAMPS.

 

 

See also:

Register subpane
Scale subpane
Flavor subpane
Flavor subpane (for Strings)
Flat 2/9 subpane
Activity subpane
Activity subpane (for Bass)
Voices subpane
Rhythm subpane
Rhythm subpane (for Drums)
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Rhythm
subpane

 This mode of the Rhythm subpane is available for the Melody,Comping,Obligato
and Bass Track Categories. However, Rhythm subpane settings will not be
available unless the Rhythm Compose check box is selected.

Analysis
radio buttons

The Analysis radio buttons control the analysis of Rhythm components and
Rhythmic Auto Composition sensitivity.

Auto/Custom
radio buttons

When you select Auto, analysis of Rhythm components and Rhythmic Auto
Composition sensitivity are automatic. When you select Custom, the Custom
Analysis slider becomes active.

When the Rhythm Compose check box is selected, the Auto/Custom radio
buttons will be available for all Track Categories except Strings.

Custom
Analysis
slider

Use the Custom Analysis slider to adjust the analysis of Rhythm components and
Rhythmic Auto Composition sensitivity. The more you drag the slider toward
complex, the higher the sensitivity to Rhythmic analysis and Auto Composition
information.

Tuplet
check box,
box

If the original line data was created using Tuplets, selecting the Tuplet check box
makes it possible to Auto Compose Rhythm that takes them into account. Activating
the Tuplet check box with no original Tuplet feel adds it, though a bit more blindly.
You can select Triplet, Quintuplet, or Septuplet from the drop-down list to the right
of the Tuplet check box.

 

 



See also:

Register subpane
Scale subpane
Flavor subpane
Flavor subpane (for Strings)
Flat 2/9 subpane
Activity subpane
Activity subpane (for Bass)
Overlap subpane
Voices subpane
Rhythm subpane (for Drums)

 

file:///C|/My Documents/CampsHelp/Dialogboxes/compose/Leap.htm


Using the Compose dialog box  
Compose dialog box

Parameters pane

  

Rhythm
subpane
(for Drums)

 This mode of the Rhythm subpane is only available for the Drums Track
Category. Also, the Rhythm Compose function is automatically selected for
Drums.

Analysis
radio buttons

The Analysis radio buttons control the analysis of Rhythm components and
Rhythmic Auto Composition sensitivity.

Auto/Custom
radio buttons

When you select Auto, analysis of Rhythm components and Rhythmic Auto
Composition sensitivity are automatic. When you select Custom, the Custom
Analysis slider becomes active.

Custom
Analysis
slider

Use the Custom Analysis slider to adjust the analysis of Rhythm components
and Rhythmic Auto Composition sensitivity. The more you drag the slider
toward complex, the higher the sensitivity to Rhythmic analysis and Auto
Composition information.

Tuplet
check box,
box

If the original line data was created using Tuplets, selecting the Tuplet check
box makes it possible to Auto Compose Rhythm that takes them into account.
Activating the Tuplet check box with no original Tuplet feel adds it. You can
select Triplet, Quintuplet, or Septuplet from the drop-down list to the right of the
Tuplet check box.

Repetitiveness
slider,
edit box

Here, you can adjust the regularity of Rhythm pattern repetition in the Compose
function's Rhythm Compose results.

 
 MIDI Pitches are translated into Drum Sounds by your MIDI Sound

Module. When Auto Composing in the Drums Category, CAMPS analyzes
Pitches (Drum Sounds) in conjunction with each other and Auto Composes
appropriate Takes, regardless of your current Drum Sounds Map.

 



 

See also:

Register subpane
Scale subpane
Flavor subpane
Flavor subpane (for Strings)
Flat 2/9 subpane
Activity subpane
Activity subpane (for Bass)
Overlap subpane
Voices subpane
Rhythm subpane
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Compose dialog box
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Voices
subpane

Overview The Voices subpane is only available for the Strings Track Category.
Furthermore, Voices subpane settings will be unavailable unless the Rhythm
Compose check box is selected.

Without Rhythm Compose selected in the Strings Category, CAMPS refers to
the existing Line data, recomposing new Line data according to Original Line
data analysis, Compose dialog box Parameters and the currently assigned
Chords.

In this case, CAMPS will only be able to provide limited results because of the
amount of Sustaining and Overlapping Notes combined with Register and
other limitations in Strings parts. Using the Rhythm Compose mode and
Voices subpane settings when Auto Composing in the Strings Category may
yield more practical results.

With Rhythm Compose selected in the Strings Category, CAMPS doesn't refer
to the existing Line data for Pitch information, as it does for most other
Categories. Instead, it generates Pitches from scratch, referencing only the
Compose dialog box Parameters (including Number of Voices settings) and
the currently assigned Chords.

Number of Voices
buttons

In the Rhythm Compose mode for the Strings Category, Chordal Line data is
Auto Composed with the Number of Voices specified here. Available options
range from 2 to 6 Voices.

These Auto Composed Voices follow Chord changes while maintaining the
Number of Voices assigned. Regardless of your Common Tones or Harmonic
Tension settings, CAMPS always Auto Composes String parts with smaller
Pitch Intervals between neighboring Voices for smooth continuity between
Chord changes.

 



 

See also:

Register subpane
Scale subpane
Flavor subpane
Flavor subpane (for Strings)
Flat 2/9 subpane
Activity subpane
Activity subpane (for Bass)
Overlap subpane
Rhythm subpane
Rhythm subpane (for Drums)
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Description of this dialog box
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MelodyDraw
pane

Overview MelodyDraw is a unique freestyle drawing tool for directing the Pitch
occurrences in Line data being Auto Composed. MelodyDraw will guide the
vertical motion of Melodic and Chordal Line data Auto Composition.

 MelodyDraw is available for all Track Categories except Drums.

MelodyDraw
area

In the MelodyDraw area, you can actually draw a graph for the Compose
function to follow.

Pen
tool
button

Click the Pen button to activate the Pen tool in the MelodyDraw area. By
dragging the Pen tool, you can draw a graph for the Compose function to follow.

You can start at either side, or anywhere inside of the MelodyDraw area.
Dragging the Pen tool in the opposite direction of a completed graph redraws
that graph.

Drawing in only a certain part of the MelodyDraw area effects only that portion
of Line data when the Compose button is clicked. The rest of the selected Line
data will be Auto Composed as well, but without regard for MelodyDraw
orientation.

Eraser
tool
button

If you want to alter only part of a completed MelodyDraw graph, Click the
Eraser button to activate the Eraser tool. You can then Erase only the portion of
your graph that needs to be changed.

 CAMPS Auto Composes Line data Pitches according to its analysis of selected
Line data (or Take) and your settings in the Parameters pane. The Pitches of
the resulting Notes will always fit the current Tonality, while following your
MelodyDraw graph.

Clicking the Compose button instantly Auto Composes Line data according to
the vertical motion you specify with MelodyDraw. Depending on your
Parameters settings, you can get slightly different results with the same graph
by clicking the Compose button again and again, or you can draw a new graph
anytime before clicking the Compose button.

 Because settings in the Parameters pane effect the Compose function's
results, you may need to adjust Register settings to bring all of the selected Line
data into the MelodyDraw area's view.



 MelodyDraw can be used with any length of Line data, including whole Line
Blocks. For more detailed results, select a smaller region of Line data in the
Pianoroll or Notation Editor before opening the Compose dialog box.

 MelodyDraw may not always yield desirable results. In this case, adjust
settings in the Parameters pane. Relaxing the Register and/or Scale settings
may help you obtain better results.

 

See also:

Category selection box
Parameters pane
Rhythm Compose check box
Compose button
Managing Takes
Getting Results
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Category
selection box

Line data Tracks in CAMPS have an attribute known as a Category. This is one of the
parameters that CAMPS references when Auto Composing Line data. The Category selection
box displays the Category of the Track you selected before opening the Compose dialog box.

Use the drop-down button to open the list of six Track Categories. You can select a different
Category for the Line data being Auto Composed. Each Category has different Composition
features, and therefore changes available options in the Parameters pane.

Melody: Use for the main Melody.
Comping: Use for accompaniments that include a large number of Harmonies.
Obligato: Use for additional accompaniments to the Melody Line.
Bass: Use for Bass.
Strings: Use for Strings and other Line data with sustained Chord Tones.
Drums: Use for Drums and Percussion.

 Category attributes are assigned by Track in the Track Area of the Document window.

 

See also:

Parameters pane
MelodyDraw pane
Rhythm Compose check box
Compose button
Managing Takes
Getting Results
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Compose
button

This is it...the magic button! While getting the best results from the CAMPS Auto Compose feature
involves tweaking many detailed settings, clicking the Compose button can quickly produce quite
a variety of interesting results.

The most important thing to remember when using the Compose dialog box is the need for
relevant Chord data. Without Chord Blocks, CAMPS has no basic Tonality reference with which to
perform Auto Composition, and Melodic or Chordal results can be, shall we say, extremely
Discordant!

After selecting desired Line data to Auto Compose and opening the Compose dialog box, Clicking
the Compose button starts Auto Composition of the selected Line data. Each time the Compose
button is clicked, CAMPS analyzes the currently selected Line data, its assigned Chord data, and
all of the many other adjustments available in the Compose dialog box to Auto Compose a result.

Once you've generated at least one Take, the currently selected Line data CAMPS analyzes the
next time you click the Compose button is whichever Take is selected in the Take scroll area
before the Compose button is clicked again. When a Take is generated, it is added to the Take
scroll area in the selected state.

When the Rhythm Compose check box is not selected, only Pitches are Auto Composed. When
the Rhythm Compose check box is selected, both Rhythmic and Pitch Auto Composition are
performed. When the Track Category is Drums, the Rhythm Compose mode is automatically
selected, and the "Pitch" data Auto Composed will fit the Drum Sounds Map of the standard
General MIDI Drum Kit.

When using the MelodyDraw pane in the Compose dialog box, the Pitches of the resulting Notes
will always fit the current Tonality, while following your MelodyDraw graph.

 

 

See also:

Category selection box
Parameters pane
MelodyDraw pane
Rhythm Compose check box
Managing Takes
Getting Results
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Rhythm Compose
check box 

The Rhythm Compose check box determines whether Rhythmic Auto Composition is
added to the Compose function. When checkmarked while Auto Composing Melodic or
Chordal Line data, both Rhythmic and Pitch Auto Composition are performed. When not
checkmarked, only Pitch Auto Composition is performed.

When Auto Composing Line data in the Drums Track Category, Rhythm Compose is
automatically selected.

While optional, Rhythm Compose plays an important role when Auto Composing Line
data in the Strings Track Category.

The Rhythm Compose function always analyzes rhythm information in the Original Line
data, without regard for which Take is currently selected in the Take scroll area. CAMPS
then Auto Composes a similar rhythmic figure based on this analysis and settings made
in the Rhythm subpane of the Parameters pane. Finally, CAMPS Auto Composes Pitch
data using the new Rhythm, analysis of the currently selected Line data (or Take) and
settings in the Parameters and/or MelodyDraw panes.

Available options in the Rhythm subpane of the Parameters pane change depending on
Track Category, and are not active if the Rhythm Compose check box is not selected.

 

See also:

Category selection box
Parameters pane
MelodyDraw pane
Compose button
Managing Takes
Getting Results
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Managing Takes Remove
button

The Remove button is provided for deleting undesirable Takes from the Take
scroll area while working in the Compose dialog box. Simply select the Take to
be deleted, and click the Remove button.

Take
scroll area

This is where CAMPS temporarily stores results from Auto Composing. When
the Compose dialog box is first opened, only the original form of the selected
Line data is available in the Take scroll area, with the name "Original". The
Original Take is the Line data analyzed when the Compose button is clicked for
the first time.

Each time you click the Compose button, CAMPS performs Auto Composition
on the selected Line data, adding the results, one by one, as new entries in the
Take scroll area. The currently completed Auto Composition will be the active
Take until you select another one.

Whichever Take is selected temporarily replaces the Line data selected in the
Line Area of the Document Window, Pianoroll Editor or Notation Editor when
the Compose dialog box was opened. This is important to remember, because
besides enabling the Audition feature, it effects Auto Composition results. That
is, the currently selected Line data CAMPS analyzes for Auto Composition is
whichever Take is selected (highlighted) in the Take scroll area before the
Compose button is clicked. If you wish to keep recomposing the Original Take,
you must select it before each additional click of the Compose button, as Auto
Composed Takes are added the scroll area in a selected state.

An ORANGE TRIANGULAR WARNING icon with a Note inside it next to any
new Take indicates that some Notes were removed (instead of just relocated) in
this version of the Line data to comply with Tonality settings in the Parameters
pane. This happens mostly with Line data containing Harmonies, such as the
Strings Category. More predefined Harmony results in more restrictions for the
Compose function.

A check box is provided next to each Take for the purpose of saving them.
When closing the Compose dialog box with the OK button, checkmarked Takes
are saved to the currently selected Line Block's Take List.

The Take selected (highlighted) when OK is clicked replaces the Original,
regardless of checkmarking. Once the Compose dialog box is closed, all the
unselected Takes in the Take scroll area expire. When closing the Compose
dialog box with the Cancel button, all the Auto Composed Takes expire, and
the Original is left intact.

Name
edit box

You can rename any entries in the Take scroll area except for the Original. To
do this, select the Take you wish to rename and click anywhere in the Name
edit box. You can then use the Backspace, Delete, and any other regular text
keys on your computer's keyboard to rename the selected Take.



 

 

See also:

Category selection box
Parameters pane
MelodyDraw pane
Rhythm Compose check box
Compose button
Getting Results
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Getting
Results

 Each time you make click the Compose button, the selected Line data is
temporarily replaced.

Playback,
Playback with Others,
Stop
buttons

Click the Playback (Single Speaker) button to hear the currently selected
Take in "Solo" mode. This Auditioning mode will include any existing
Chords if the Chord Track Play button in the Track Area of the Document
Window is activated.

Click the Playback with Others (Double Speaker) button to hear the
currently selected Take along with all the other activated Tracks.

Once either Playback button is clicked, CAMPS will repeat (Loop) Playback
of selected Takes as you select them, until you click the Stop (No Speaker)
button. With this feature, you can Auto Compose, select and Audition
different Compose Takes "on the fly" or one by one.

OK
button

When you have achieved the desired results, checkmark Takes you wish to
save to the Take List, select (highlight) the Take you wish to have replace
the currently selected Line data, and click OK. This closes the Compose
dialog box, saves the checkmarked Takes to the currently selected Line
Block's Take list, and replaces the selected Line data.

 

See also:

Category selection box
Parameters pane
MelodyDraw pane
Rhythm Compose check box
Compose button
Managing Takes
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Contents
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Description In the Dissonant Intervals Detection dialog box, CAMPS automatically Detects Dissonant (harsh
sounding) Intervals between Notes in selected Line data and Notes occurring at the same time in
Line Blocks of other Tracks. You can then automatically or manually Resolve Detected Dissonant
Intervals to Consonant (smooth sounding) alternative Intervals.

Uses Upon opening the Dissonant Intervals Detection dialog box, CAMPS automatically performs
Dissonant Interval Detection, comparing Notes in selected Line data to Notes in all other Tracks
in the same time slice. You can then alter the Pitch of either the originally Selected Note(s) or the
other Tracks' Offending Note(s) to resolve the Dissonant Interval.

Using the Playback buttons, you can then audition results and select one that sounds good to
you.

  

Items Detect button
Status display
Ignore Dissonant Notes
Overlapping for short duration
check box
Selected Note(s) area
Offending Note(s) area
Playback button
Playback with Others button
Stop button
OK button
Cancel button
Help button

  



Opening From the...
Document Window
Pianoroll Editor
Event List Editor

Choose Detect Dissonant Intervals... from the Line menu.
Alternatively, right-click desired Line data and choose Actions, Detect
Dissonant Intervals....

 When choosing Detect Dissonant Intervals... from the Line menu, you must first have
selected Line data, otherwise the Detect Dissonant Intervals... item won't be available.
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Description of this dialog box

Using this dialog box

  

Getting Started Detect
button

Click the Detect button to rerun the
Detection process after making changes
in the Dissonant Intervals Detection
dialog box.

Status
display

The Status display reports the current
results in the Dissonant Intervals
Detection dialog box. Between reports,
it disappears.

Ignore Dissonant Notes
Overlapping for short duration
check box

Checkmark this option to exclude Notes
in other Tracks from being considered
as happening at the same time as
Selected Notes when the Overlap time
between these Notes equals a 32nd
Note or less.

Managing Intervals across Tracks
from the Selected Line data

Selected Note(s)
area

When the Show All option is
checkmarked, this area lists all the
Notes in the Line data selected for
Detection of Dissonant Intervals, and
which ones cause Dissonant Intervals.
Without checkmarking the Show All
option, only Notes found to cause
Dissonant Intervals will be listed here.
The Pitch of these Notes can then be
altered to Resolve Dissonant Intervals.

Managing Intervals across Tracks
from the other Tracks

Offending Note(s)
area

When a Note that is found to cause a
Dissonant Interval is highlighted in the
Selected Notes area, the other Notes
making the Dissonant Interval and the
Line Blocks they reside in are listed
here. The Pitch of these Notes can then
be altered to Resolve Dissonant
Intervals.

Auditioning  Playback Click the Playback (Single Speaker)
button to listen to a Selected Note.

 Playback with Others Click the Playback with Others
(Double Speaker) button to listen to a
Selected Note and its resulting Intervals
along with all the other activated Tracks.

 Stop Click the Stop (No Speaker) button to
stop Playback.

Closing OK
button

Closes the Dissonant Intervals
Detection dialog box and commits
changes.

Cancel
button

Closes the Dissonant Intervals
Detection dialog box without committing
changes.



Help
button

Opens this Help document.
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Getting
Started

Overview Dissonant Intervals are more harsh (less smooth) sounding Pitch
combinations. This is not necessarily a bad thing. As a matter of
fact, Dissonance may be desired as developing certain moods or
tonalities in a Musical piece. The Dissonant Intervals Detection
dialog box is provided to help you seek out these Intervals and
decide if or how to Resolve them to more Consonant alternatives.

 Detect
button

Because Detection is automatically performed when first opening
the Dissonant Intervals Detection dialog box, the Detect button will
be inactive at this time. The Detect button is provided for rerunning
the Detection process after adjustments have been made, avoiding
the need to close and reopen this dialog box. Changing the
Detection criteria or Resolving a selected Interval immediately
activates the Detect button, allowing you to rerun the Detection
process for the new conditions.

 Status
display

The Status display will report whether Dissonant Intervals have
been Detected or not. Additionally, the Status display reports
Resolving of Dissonant Intervals. The Status display disappears
when you begin working in the Dissonant Intervals Detection dialog
box, but reappears with any new Status reports resulting from your
actions.

 Ignore Dissonant Notes
Overlapping for short duration
check box

Checkmark this option to exclude Notes in other Tracks from being
considered as happening at the same time as Selected Notes when
the Overlap time between these Notes equals a 32nd Note or less.
Only Notes occurring at the same time are considered in the
Dissonant Interval Detection process. Simultaneous Notes or Pitch
Leap distance between separate Notes within one Track are not
considered in the Dissonant Intervals Detection dialog box.

  

 

See also:

Using the Selected Note(s) area
Using the Offending Note(s) area
Getting Results

 



Using the Dissonant Intervals Detection dialog box  
Description of this dialog box

Items in this dialog box

  

Using the
Selected Note(s)
area

Show All
check box

A checkmark here causes all Notes in Line data selected before
opening the Dissonant Intervals Detection dialog box to be listed in the
Selected Note(s) scroll area, whether they cause Dissonant Intervals or
not. By uncheckmarking this item, CAMPS will only display Notes that
cause Dissonant Intervals.

Selected Note(s)
scroll area

The Number column displays how many Dissonant Intervals across
Tracks were Detected for each Note.

The Line Block column displays which Line Block each Note causing
the Detected Dissonant Interval resides in.

The Pitch column displays the MIDI Pitch value and Note
Name/Octave for each Note.

The Location column displays the starting and ending locations and
the length of each Note. This display is for your reference. Changing
these properties can be done freely in the Pianoroll or Notation Editor,
or in controlled amounts with the Quantize and Articulation Adjustment
dialog boxes.

Auto Resolve
button

Clicking the Auto button in the Selected Note(s) area automatically
changes the Pitch of a highlighted Note in the Selected Note(s) scroll
area to Resolve a Dissonant Interval between that Note and Notes in
other Tracks causing the Dissonant Interval. If there is no possible
Resolution under the current Musical circumstances, this condition will
be reported in the Status display and no Pitch change will occur.

Manual... Resolve
button

Clicking the Manual... button in the Selected Note(s) area opens the
Manual Pitch Adjustment dialog box, allowing you to manually adjust
the Pitch of a highlighted Note in the Selected Note(s) scroll area to
Resolve a Dissonant Interval between that Note and Notes in other
Tracks causing the Dissonant Interval.

Editor
buttons

The Editor buttons allow you to choose which Editing environment
displays your changes in the background while working in the Selected
Note(s) area of the Dissonant Intervals Detection dialog box.
Additionally, this will become the currently active Editor when closing
the Dissonant Intervals Detection dialog box if your last actions were in
the Selected Note(s) area.

 

 



See also:

Getting Started
Using the Offending Note(s) area
Getting Results
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Using the
Offending Note(s)
area

Offending Note(s)
scroll area

The Line Block column displays which Line Block each Offending
Note causing the Detected Dissonant Interval resides in.

The Pitch column displays the MIDI Pitch value and Note
Name/Octave for each Note.

The Location column displays the starting and ending locations and
the length of each Offending Note. This display is for your reference.
Changing these properties can be done freely in the Pianoroll or
Notation Editor, or in controlled amounts with the Quantize and
Articulation Adjustment dialog boxes.

The Overlapping Duration column displays the Duration of Note
Overlap between the originally Selected Note and the Offending Note
in Divisions, where one Quarter Note equals 480 Divisions.

Auto Resolve
button

Clicking the Auto button in the Offending Note(s) area automatically
changes the Pitch of a highlighted Offending Note to Resolve a
Dissonant Interval between that Note and the originally Selected Note
in another Track causing the Dissonant Interval. If there is no possible
Resolution under the current Musical circumstances, this condition
will be reported in the Status display and no Pitch change will occur.

Manual... Resolve
button

Clicking the Manual... button in the Offending Note(s) area opens the
Manual Pitch Adjustment dialog box, allowing you to manually adjust
the Pitch of a highlighted Offending Note to Resolve a Dissonant
Interval between that Note and the originally Selected Note in another
Track causing the Dissonant Interval.

Editor
buttons

The Editor buttons allow you to choose which Editing environment
displays your changes in the background while working in the
Offending Note(s) area of the Dissonant Intervals Detection dialog
box. Additionally, this will become the currently active Editor when
closing the Dissonant Intervals Detection dialog box if your last
actions were in the Offending Note(s) area.

 

 

See also:

Getting Started
Using the Selected Note(s) area
Getting Results
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Getting
Results

Playback,
Playback with Others,
Stop
buttons

Each time you Resolve a Dissonant Interval, the selected Line data is
temporarily replaced.

Click the Playback (Single Speaker) button to hear the Resolution of
Dissonant Intervals in "Solo" mode. This Auditioning mode will include any
existing Chords if the Chord Track Play button in the Track Area of the
Document Window is activated.

Click the Playback with Others (Double Speaker) button to hear the
Resolution of Dissonant Intervals along with all the other activated Tracks.
Since selected Notes are being compared to Notes in other Tracks, this
auditioning mode may be more useful when working in the Dissonant
Intervals Detection dialog box.

Once either Playback button is clicked, CAMPS will repeat (Loop) Playback
of selected Line data with current Dissonant Interval Resolutions as you
make them, until you click the Stop (No Speaker) button. With this feature,
you can change and listen to different Dissonant Interval Resolutions for a
highlighted Selected or Offending Note "on the fly" or one by one. To
Audition a different Selected or Offending Note, highlight it and reclick the
Playback or Playback with Others button.

OK
button

Click OK when you have achieved the desired results. This closes the
Dissonant Intervals Detection dialog box and replaces the selected Line
data.

 

See also:

Getting Started
Using the Selected Note(s) area
Using the Offending Note(s) area

 



Manual Pitch Adjustment dialog box  
Dialog Boxes

Dissonant Intervals Detection dialog box

  

Description The Manual Pitch Adjustment dialog box allows you to manually adjust the Pitch of highlighted
Notes in the Dissonant Intervals Detection dialog box.

Uses After selecting a Note to be Resolved from the Selected Note(s) area or Offending Note(s) area
and clicking the appropriate Manual... button, adjust the Note's Pitch as desired and click the OK
button to return to the Dissonant Intervals Detection dialog box.

  

Items Pitch
edit box

Use the up/down buttons or directly edit the MIDI Pitch value in this box to change
the Pitch of the Note being Resolved.

Pitch
display

The Pitch display shows the Note Name/Octave for the current MIDI Pitch value in
the Pitch edit box.

Location
display

The Location display shows the starting and ending locations and the length of the
Note subject to Manual Pitch Adjustment. This display is for your reference.
Changing these properties can be done freely in the Pianoroll or Notation Editor, or
in controlled amounts with the Quantize and Articulation Adjustment dialog boxes.

Line Block
display Displays the Name of the Line Block in which the Note being resolved resides.

Editor
buttons

The Editor buttons allow you to choose which Editing environment displays your
changes in the background while working in the Manual Pitch Adjustment dialog
box. Additionally, this will become the currently active Editor when closing the
Dissonant Intervals Detection dialog box if your last actions were in the Manual
Pitch Adjustment dialog box.

OK
button

Closes the Manual Pitch Adjustment dialog box, returning to the Dissonant Intervals
Detection dialog box and enters changes there.

Cancel
button

Closes the Manual Pitch Adjustment dialog box, returning to the Dissonant Intervals
Detection dialog box without entering changes there.

Help
button Opens this Help document.

 

  

Opening From the
Dissonant Intervals Detection
dialog box

Select a Note to be Resolved from the Selected Note(s) area or
Offending Note(s) area, and click the appropriate Manual...
button.

  



Drums Notation Setup dialog box  
Contents

Dialog Boxes

  

Description The Drums Notation Setup dialog box allows you to customize the Notation Editor's Percussion
Notation defaults for Tracks in the Drums Category.

Uses After selecting the Note whose Percussion Notation you wish to define and activating the Assign
option, choose a Note head style and additional articulation Mark, if desired. You can also adjust
where on the musical staff the Note will appear, and even the style of the Staff itself. Finally, you
can save your changes to the current or a custom Drums Notation Set.

  

Items Set selection box
Save button
Delete button
Note scroll area
Assign check box
Assignment buttons
Notes radio buttons
Marks radio buttons
Circled check box
Note display
5 Lines radio button
Single Line radio button
Apply button
OK button
Cancel button
Help button

  

Opening From the
Notation Editor

Choose Drums Notation Setup... from the Clef submenu of the View menu.
Alternatively, right-click anywhere in the Line Area and choose Clef, Drums
Notation Setup....



Items in the Drums Notation Setup dialog box  
Description of this dialog box

Using this dialog box

  

Saving Sets of
Assigned Drum Notes

Set
selection box

The Set selection box is where you store and retrieve Drums Notation
configurations made in the Drums Notation dialog box.

Save
button

Use the Save button to store your current Drums Notation configuration
to a new Drums Notation Set.

Delete
button

Use the Delete button to remove the currently selected Set from the list
in the Set selection box.

Selecting Notes Note
scroll area

Use the Note scroll area to choose a Note for assignment of custom
Drums Notation configuration.

Assigning
Percussion Notation
to Drum Notes

Assign
check box

Checkmarking the Assign option activates the Notation adjustment area
of the Drums Notation Setup dialog box.

Assignment
buttons

Use the up and down Assignment buttons to move the currently
selected Note to the desired position on the Musical Notation Staff.

Notes
radio buttons

Use the Notes radio buttons to choose the desired Percussion Notation
style for the head of the currently selected Note.

Marks
radio buttons

Use the Marks radio buttons to choose an articulation Mark to include
with the currently selected Notation style being Assigned.

Circled
check box

Checkmarking this option causes a circle to be included around the
head of the Note whose Notation you are assigning.

Note
display

As you make adjustments to Percussion Notation being assigned to a
Note, the results are are immediately displayed in the Note display for
your reference.

5 Lines
radio button

Choosing this option sets the Musical Notation Staff in the current
Drums Notation Set to the standard 5 Line format.

Single Line
radio button

Choosing this option sets the Musical Notation Staff in the current
Drums Notation Set to a Single Line.

 Apply
button

Commits changes without closing the Drums Notation Setup dialog box.

Closing OK
button

Closes the Drums Notation Setup dialog box and commits changes.

Cancel
button

Closes the Drums Notation Setup dialog box without committing
changes.

Help
button

Opens this Help document.



 

  



Using the Drums Notation Setup dialog box  
Description of this dialog box

Items in this dialog box

  

Drums Notation Sets Overview While the Drums Notation Setup dialog box is available for all Track
Categories, it is intended for use with Drums Tracks.

Adjustments in this dialog box can be saved as Sets, allowing you to
recall custom Percussion Notation configurations for different situations.
Uses for this feature include defining Percussion Notation styles for
different MIDI Instruments or Drum Set Programs (Patches), as well as
different Musical styles.

Drums Notation Sets are saved separately from Documents, and can
therefore be reused in other songs.

Set
selection box

The Set selection box is where you store and retrieve Drums Notation
configurations made in the Drums Notation dialog box. Use the
drop-down button on the right side of this box to open the list of Sets.
You can then select a Set to use, edit or delete. Attempting to select a
different Set after making unsaved changes to the currently selected Set
opens an "Alert" dialog box asking if you want to Save changes to the
current Set before changing to a different one.

Save
button

Use the Save button to store your current Drums Notation configuration.
Clicking Save opens the Naming dialog box. After specifying a Set name
and closing the Naming dialog box, the new Set will appear in the
drop-down list of the Set selection box.

Delete
button

The Delete button allows you to permanently remove the currently
selected Set from the list in the Set selection box.

 Clicking Delete immediately deletes the currently selected set
without any additional confirmation.

 



 

See also:

Percussion Notation Assignment
Getting Results

 



Using the Drums Notation Setup dialog box  
Description of this dialog box

Items in this dialog box

  

Percussion
Notation
Assignment

Note
scroll area

Use the Note scroll area to choose a Note for assignment of custom Drums
Notation configuration. Double-clicking a Note automatically activates the Assign
mode for that Note. Double-clicking the same Note again deactivates the Assign
mode for that Note. Each Note is displayed with corresponding Sound definitions
of the currently selected Program Set, which is defined in the MIDI Setup dialog
box's Output Device pane.

Assign
check box

Checkmarking the Assign option activates the Notation adjustment area of the
Drums Notation Setup dialog box for the currently selected Note. You can then
assign your choice of Musical Notation for the Note currently selected in the Notes
scroll area.

Assignment
buttons

Use the up and down Assignment buttons to move the currently selected Note to
the desired position on the Musical Notation Staff. Adjustments are immediately
displayed in the Note display to the left of these buttons.

Notes
radio buttons

Use the Notes radio buttons to choose the desired Percussion Notation style for
the head of the currently selected Note.

Marks
radio buttons

If desired, choose an articulation Mark to include with the currently selected
Notation style being Assigned.

Circled
check box

Checkmarking this option causes a circle to be included around the head of the
Note whose Notation you are assigning.

Note
display

As you make adjustments to Percussion Notation being assigned to a Note, the
results are are immediately displayed in the Note display for your reference.

5 Lines
radio button

Choosing this option sets the Musical Notation Staff in the current Drums Notation
Set to the standard 5 Line format. Changes made here will appear the next time
the Notation Editor is opened.

Single Line
radio button

Choosing this option sets the Musical Notation Staff in the current Drums Notation
Set to a Single Line. Changes made here will appear the next time the Notation
Editor is opened.

 



 

See also:

Drums Notation Sets
Getting Results

 



Using the Drums Notation Setup dialog box  
Description of this dialog box

Items in this dialog box

  

Getting
Results

Overview Any changes you make in the Drums Notation dialog box will be written to the currently
selected Drums Notation Set in the Set selection box.

To save changes to a new Set, click the Save button and specify a Set name. To save
changes to a different existing Set, select the alternate Set from the drop-down list in the
Set selection box before making changes.

Apply
button

Use the Apply button to immediately commit your changes to the currently selected
Drums Notation Set without closing the Drums Notation dialog box.

 Changes committed with the Apply button are immediate, bypassing the Cancel
option, and will therefore require manual adjustment to revert.

OK
button

Click OK when you have achieved the desired results. This closes the Drums Notation
Setup dialog box and commits your changes to the currently selected Drums Notation
Set.

 
 All changes committed by clicking Apply or OK will immediately be seen in the

Notation Editor except the Staff Lines selections. These will take effect the next time you
open the Notation editor.

 

See also:

Drums Notation Sets
Percussion Notation Assignment

 



Export Options dialog box  
Dialog Boxes

Export Standard MIDI File dialog box

  

Description The Export Options dialog box allows you set final conditions for saving a Document in the
Standard MIDI File format.

Uses After choosing Export SMF... from the File menu, specifying a file name and clicking Save,
select desired Export Options and click the Export button to save your Document as a Standard
MIDI File.

  

Items Save Muted Tracks
check box

In a CAMPS native Document, the Track Mute settings are temporary
"filters" that don't actually change the Line data in a Track's Line
Blocks. Checkmarking the Save Muted Tracks check box sets CAMPS
to save all your Document's Tracks with the Standard MIDI File being
Exported, whether any Tracks have been Muted or not.
Uncheckmarking this option sets CAMPS to exclude Muted Tracks
from the Standard MIDI File being Exported.

Effect Track Transpose
check box

In a CAMPS native Document, the Track Transpose settings are
temporary "filters" that don't actually change the Line data in a Track's
Line Blocks. Checkmarking the Effect Track Transpose check box sets
CAMPS to Transpose Line data in a Track's Line Blocks as per its
Transpose settings in the Track area of the Document Window when
Exporting a Document to a Standard MIDI File. Uncheckmarking this
option sets CAMPS to Export Tracks in their original Key, regardless
of Transpose settings.

Save Chord Names
check box

Checkmarking the Save Chord Names check box causes CAMPS to
include Chord Names in their appropriate locations with the Standard
MIDI File being Exported. Uncheckmarking this option sets CAMPS to
ignore Chord Names when Exporting a Standard MIDI File.

Export
button

Closes the Export Options dialog box and Saves the current
Document as a Standard MIDI File, using your settings for the options
described above.

Cancel
button

Closes the Export Options dialog box without Saving a Standard MIDI
File and returns you to the Export Standard MIDI File dialog box.

Help
button Opens this Help document.

 

  



Opening From the
Export Standard MIDI File
dialog box

Click the Save button.

  



Export Standard MIDI File dialog box  
Contents

Dialog Boxes

  

Description The Export Standard MIDI File dialog box allows save your composition as a Standard MIDI File.

Because certain CAMPS-specific data such as Chord Blocks, Line Blocks and Track Categories
can not be included in a Standard MIDI File, the Export SMF... command leading to this dialog
box has been implemented separately, enabling the additional Export Options dialog box.

It is also important to note that the appearance of this dialog box may vary depending on your
computer's setup. While these variations are basically the same, Windows version
(95/98/NT/2000), and whether or not you are using the Microsoft Internet Explorer's Active
Desktop option on your system will effect the appearance of the Export Standard MIDI File dialog
box.

Uses After making the Document to be Exported active and choosing Export SMF... from the File
menu, specifying a file name and click Save.

  

Items Save in
selection box

Use the drop-down button on the right side of this selection box to brows your
computer's folder tree for a desired location in which to save your Standard MIDI
File. Use this selection box in conjunction with the Location scroll area.

Location
scroll area

Use this scroll area in conjunction with the Save in selection box to specify a
location for the Standard MIDI File to be saved in.

File name
selection box Specify a valid Windows filename here.

Save as type
selection box

When Exporting a Standard MIDI File from CAMPS, this selection box is already
set to the only choice of "Standard MIDI Files (*.mid)", and cannot be changed for
reasons explained above.

Save
button

Closes the Export Standard MIDI File dialog box and opens the Export Options
dialog box.

Cancel
button

Closes the Export Standard MIDI File dialog box without Saving a Standard MIDI
File.

 

  



Opening From the...
Document Window
or
Any Editor in CAMPS

Choose Export SMF... from the File menu.

  



Grid Setup dialog box  
Contents

Dialog Boxes

  

Description The Grid Setup dialog box allows you to adjust the Grid Resolution for individual areas of the
Document Window and applicable Editors.

Uses In the Grid Setup dialog box, you can independently adjust the Grid Resolution for the Bar, Text,
Chord and Line Block Areas of the Document Window, as well as similar areas in the Control
Draw, Pianoroll and Tempo Draw Editors at any time during your work in them. You can then
Apply and reApply new settings in the same Grid Setup dialog box session.

  

Items Play&Rec Region pane
Text Event pane
Chord pane
Line Block pane
Pianoroll pane
Control Draw pane
Pitch Bend pane
Notation pane
Tempo Draw pane
OK button
Cancel button
Apply button
Help button

  

Opening From the...
Document Window
Pianoroll Editor
Control Draw Editor
Tempo Draw Editor

Choose Grid Setup... from the Grid View submenu of the View menu.

  



Items in the Grid Setup dialog box  
Description of this dialog box

Using this dialog box

  

Document
Window

Play&Rec Region
pane

Click the Play&Rec Region tab to open the Play&Rec Region pane. This pane
allows you to set Horizontal Grid Resolution for the Bar Area of relevant
Editors.

Text Event
pane

Click the Text Event tab to open the Text Event pane. This pane allows you to
set Horizontal Grid Resolution for the Text Event Area of relevant Editors.

Chord
pane

Click the Chord tab to open the Chord pane. This pane allows you to set
Horizontal Grid Resolution for the Chord Area of relevant Editors.

Line Block
pane

Click the Line Block tab to open the Line Block pane. This pane allows you to
set Horizontal Grid Resolution for the Line Area of the Document Window.

Editors Pianoroll
pane

Click the Pianoroll tab to open the Pianoroll pane. This pane allows you to set
Horizontal Grid Resolution for the Line Area, and Vertical Grid Resolution for
the Velocity Area of the Pianoroll Editor.

Control Draw
pane

Click the Control Draw tab to open the Control Draw pane.This pane allows
you to set Horizontal and Vertical Grid Resolution for the Control Draw Editor.

Pitch Bend
pane

Click the Pitch Bend tab to open the Pitch Bend pane. This pane allows you
to set Horizontal and Vertical Grid Resolution for Pitch Bend Events in the
Control Draw Editor.

Notation
pane

Click the Notation tab to open the Notation pane. This pane allows you to set
Horizontal Grid Resolution for the Notation and Bar Areas of the Notation
Editor.

Tempo Draw
pane

Click the Tempo Draw tab to open the Tempo Draw pane. This pane allows
you to set Horizontal and Vertical Grid Resolution for Tempo Change Events
in the Tempo Draw Editor.

Closing OK
button

Closes the Grid Setup dialog box and commits changes.

 Grid Resolution changes will only be effective if Align to Grid in the Grid
View submenu of the View menu has been selected for the Editor in which
Grid Resolution changes are being made. Additionally, Grid Resolution
adjustments will revert to previous settings in the relevant Editor unless Save
Display Settings in the View menu is selected before closing that Editor.

Cancel
button

Closes the Grid Setup dialog box without committing changes.

Apply
button Commits changes without closing the Grid Setup dialog box.

Help
button

Opens this Help document.



 

  



Using the Grid Setup dialog box  
Description of this dialog box

Items in this dialog box

  

Play&Rec
Region
pane

Horizontal
Grid Resolution
radio buttons

These radio buttons allow you to adjust Horizontal Grid Resolution of Loop and
Punch In/Out region placement by absolute Note time values from Whole Notes
(less resolution) to Thirty Second Notes (more resolution). This effects the size
of time sections that Loop and Punch In/Out regions snap to as you create or
edit them in the Bar Area of the Document Window, Pianoroll Editor, Control
Draw Editor and Tempo Draw Editor.

Other divisions
edit box

Use the left/right buttons or directly edit the number in this box to more finely
set how many Divisions wide the Bar Area Horizontal Grid Resolution will be in
the Bar Area of the Document Window, Pianoroll Editor, Control Draw Editor
and Tempo Draw Editor.

 

 Grid Resolution changes will only be effective if Align to Grid in the Grid
View submenu of the View menu has been selected for the Editor in which
Grid Resolution changes are being made. Additionally, Grid Resolution
adjustments will revert to previous settings in the relevant Editor unless Save
Display Settings in the View menu is selected before closing that Editor.

 

See also:

Text Event pane
Chord pane
Line Block pane
Pianoroll pane
Control Draw pane
Pitch Bend pane
Notation pane
Tempo Draw pane

 



Using the Grid Setup dialog box  
Description of this dialog box

Items in this dialog box

  

Text Event
pane

Horizontal
Grid Resolution
radio buttons

These radio buttons allow you to adjust Horizontal Grid Resolution of Text
Event placement by absolute Note time values from Whole Notes (less
resolution) to Thirty Second Notes (more resolution). This effects the size of
time sections that Text Events snap to as you create or move them in the Text
Info Area of the Document Window, Pianoroll Editor, Control Draw Editor and
Tempo Draw Editor.

Other divisions
edit box

Use the left/right buttons or directly edit the number in this box to more finely
set how many Divisions wide the Horizontal Grid Resolution of Text Event
placement will be in the Text Info Area of the Document Window, Pianoroll
Editor, Control Draw Editor and Tempo Draw Editor.

 

 Grid Resolution changes will only be effective if Align to Grid in the Grid
View submenu of the View menu has been selected for the Editor in which
Grid Resolution changes are being made. Additionally, Grid Resolution
adjustments will revert to previous settings in the relevant Editor unless Save
Display Settings in the View menu is selected before closing that Editor.

 

See also:

Play&Rec Region pane
Chord pane
Line Block pane
Pianoroll pane
Control Draw pane
Pitch Bend pane
Notation pane
Tempo Draw pane

 



Using the Grid Setup dialog box  
Description of this dialog box

Items in this dialog box

  

Chord
pane

Horizontal
Grid Resolution
radio buttons

These radio buttons allow you to adjust Horizontal Grid Resolution of Chord Block
placement by absolute Note time values from Whole Notes (less resolution) to
Thirty Second Notes (more resolution). This effects the size of time sections that
Chord Blocks snap to as you create or move them in the Chord Area of the
Document Window and Pianoroll Editor.

Other divisions
edit box

Use the left/right buttons or directly edit the number in this box to more finely set
how many Divisions wide the Horizontal Grid Resolution of Chord Block placement
will be in the Chord Area of the Document Window and Pianoroll Editor.

 

 Grid Resolution changes will only be effective if Align to Grid in the Grid View
submenu of the View menu has been selected for the Editor in which Grid
Resolution changes are being made. Additionally, Grid Resolution adjustments will
revert to previous settings in the relevant Editor unless Save Display Settings in
the View menu is selected before closing that Editor.

 

See also:

Play&Rec Region pane
Text Event pane
Line Block pane
Pianoroll pane
Control Draw pane
Pitch Bend pane
Notation pane
Tempo Draw pane

 



Using the Grid Setup dialog box  
Description of this dialog box

Items in this dialog box

  

Line Block
pane

Horizontal
Grid Resolution
radio buttons

These radio buttons allow you to adjust Horizontal Grid Resolution of Line
Block placement by absolute Note time values from Whole Notes (less
resolution) to Thirty Second Notes (more resolution). This effects the size of
time sections that Line Blocks snap to as you create or move them in the Line
Area of the Document Window.

Other divisions
edit box

Use the left/right buttons or directly edit the number in this box to more finely
set how many Divisions wide the Horizontal Grid Resolution of Line Block
placement will be in the Document Window.

 

 Grid Resolution changes will only be effective if Align to Grid in the Grid
View submenu of the View menu has been selected for the Editor in which
Grid Resolution changes are being made. Additionally, Grid Resolution
adjustments will revert to previous settings in the relevant Editor unless Save
Display Settings in the View menu is selected before closing that Editor.

 

See also:

Play&Rec Region pane
Text Event pane
Chord pane
Pianoroll pane
Control Draw pane
Pitch Bend pane
Notation pane
Tempo Draw pane

 



Using the Grid Setup dialog box  
Description of this dialog box

Items in this dialog box

  

Pianoroll
pane

Horizontal
Grid Resolution
radio buttons

These radio buttons allow you to adjust the Horizontal Grid Resolution of the
Pianoroll area in the Pianoroll Editor by absolute Note time values, from Whole
Notes (less resolution) to Thirty Second Notes (more resolution). This effects
the size of time sections Notes snap to when freely moving them Horizontally in
the Pianoroll Editor.

Other divisions
edit box

Use the left/right buttons or directly edit the number in this box to more finely set
how many Divisions wide the Horizontal Grid Resolution of Note placement in
the Line area of the Pianoroll Editor will be. By changing this value after first
completing other parts of your song, effects like Rhythmic offset between Lines
can more easily be achieved on a Note by Note basis.

Velocity
edit box

Use the up/down buttons or directly edit the number in this box to set the
Vertical resolution of the Velocity area in the Pianoroll Editor. This effects the
size of Velocity increments that Velocity adjustments snap to when freely
moving them Vertically in the Velocity area of the Pianoroll Editor.

 

 Grid Resolution changes will only be effective if Align to Grid in the Grid
View submenu of the View menu has been selected for the Editor in which Grid
Resolution changes are being made. Additionally, Grid Resolution adjustments
will revert to previous settings in the relevant Editor unless Save Display
Settings in the View menu is selected before closing that Editor.

 

See also:

Play&Rec Region pane
Text Event pane
Chord pane
Line Block pane
Control Draw pane
Pitch Bend pane
Notation pane
Tempo Draw pane

 



Using the Grid Setup dialog box  
Description of this dialog box

Items in this dialog box

  

Control Draw
pane

Horizontal
Grid Resolution
radio buttons

These radio buttons allow you to adjust the Horizontal Grid Resolution of
MIDI Control Event placement by absolute Note time values, from Whole
Notes (less resolution) to Thirty Second Notes (more resolution). This
effects the size of time sections MIDI Control Events snap to when creating
them with the Pen tool or freely moving them Horizontally in the Control
Draw Editor.

Other divisions
edit box

Use the left/right buttons or directly edit the number in this box to more
finely set how many Divisions wide the Horizontal Grid Resolution of MIDI
Control Event placement will be in the Control Draw Editor.

Control
edit box

Use the up/down buttons or directly edit the number in this box to set the
Vertical resolution of MIDI Control Events. This effects the size of MIDI
Control increments when creating them with the Pen tool or freely moving
them Vertically in the Control Draw Editor.

 

 Grid Resolution changes will only be effective if Align to Grid in the
Grid View submenu of the View menu has been selected for the Editor in
which Grid Resolution changes are being made. Additionally, Grid
Resolution adjustments will revert to previous settings in the relevant Editor
unless Save Display Settings in the View menu is selected before closing
that Editor.

 

See also:

Play&Rec Region pane
Text Event pane
Chord pane
Line Block pane
Pianoroll pane
Pitch Bend pane
Notation pane
Tempo Draw pane

 



Using the Grid Setup dialog box  
Description of this dialog box

Items in this dialog box

  

Pitch Bend
pane

Horizontal
Grid Resolution
radio buttons

These radio buttons allow you to adjust the Horizontal Grid Resolution of Pitch
Bend Event placement by absolute Note time values, from Whole Notes (less
resolution) to Thirty Second Notes (more resolution). This effects the size of
time sections Pitch Bend Events snap to when creating them with the Pen tool
or freely moving them Horizontally in the Control Draw Editor.

Other divisions
edit box

Use the left/right buttons or directly edit the number in this box to more finely
set how many Divisions wide Horizontal Grid Resolution of Pitch Bend Event
placement will be in the Control Draw Editor.

Pitch Bend
edit box

Use the up/down buttons or directly edit the number in this box to set the
Vertical resolution of Pitch Bend Events. This effects the size of Pitch Bend
increments when creating them with the Pen tool or freely moving them
Vertically in the Control Draw Editor. This number is expressed as degrees of
change, and its actual value depends on the range of MIDI data values being
edited in a given section of Line Data.

 

 Grid Resolution changes will only be effective if Align to Grid in the Grid
View submenu of the View menu has been selected for the Editor in which
Grid Resolution changes are being made. Additionally, Grid Resolution
adjustments will revert to previous settings in the relevant Editor unless Save
Display Settings in the View menu is selected before closing that Editor.

 

See also:

Play&Rec Region pane
Text Event pane
Chord pane
Line Block pane
Pianoroll pane
Control Draw pane
Notation pane
Tempo Draw pane

 



Using the Grid Setup dialog box  
Description of this dialog box

Items in this dialog box

  

Notation
pane

Horizontal
Grid Resolution
radio buttons

These radio buttons allow you to adjust the Horizontal Grid Resolution of the
Notation and Bar areas in the Notation Editor by absolute Note time values, from
Whole Notes (less resolution) to Thirty Second Notes (more resolution). This
effects the size of time sections Notes snap to when freely moving them
Horizontally in the Notation Editor.

Other divisions
edit box

Use the left/right buttons or directly edit the number in this box to more finely set
how many Divisions wide the Horizontal Grid Resolution of Note placement in
the Notation and Bar Areas of the Notation Editor will be. By changing this value
after first completing other parts of your song, effects like Rhythmic offset
between Lines can more easily be achieved on a Note by Note basis.

 

 Grid Resolution changes will only be effective if Align to Grid in the Grid
View submenu of the View menu has been selected for the Editor in which Grid
Resolution changes are being made. Additionally, Grid Resolution adjustments
will revert to previous settings in the relevant Editor unless Save Display
Settings in the View menu is selected before closing that Editor.

 

See also:

Play&Rec Region pane
Text Event pane
Chord pane
Line Block pane
Pianoroll pane
Control Draw pane
Pitch Bend pane
Tempo Draw pane

 



Using the Grid Setup dialog box  
Description of this dialog box

Items in this dialog box

  

Tempo Draw
pane

Horizontal
Grid Resolution
radio buttons

These radio buttons allow you to adjust the Horizontal Grid Resolution of
MIDI Tempo Event placement by absolute Note time values, from Whole
Notes (less resolution) to Thirty Second Notes (more resolution). This
effects the size of time sections MIDI Tempo Events snap to when creating
them with the Pen tool or freely moving them Horizontally in the Tempo
Draw Editor.

Other divisions
edit box

Use the left/right buttons or directly edit the number in this box to more finely
set how many Divisions wide the Horizontal Grid Resolution of MIDI Tempo
Event placement will be in the Tempo Draw Editor.

Tempo
edit box

Use the up/down buttons or directly edit the number in this box to set the
Vertical resolution of MIDI Tempo Events. This effects the size of MIDI
Tempo increments when creating them with the Pen tool or freely moving
them Vertically in the Tempo Draw Editor.

 

 Grid Resolution changes will only be effective if Align to Grid in the
Grid View submenu of the View menu has been selected for the Editor in
which Grid Resolution changes are being made. Additionally, Grid
Resolution adjustments will revert to previous settings in the relevant Editor
unless Save Display Settings in the View menu is selected before closing
that Editor.

 

See also:

Play&Rec Region pane
Text Event pane
Chord pane
Line Block pane
Pianoroll pane
Control Draw pane
Pitch Bend pane
Notation pane

 



Harmonize dialog box  
Contents

Dialog Boxes

  

Description Generates numerous alternate Chord Progressions for Melody harmonization.

Uses Upon opening the Harmonize dialog box, CAMPS automatically analyzes Tracks in the Bar
region of the selected Chords, and begins detecting Keys and Modes based on the Track Line
data.

CAMPS will generate and list available Chords or Chord Progressions based on your selection
from a list of detected Keys and Modes .

Using the Playback buttons, you can then audition the generated chords and select one that
sounds good to you.

  

Items Analyzed Track(s) scroll area
Detected Keys and Modes scroll area
Key Signature display
Key and Mode display
Detected Chords / Progressions scroll area

Suspend/Continue button
Chord Name radio button
Roman Numeral radio button
Playback button
Playback with Others button
Stop button

Next button

Previous button
OK button
Cancel button
Help button

  



Opening From the...
Document Window
Pianoroll Editor

Choose Harmonize... from the Chord menu to open the Harmonize dialog
box.
Alternatively, right-click desired Chord(s) and choose Actions,
Harmonize...

 When choosing Harmonize... from the Chord menu, you must have selected Chord
Container(s) in the Chord Area, otherwise the Harmonize... item won't be available.

  



Items in the Harmonize dialog box  
Description of this dialog box

Using this dialog box

  

Selecting
Track(s)

Analyzed Track(s)
scroll area

This area contains a list of selected Track names in the
Document Window for which you are attempting to find
harmonizing Chords.

Selecting a
Key and Mode

Detected
Keys and Modes
scroll area

As the Auto Key Detection procedure is completed, this
scroll area displays the results in the order of trueness
using the format "Trueness %: Key Mode ".

Key Signature
display

Displays the musical notation form of the Key Signature
resulting from your selections in the Detected Keys and
Modes scroll area.

Key and Mode
display

Displays the alphabetic form of Key and Mode selected
from the Detected Keys and Modes scroll area.

Selecting a
Chord

Detected
Chord(s)/Progression(s)
scroll area

Displays a list of harmonizing Chord Progressions in the
Key and Mode selected in the Detected Keys and Modes
scroll area.

Suspend/Continue
button

Click the Suspend/Continue button to suspend or
continue generating Chords or Chord Progressions in the
Detected Chord(s) / Chord Progression(s) scroll area.

Appearance of
Generated Chords

Chord Name
radio button

Sets the Chord display in the Detected Chord(s)/Chord
Progression(s) scroll area to Chord Name form.

Roman Numeral
radio button

Sets the Chord display in the Detected Chord(s)/Chord
Progression(s) scroll area to Roman Numeral form.

Auditioning  Playback Click the Playback (Single Speaker) button to listen to the
Chord or Chord Progression selected in the Detected
Chord(s)/Chord Progression(s) scroll area.

 Playback with Others Click the Playback with Others (Double Speaker) button
to listen to the Chord or Chord Progression selected in the
Detected Chord(s)/ Progression(s) scroll area along with all
the other activated Tracks.

 Stop Click the Stop (No Speaker) button to stop Audition
Playback.

Next
button

Click the Next button to hear the next Chord or Chord
Progression you have check marked in the Detected
Chord(s)/Chord Progression(s) scroll area.

Previous
button

Click the Previous button to hear the previous Chord or
Chord Progression you have check marked in the Detected
Chord(s)/Chord Progression(s) scroll area.

Closing OK
button

Closes the Harmonize dialog box and commits changes.

Cancel
button

Closes the Harmonize dialog box without committing
changes.

Help
button

Opens this Help document.



 

  



Using the Harmonize dialog box  
Description of this dialog box

Items in this dialog box

  

Selecting
Track(s)

Analyzed Track(s)
scroll area

Tracks that are "turned on" by using the Play button in the Track Area of the
Document Window have already been selected for your convenience and will
be referred to by CAMPS during the Auto Key Detection procedure.

Tracks that are assigned to the Drums Category are not displayed in the
Analyzed Track(s) scroll area and will not be referred to by CAMPS during the
Auto Key Detection procedure.

CAMPS will detect Keys and Modes based on Tracks you select. As you
select Tracks to be Analyzed, consider previously defined categories like
Melody, Comping, Obligato, Bass and Strings represented by the respective
corresponding labels [M], [C], [O], [B] or [S] to the left of each Track's name.

When you change Track selections, CAMPS automatically begins the Auto
Key Detection procedure all over again, erasing the previously detected Keys
and Modes in the Detected Keys and Modes scroll area.

 

See also:

Selecting a Key and Mode
Selecting a Chord
Getting Results

 



Using the Harmonize dialog box  
Description of this dialog box

Items in this dialog box

  

Selecting
a Key & Mode

Detected
Keys and Modes
scroll area

Select a Key and Mode as needed, referring to the Detected Keys and
Modes and Key Signature displays.

The word "Original" appearing at the top of this display area represents the
original Key and Mode before opening the Harmonize dialog box.

Selecting a Key and Mode in this display area starts the Auto Chord
Detection procedure, harmonizing with the selected Track data in that Key.

When you change Key and Mode selections, CAMPS automatically begins
the Auto Chord Detection procedure all over again, erasing the previously
detected Chords or Chord Progressions in the Detected Chords or
Progressions scroll area.

 

See also:

Selecting Tracks
Selecting a Chord
Getting Results

 



Using the Harmonize dialog box  
Description of this dialog box

Items in this dialog box

  

Selecting
a Chord

Detected
Chord(s)/
Progression(s)
scroll area

Choose a desired Detected Chord or Progression from the Detected
Chord(s)/Progression(s) scroll area.

Suspend/Continue
button

During the Auto Chord Detection procedure, you can always suspend and
continue the generation process by clicking the Suspend/Continue button.
This feature is especially useful when CAMPS is generating a vast number of
Chords or Chord Progressions. When CAMPS is finished Detecting Chords,
the Suspend/Continue button's label changes to Done.

Chord Name
and
Roman Numeral
radio buttons

Click the Chord Name or Roman Numeral radio button to choose your
desired Chord display style in the Detected Chord(s)/Progression(s) area.

 

See also:

Selecting Tracks
Selecting a Key and Mode
Getting Results

 



Using the Harmonize dialog box  
Description of this dialog box

Items in this dialog box

  

Getting
Results

Playback,
Playback with Others,
Stop
buttons

Click the Playback (Single Speaker) button to listen to the Chord or Chord
Progression currently selected in the Detected Chord(s)/Progression(s)
scroll area. Click the Playback with Others (Double Speaker) button to
hear the Chord or Chord Progression along with all the other activated
Tracks.

Once either Playback button is clicked, CAMPS will repeat (Loop) Playback
of Detected Chords and Progressions as you select them, even while
selecting different Keys and Modes, until you click the Stop (No Speaker)
button. With this feature, you can change and listen to different Chords or
Chord Progressions "on the fly" or one by one.

Next,
Previous
buttons

When CAMPS detects a vast number of Chords or Chord Progressions,
check mark the ones that sound good to you as you listen. Use the Next
and Previous buttons to instantly switch between the check marked
Chords.

OK
button

Selecting a Chord or Chord Progression in the Detected
Chord(s)/Progression(s) scroll area and clicking OK closes the Harmonize
dialog box and replaces the contents of the selected Chord Container(s)
with the newly generated Chord(s) or Progression(s).

 CAMPS will always generate Chord Progressions that smoothly flow
into each other unless you assign otherwise.

 

See also:

Selecting Tracks
Selecting a Key and Mode
Selecting a Chord

 



Jump To Location dialog box  
Contents

Dialog Boxes

  

Description The Jump To Location dialog box allows you to relocate the viewpoint in a CAMPS document to
a specified Bar.

Uses After opening the Jump To Location dialog box, specify a Bar Number from which to begin a new
viewpoint and click OK.

  

Items Bar
edit box

Use the left/right buttons or directly edit the Bar Number in this box to specify a new
viewpoint.

Time
display

The Time display shows your song Document's projected elapsed time at the Bar
specified in the Bar edit box.

Range
display

The Range display only appears when opening the Jump To Location dialog box from
the Event List, Pianoroll, Control Draw, and Notation Editors. This display shows the
available Bar and Time Range for the Line Block being Edited.

OK
button

Closes the Jump To Location dialog box and relocates the current viewpoint to the
specified Bar.

Cancel
button Closes the Jump To Location dialog box without changing the current viewpoint.

 

  

Opening From the...
Document Window
Pianoroll Editor
Control Draw Editor
Notation Editor
Tempo Draw Editor

Click the Jump To Location button. Alternatively, right-click an empty
Bar, Chord or Line Area and choose Jump To Location.

From the...
Event List Editor
Tempo List Editor
Text List Editor

Click the Jump To Location button. Alternatively, right-click the Playback
Pointer Area or any of the Beat Sections and choose Jump To Location.

  



New Line Block dialog box  
Contents

Dialog Boxes

  

Description The New Line Block dialog box allows you to create and insert new Line Blocks with or without
automatically generated Line data.

Uses After selecting the desired Line Area and opening the New Line Block dialog box, specify a Take
Name and how many Bars long you want the New Line Block to be. Checkmarking the
EZgenerate Line Data option causes CAMPS to create Line data with the New Line Block, and
enables the Rhythm radio buttons for adjusting the EZgenerated Line data's rhythmic
tendencies.

  

Items Take Name
edit box

Upon opening the New Line Block dialog box, this field is automatically
filled in with the phrase "Block #", where "#" equals the next unused
number above the current quantity of Line Blocks in your Document.
You can leave this designation, or replace it with a Name of your choice.

Bar Quantity
edit box

Use the up/down buttons or directly edit the number in this box to
specify how many Bars long the New Line Block will be.

EZgenerate Line Data
check box

Checkmarking this option causes CAMPS to automatically generate
Line data in your New Line Block. It also enables the Rhythm radio
buttons.

 EZgenerated Line data is created in the context of Harmony defined
by Chord Blocks in the same Bar region as the New Line Block being
created.

 If no Chords are defined in the Bar region where a New Line Block
is being created, EZgenerated Line data will most likely not fit your
composition; sounding totally "outside" or even quite unpleasant.

Rhythm
radio buttons

When enabling the EZgenerate Line Data option, use these radio
buttons to adjust the rhythmic complexity of EZgenerated Line data.

New
button

Closes the New Line Block dialog box and creates the New Line Blocks
you specify.

Cancel
button

Closes the New Line Block dialog box without creating a New Line
Block.

Help
button Opens this Help document.

 

  



Opening From the
Document Window

There are 3 versions of this dialog box. This one appears when you
right-click an empty Tonal Line Area (any Track except those in the Drums
Category) and choose New Line Block....

  



New Line Block dialog box  
Contents

Dialog Boxes

  

Description The New Line Block dialog box allows you to create and insert new Line Blocks with or without
automatically generated Line data.

Uses After selecting the desired Drums Line Area and opening the New Line Block dialog box, specify
a Take Name and how many Bars long you wish the New Line Block to be. Checkmarking the
EZgenerate Line Data option causes CAMPS to create Line data with the New Line Block. This
also enables the Rhythm and Instrument controls, allowing you to adjust rhythmic tendencies,
and Percussion Instrumentation of EZgenerated Line data.

  

Items Take Name
edit box

Upon opening the New Line Block dialog box, this field is automatically
filled in with the phrase "Block #", where "#" equals the next unused
number above the current quantity of Line Blocks in your Document.
You can leave this designation, or replace it with a Name of your choice.

Bar Quantity
edit box

Use the up/down buttons or directly edit the number in this box to
specify how many Bars long the New Line Block will be.

EZgenerate Line Data
check box

Checkmarking this option causes CAMPS to automatically generate
Line data in your New Line Block. It also enables the Rhythm radio
buttons, Instruments selection box, Instrument Settings display and
Reassign To selection box.

Rhythm
radio buttons

When enabling the EZgenerate Line Data option, use these radio
buttons to adjust the rhythmic complexity of EZgenerated Line data.

Instruments
selection box

When enabling the EZgenerate Line Data option, you can use this
selection box to choose Percussion Instruments included in the
EZgenerated Line data.

Instrument Settings
display

When enabling the EZgenerate Line Data option, this area displays
Percussion Instruments to be included in the EZgenerated Line data, as
selected in the Instruments selection box.

Reassign To
selection box

When enabling the EZgenerate Line Data option, you can use this
selection box to reMap MIDI Keys of Percussion Instruments (Sounds)
selected in the Instruments selection box.

New
button

Closes the New Line Block dialog box and creates the New Line Blocks
you specify.

Cancel
button

Closes the New Line Block dialog box without creating a New Line
Block.

Help
button Opens this Help document.



 

  

Opening From the
Document Window

There are 3 versions of this dialog box. This one appears when you
right-click an empty Drums Line Area and choose New Line Block....

  



New Line Block dialog box  
Contents

Dialog Boxes

  

Description The New Line Block dialog box allows you to create and insert new Line Blocks with or without
automatically generated Line data.

Uses After opening the New Line Block dialog box, specify a Take Name, Track, Starting Bar and how
many Bars long you wish the New Line Block to be. Checkmarking the EZgenerate Line Data
option causes CAMPS to create Line data with the New Line Block, and enables Rhythm radio
buttons for adjusting the EZgenerated Line data's rhythmic tendencies. If the selected Track is in
the Drums Category, you can also specify Percussion Instrumentation of EZgenerated Line data.

  

Items Take Name
edit box

Upon opening the New Line Block dialog box, this field is automatically
filled in with the phrase "Block #", where "#" equals the next unused
number above the current quantity of Line Blocks in your Document.
You can leave this designation, or replace it with a Name of your choice.

Track
selection box

Clicking the drop-down button on the right side of this box opens the list
of available Tracks in your Document. Select the Track to which you
wish to add a New Line Block. If you select a Track in the Drums
Category and checkmark the EZgenerate Line Data option, the
Instruments selection box, Instrument Settings display and Reassign To
selection box are also enabled.

Start Bar
edit box

Use the up/down buttons or directly edit the number in this box to
specify which Bar the New Line Block will start from.

Bar Quantity
edit box

Use the up/down buttons or directly edit the number in this box to
specify how many Bars long the New Line Block will be.

EZgenerate Line Data
check box

Checkmarking this option causes CAMPS to automatically generate
Line data with your New Line Block. It also enables the Rhythm radio
buttons. If the Track selected in the Track selection box is in the Drums
Category, then the Instruments selection box, Instrument Settings
display and Reassign To selection box are also enabled.

 If you select a Track in a Category other than Drums, EZgenerated
Line data is created in the context of Harmony defined by Chord Blocks
in the same Bar region as the New Line Block being created.

 If no Chords are defined in the Bar region where a New Line Block
is being created, EZgenerated Line data will most likely not fit your
composition; sounding totally "outside" or even quite unpleasant.

Rhythm
radio buttons

When enabling the EZgenerate Line Data option, use these radio
buttons to adjust the rhythmic complexity of EZgenerated Line data.

Instruments
selection box

When choosing a Track in the Drums Category and enabling the
EZgenerate Line Data option, you can use this selection box to choose
Percussion Instruments included in the EZgenerated Line data.

Instrument Settings
display

When choosing a Track in the Drums Category and enabling the
EZgenerate Line Data option, this area displays Percussion
Instruments to be included in the EZgenerated Line data, as selected in
the Instruments selection box.



Reassign To
selection box

When choosing a Track in the Drums Category and enabling the
EZgenerate Line Data option, you can use this selection box to reMap
MIDI Keys of Percussion Instruments (Sounds) selected in the
Instruments selection box.

New
button

Closes the New Line Block dialog box and creates the New Line Blocks
you specify.

Cancel
button

Closes the New Line Block dialog box without creating a New Line
Block.

Help
button Opens this Help document.

 

  

Opening From the
Document Window

There are 3 versions of this dialog box. This one appears when you click
anywhere in the Line Area and choose New Line Block... from the Edit
menu.

  



Map Pitches dialog box  
Contents

Dialog Boxes

  

Description The Map Pitches dialog box allows you to shift the MIDI Pitch value of all occurrences of
specified Notes in selected Line data.

Uses Upon opening the Map Pitches dialog box, CAMPS lists the selected Pitches in the Map Pitches
scroll area.

Select a Pitch in the Map Pitches scroll area to reMap, and choose a new Pitch from the
Reassign To box's drop-down list.

Using the Playback buttons, you can then audition Pitch Mappings and select one that sounds
good to you.

  

Items Map Pitches scroll area
Reassign To selection box
Playback button
Playback with Others button
Stop button
OK button
Cancel button
Help button

  

Opening From the...
Document Window
Event List Editor
Pianoroll Editor
Notation Editor

Choose Map Pitches... from the Line menu.
Alternatively, right-click desired Line data and choose Actions, Map
Pitches....

 When choosing Map Pitches... from the Line menu, you must first have selected Line data,
otherwise the Map Pitches... item won't be available.

  



Items in the Map Pitches dialog box  
Description of this dialog box

Using this dialog box

  

Selecting Pitches Map Pitches
scroll area

Use this area to select a Pitch to reMap, and to select which
Pitches sound during Auditioning.

Reassign To
selection box

Select a Pitch from the drop-down list in this box that you
want to use to replace the selected Pitch in the Map Pitches
scroll area.

Auditioning  Playback Click the Playback (Single Speaker) button to listen to the
selected Pitch Mapping along with any existing Chords.

 Playback with Others Click the Playback with Others (Double Speaker) button to
listen to the selected Pitch Mapping along with all the other
activated Tracks.

 Stop Click the Stop (No Speaker) button to stop Playback.

Closing OK
button

Closes the Map Pitches dialog box and commits changes.

Cancel
button

Closes the Map Pitches dialog box without committing
changes.

Help
button

Opens this Help document.

 

  



Using the Map Pitches dialog box  
Description of this dialog box

Items in this dialog box

  

Selecting and
Mapping Pitches

Map Pitches
scroll area

After selecting individual Notes or whole Line Blocks and opening the Map
Pitches dialog box, CAMPS lists all selected Pitches and their current
Mappings in three columns:

The Play column provides a check box you can use to select which Pitches
sound during Auditioning.

The Pitch column displays the MIDI Pitch value of each respective Pitch.

The Original Pitch -> New Pitch column displays the current Pitch Mappings.
(Unaltered Pitches will always be Mapped to themselves.)

Upon selecting a Pitch in the Map Pitches scroll area, CAMPS automatically
sounds the Original Pitch, immediately followed by the New (currently
Mapped) Pitch. Simply select a Pitch you wish to reMap.

Reassign To
selection box

Use the drop-down button on the right side of the Reassign To selection box
to open the list of available Pitches, and choose one to Map to the Pitch
selected in the Map Pitches scroll area. Upon selecting a new Pitch, CAMPS
automatically re-enables its Play setting (if previously unchecked), sounds
the corresponding New Pitch, and displays the New Pitch Mapping in the
Original Pitch -> New Pitch column of the Map Pitches scroll area.

 



See also:

Getting Results

 



Using the Map Pitches dialog box  
Description of this dialog box

Items in this dialog box

  

Getting
Results

Playback,
Playback with Others,
Stop
buttons

Each time you reMap Pitches, the selected Line data is
temporarily replaced.

Click the Playback (Single Speaker) button to hear the results of Pitch
Mapping along with any existing Chords. Click the Playback with

Others (Double Speaker) button to hear the results of Pitch Mapping
along with all the other activated Tracks.

Once either Playback button is clicked, CAMPS will repeat (Loop) Playback
of selected Line data with current Pitch Maps as you make them, until you
click the Stop (No Speaker) button. With this feature, you can change and
listen to different Pitch Maps "on the fly" or one by one.

OK
button

Click OK when you have achieved the desired results. This closes the Map
Pitches dialog box and applies the new Pitch Maps to the selected Line
data.

 While reMapping Pitches can provide interesting results with harmonic
Line data, Its main intended use is translating Drum sounds from one synth
program to another.

 Keep in mind that different Drum sounds may have different Control
data sensitivity. After reMapping Pitches for Drum sound assignment, it may
be necessary to adjust control data such as Velocity or After Touch to
maintain originally desired sound.

 

See also:

Selecting and Mapping Pitches

 



Memo dialog box  
Contents

Dialog Boxes

  

Description The Memo dialog box allows you to add background text, such as descriptions, to a CAMPS
Document and its individual Tracks and Line Blocks.

Uses Different types of Memos are available depending on area selected. The Document Memo is
always available. In the Tempo List, Tempo Draw and Text List Editors, only the Document
Memo is available. In the Event List, Pianoroll, Control Draw and Notation Editors, the Document
and Line Block Memos are available. Depending on your selection in the Document Window, the
Document, Line Block and Track Memos are available.

After selecting an area and choosing the appropriate Memo type, enter desired text and click OK.

  

Items Text
scroll area

Enter or edit desired Text in this scroll area.

OK
button

Click the OK button to close the Memo dialog box and save text in the Text scroll
area as a Memo for the selected area. As with all Editing in CAMPS, changes will not
actually be saved in the Document until you save the Document File, either during
your CAMPS session, or upon exiting

Cancel
button Click the Cancel button to close the Memo dialog box and discard text changes.

 

  

Opening

From the
Document Window

Choose Document Memo from the Help menu.
Select a desired Track in the Track Area and choose Track Memo from
the Help menu. Alternatively, right-click desired Track and select Track
Memo.
Select a desired Line Block in the Line Area and choose Line Block
Memo from the Help menu. Alternatively, right-click desired Line Block
and select Line Block Memo.

From the...
Tempo List Editor
Tempo Draw Editor
Text List Editor

Choose Document Memo from the Help menu.



From the...
Event List Editor
Pianoroll Editor
Control Draw Editor
Notation editor

Choose Document Memo or Line Block Memo from the Help menu.

  



MIDI Setup dialog box  
Contents

Dialog Boxes

  

Description The MIDI Setup dialog box allows you to make global settings for MIDI data Input and Output in
CAMPS.

Uses The MIDI Setup dialog box can be accessed from any Editor screen in CAMPS. This way, you
can adjust MIDI Input, Output, Sync and Metronome settings at any moment during your work.

  

Items Default pane
Output Device pane
Metronome pane
Record pane
Tap pane
MIDI Clock pane
SMPTE pane
OK button
Cancel button
Apply button
Help button

  

Opening Choose MIDI Setup... from the MIDI menu.

  



Items in the MIDI Setup dialog box  
Description of this dialog box

Using this dialog box

  

MIDI Output Default
pane

Click the Default tab to open the Default pane. The Default pane shows which
of your computer's MIDI Output resources will be associated with a newly
created Track. This is also where you set the speed of the Playback Control
toolbar's Fast Forward and Rewind functions.

Output Device
pane

Click the Device tab to open the Device pane. This pane allows you to select
which of your computer's MIDI Output devices CAMPS sends MIDI data to, and
lets you manage Synth Program (Patch) names used when selecting a Track's
MIDI Program number.

Metronome
pane

Click the Metronome tab to open the Metronome pane. Here is where you set
the default operation of the CAMPS Metronome.

MIDI Input Record
pane

Click the Record tab to open the Record pane. The Record pane gives you
most of CAMPS MIDI input settings.

Tap
pane

Click the Tap tab to open the Tap pane. This is where you select the Input
source for manual Tap Tempo.

MIDI Timing MIDI Clock
pane

Click the MIDI Clock tab to open the MIDI Clock pane. This is where you
choose MIDI Clock Input and Output sync sources.

SMPTE
pane

Click the SMPTE tab to open the SMPTE pane. If you're using SMPTE to
synchronize your MIDI performance, this is where you choose SMPTE Input
and Output sync sources and timing.

Closing OK
button

Closes the MIDI Setup dialog box and commits changes.

Cancel
button

Closes the MIDI Setup dialog box without committing changes.

Apply
button Commits changes without closing the MIDI Setup dialog box.

Help
button

Opens this Help document.

 

  



Using the MIDI Setup dialog box  
Description of this dialog box

Items in this dialog box

  

Default
pane

Default Output
for New Track
scroll area

This area lets you choose the default MIDI Output device to be assigned to
newly created Tracks in CAMPS.

Fast Forward/Rewind
Speed
radio buttons

Use these radio buttons to set the speed of the Playback Control toolbar's
Fast Forward and Rewind functions. There are 5 settings, with left-most
buttons yielding slower shuttle action, and right-most buttons increasing
shuttle speed.

 
 Multiple MIDI Output Devices installed in your computer will not be

available in the Default Output for New Track scroll area if the MIDI Mapper
item is selected in the MIDI menu.

 

See also:

Output Device pane
Metronome pane
Record pane
Tap pane
MIDI Clock pane
SMPTE pane

 



Using the MIDI Setup dialog box  
Description of this dialog box

Items in this dialog box

  

Output Device
pane

Output Device Settings
scroll area

The Output Device Settings scroll area allows you to choose which
of your computer's MIDI Devices CAMPS will send MIDI data to.
Any Document open during Output Device changes will retain
previous settings However, you can change Output Device
Settings for an open Document on a Track by Track basis by using
a Track's Device button.

 Virtual (Software) Synthesizers typically have a slower initial
response time. Therefore, using them while a Hardware MIDI
Device is assigned to some Tracks in the same Document may
result in an unwanted offset of Playback time between Instruments
in your song.

Because of the enhanced ability of CAMPS to manage MIDI
Output Devices, the typical "override to OS Settings" MIDI Mapper
selection has been placed in a higher level of the MIDI menu in
CAMPS.

Program Set
selection box

In the Program Set selection box, you can choose between a few
basic General MIDI Synth Program (Patch) name lists for the
purpose of automatically displaying corresponding musical
Instrument (Sound) names while adjusting a Track's Program
number in the Document Window and Event List Editor. Use the
drop-down button to see and choose from available Program Sets.

Program Examples
display

This display area shows a short list of Program name examples in
the chosen Program Set.

 
 Multiple MIDI Output Devices installed in your computer will

not be available in the Output Device Settings scroll area if the
MIDI Mapper item is selected in the MIDI menu.

 



See also:

Default pane
Metronome pane
Record pane
Tap pane
MIDI Clock pane
SMPTE pane

 



Using the MIDI Setup dialog box  
Description of this dialog box

Items in this dialog box

  

Metronome
pane

Output
scroll area

The Metronome Output scroll area is where you choose the MIDI Device to
which CAMPS directs the Metronome MIDI signal.

Channel
edit box

Use the up/down buttons or directly edit the number in this box to choose
the MIDI Channel to which CAMPS directs the Metronome MIDI signal.

Program Change
edit box

Use the up/down buttons or directly edit the number in this box to set the
Synth Program (Patch) for the Metronome Sounds.

Sound A & B
boxes

CAMPS provides the ability to use 2 different Sounds (A and B) for
Metronome "clicks", for the purpose of assigning each Sound to certain
Beats per Bar. This feature lets you set stress or accent Beats for each Bar.
Use the drop-down buttons to open a list from which to select a MIDI Pitch
(Instrument Key) for each Metronome Sound.

Since Synth Module Drum Programs usually provide different Drum Sounds
at different MIDI Pitch values, these Metronome Sounds can be 2 different
Drum Sounds, as well as 2 different Pitches of a regular Keyboard Sound,
depending on which Program Change value is specified.

Velocity A & B
edit boxes

Use the up/down buttons or directly edit the numbers in these boxes to
change the velocity (loudness) of each of the 2 Metronome "click" Sounds.

Playback Order
radio buttons

Use these radio buttons to rearrange which Sound (A or B) is used for which
Beat(s) in a Bar. These settings are based on a 4/4 Time Signature. If, for
example, your song is in 2/4, only the first 2 of each 4 Sounds will be
relevant for each radio button setting.

 
 Multiple MIDI Output Devices installed in your computer will not be

available in the Output scroll area if the MIDI Mapper item is selected in the
MIDI menu.

 



See also:

Default pane
Output Device pane
Record pane
Tap pane
MIDI Clock pane
SMPTE pane

 



Using the MIDI Setup dialog box  
Description of this dialog box

Items in this dialog box

  

Record
pane

Input
scroll area

This area is where you select which of your computer's MIDI devices CAMPS
listens to for incoming MIDI data during Recording.

Punch-in Preroll
edit box

Use the up/down buttons or directly edit the number in this box to change how
many beats of your song CAMPS will Play before your Record Punch-In point.
The term "Preroll" comes from the idea of rewinding a recording tape back
farther than an intended Punch-In Recording point and letting it roll (Play) a
few preceding Bars as an Intro for Punch-In Cue.

Include Channel(s)
check boxes

When Recording, all checkmarked MIDI channels will be received by CAMPS.
Actually, CAMPS "translates" incoming MIDI Channel information to whichever
Channel is being used for the Track currently being Recorded. Unselected
Channels are simply ignored. All selected Channels will be "translated" to the
Channel needed for your current task in CAMPS. It is therefore unnecessary to
specify a particular MIDI Output channel on your MIDI Instrument when
Recording in CAMPS.

Include Events
check boxes

When Recording, all checkmarked MIDI data Events will be received by
CAMPS. Unselected Event Data types are simply ignored.

 

See also:

Default pane
Output Device pane
Metronome pane
Tap pane
MIDI Clock pane
SMPTE pane

 



Using the MIDI Setup dialog box  
Description of this dialog box

Items in this dialog box

  

Tap
pane

Input
scroll area

This is where you select which of your computer's devices CAMPS listens to for your
manual Tap Tempo Input. To use your computer's keyboard instead of a MIDI
Instrument, select [Shift] key from the Input Device list.

Click Key
area

The Click Key area becomes active when a MIDI Device is chosen from the Input
scroll area instead of your computer's keyboard.

Channel,
Key
edit boxes

Use the Channel and Key edit boxes to assign which MIDI Channel and which MIDI
Instrument Key (Pitch value) will be used as a Tap Tempo reference by CAMPS.

The Pitch display shows the current Pitch Mapping of the selected Instrument Key.

From
MIDI Instrument
button

To directly assign a MIDI Instrument Key to Tap Input, click the From MIDI
Instrument button and press any Key on your MIDI Instrument.

Sync with
radio buttons

Here, you can choose whether CAMPS uses the Song Beat (Time Signature) or an
absolute Half, Quarter or Eighth Note time value (regardless of Time Signature)
when receiving Sync information from the incoming Tap Tempo MIDI signal to
Synchronize with.

 

See also:

Default pane
Output Device pane
Metronome pane
Record pane
MIDI Clock pane
SMPTE pane

 



Using the MIDI Setup dialog box  
Description of this dialog box

Items in this dialog box

  

MIDI Clock
pane

Overview The MIDI Clock pane of the MIDI Setup dialog box allows you to select MIDI
devices and data types that CAMPS will use for Sending and receiving MIDI Time
Code Synchronization signals to and from the world outside your computer. This
can include other MIDI Interfaces and Instruments, and digital or analog recording
devices (Tape decks, etc.), among other things.

Input
scroll area

Choose the MIDI device from the Input scroll area from which CAMPS will derive
MIDI Clock Synchronization when the MIDI menu Synchronize With item is set to
MIDI Clock.

Sync with
radio buttons

Here, you can choose whether CAMPS uses the Song Beat (Time Signature) or
an absolute Quarter Note time value (regardless of Time Signature) when
receiving Sync information from the incoming MIDI signal to Synchronize with.

Output
scroll area

Choose the MIDI device from the Output scroll area to which CAMPS will send
MIDI Clock Synchronization when the MIDI menu Transmit Clock item is set to
MIDI Clock.

Sync To
radio buttons

Here, you can choose whether CAMPS uses the Song Beat (Time Signature) or
an absolute Quarter Note time value (regardless of Time Signature) to send Sync
information to the outgoing MIDI signal for other MIDI devices to Synchronize with.

 
 Multiple MIDI Output Devices installed in your computer will not be available

in the Output scroll area if MIDI Mapper is selected in the MIDI menu.

 

See also:

Default pane
Output Device pane
Metronome pane
Record pane
Tap pane
SMPTE pane
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Description of this dialog box

Items in this dialog box

  

SMPTE
pane

Overview Motion pictures are comprised of a long series of still images, called Frames,
displayed in rapid succession. Therefore, the exact moment an image event begins in
a motion picture can be resolved to one of these Frames. When synchronizing sounds
with motion picture events in film and video, SMPTE Time Code is used to reference
how many of these Frames flip by in a given time period, defined as Frames per
Second ("fps" or "f/s"). SMPTE Time Code also includes regular time
(Hours/Minutes/Seconds) information.

Because of its accuracy and standardization, SMPTE Time Code has become widely
used for Synchronization in the professional audio production world. The audio
version of SMPTE Time Code, called Longitudinal Time Code (LTC) is often used
even when there is no accompanying motion picture, and this is the form used in
CAMPS, simply called SMPTE.

Input
scroll area

Choose a MIDI device from the Input scroll area from which CAMPS will derive
SMPTE Synchronization when the MIDI menu Synchronize With item is set to
SMPTE.

Output
scroll area

Choose the MIDI device from the Output scroll area to which CAMPS will send
SMPTE Synchronization signals when the MIDI menu Transmit Clock item is set to
SMPTE.

Sync Rate
radio buttons

24 f/s is used for film (movies; cinema) in the US.

25 f/s is used for film, television and video in Europe and other parts of the world. This
includes the PAL and SECAM television standards.

30 f/s Non-Drop is the most often used for audio-only Synchronization because of it's
constant degree of accuracy and simpler rate calculation. It matches the first
Television standard for Black & White video in the US.

30 f/s Drop is used for the NTSC color television standard in the US and some other
countries. The term "Drop" refers to intentionally dropped Frame code numbers in the
SMPTE LTC. SMPTE LTC drops (skips) 18 Frame code numbers every 10 minutes to
compensate for color video's slightly slower Frame Rate. NTSC's Frame Rate is
actually 29.97 due to the addition of color information to an originally B&W standard.
Although 30 f/s Drop is essential for proper Sync timing in NTSC color video projects,
it exhibits slight time display inaccuracies due to the Drop pattern, making it less
desirable for audio-only projects.

 
 CAMPS transmits and receives only MIDI protocol. These SMPTE settings allow

CAMPS to treat MIDI Time Code as SMPTE Longitudinal Time Code for User
Interface purposes. To read or generate actual SMPTE LTC, you'll need to connect
conversion hardware to your computer's MIDI port.

 Multiple MIDI Output Devices installed in your computer will not be available in
the Output Device Settings scroll area if the MIDI Mapper item is selected in the MIDI
menu.



 

See also:

Default pane
Output Device pane
Metronome pane
Record pane
Tap pane
MIDI Clock pane

 



New Document Setup dialog box  
Contents

Dialog Boxes

  

Description The New Document Setup dialog box allows you to set defaults for and create a New Document.

Uses After making desired settings for a New Document, click New to close the New Document Setup
dialog box and create a New Document, saving settings for future use, or click OK to close the
New Document Setup dialog box and save settings for future use without creating a New
Document.

  

Items Time Signature edit boxes
Tracks check box
Line Block on each Track check box
Number of Bar(s) edit box
Chord Block check box
Number of Chord(s) edit box
Text Events check box
New button
OK button
Cancel button
Help button

  

Opening Choose New Setup... from the File menu.

  



Items in the New Document Setup dialog box  
Description of this dialog box

Using this dialog box

  

Setting default
Time Signature

Time Signature
edit boxes

Enter appropriate numbers in the Beats per Bar (Numerator)
and Beat Note Type (Denominator) edit boxes to set desired
Time Signature.

Selecting Objects
to include

Tracks
check box

Checkmarking this option causes CAMPS to automatically
create 6 basic empty Tracks with a New Document.

Line Block on each Track
check box

Checkmarking this option causes CAMPS to automatically
create a new empty Line Block for each automatically created
Track.

Number of Bar(s)
edit box

Use the up/down buttons or directly edit the number in this
box to set how many Bars long automatically created Line
Blocks will be.

Chord Block
check box

Checkmarking this option causes CAMPS to automatically
create one Chord Block with a New Document.

Number of Chord(s)
edit box

Use the up/down buttons or directly edit the number in this
box to set how many Chord Containers will be created in the
automatically created Chord Block.

Text Events
check box

Checkmarking this option causes CAMPS to automatically
create a Text Event and a pair of Markers with a New
Document.

Closing New
button

Click New to close the New Document Setup dialog box, save
your New Document default settings and create a New
Document, using your settings.

OK
button

Click OK to close the New Document Setup dialog box and
save your New Document default settings without creating a
New Document.

Cancel
button

Click Cancel to close the New Document Setup dialog box
without committing changes or creating a New Document.

Help
button

Opens this Help document.
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Description of this dialog box

Items in this dialog box

  

Setting Default
Time Signature

Getting Started In musical Notation, Time Signature is indicated as a numerical fraction at
the beginning of a musical staff after the Key Signature. The top number
(Numerator) indicates how many Beats per Bar, and the bottom number
(Denominator) indicates what kind of Note gets 1 Beat.

Time Signature
edit boxes

The Time Signature area of the New Document Setup dialog box exactly
mimics the Notation form of Time Signature. Simply enter appropriate
numbers in the Beats per Bar (Numerator) and Beat Note Type
(Denominator) edit boxes to set desired Time Signature.

Valid numbers for Beat Note Type (bottom Denominator field) include:
1 -Whole Note
2 -Half Note
4 -Quarter Note
8 -Eighth Note
16 -Sixteenth Note
32 -Thirty Second Note
64 -Sixty Forth Note

 

See also:

Selecting Objects to Include
Getting Results
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Description of this dialog box

Items in this dialog box

  

Selecting Objects
to Include

Tracks
check box

Checkmarking this option causes CAMPS to automatically
create 6 basic empty Tracks with a New Document; one in
each of the following Categories:

Melody
Comping
Obligato
Bass
Strings
Drums

Line Block on each Track
check box

A checkmark here causes CAMPS to automatically create a
new empty Line Block for each automatically created Track.
Checkmarking this option also enables the Number of Bars
edit box.

Number of Bar(s)
edit box

Use the up/down buttons or directly edit the number in this
box to set how many Bars long automatically created Line
Blocks will be when the Line Block on each Track option is
checkmarked.

Chord Block
check box

A checkmark here causes CAMPS to automatically create
one Chord Block with a New Document. Checkmarking this
option also enables the Number of Chords edit box.

Number of Chord(s)
edit box

Use the up/down buttons or directly edit the number in this
box to set how many Chord Containers will be created in the
automatically created Chord Block when the Chord Block
option is checkmarked.

Text Events
check box

Checkmarking this option causes CAMPS to automatically
create a Text Event and a pair of Markers with a New
Document.



See also:

Setting Default Time Signature
Selecting Objects to Include
Getting Results
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Description of this dialog box

Items in this dialog box

  

Getting
Results

New
button

Click New to close the New Document Setup dialog box, save your New Document default
settings and create a New Document, using your settings.

OK
button

Click OK to close the New Document Setup dialog box and save your New Document default
settings without creating a New Document.

 
 When closing the New Document Setup dialog box with the New or OK buttons, settings

in this dialog box will be saved for future use by the New command in the File menu, or by
CAMPS at startup, when set to Launch with a Blank Document in the Preferences dialog
box.

See also:

Setting Default Time Signature
Selecting Objects to Include

 



New Text Event dialog box  
Contents

Dialog Boxes

  

Description The New Text Event dialog box allows you to select a New Text Event, such as a Rehearsal
Letter or Marker, and insert it in the Text Info Area of your Document.

Uses After selecting a Text Info Area region and opening the New Text Event dialog box, simply click
the button corresponding to the desired Text Event. These Events are for visual reference only,
and do not effect Playback, Recording or any other functions in CAMPS.

  

Items Rehearsal Letter
button

Clicking this button immediately creates a new Text Event in the selected
region of the Text Info Area and closes the New Text Event dialog box.
Double clicking the New Text Event opens an editing mode, allowing you to
change the default phrase "New Text" to whatever you want.

Marker <From>
button

Clicking this button immediately creates a new Text Event with a "starting
point" arrow in the selected region of the Text Info Area and closes the New
Text Event dialog box. Double clicking the New Text Event opens an editing
mode, allowing you to change the default phrase "New Text" to whatever you
want.

Marker <To>
button

Clicking this button immediately creates a new Text Event with an "ending
point" arrow in the selected region of the Text Info Area and closes the New
Text Event dialog box. Double clicking the New Text Event opens an editing
mode, allowing you to change the default phrase "New Text" to whatever you
want.

Cancel
button Closes the New Text Event dialog box without committing changes.

Help
button Opens this Help document.

 



  

Opening From the...
Document Window
Pianoroll Editor
Control Draw Editor
Text List Editor

Select a region in the Text Info Area and choose New Text Event... from
the Edit menu.

  



SMPTE Offset Setup dialog box  
Contents

Dialog Boxes

  

Description The SMPTE Offset Setup dialog box allows you to offset SMPTE synchronization between
CAMPS in slave mode and a master SMPTE device during Playback and Recording.

Uses After opening the SMPTE Offset Setup dialog box, enter the desired Offset Time and click OK.

  

Items Offset Time
edit boxes

Directly edit the numbers in these boxes to specify the exact amount of time
CAMPS Playback or Recording will lag behind the master SMPTE Sync device.
The format is Hours:Minutes:Seconds:Frames.

Reset
button Resets the Offset Time to zero.

Frame Rate
selection box

Click the drop-down list button on the right side of this box to choose the SMPTE
Offset Sync Frame Rate. This setting only reflects how you refer to Offset Time
entered in the Frame Offset Time edit box of this dialog box. During Synchronized
slave operation, CAMPS automatically locks to the SMPTE master's Frame Rate.

OK
button Closes the SMPTE Offset Setup dialog box and commits changes.

Cancel
button Closes the SMPTE Offset Setup dialog box without committing changes.

Help
button Opens this Help document.

 

  

Opening From the...
Document Window
Event List Editor
Pianoroll Editor
Notation Editor
Control Draw Editor
Tempo List Editor
Tempo Draw Editor
Text List Editor

Choose SMPTE Offset Setup... from the Edit menu.

  



Preferences dialog box  
Contents

Dialog Boxes

  

Description The Preferences dialog box allows you to set basic operational and appearance defaults in
CAMPS.

Uses Using the various controls in the Preferences dialog box, you can choose how CAMPS starts and
loads Files, and select Background wallpaper and Button Styling.

  

Items Launch with radio buttons
Loading Standard MIDI File radio buttons
Recent Files edit box
Choose (Background Bitmap) button
Button Style radio buttons
Background Color check box
Change (Background Color) button
Foreground Color check box
Change (Foreground Color) button
Emboss Text check box
OK button
Cancel button
Help button

  

Opening Choose Preferences from the Edit menu.

  



Items in the Preferences dialog box  
Description of this dialog box

Using this dialog box

  

Setting File
defaults

Launch with
radio buttons

Choose whether CAMPS starts with a new Blank
Document or No Document loaded.

Loading Standard MIDI File
radio buttons

Select whether CAMPS loads Standard MIDI Files in
Smart or Quick mode.

Recent Files
edit box

Use the up/down buttons or directly edit the number in this
box to set how many recently opened Files CAMPS lists in
the File menu.

Setting CAMPS
appearance

Choose (Background Bitmap)
button

Use the Choose button to browse for and select a Bitmap
Image File to use as Background wallpaper for the Grid
area in the Document Window and other Editors.

Button Style
radio buttons

Use these radio buttons to choose how the large Buttons
appear in various CAMPS dialog boxes

Background Color
check box

Checkmarking this option allows you to specify the color of
large Buttons in various CAMPS dialog boxes.

Change (Background Color)
button

The Background Color Change button allows you to edit
and select a Color for large Buttons in various CAMPS
dialog boxes.

Foreground Color
check box

Checkmarking this option allows you to specify the color for
the Text of large Buttons in various CAMPS dialog boxes.

Change (Foreground Color)
button

The Foreground Color Change button allows you to edit
and select a Color for the Text of large Buttons in various
CAMPS dialog boxes.

Emboss Text
check box

Checkmarking this option sets the Text for large Buttons in
various CAMPS dialog boxes to appear engraved or 3-D.

Closing OK
button

Closes the Preferences dialog box and commits changes.

Cancel
button

Closes the Preferences dialog box without committing
changes.

Help
button

Opens this Help document.
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Description of this dialog box

Items in this dialog box

  

Setting File
Defaults

Launch with
radio buttons

Use these radio buttons to choose whether CAMPS starts with a
new Blank Document or No Document loaded. When Launching
CAMPS with a new Blank Document, the new Document will be
created as specified in the New Document Setup dialog box. Upon
opening the Preferences dialog box, current settings will be
displayed.

Loading Standard MIDI File
radio buttons

Choosing Smart sets CAMPS to analyze a Standard MIDI File's
Track Line data for Line Block preparation for use with Harmonize
and Compose functions in CAMPS. The main effect of this is the
separation of Line data into phrases. CAMPS starts a new Line
Block when it reaches a Note that doesn't span into the next Bar.
While Line Blocks may still require finer adjustments with the
Razor tool or Merge Line Block command to obtain desired
results, initial setup will be closer to what's required to immediately
begin applying CAMPS unique features to a newly loaded
Standard MIDI File.

Choosing Quick sets CAMPS to load a Standard MIDI File in its
original form without extra analysis. Each Track's Line data is
prepared as one continuous Line Block without regard for musical
Category or Bar separation or Notes that don't overlap Bars.

Upon opening the Preferences dialog box, current settings will be
displayed.

Recent Files
edit box

Use the up/down buttons or directly edit the number in this box to
set how many recently opened Files CAMPS lists in the File menu
for quick access when reopening. This list appears in the bottom
of the File drop-down menu. Upon opening the Preferences dialog
box, current settings for this will be displayed.

 

 

See also:

Setting CAMPS Appearance
Getting Results
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Description of this dialog box

Items in this dialog box

  

Setting CAMPS
Appearance

Choose (Background Bitmap)
button

Use the Choose button to browse for and select a Bitmap
Image File to use as Background wallpaper for the Grid
area in the Document Window and other Editors using the
Microsoft Windows Open dialog box. Your selection here
can then be activated with the Background Bitmap option
in the CAMPS View menu. Current settings will be
displayed to the left of the Choose button.

 Bitmap Files have the Windows Filename Extension
"BMP".

 If the File you choose here gets deleted or moved, the
Background Bitmap option in the View menu will be
unavailable until a new Bitmap Image File is specified.

Button Style
radio buttons

Use these radio buttons to choose how the large Buttons
appear in various CAMPS dialog boxes. Four different
Styles are offered. Upon opening the Preferences dialog
box, current settings will be displayed.

Background Color
check box

Checkmarking this option allows you to specify the color of
large Buttons in various CAMPS dialog boxes. A
Checkmark here also enables the Background Color
Change button. Upon opening the Preferences dialog box,
current settings will be displayed.

Change (Background Color)
button

The Background Color Change button allows you to edit
and select a Color for large Buttons in various CAMPS
dialog boxes using the Microsoft Windows Color dialog
box. Upon opening the Preferences dialog box, current
settings will be displayed.

Foreground Color
check box

Checkmarking this option allows you to specify the color for
the Text of large Buttons in various CAMPS dialog boxes.
A Checkmark here also enables the Foreground Color
Change button. Upon opening the Preferences dialog box,
current settings will be displayed.

Change (Foreground Color)
button

The Foreground Color Change button allows you to edit
and select a Color for the Text of large Buttons in various
CAMPS dialog boxes using the Microsoft Windows Color
dialog box. Upon opening the Preferences dialog box,
current settings will be displayed.

Emboss Text
check box

Checkmarking this option sets the Text for large Buttons in
various CAMPS dialog boxes to appear engraved or 3-D.
Upon opening the Preferences dialog box, current settings
will be displayed.



 

 

See also:

Setting File Defaults
Getting Results
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Description of this dialog box

Items in this dialog box

  

Getting
Results

OK
button

Click OK when you have achieved the desired results. This closes the Preferences dialog
box and applies your settings to all applicable areas in CAMPS.

 Background Bitmap settings only take effect after the Background Bitmap option in the
View menu is selected. Choosing a new Background Bitmap Image automatically inserts it in
whichever CAMPS Windows or Editors for which this option has been activated.

See also:

Setting File Defaults
Setting CAMPS Appearance

 



Quantize dialog box  
Contents

Dialog Boxes

  

Description The Quantize dialog box allows you to automatically correct the start time of Notes on an
individual or Line Block basis by aligning or "snapping" them to a user-definable virtual correction
Grid of perfectly spaced points.

Uses There are several ways to set the Grid resolution and Grid point arrangement for time correction,
including Tuplet timing.

Additionally, there are three "feel" adjustments which allow you to smooth out that mechanical
tendency of computer-generated music while still maintaining accurate Beat alignment of Notes.

Using the Playback buttons, you can then audition Quantize adjustments and select one that
sounds good to you.

  

Items Grid Resolution radio buttons
Tuplet selection box
Swing slider
Swing edit box
Offset slider
Offset edit box
Humanize slider
Humanize edit box
Playback button
Playback with Others button
Stop button
OK button
Cancel button
Help button

  



Opening From the...
Document Window
Event List Editor
Pianoroll Editor
Notation Editor

Choose Quantize... from the Line menu.
Alternatively, right-click desired Line data and choose Actions, Quantize...

 When choosing Quantize... from the Line menu, Line data must first be selected, otherwise
the Quantize... item won't be available.

  



Items in the Quantize dialog box  
Description of this dialog box

Using this dialog box

  

Setting
Quantize
Resolution

Grid Resolution
radio buttons

Sets the Quantize Grid Resolution to multiples or
divisions of current Beats per Bar or absolute Note
Lengths.

Tuplet
selection box

Replaces each Beat per Bar with a string of evenly
spaced faster beats in odd amounts.

Adjusting
Feel

Swing
slider

Click and drag this slider to the left for Swing timing
more ahead of Beats, or to the right for Swing timing
more behind Beats.

Swing
edit box

Use the left/right buttons or directly edit the number in
this box to add Swing timing ahead of or behind Beats.

Offset
slider

Click and drag this slider to the left to evenly shift Note
start times more ahead of Beats, or to the right to
evenly shift Note start times more behind Beats.

Offset
edit box

Use the left/right buttons or directly edit the number in
this box to evenly shift Note start times more ahead of
or more behind Beats.

Humanize
slider

Click and drag this slider to the left for Tighter (more
exact) timing, or to the right for Looser (more
fluctuating) timing.

Humanize
edit box

Use the left/right buttons or directly edit the number in
this box for Tighter (more exact) or Looser (more
fluctuating) timing.

Auditioning  Playback Click the Playback (Single Speaker) button to listen to
Quantize adjustments as you make them.

 Playback with Others Click the Playback with Others (Double Speaker)
button to listen to Quantize adjustments you make
along with all the other activated Tracks.

 Stop Click the Stop (No Speaker) button to stop Playback.

Closing OK
button

Closes the Quantize dialog box and commits changes.

Cancel
button

Closes the Quantize dialog box without committing
changes.

Help
button

Opens this Help document.
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Description of this dialog box

Items in this dialog box

  

Setting
Quantize
Resolution

Grid Resolution
radio buttons

After selecting Note data to Quantize and opening the Quantize dialog box, set
the Quantize Grid Resolution for the desired Note start time correction.

The top row of radio buttons allows you to adjust Quantize Grid Resolution by
multiples or divisions of original Beats per Bar from 2X (less resolution) to 1/8
(more resolution).

The second row of radio buttons allows you to adjust Quantize Grid Resolution
by absolute Note time values from 1/2 Notes (less resolution) to 1/32 Notes
(more resolution), regardless of Time Signature.

Tuplet
selection box

Tuplet timing actually further divides the virtual Quantize Grid into 3, 5, or 7
smaller divisions per Beat. Another way to think of this is "overlaying" odd
numbers of faster, evenly spaced Beats on each Beat per Bar. Click the
drop-down button on the right side of this box to select one of three types of
Tuplet resolution:

Triplets divides each Beat per Bar into 3 smaller, evenly spaced divisions.
Quintuplets divides each Beat per Bar into 5 smaller, evenly spaced divisions.
Septuplets divides each Beat per Bar into 7 smaller, evenly spaced divisions.
Select (None) if no Tuplet timing is desired.

 CAMPS resolves Quarter Notes to 480 divisions.

 

See Also:

Adjusting Feel
Getting Results
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Description of this dialog box

Items in this dialog box

  

Adjusting
Feel

Swing
adjustment
area

The Swing adjustment allows you to add the special rhythmic quality of Swing to
selected Line data by "sliding" every other (even numbered) Quantize Grid point away
from original equidistant locations. For the purpose of musical practicality, the Swing
adjustment sets the degree to which even numbered Beats are shifted out of evenly
spaced alignment in a range of -50% ahead of perfect alignment to 50% behind
perfect alignment. Leaving Swing set to "0" leaves Beats perfectly evenly spaced.
Use the Swing slider or edit box to adjust Quantize Swing. Dragging the slider to the
left or entering a lower number in the box Swings Notes ahead of the Beat, while
dragging the slider to the right or entering a higher number in the box Swings Notes
being behind the Beat.

Offset
adjustment
area

The Offset adjustment allows you to make selected Line data "Lead" or "Lag" other
Tracks by evenly shifting all Quantize Grid points away from original locations. For the
purpose of musical practicality, the Offset adjustment sets the amount of Beat shift in a
range of -240 divisions to 240 divisions. Leaving Offset set to "0" leaves Beats
perfectly aligned with the Quantize Grid.
Use the Offset slider or edit box to adjust Quantize Offset. Dragging the slider to the
left or entering a smaller number in the box or results in Notes being shifted ahead of
the Beat, while dragging the slider to the right or entering a bigger number in the box
results in Notes being shifted behind the Beat.

Humanize
adjustment
area

When Line data's Note starting points are Quantized, they are distributed evenly or
systematically (which is the purpose of Quantizing). Consequentially, when you hear
the results, it can have a stiff or mechanical feeling to it. The Humanize adjustment
adds a fluctuating quality, similar to the feel of time that varies from one musician to
another. This function has been added to CAMPS in an attempt to help you Humanize
your MIDI songs. For the purpose of musical practicality, the Humanize adjustment
sets the amount of fluctuating Beat shift in a range of 0% to 50%. Leaving Humanize
set to "0" leaves Beats perfectly aligned with the Quantize Grid.
Use the Humanize slider or edit box to Humanize the time performance of you MIDI
data. Drag the slider to the left or enter a lower number in the box for Tighter (more
exact) timing. Drag the slider to the right or enter a higher number in the box for
Looser (more fluctuating) timing.

 CAMPS resolves Quarter Notes to 480 divisions.

 



See Also:

Setting Quantize Resolution
Getting Results
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Items in this dialog box

  

Getting
Results

Playback,
Playback with Others,
Stop
buttons

Each time you make Quantize adjustments, the selected Line
data is temporarily replaced.

Click the Playback (Single Speaker) button to hear the results of
Quantize processing in "Solo" mode. This Auditioning mode will
include any existing Chords if the Chord Track Play button in the
Track Area of the Document Window is activated.

Click the Playback with Others (Double Speaker) button to hear the

results of Quantize processing along with all the other activated
Tracks.

Once either Playback button is clicked, CAMPS will repeat (Loop) Playback
of selected Line data with current Quantize adjustments as you make them,
until you click the Stop (No Speaker) button. With this feature, you can
change and listen to different Quantize adjustments "on the fly" or one by
one.

OK
button

Click OK when you have achieved the desired results. This
closes the Quantize dialog box and replaces the selected Line
data.

 MIDI Control Events such as Pitch Bend and After Touch data are
proportionally moved along with original Note Pitch and Length when
correcting Note start time.

 Changing the start time of Note data may cause Notes to overlap. As
always, when Notes overlap you may encounter some unexpected MIDI
performance.

 

See Also:

Setting Quantize Resolution
Adjusting Feel

 



Take List dialog box  
Contents

Dialog Boxes

  

Description The Take List dialog box allows you to create, insert and audition New Takes with or without
automatically generated Line data. Takes are different versions of a given Line Block. Except for
Notes in the Line data, Length and other attributes are the same as the original.

Uses After selecting the desired Line Block and opening the Take List dialog box, specify a Take
Name or select an existing Take.

Using the Playback buttons, you can then audition results and select one that sounds good to
you.

  

Items Name edit box
Take scroll area
Duplicate button
Remove button
New button
Playback button
Playback with Others button
Stop button
OK button
Cancel button
Help button

  



Opening From the...
Document Window
Event List Editor
Pianoroll Editor
Control Draw Editor
Notation Editor

Select desired Line Block and choose Take List... from the Take
submenu of the Line menu. Alternatively, right-click desired Line Block
and choose Take, Take List....

 When choosing Take List... from the Take submenu of the Line menu, you must first have
selected a Line Block, otherwise the Take List... item won't be available.

  



Items in the Take List dialog box  
Description of this dialog box

Using this dialog box

  

Managing
Takes

Name
edit box

Use the Name edit box to edit the Name of the currently selected
Take.

Take
scroll area

Use the Take scroll area to select desired Take. As you create
New Takes, they are added to this list.

Duplicate
button

Creates a Copy of the currently selected Take.

Remove
button Deletes the currently selected Take.

New
button

Clicking New opens the New Take dialog box. You can then create
a New Take, with or without automatically generated Line data.

Auditioning  Playback Click the Playback (Single Speaker) button to listen to the
currently selected Take.

 Playback with Others Click the Playback with Others (Double Speaker) button to listen
to the currently selected Take along with all the other activated
Tracks.

 Stop Click the Stop (No Speaker) button to stop Playback.

Closing OK
button

Closes the Take List dialog box and activates the currently
selected Take.

Cancel
button

Closes the Take List dialog box without changing Takes.

Help
button

Opens this Help document.
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Managing
Takes

Overview Takes are different versions of a given Line Block. Except for MIDI Events in the Line
data, Length and other attributes are the same as the original. This allows you to store
and choose between alternate performances of a particular Line Block.

While a given location in the Line Area can contain multiple Line Blocks, Takes are
stored in the "background" of each individual Line Block. If you delete a Line Block, all
of its Takes will also be deleted.

Name
edit box

Use the Name edit box to edit the Name of the currently selected Take. This field is
automatically filled-in with a temporary Name when creating New or Duplicate Takes.

Take
scroll area

Use the Take scroll area to select desired Take. As you create New or Duplicate
Takes, they are added to this list and become the currently selected Take.

Duplicate
button

Creates a Copy of the selected Take. This Copy then becomes the selected Take,
with its designation in the Name edit box initially entered as "[Name] Copy". As with
any Take Name, this can be edited whenever selected.

Remove
button

Deletes the currently selected Take. CAMPS will not allow you to Remove the last
remaining Take for any Line Block.

New
button

Clicking New opens the New Take dialog box. You can then create a New Take, with
or without automatically generated Line data. See the New Take or New Take (for
Drums) documentation for details.

 

See also:

Getting Results
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Getting
Results

Playback,
Playback with Others
and
Stop
buttons

Click the Playback (Single Speaker) button to hear a selected Take in
"Solo" mode. This Auditioning mode will include any existing Chords if the
Chord Track Play button in the Track Area of the Document Window is
activated.

Click the Playback with Others (Double Speaker) button to hear a Take
along with all the other activated Tracks.

Once either Playback button is clicked, CAMPS will repeat (Loop) Playback
of Takes as you select them, until you click the Stop (No Speaker) button.
With this feature, you can change and listen to different Takes "on the fly" or
one by one.

OK
button

Click OK when you have achieved the desired results. This closes the Take
List dialog box and activates the currently selected Take.

 

See Also:

Managing Takes

 



New Take dialog box  
Contents

Dialog Boxes

  

Description The New Take dialog box allows you to create and insert New Takes with or without
automatically generated Line data. Takes are different versions of a given Line Block. Except for
Notes in the Line data, Length and other attributes are the same as the original.

Uses After selecting the desired Line Area and opening the New Take dialog box, specify a Take
Name. Checkmarking the EZgenerate Line Data option causes CAMPS to create Line data with
the New Take, and enables the Rhythm radio buttons for adjusting the EZgenerated Line data's
rhythmic tendencies.

  

Items Take Name
edit box

Upon opening the New Take dialog box, this field is automatically filled
in with the phrase "Take #", where "#" equals the next unused number
above the current quantity of Takes for the currently selected Line Block.
You can leave this designation, or replace it with a Name of your choice.

EZgenerate Line Data
check box

Checkmarking this option causes CAMPS to automatically generate
Line data in your New Line Block. It also enables the Rhythm radio
buttons.

 EZgenerated Line data is created in the context of Harmony defined
by Chord Blocks in the same Bar region as the New Take being created.

 If no Chords are defined in the Bar region where a New Take is
being created, EZgenerated Line data will most likely not fit your
composition; sounding totally "outside" or even quite unpleasant.

Rhythm
radio buttons

When enabling the EZgenerate Line Data option, use these radio
buttons to adjust the rhythmic complexity of EZgenerated Line data.

New
button Closes the New Take dialog box and creates the New Take you specify.

Cancel
button Closes the New Take dialog box without creating a New Take.

Help
button Opens this Help document.

 

  



Opening From the...
Document Window
Event List Editor
Pianoroll Editor
Control Draw Editor
Notation Editor

There are 2 versions of this dialog box. This one appears for Tonal Line
Blocks (any Line Block except those in the Drums Category). After
selecting a Line Block, choose New Take... from the Take submenu of the
Line menu. Alternatively, right-click desired Line Block and choose Take,
New Take....

 When choosing New Take... from the Take submenu of the Line menu, you must first have
selected a Line Block, otherwise the New Take... item won't be available.

  



New Take dialog box  
Contents

Dialog Boxes

  

Description The New Take dialog box allows you to create and insert New Takes with or without
automatically generated Line data. Takes are different versions of a given Line Block. Except for
Notes in the Line data, Length and other attributes are the same as the original.

Uses After selecting the desired Drums Line Area and opening the New Take dialog box, specify a
Take Name. Checkmarking the EZgenerate Line Data option causes CAMPS to create Line
data with the New Take. This also enables the Rhythm and Instrument controls, allowing you to
adjust rhythmic tendencies, and Percussion Instrumentation of EZgenerated Line data.

  

Items Take Name
edit box

Upon opening the New Take dialog box, this field is automatically filled
in with the phrase "Take #", where "#" equals the next unused number
above the current quantity of Takes for the currently selected Line Block.
You can leave this designation, or replace it with a Name of your choice.

EZgenerate Line Data
check box

Checkmarking this option causes CAMPS to automatically generate
Line data in your New Line Block. It also enables the Rhythm radio
buttons, Instruments selection box, Instrument Settings display and
Reassign To selection box.

Rhythm
radio buttons

When enabling the EZgenerate Line Data option, use these radio
buttons to adjust the rhythmic complexity of EZgenerated Line data.

Instruments
selection box

When enabling the EZgenerate Line Data option, you can use this
selection box to choose Percussion Instruments included in the
EZgenerated Line data.

Instrument Settings
display

When enabling the EZgenerate Line Data option, this area displays
Percussion Instruments to be included in the EZgenerated Line data, as
selected in the Instruments selection box.

Reassign To
selection box

When enabling the EZgenerate Line Data option, you can use this
selection box to reMap MIDI Keys of Percussion Instruments (Sounds)
selected in the Instruments selection box.

New
button

Closes the New Take dialog box and creates the New Takes you
specify.

Cancel
button Closes the New Take dialog box without creating a New Take.

Help
button Opens this Help document.



 

  

Opening From the...
Document Window
Event List Editor
Pianoroll Editor
Control Draw Editor
Notation Editor

There are 2 versions of this dialog box. This one appears for Line Blocks
in the Drums Category. After selecting a Line Block in the Drums
Category, choose New Take... from the Take submenu of the Line menu.
Alternatively, right-click desired Line Block in the Drums Category and
choose Take, New Take....

 When choosing New Take... from the Take submenu of the Line menu, you must first have
selected a Line Block, otherwise the New Take... item won't be available.

  



Value Adjustment dialog box  
Contents

Dialog Boxes

  

Description The Value Adjustment dialog box allows you to adjust the value of selected MIDI Events.

Uses The function of this dialog box changes depending on the type of MIDI Event or Editor you are
working with.

As you make Adjustments, use the Playback buttons to audition results and select settings that
sound good to you.

  

Items Relative radio button
Offset radio button
Absolute radio button
[Value Adjustment] slider
[Value Adjustment] edit box
Playback button
Playback with Others button
OK button
Cancel button
Help button

  

Opening From the...
Event List Editor
Control Draw Editor
Tempo List Editor
Tempo Draw Editor

Choose Adjust Value... from the Line menu.
Alternatively, right-click desired MIDI Event and choose Actions, Adjust
Value....

  



Items in the Value Adjustment dialog box  
Dialog Boxes

Description of this dialog box

  

Adjusting value
of MIDI Event

Relative
radio button

Sets the Value Adjustment edit box to display a relative
percentage of change from 0-200% as adjustments are made.
This might be useful for adjusting Events like After Touch.

Offset
radio button

Sets the Value Adjustment edit box to display an offset of the
current absolute value, where the initial displayed value before
adjustment is "0" and adjusting down displays a negative
number, while adjusting up displays a positive number. This
might be useful for adjusting Events like Volume.

Absolute
radio button

Sets the Value Adjustment edit box to display the actual Event
value (typically 0-127) as adjustments are made. This might be
useful for adjusting Events like Program Change (Patch)
number.

[Value Adjustment]
slider

The name and function of this slider changes depending on
the type of MIDI Event or Editor you are working with. For
example, if the Event List Editor is active and you select a
Program Change Event, this slider changes the Program
(Patch) number associated with the currently selected
Program Change Event.

[Value Adjustment]
edit box

The name and function of this edit box changes depending on
the type of MIDI Event or Editor you are working with. For
example, if the Event List Editor is active and you select a
Program Change Event, changing the number in this edit box
changes the Program (Patch) number associated with the
currently selected Program Change Event.

Auditioning  Playback Click the Playback (Single Speaker) button to listen to the
current Value Adjustment.

 Playback with Others Click the Playback with Others (Double Speaker) button to
listen to the current Value Adjustment along with all the other
activated Tracks.

 Stop Click the Stop (No Speaker) button to stop playback.

Closing OK
button

Closes the Value Adjustment dialog box and commits
changes.

Cancel
button

Closes the Value Adjustment dialog box without committing
changes.

Help
button

Opens this Help document.



 

  



Time Signature Setup dialog box  
Contents

Dialog Boxes

  

Description The Time Signature Setup dialog box allows you to set MIDI Time Signature values for different
parts of your song.

Uses After opening the Time Signature Setup dialog box, select the Bar in your song where you want
the specified Time Signature to start. Then simply edit the Notes per Bar (Numerator) and Beat
Note Type (Denominator) fields.

  

Items Bar edit box
Time Signature edit boxes
OK button
Cancel button
Apply button
Help button

  

Opening From the...
Document Window
Pianoroll Editor
Control Draw Editor
Notation Editor
Tempo Draw Editor

Choose Time Signature Setup... from the Edit menu.
Alternatively, right-click desired Bar Area and choose Time Signature
Setup....

 When choosing Time Signature Setup..., you must first have opened a Document,
otherwise the Time Signature Setup... item won't be available.

  



Items in the Time Signature Setup dialog box  
Description of this dialog box

Using this dialog box

  

Setting
Time Signature

Bar
edit box

Use the left/right buttons or directly edit the number in this box to choose
the Bar number from which you want your Time Signature settings to take
effect.

Time Signature
edit boxes

Use the up/down buttons or directly edit the numbers in the Beats per Bar
(Numerator) and Beat Note Type (Denominator) edit boxes to enter desired
Time Signature.

Closing OK
button

Closes the Time Signature Setup dialog box and commits changes.

Cancel
button

Closes the Time Signature Setup dialog box without committing changes.

Apply
button Commits changes without closing the Time Signature Setup dialog box.

Help
button

Opens this Help document.

 

  



Using the Time Signature Setup dialog box  
Description of this dialog box

Items in this dialog box

  

Setting
Time Signature

Bar
edit box

Enter the Bar number from which you want your Time Signature settings to
take effect. To set the Time Signature for a whole song, enter "1" here.

If you need a Time Signature change somewhere in your song, enter the
Bar number where the change starts and set the Numerator and
Denominator fields accordingly.

To return to a previous Time Signature in a song, enter the Bar number
where the original Time Signature returns and set the Numerator and
Denominator fields accordingly.

 

Time Signature
edit boxes

The Time Signature area of the Time Signature Setup dialog box exactly
mimics the Notation form of Time Signature. Simply enter appropriate
numbers in the Beats per Bar (Numerator) and Beat Note Type
(Denominator) edit boxes to set desired Time Signature.

Valid numbers for Beat Note Type (bottom Denominator field) include:
1 -Whole Note
2 -Half Note
4 -Quarter Note
8 -Eighth Note
16 -Sixteenth Note
32 -Thirty Second Note
64 -Sixty Forth Note

 

See Also:

Getting Results

 



Using the Time Signature Setup dialog box  
Description of this dialog box

Items in this dialog box

  

Getting
Results

OK
button

When you've finished Setting Time Signature values, Click OK to close the Time Signature
dialog box and write your settings to the current Document.

 
 Time Signature settings primarily effect the MIDI Clock. Changes in Time Signature also

effect the Bar Grid, and the Metronome and Recording/Preroll functions. Matching settings
must be made in the New Chord or New Chord Block Setup dialog boxes to have newly
created Chord Blocks automatically fit into a Time Signature's resulting Bar Grid. The Grid
View menu's Align To Grid command can also be helpful.

 Making Time Signature changes in a song that already has Line or Chord data will not
change that data in any way. However, you can drag Chord Blocks to align them with a new
Bar Grid and add or delete Chord Containers to match new Time Signatures. Additionally,
Quantize settings may need to be adjusted.

 

See Also:

Setting Time Signature

 



Transpose dialog box  
Contents

Dialog Boxes

  

Description The Transpose Dialog Box allows you to shift the Pitch of all selected Notes equally.

Uses Upon opening the Transpose dialog box, CAMPS displays the current relative Note Range and
MIDI Pitch values of the selected Line data.

Use the Transpose slider or edit box to Transpose currently selected Line data up or down by
Half Steps (Chromatic Intervals; Semitones).

Using the Playback buttons, you can then audition different Transposition settings and select
one that sounds good to you.

  

Items Transpose slider
Transpose edit box
Note Range displays
Pitch Value displays
Playback button
Playback with Others button
Stop button
OK button
Cancel button
Help button

  



Opening From the...
Document Window
Event List Editor
Pianoroll Editor
Notation Editor

Choose Transpose... from the Line menu.
Alternatively, right-click desired Line data and choose Actions,
Transpose....

 When choosing Transpose... from the Line menu, you must first have selected Line data,
otherwise the Transpose... item won't be available.

  



Items in the Transpose dialog box  
Description of this dialog box

Using this dialog box

  

Transposing Transpose
slider

Click and drag this slider down to Transpose selected Notes
down, or up to Transpose selected Notes up.

Transpose
edit box

Use the up/down buttons or directly edit the Chromatic Interval
value in this box to Transpose Notes.

Note Range
displays

These display areas show the upper and lower Note range of the
Line data currently being Transposed.

Pitch Value
displays

These display areas show the MIDI Pitch values of the upper and
lower Note range.

Auditioning  Playback Click the Playback (Single Speaker) button to listen to
Transposition adjustments as you make them.

 Playback with Others Click the Playback with Others (Double Speaker) button to
listen to Transposition Adjustments you make along with all the
other activated Tracks.

 Stop Click the Stop (No Speaker) button to stop Playback.

Closing OK
button

Closes the Transpose dialog box and commits changes.

Cancel
button

Closes the Transpose dialog box without committing changes.

Help
button

Opens this Help document.

 

  



Using the Transpose dialog box  
Description of this dialog box

Items in this dialog box

  

Transposing Transpose
slider,
edit box

Click and drag this slider down to Transpose selected Notes down, or up to
Transpose selected Notes up. Alternatively, use the up/down buttons or directly
edit the Half Step (Chromatic Interval; Semitone) value in the Transpose edit box
to Transpose Notes.

Note Range,
Pitch Value
displays

These display areas above and below the Transpose edit box show the upper
and lower Note Range and corresponding MIDI Pitch values of the selected Line
data with respect to the Note currently being Transposed and its current
Transposition setting. Referring to these displays while adjusting Transposition
will help you keep in mind where the highest and lowest Notes in the Line data
you are Transposing will end up. As well, they give quick indication of how close
you're getting to MIDI Pitch range limits (0-127).

 

 

See also:

Getting Results

 



Using the Transpose dialog box  
Description of this dialog box

Items in this dialog box

  

Getting
Results

Playback,
Playback with Others,
Stop
buttons

Each time you make Transposition Adjustments, the selected
Line data is temporarily replaced.

Click the Playback (Single Speaker) button to hear the results of
Transposition processing in "Solo" mode. This Auditioning mode
will include any existing Chords if the Chord Track Play button in
the Track Area of the Document Window is activated.

Click the Playback with Others (Double Speaker) button to hear the

results of Transposition processing along with all the other activated
Tracks.

Once either Playback button is clicked, CAMPS will repeat (Loop) Playback
of selected Line data with current Transposition Adjustments as you make
them, until you click the Stop (No Speaker) button. With this feature, you
can change and listen to different Transposition Adjustments "on the fly" or
one by one.

OK
button

Click OK when you have achieved the desired results. This
closes the Transpose dialog box and replaces the selected Line
data.

 

See Also:

Transposing

 



Velocity Adjustment dialog box  
Contents

Dialog Boxes

  

Description The Velocity Adjustment dialog box allows you to change the loudness of Notes on an individual
or Line Block basis.

Uses There are three ways to specify the Velocity of Note data in the Velocity Adjustment dialog box;
Relative, Offset and Absolute. Which ever mode you use, setting the Note Velocity lower results
in softer (more Piano) Notes, while setting it higher results in louder (more Forte) Notes.

Using the Playback buttons, you can then audition Velocity Adjustments and select one that
sounds good to you.

  

Items Relative radio button
Offset radio button
Absolute radio button
Note Velocity slider
Note Velocity edit box
Playback button
Playback with Others button
Stop button
OK button
Cancel button
Help button

  



Opening From the...
Document Window
Event List Editor
Pianoroll Editor
Notation Editor

Choose Adjust Velocity... from the Line menu.
Alternatively, right-click desired Line data and choose Actions, Adjust
Velocity...

 When choosing Adjust Velocity... from the Line menu, Line data must first be selected,
otherwise the Adjust Velocity... item won't be available.

  



Items in the Velocity Adjustment dialog box  
Description of this dialog box

Using this dialog box

  

Selecting an
Adjustment
Mode

Relative
radio button

Sets the Velocity adjustment to render a relative percentage of
the original Note Velocity.

Offset
radio button

Sets the Velocity adjustment to increase or decrease degrees of
original Note Velocity MIDI value.

Absolute
radio button

Sets the Velocity adjustment to use an absolute MIDI value to
adjust original Note Velocity.

Adjusting
Velocity

Note Velocity
slider

Click and drag this slider down for softer (more Piano) notes, or
up for louder (more Forte) notes.

Note Velocity
edit box

Use the up/down buttons or directly edit the Velocity value in this
box to change Note loudness .

Auditioning  Playback Click the Playback (Single Speaker) button to listen to Velocity
Adjustments as you make them.

 Playback with Others Click the Playback with Others (Double Speaker) button to
listen to Velocity Adjustments you make along with all the other
activated Tracks.

 Stop Click the Stop (No Speaker) button to stop Playback.

Closing OK
button

Closes the Velocity Adjustment dialog box and commits changes.

Cancel
button

Closes the Velocity Adjustment dialog box without committing
changes.

Help
button

Opens this Help document.

 

  



Using the Velocity Adjustment dialog box  
Description of this dialog box

Items in this dialog box

  

Adjusting
Velocity

Relative,
Offset,
Absolute
radio buttons

After selecting Note data to adjust and opening the Velocity Adjustment dialog box,
Choose an adjustment mode. There are three modes for specifying the Velocity of
Note data in the Velocity Adjustment dialog box.

Relative ...Sets a relative percentage of the original Notes' Velocity from 0% (none)
to 200% (double).
Offset ...Sets change of Velocity by degrees, based on the range of MIDI Velocity
values in the currently selected region of Line data.
Absolute ...Uses an absolute MIDI value (0-127) to set the Velocity of all selected
Notes.

Note
Velocity
adjustment
area

Next, use the Note Velocity slider or edit box to adjust Velocity. Dragging the slider
down or entering a smaller number in the box results in softer (more Piano) Notes,
while dragging the slider up or entering a bigger number in the box results in louder
(more Forte) Notes.

 

See Also:

Getting Results

 



Using the Velocity Adjustment dialog box  
Description of this dialog box

Items in this dialog box

  

Getting
Results

Playback,
Playback with Others,
Stop
buttons

Each time you make Velocity Adjustments, the selected Line
data is temporarily replaced.

Click the Playback (Single Speaker) button to hear the results of
Velocity processing in "Solo" mode. This Auditioning mode will
include any existing Chords if the Chord Track Play button in the
Track Area of the Document Window is activated.

Click the Playback with Others (Double Speaker) button to hear the

results of Velocity processing along with all the other activated Tracks.

Once either Playback button is clicked, CAMPS will repeat (Loop) Playback
of selected Line data with current Velocity Adjustments as you make them,
until you click the Stop (No Speaker) button. With this feature, you can
change and listen to different Velocity Adjustments "on the fly" or one by
one.

OK
button

Click OK when you have achieved the desired results. This
closes the Velocity Adjustment dialog box and replaces the
selected Line data.

 

See Also:

Adjusting Velocity

 



Voicing dialog box  
Contents

Dialog Boxes

  

Description In the Voicing dialog box, CAMPS automatically analyzes the selected Note data along with
relevant Chords to provide you with various kinds of Voicings for your Line data.

Uses Selecting several Notes of Line data at a time is possible for Voicing. After selecting appropriate
Line data from the Pianoroll or Notation Editor and opening the Voicing Dialog box, you can
select Voicing Modes, Harmonic Tensions, and quantity of Voices to be used for each Lead
Note's Voicing results. It is also possible to alter the original Lead Note to change a Voicing's
Register from within the Voicing dialog box. To obtain Voicings that do not fall within the context
of a Lead Note's Chord assignment, a provision is made to temporarily alter a Lead Note's
current Chord assignment.

Using the Playback buttons, you can then audition results and select one that sounds good to
you.

  

Items Voicing Parameters scroll area
Lead Note edit box
Location display
Voicings scroll area
Absolute Pitch radio button
Scale Spelling radio button
Playback button
Playback with Others button
Stop button
OK button
Cancel button
Help button

  



Opening From the...
Pianoroll Editor
Notation Editor

Choose Voicing... from the Line menu.
Alternatively, right-click desired Line data and choose Actions, Voicing....

 When choosing Voicing... from the Line menu, you must first have selected Line data,
otherwise the Voicing... item won't be available.

 The Voicing feature is not available when the selected Track's Category is Drums.

  



Items in the Voicing dialog box  
Description of this dialog box

Using this dialog box

  

Adjusting Voicings Voicing Parameters
scroll area

Here you can set Harmonic Tension, Voicing Mode and
Voice Quantity. Additionally, The Voicing Parameters scroll
area also provides a Chord reharmonizing button so you
can temporarily change the Harmony CAMPS references
during Voicing analysis to yield different results.

Lead Note
edit box

Use the up/down buttons or directly edit the Note in this
box to change a Voicing's Lead (Top) Note. This directly
effects a Voicing's register.

Location
display

The Location display shows song Location of the Line data
being voiced. The display format is:
"Beginning Bar:Beat:Divisions...Ending Bar:Beat:Divisions
(Length in Divisions)".

Choosing Voicings Voicings
scroll area

Voicing results are displayed here, listing a Voicing's Notes
from top to bottom. Select a desired Voicing from this scroll
area.

Viewing Voicings Absolute Pitch
radio button

Sets the display of Notes in the Voicings scroll area to
actual Note names.

 Scale Spelling
radio button

Sets the display of Notes in the Voicings scroll area to
Scale Intervals.

Auditioning  Playback Click the Playback (Single Speaker) button to listen to the
selected Voicing.

 Playback with Others Click the Playback with Others (Double Speaker) button
to listen to the selected Voicing along with all the other
activated Tracks.

 Stop Click the Stop (No Speaker) button to stop Playback.

Closing OK
button

Closes the Voicing dialog box and commits changes.

Cancel
button

Closes the Voicing dialog box without committing changes.

Help
button

Opens this Help document.



 

  



Using the Voicing dialog box  
Description of this dialog box

Items in this dialog box

  

Using the
Voicing Parameters
scroll area

Overview CAMPS supports all typical Voicing techniques including Closed,
Drop 2, Spread U.S.T.,and others, with or without Harmonic
Tensions and with different Voice quantities. Depending on how
the Lead Note you've selected relates to the currently assigned
Chord and current Register for its region, certain techniques,
Voice quantities and Voicings will not be available. Fewer
techniques will be available when voicing a Lead Note that spans
more than one Chord.

 Lead Note
display column

The Lead Note display column simply displays a sequence
number for each Lead Note selected for Voicing... "1" for "First";
"2" for "Second", etc. Use this column or the areas between
columns in the Voicing Parameters scroll area to select which
Lead Note will be Voiced.

 Chord
button/display column

The Chord column shows the assigned Chord for the Lead Note
that will undergo Voicing. When selecting a Lead Note which is
neither a Chord Tone nor a valid Tension Note of its Chord, no
techniques will be available. In this case, you can temporarily
assign a different Chord by clicking the Lead Note's Chord
button and selecting "Reharmonize..." from the drop-down
menu. If no Chord is assigned, Voicing will not be possible.

 Harmonic Tension
check box column

Checkmark the Harmonic Tension check box for the Note being
Voiced when you want to include a Harmonic Tension Note in its
Voicing. Depending on other Voicing settings, a Harmonic
Tension may already exist in the current Voicing, rendering this
check box ineffective. On the other hand, if you wish to
manipulate Voicing Modes and Voices (quantity) while
maintaining Harmonic Tension assignment, leave this check box
selected. In this case, certain Voicing Mode and Voices
selections may yield less alternate results.

 Voicing Mode
selection box column

Using the drop-down button, select a Voicing technique from a
Lead Note's Voicing Mode selection box. Depending on the Lead
Note's current Chord and Register, different choices will be
available here. Voicing techniques involve Scale Interval choices
and their placement (order) from bottom to top. Their names
directly reflect these factors.

 Voices
selection box column

After choosing a Voicing Mode, the theoretically possible number
of Voices appears in the Voices selection box. Using the
drop-down button, select desired quantity of Voices from a Lead
Note's Voices selection box and CAMPS will show available
Voicing results in the Voicings scroll area.



  

 

See also:

Choosing a Lead Note and Voicing
Getting Results

 



Using the Voicing dialog box  
Description of this dialog box

Items in this dialog box

  

Choosing a
Lead Note
and
Voicing

Lead Note
edit box

The Lead Note edit box shows the Pitch of the Lead Note subject to Voicing
using the format "MIDI Pitch value:Note Name/Octave". Using the up/down
buttons, you can alter the Pitch of the Lead Note being Voiced. As the Lead
Note Pitch is changed, so are its available Voicings. Depending on the current
Chord you are working in the context of, some Lead Note choices will have no
available Voicings.

Location
display

The Location Area of the Voicing dialog box shows the starting and ending
locations and the length of the Lead Note subject to Voicing. This display is for
your reference. Changing these properties can be done freely in the Pianoroll
or Notation Editor, or in controlled amounts with the Quantize and Articulation
Adjustment dialog boxes.

Voicings
scroll area

When Voicing a Lead Note is successful using specified Voicing Parameters,
the available Voicings will be detected and and their Note spellings will be
displayed from highest to lowest Pitch in the Voicings scroll area. When the
Lead Note does not harmonize with the Chord in the Voicing Parameters scroll
area or the Chord itself is not appropriate for the specified Voicing Parameters,
no Voicing results will appear here.

Select a Voicing shown in the Voicings scroll area to develop harmony in the
selected Line data. When a Voicing is selected, any adjacent Note data
overlapping the Lead Note in the Track is automatically removed.

Absolute Pitch,
Scale Spelling
radio buttons

The Absolute Pitch and Scale Spelling radio buttons are used to set up how
a Voicing's Notes will be displayed in the Voicings scroll area.

Selecting Absolute Pitch displays a Lead Note's Voicing components by their
absolute Pitch, enharmonically the same as the Notes for the Chord in that
area.

Selecting Scale Spelling displays a Lead Note's Voicing components by their
Intervalic Scale spelling for the Chord in that area.

 

See also:

Using the Voicing Parameters scroll area
Getting Results

 



Using the Voicing dialog box  
Description of this dialog box

Items in this dialog box

  

Getting
Results

Playback,
Playback with Others,
Stop
buttons

Each time you make Voicing adjustments, the selected Line data is
temporarily replaced.

Click the Playback (Single Speaker) button to hear a Voicing in "Solo"
mode. This Auditioning mode will include any existing Chords if the Chord
Track Play button in the Track area of the Document Window is activated.

Click the Playback with Others (Double Speaker) button to hear a Voicing
along with all the other activated Tracks.

Once either Playback button is clicked, CAMPS will repeat (Loop) Playback
of selected Line data with current Voicing adjustments as you make them,
until you click the Stop (No Speaker) button. With this feature, you can
change and listen to different Voicings "on the fly" or one by one.

OK
button

Click OK when you have achieved the desired results. This closes the
Voicing dialog box and replaces the selected Line data with the Voicing
highlighted in the Voicings scroll area.

 

See also:

Using the Voicing Parameters scroll area
Choosing a Lead Note and Voicing

 



Chord Construction dialog box  
Contents

Dialog Boxes

  

Description The Chord Construction dialog box allows you to temporarily assign a different Chord to the Lead
Note by manually defining three elements: Symbol , Quality and Tension.

Uses In the Chord Construction dialog box, CAMPS automatically displays lists of Symbols, Qualities
and Tensions available in the chosen Key and Mode, allowing you to select one of each element
for constructing a Chord.

The Chord Construction dialog box, when opened from the Voicing dialog box, automatically
displays only lists of Symbols, Qualities and Tensions based on the Lead Note as either a Chord
Tone or a valid Tension Note.

Using the Playback buttons, you can then audition Constructed Chords and select one that
sounds good to you.

  

Items Key and Mode scroll area

Symbol scroll area

Quality scroll area

Tension scroll area

Constructed Chord(s) scroll area
Key Signature display
Key and Mode display
Chord Name radio button
Roman Numeral radio button
Playback button
Playback with Others button
Stop button
OK button
Cancel button
Help button



  

Opening From the...
Voicing dialog box

Select "Reharmonize..." from the drop-down menu.

  



Items in the Chord Construction dialog box  
Description of this dialog box

Using this dialog box

  

Selecting
Chord
Components

Key and Mode
scroll area

The Mode and Key you select here determine the range of
Chords that can be built.

Symbol
scroll area

The Symbol scroll area displays all of the conceivable Chord
Symbols in the range specified by the Key and Mode scroll
area. This is where you select the Chord Symbols you want to
build.

Quality
scroll area

All of the conceivable chord Qualities for the Symbol selected
in the Symbol Scroll area appear in the Quality scroll area. This
is where you select the Quality for the Chord you want to build.

Tension
scroll area

The Tension scroll area displays all of the conceivable Tension
sets from the combination of selected Symbol and Quality. This
is where you select the Tension sets for the Chords you want
to build. 

Selecting a
Constructed
Chord

Constructed Chord(s)
scroll area

The Constructed Chord(s) scroll area displays a list of
Constructed Chords based on your selections in the Key and
Mode, Symbol, Quality and Tension scroll areas.

Key Signature
display

Displays the musical notation form of the Key Signature
selected in the Key and Mode scroll area.

Key and Mode
display

Displays the alphabetic form of Key and Mode selected from
the Key and Mode scroll area.

Appearance of
Constructed
Chord(s)

Chord Name
radio button

Sets the Chord display in the Constructed Chord(s) area to
Chord Name form.

Roman Numeral
radio button

Sets the Chord display in the Constructed Chord(s) area to
Roman Numeral form.

Auditioning  Playback Click the Playback (Single Speaker) button to listen to a
selected Constructed Chord.

 Playback with Others Click the Playback with Others (Double Speaker) button to
listen to a selected Constructed Chord along with all the other
activated Tracks.

 Stop Click the Stop (No Speaker) button to stop Playback.

Closing OK
button

Closes the Chord Construction dialog box and commits
changes.

Cancel
button

Closes the Chord Construction dialog box without committing
changes.

Help
button

Opens this Help document.



 

  



Using the Chord Construction dialog box  
Description of this dialog box

Items in this dialog box

  

Selecting
Chord
Components

Key and Mode
scroll area

Upon selecting Chord Containers whose Chords you want to construct and
opening the Chord Construction dialog box, CAMPS displays the Key and
Mode, Symbol, Quality and Tension for the selected Chord.
Use any desired combination of the following four steps to build Chords in the
Chord Construction dialog box:

1. Select a Key and Mode from the Key and Mode scroll area.

Symbol
scroll area

2. Select a Symbol from the Symbol scroll area. All of the conceivable
Qualities for the selected Symbol appear in the Quality scroll area.



Quality
scroll area

3. Select a Quality from the Quality Scroll Area. All of the conceivable Tension
combinations resulting from Symbol and Quality selections appear in the
Tension scroll area..

Tension
scroll area

4. Select a Tension set from the Tension scroll area. All of the Chords of the
same name that can logically be formed by combining the selected Symbol,
Quality, and Tension appear in the Constructed Chord(s) area.

 

See also:

Selecting a Chord
Getting Results

 



Using the Chord Construction dialog box  
Description of this dialog box

Items in this dialog box

  

Selecting a
Chord

Constructed
Chord(s)
scroll area

When there are a number of Chords of the same name in the Constructed
Chord(s) scroll area, you can select any one you want. Refer to the Key
Signature and Key and Mode Displays for the Chord when making your
selection.

Chord Name,
Roman Numeral
radio buttons

Click the Chord Name or Roman Numeral radio button to choose your
desired Chord display style in the Constructed Chord(s) area.

 

See also:

Selecting Chord Components
Getting Results

 



Using the Chord Construction dialog box  
Description of this dialog box

Items in this dialog box

  

Getting
Results

Playback,
Playback with Others,
Stop
buttons

Click the Playback (Single Speaker) button to listen to the Chord currently
selected in the Constructed Chord(s) scroll area. Click the Playback with
Others (Double Speaker) button to hear the Constructed Chord along with
all the other activated Tracks.

Once either Playback button is clicked, CAMPS will repeat (Loop) Playback
of a Constructed Chord, even while selecting different Chord components,
until you click the Stop (No Speaker) button. With this feature, you can
change and listen to different Chord Constructions "on the fly" or one by
one.

OK
button

Selecting a Chord in the Constructed Chord(s) scroll area and clicking OK
closes the Chord Construction dialog box and replaces the Chord for the
Lead Note with your newly Constructed Chord.

 

See also:

Selecting Chord Components
Selecting a Chord

 



Menu Items  
Contents

  

Overview CAMPS provides different Menu Items in the Menu Bar depending on which Editor or window is
active. CAMPS also automatically changes some Menu Items according to the Editor Area clicked
before opening menus.

 

Menu items for the Document Window

Menu items for the Event List Editor

Menu items for the Pianoroll Editor

Menu items for the Control Draw Editor

Menu items for the Notation Editor

Menu items for the Tempo List Editor

Menu items for the Tempo Draw Editor

Menu items for the Text List Editor

Menu items with no Document open

 



Menu Items with no Document open  
Contents

Menu Items

  

Description Here is a complete list of the Menu when no Document is open.

 

Items

 File    

 New  Ctrl + N  

 New Setup...  Ctrl + Shift + N 
 Open...  Ctrl + O  
 Close    
   
 1  [Recent Document]   
 2  [Recent Document]   
   :    
   
 Exit     

 Edit    
 Undo  Ctrl + Z  

  
 Cut  Ctrl + X 
 Copy  Ctrl + C 
 Paste  Ctrl + V 

 Clear  Del  
 Select All  Ctrl + A 
  
 Preferences...   

 MIDI    
 Metronome  Ctrl +M 
  
 All Notes Off    

 Reset All Controllers   
  
 Synchronize With  >  

 Transmit Clock  >  
  
 MIDI Mapper    
 MIDI Setup...    

 

 Synchronize With 
 Internal Clock  

 Tap  
 MIDI Clock  
 SMPTE  

 

 Transmit Clock 
 MIDI Clock  
 SMPTE  



 View    

 Toolbars  > 
  
 Big Beat Window    
 Big Time Window   

 

 Toolbars  
 Main Toolbar  

 Status Bar  
  
 Playback Control Toolbar 
 Record Control Toolbar  
  
 Clock Sync Toolbar  
 Device Control Toolbar  
 Tempo Toolbar  
  
 Note Stamp Toolbar  
 Rest Toolbar  
  
 Beat Toolbar  
 Time Toolbar  

 Help  

 Help  
  
 About CAMPS 

 



Menu Items for the Document Window  
Contents

Menu Items

  

Description Here is a complete list of Menu Items when the Document Window is active.

 

Items

 File    

 New  Ctrl + N  

 New Setup...  Ctrl + Shift + N 
 Open...  Ctrl + O  
 Close    
   
 Save  Ctrl + S  
 Save As...    
 Revert    
   
 Export SMF...    
   
 1  [Recent Document]   
 2  [Recent Document]   
   :    
   
 Exit     

 Edit    
 Undo [Action] [Object]  Ctrl + Z  

  
 Cut [Object]  Ctrl + X  
 Copy [Object]  Ctrl + C  
 Paste [Object]  Ctrl + V  

 Clear [Object]  Del  
 Select All  Ctrl + A  
  
 New [Object]...  Ctrl + I  
 Duplicate [Object]  Ctrl + D  
 Make Alias of [Object]  Ctrl + Shift + D 

 Suspend Alias    
 Merge [Object]    
  
 Bring To Front    

 Send To Back    
  
 Time Signature Setup...   

 SMPTE Offset Setup...    
  
 Preferences...    



 Chord    
 Generate...  Ctrl + Shift + G 
 EZgenerate  Ctrl + G  
  
 Harmonize...  Ctrl + Shift + H 
 EZharmonize  Ctrl + H  
 EZharmonize with Same Key    
  
 Detect from MIDI Instrument...   

 Construct...    
  
 EZcompose Lines in Region  Ctrl + R  

  
 EZharmonize All    

 Line    
 Take   >  
  
 Compose...  Ctrl + Shift + K 
 EZcompose  Ctrl + K  
  
 Detect Dissonant Intervals...   
  
 Quantize...    

 Transpose...    
 Adjust Articulation...    
 Adjust Velocity...    
 Map Pitches....    
  
 Half Time    
 Double Time    
  
 EZharmonize With    

 

 Take    
 Take List...  Ctrl + F  
  
 New Take...  Ctrl + T  
 Duplicate Take Ctrl + U 
 Remove Take    
  
 [Take #1]    

 [Take #2]    
 :    

 MIDI    

 Play    

 Stop    
 Record   >  
 Jump To   >  
  

 Metronome  Ctrl
+M

 

  
 All Notes Off    

 Reset All Controllers   
  
 Synchronize With   >  

 Transmit Clock   >  
  
 MIDI Mapper    
 MIDI Setup...    

 

 Record    
 Start Recording  F5 

 Start Over-dubbing  F7 
 Start Step Recording F8 

 

 Jump To   
 Top  Home 

 End  End  

 

 Synchronize With 
 Internal Clock  

 Tap  
 MIDI Clock  
 SMPTE  

 

 Transmit Clock 
 MIDI Clock  
 SMPTE  



 View    

 Chord View   >  
 Grid View   >  
 Toolbars   >  
 Zoom   >  
  
 Auto Scroll  Ctrl +L 
 Jump To Location...    
  
 Edit Buttons    
 Interactive Information   
  
 Line Block Name    
  
 Big Beat Window    
 Big Time Window    
  
 Background Bitmap    
  
 Save Display Settings    

 

 Chord View  
 Roman Numeral 

 Chord Name  
 Scale Name  
 Scale Spelling  
 Key and Mode  

 

 Grid View  
 Bar Grid  

 Beat Grid  
 Track Grid  
  
 Align To Grid 
 Grid Setup...  

 

 Toolbars  
 Main Toolbar  

 Status Bar  
  
 Playback Control Toolbar 
 Record Control Toolbar  
  
 Clock Sync Toolbar  
 Device Control Toolbar  
 Tempo Toolbar  
  
 Note Stamp Toolbar  
 Rest Toolbar  
  
 Beat Toolbar  
 Time Toolbar  

 

 Zoom  
 Zoom Out (V) 

 Zoom In (V)  
 Zoom Out (H) 
 Zoom In (H)  

 Editors    

 Event List Editor  F9  
 Pianoroll Editor  F10 
 Control Draw Editor F11 
 Notation Editor  F12 
  
 Tempo List Editor    
 Tempo Draw Editor    
  
 Text List Editor    
  
 Tool   >  

 

 Tool  
 Arrow  

 Pen  
 Magic Wand 
 Eraser  
 Razor  

 Window  

 
New
Window  

 Cascade  
 Tile  
 

Arrange
Icons  

  
 1 [Window] 
 2 [Window] 
   :  



 Help  

 Help  
  
 [Object] Memo...  
 Document Memo... 
  
 About CAMPS  

 



Menu Items with no Document open / File  
Menu Items

Menu Items with no Document Open

  

Description The File menu allows you to manage Document files and shut down CAMPS.

 

Items New Creates a New untitled Document as specified by the settings in the New
Document Setup dialog box.

New Setup... Opens the New Document Setup dialog box, allowing you to set basic
defaults for New Documents.

Open... Opens the Open dialog box, allowing you to select and open a Document.

 When opening a Standard MIDI File, CAMPS automatically analyzes
Line data and assigns appropriate Line Blocks and one of six Category
settings to each Track. You can alter these settings at any time.

Close Closes the current Document. If this Document has been altered since
opening, you will be asked whether or not you wish to save changes
before closing.

[Recent Document] Opens the recently opened Document named here. The number of Recent
Documents listed here is adjustable in the Preferences dialog box which
can be opened from the Edit menu.

Exit Closes CAMPS and any open Documents. If any currently open
Documents have been altered since opening, you will be asked whether or
not you wish to save changes before closing.

 



Menu Items with no Document open / Edit  
Menu Items

Menu Items with no Document open

  

Description The Edit menu allows you to manipulate objects in the Document Window and other Editors.
However, with no Document open, the Preferences... command will be the only available
command here.

 

Items Undo [Action] [Object]
 This Menu Item won't be available unless a Document is open.

See Help documentation on the Edit menu for the Document Window
and other Editors.

Cut [Object]
 This Menu Item won't be available unless a Document is open.

See Help documentation on the Edit menu for the Document Window
and other Editors.

Copy [Object]
 This Menu Item won't be available unless a Document is open.

See Help documentation on the Edit menu for the Document Window
and other Editors.

Paste [Object]
 This Menu Item won't be available unless a Document is open.

See Help documentation on the Edit menu for the Document Window
and other Editors.

Clear [Object]
 This Menu Item won't be available unless a Document is open.

See Help documentation on the Edit menu for the Document Window
and other Editors.

Select All
 This Menu Item won't be available unless a Document is open.

See Help documentation on the Edit menu for the Document Window
and other Editors.

Preferences... Opens the Preferences dialog box, allowing you to set basic
operational and appearance defaults in CAMPS.

 



Menu Items with no Document open / MIDI  
Menu Items

Menu Items with no Document open

  

Description The MIDI menu allows you to control the CAMPS Sequencer Engine and manage MIDI signals.

 No Sequencer actions such as Playback or Record will be possible without a Document
open.

 

Items Metronome Switches between activate or deactivate the Metronome
during Playback and Recording. A checkmark appears next
to this item when activated.

All Notes Off Sends the "All Notes Off" MIDI Event to current MIDI
Devices. Use this command to stop unwanted sustained
Notes after stopping Playback or inadvertently interrupting
MIDI signaling.

Reset All Controllers Sends the "Reset All Controllers" MIDI Event to current MIDI
Devices. Use this command to reset certain MIDI parameters
such as Volume, Pan or Modulation.

Synchronize With/Internal Clock Sets CAMPS to Playback and Record using its own internal
MIDI Clock. A bullet appears next to the current selection.

Synchronize With/Tap Sets CAMPS to Playback and Record using "freewheel"
Tempo pulses input by you on your computer's keyboard or
your MIDI Instrument. A bullet appears next to the current
selection.

Synchronize With/MIDI Clock Sets CAMPS to Playback and Record in "slave" mode using
an external MIDI Clock source, such as another Sequencer.
A bullet appears next to the current selection.

Synchronize With/SMPTE Sets CAMPS to Playback and Record using MIDI Time Code
converted from an external SMPTE Time Code source, such
as a click track from an audio or video tape deck. A SMPTE
converter must be employed between a raw SMPTE source
and the MIDI port used by CAMPS. A bullet appears next to
the current selection.

Transmit Clock/MIDI Clock Enables CAMPS to send its MIDI Clock signal to an external
device. When using this setting in conjunction with Internal
Clock Sync, CAMPS Plays and Records in "Master" mode,
allowing an external Sequencer to synchronize with CAMPS.
A checkmark appears next to this item when enabled.

Transmit Clock/SMPTE Enables CAMPS to send MIDI Time Code to an external
SMPTE converter. When using this setting in conjunction
with Internal Clock Sync, CAMPS Plays and Records in
"Master" mode, allowing an external Sequencer or other
device to synchronize with CAMPS. A checkmark appears
next to this item when enabled.



MIDI Mapper Switches between enable or disable the Windows Operating
System MIDI Mapper. When enabled, CAMPS passes MIDI
Output Device selection control to the Windows Multimedia
applet in the Control Panel. When disabled, MIDI Output
Devices can be selected from within CAMPS, allowing much
greater flexibility. A checkmark appears next to this item
when enabled.

MIDI Setup... Opens the MIDI Setup dialog box, allowing you to manage
many MIDI signaling details. This includes settings for input,
output, sync and Devices.

 



Menu Items with no Document open / View  
Menu Items

Menu Items with no Document open

  

Description The View menu allows you to select objects to display and how to display them. Use Save
Display Settings to save the current display settings of the Document Window for its next
session.

 

Items Toolbars/Main Toolbar Switches between Show or Hide the Main toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Status Bar Switches between Show or Hide the Status Bar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Playback Control Toolbar Switches between Show or Hide the Playback Control
toolbar. A checkmark appears next to this Menu Item
when set to Show.

Toolbars/Record Control Toolbar Switches between Show or Hide the Record Control
toolbar. A checkmark appears next to this Menu Item
when set to Show.

Toolbars/Clock Sync Toolbar Switches between Show or Hide the Clock Sync toolbar.
A checkmark appears next to this Menu Item when set to
Show.

Toolbars/Device Control Toolbar Switches between Show or Hide the Device Control
toolbar. A checkmark appears next to this Menu Item
when set to Show.

Toolbars/Tempo Toolbar Switches between Show or Hide the Tempo toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Note Stamp Toolbar Switches between Show or Hide the Note Stamp toolbar.
A checkmark appears next to this Menu Item when set to
Show.

Toolbars/Rest Toolbar Switches between Show or Hide the Rest toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Beat Toolbar Switches between Show or Hide the Beat toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Time Toolbar Switches between Show or Hide the Time toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Big Beat Window Switches between Show or Hide the Big Beat Window. A
checkmark appears next to this Menu Item when set to
Show. When Showing, you can drag this Window to
desired location, or use its Close button to hide it again.
See details. See also Beat Toolbar..



Big Time Window Switches between Show or Hide the Big Time Window. A
checkmark appears next to this Menu Item when set to
Show. When Showing, you can drag this Window to
desired location, or use its Close button to hide it again.
See details. See also Time Toolbar..

 



Menu Items with no Document open / Help  
Menu Items

Menu Items with no Document open

  

Description The Help menu allows you to access these Help documents.

 

Items Help Opens the Table of Contents for these Help documents.

About CAMPS Opens the CAMPS banner with a text scroll area containing information about
CAMPS and the Microworks Corporation.

 



Menu Items / View  Menu Items

 
 

Big Beat Window

Description The Big Beat Window displays the Playback/Record Location in the current Document in MIDI
form, expressed as "Bar:Beat:Divisions".

 

Uses You can drag this Window to any location in the top or bottom of the CAMPS Application window
frame. Additionally, double clicking this toolbar between buttons or dragging it outside the
CAMPS Application window brings it into its own window that can be put anywhere, even on the
Microsoft Windows desktop. Double clicking it again or dragging it back into the top or bottom of
the CAMPS Application window reintegrates it with the CAMPS Application window frame.

You can choose to Show or Hide this Window with the corresponding command in the View
menu. When contained in its own window, you can hide this Window by clicking its top-right
"Close window" ("X") button. Hiding or liberating Window can increase the useable work area in
the CAMPS Application window.

You have three options to customize the Window display: Font, Color and Background Color.
Right-click an empty location in the Window and then choose a command from the drop-down
menu. Choose Font... for selecting a font, Color... for the font color, and Background Color...
for the background color.

 



Menu Items / View  Menu Items

 
 

Big Time Window

Description The Big Time Window displays the Playback/Record Location in the current Document in SMPTE
Time Code form, expressed as "Hours:Minutes:Seconds:Frames".

 

Uses You can drag this Window to any location in the top or bottom of the CAMPS Application window
frame. Additionally, double clicking this toolbar between buttons or dragging it outside the
CAMPS Application window brings it into its own window that can be put anywhere, even on the
Microsoft Windows desktop. Double clicking it again or dragging it back into the top or bottom of
the CAMPS Application window reintegrates it with the CAMPS Application window frame.

You can choose to Show or Hide this Window with the corresponding command in the View
menu. When contained in its own window, you can hide this Window by clicking its top-right
"Close window" ("X") button. Hiding or liberating Window can increase the useable work area in
the CAMPS Application window.

You have three options to customize the Window display: Font, Color and Background Color.
Right-click an empty location in the Window and then choose a command from the drop-down
menu. Choose Font... for selecting a font, Color... for the font color, and Background Color...
for the background color.

The drop-down menu also includes options which allow you to select SMPTE Frame Rate, as
well as Offset display.

 



Menu Items for the Control Draw Editor  
Contents

Menu Items

  

Description Here is a complete list of Menu Items when the Control Draw Editor is active.

 

Items

 File    

 New  Ctrl + N  

 New Setup...  Ctrl + Shift + N 
 Open...  Ctrl + O  
 Close    
   
 Save  Ctrl + S  
 Save As...    
 Revert    
   
 Export SMF...    
   
 1  [Recent Document]   
 2  [Recent Document]   
   :    
   
 Exit     

 Edit    
 Undo [Action] [Object]  Ctrl + Z  

  
 Cut [Object]  Ctrl + X 
 Copy [Object]  Ctrl + C 
 Paste [Object]  Ctrl + V 

 Clear [Object]  Del  
 Select All  Ctrl + A 
  
 New [Object]...  Ctrl + I  
 Duplicate [Object]  Ctrl + D 
  
 Time Signature Setup...   

 SMPTE Offset Setup...    
  
 Preferences...    

 Line    
 Take  > 
  
 Quantize...    

 Adjust Value...   
  
 Half Time    
 Double Time    

 

 Take    
 Take List...  Ctrl + F  
  
 New Take...  Ctrl + T  
 Duplicate Take Ctrl + U 
 Remove Take    
  
 [Take #1]    



 MIDI    

 Playback    
 Playback with Others   
  
 Play    

 Stop    
 Record  >  
 Jump To  >  
  

 Metronome  Ctrl
+M

 

  
 All Notes Off    

 Reset All Controllers    
  
 Synchronize With  >  

 Transmit Clock  >  
  
 MIDI Mapper    
 MIDI Setup...    

 

 Record    
 Start Recording  F5 

 Start Over-dubbing  F7 
 Start Step Recording F8 

 

 Jump To   
 Top  Home 

 End  End  

 

 Synchronize With 
 Internal Clock  

 Tap  
 MIDI Clock  
 SMPTE  

 

 Transmit Clock 
 MIDI Clock  
 SMPTE  

 View    

 Control View  >  
 Grid View  >  
 Toolbars  >  
 Zoom  >  
  
 Auto Scroll  Ctrl +L 
 Jump To Location...    
  
 Edit Buttons    
 Interactive Information   
  
 Big Beat Window    
 Big Time Window    
  
 Background Bitmap    
  
 Save Display Settings    

 

 Control View  
 Control Change...  

 Poly After Touch...  
 Channel After Touch 
 Program Change  
 Pitch Bend  

 

 Grid View  
 Bar Grid  

 Beat Grid  
 Value Grid  
  
 Align To Grid 
 Grid Setup...  

 

 Toolbars  
 Main Toolbar  

 Status Bar  
  
 Playback Control Toolbar 
 Record Control Toolbar  
  
 Clock Sync Toolbar  
 Device Control Toolbar  
 Tempo Toolbar  
  
 Note Stamp Toolbar  
 Rest Toolbar  
  
 Beat Toolbar  
 Time Toolbar  

 

 Zoom  
 Zoom Out (H) 
 Zoom In (H)  

 Editors    

 Event List Editor  F9  
 Pianoroll Editor  F10 
 Control Draw Editor F11 
 Notation Editor  F12 
  
 Tempo List Editor    
 Tempo Draw Editor    
  
 Text List Editor    
  
 Tool  >  

 

 Tool  
 Arrow  

 I Beam 
 Pen  
 Line  
 Oval  
 Eraser  



 Window  

 
New Control
Draw Editor  

 Cascade  
 Tile  
 

Arrange
Icons  

  
 1 [Window] 
 2 [Window] 
   :  

 Help  

 Help  
  
 Line Block Memo... 
 Document Memo...  
  
 About CAMPS  

 



Menu Items for the Control Draw Editor / File  
Menu Items

Menu Items for the Control Draw Editor

  

Description The File menu allows you to manage Document files and shut down CAMPS.

 Some of these Menu Items won't be available unless a Document is open. Additionally, the
Save and Revert commands won't be available until the current Document has been altered.

 

Items New Creates a New untitled Document as specified by the settings in the New
Document Setup dialog box.

New Setup... Opens the New Document Setup dialog box, allowing you to set basic
defaults for New Documents.

Open... Opens the Open dialog box, allowing you to select and open a Document.

 When opening a Standard MIDI File, CAMPS automatically analyzes
Line data and assigns appropriate Line Blocks and one of six Category
settings to each Track. You can alter these settings at any time.

Close Closes the current Document. If this Document has been altered since
opening, you will be asked whether or not you wish to save changes
before closing.

Save Saves the current Document using its existing filename and location.

Save As... Opens the Save As dialog box, allowing you to save the current Document
to a specified filename and location.

Revert Allows you to close and reopen the current Document in one step,
discarding any changes made after last saving it. You'll be asked if you're
sure you want to proceed before this operation is completed.

Export SMF... Opens the Export Standard MIDI File dialog box, allowing you to save the
current Document as a Standard MIDI File. After specifying a filename and
location and clicking Save, the Export Options dialog box opens, allowing
you to make final file format conversion settings.

[Recent Document] Opens the recently opened Document named here. The number of Recent
Documents listed here is adjustable in the Preferences dialog box which
can be opened from the Edit menu.

Exit Closes CAMPS and any open Documents. If any currently open
Documents have been altered since opening, you will be asked whether or
not you wish to save changes before closing.

 



Menu Items for the Control Draw Editor / Edit  
Menu Items

Menu Items for the Control Draw Editor

  

Description The Edit menu allows you to Edit objects in the Control Draw Editor. For example, you can Cut,
Copy, Paste, and Clear objects in the Text Info, Lyric and Draw Areas of the Control Draw
Editor.

 Many of these Menu Items won't be available unless a Document is open. Most also require
a related object first be selected. Finally, most of these Menu Items change depending on the
last object or Area selected in the Control Draw Editor.

 

Items Undo [Action] [Object] Reverses your last editing action. This command's name and function
change depending on your last action. For example, if you just moved
a Lyric, this command's name becomes Undo Move Event. Once
executed, the Undo command becomes Redo and vice versa.

Cut [Object] Removes selected object from a Document for reinsertion using the
Paste command, if desired. This command's name and function
change depending on your last selection. For example, if you just
selected a Lyric, this command's name becomes Cut Lyric.

Copy [Object] Specifies selected object for duplication using the Paste command.
This command's name and function change depending on your last
selection. For example, if you just selected a Lyric, this command's
name becomes Copy Lyric.

Paste [Object] Inserts the last object specified with the Cut or Copy command into
the currently selected relative Area. This command's name and
function change depending on your last action. For example, if you
just Cut a Lyric and selected a region in the Lyric Area, this
command's name becomes Paste Lyric.

Clear [Object] Deletes the currently selected objects.

Select All Automatically selects all relative objects in the currently selected
region or Area. For example, if you just selected a region in the Lyric
Area, Select All selects all the Lyrics in the Lyric Area.

New [Object]... Opens the appropriate New [Object] dialog box or inserts a new
appropriate blank object, allowing you to create a New object. This
command's name and function change depending on your last
selection. For example, if you just selected a region in the Lyric Area,
this command's name becomes New Lyric... and inserts a new Lyric
text box in the Lyric Area.

Duplicate [Object] Immediately creates a Duplicate of a selected object. This command's
name and function change depending on your last selection. For
example, if you just selected a Lyric, this command's name becomes
Duplicate Lyric.

Time Signature Setup... Opens the Time Signature Setup dialog box, allowing you to change
the Time Signature in a specified region of Bars.

SMPTE Offset Setup... Opens the SMPTE Offset Setup dialog box, allowing you to offset
SMPTE synchronization between CAMPS and a master SMPTE
source.



Preferences... Opens the Preferences dialog box, allowing you to set basic
operational and appearance defaults in CAMPS.

 



Menu Items for the Control Draw Editor / Line  
Menu Items

Menu Items for the Control Draw Editor

  

Description The Line menu allows you to edit and manipulate a Line Block's Control Event data, including
managing Takes.

 The Line menu won't be available unless a Document is open. Additionally, most of these
Menu Items won't be available unless a Control Event is selected.

 

Items Take/Take List... Opens the Take List dialog box, allowing you to manipulate Takes for the
selected Line Block.

Take/New Take... Opens the New Take dialog box, allowing you to create a New blank or
Auto Composed Take for the selected Line Block.

Take/Duplicate Take Duplicates the currently selected Take.

Take/Remove Take Deletes the currently selected Take. This command is only available
when a Take other than the original is selected.

Take/[Take #1] Makes the Take named here currently active, appearing in front of any
others. A bullet appears next to the current selection.

Quantize... Opens the Quantize dialog box, allowing you to automatically correct the
start time of selected Control Events.

Adjust Value... Opens the Value Adjustment dialog box, allowing you to adjust the value
of selected Control Events.

Half Time Halves the time value of a selected Control Event, doubling its Playback
Tempo.

Double Time Doubles the time value of a selected Control Event, halving its Playback
Tempo.

 



Menu Items for the Control Draw Editor / MIDI  
Menu Items

Menu Items for the Control Draw Editor

  

Description The MIDI menu allows you to control the CAMPS Sequencer Engine and manage MIDI signals.

 Many of these Menu Items won't be available unless a Document is open.

 

Items Playback Starts Audition Playback of the currently selected Control
Events with an automatically inserted Playback Loop. If no
individual Control Events are selected, CAMPS begins
Playback from the currently selected Line Block with no
Loop.

 If the Chord Track is activated, Chords in the same Bar
region will be also played back.

Playback with Others Starts Audition Playback of the currently selected Control
Events with an automatically inserted Playback Loop along
with all the other activated Tracks in the same Bar region. If
no individual Control Events are selected, CAMPS begins
Playback from the currently selected Line Block with no
Loop.

 If the Chord Track is activated, Chords in the same Bar
region will be also played back.

Play Starts Playback of the current Document.

Stop Stops Playback of the current Document.

Record/Start Recording Starts Recording in the current Document.

Record/Start Over-dubbing Starts Over-Dub Recording in the current Document.

Record/Start Step Recording Starts Step Recording in the current Document.

Jump To/Top Moves the Playback Pointer position and viewpoint to the
beginning of the current Line Block. Executing this command
also enables the Auto Scroll function if previously disabled.

Jump To/End Moves the Playback Pointer position and viewpoint to the
end of the current Line Block. Executing this command also
enables the Auto Scroll function if previously disabled.

Metronome Switches between activate or deactivate the Metronome
during Playback and Recording. A checkmark appears next
to this item when activated.

All Notes Off Sends the "All Notes Off" MIDI Event to current MIDI
Devices. Use this command to stop unwanted sustained
Notes after stopping Playback or inadvertently interrupting
MIDI signaling.



Reset All Controllers Sends the "Reset All Controllers" MIDI Event to current MIDI
Devices. Use this command to reset certain MIDI parameters
such as Volume, Pan or Modulation.

Synchronize With/Internal Clock Sets CAMPS to Playback and Record using its own internal
MIDI Clock. A bullet appears next to the current selection.

Synchronize With/Tap Sets CAMPS to Playback and Record using "freewheel"
Tempo pulses input by you on your computer's keyboard or
your MIDI Instrument. A bullet appears next to the current
selection.

Synchronize With/MIDI Clock Sets CAMPS to Playback and Record in "slave" mode using
an external MIDI Clock source, such as another Sequencer.
A bullet appears next to the current selection.

Synchronize With/SMPTE Sets CAMPS to Playback and Record using MIDI Time Code
converted from an external SMPTE Time Code source, such
as a click track from an audio or video tape deck. A SMPTE
converter must be employed between a raw SMPTE source
and the MIDI port used by CAMPS. A bullet appears next to
the current selection.

Transmit Clock/MIDI Clock Enables CAMPS to send its MIDI Clock signal to an external
device. When using this setting in conjunction with Internal
Clock Sync, CAMPS Plays and Records in "Master" mode,
allowing an external Sequencer to synchronize with CAMPS.
A checkmark appears next to this item when enabled.

Transmit Clock/SMPTE Enables CAMPS to send MIDI Time Code to an external
SMPTE converter. When using this setting in conjunction
with Internal Clock Sync, CAMPS Plays and Records in
"Master" mode, allowing an external Sequencer or other
device to synchronize with CAMPS. A checkmark appears
next to this item when enabled.

MIDI Mapper Switches between enable or disable the Windows Operating
System MIDI Mapper. When enabled, CAMPS passes MIDI
Output Device selection control to the Windows Multimedia
applet in the Control Panel. When disabled, MIDI Output
Devices can be selected from within CAMPS, allowing much
greater flexibility. A checkmark appears next to this item
when enabled.

MIDI Setup... Opens the MIDI Setup dialog box, allowing you to manage
many MIDI signaling details. This includes settings for input,
output, sync and Devices.

 



Menu Items for the Control Draw Editor / View  
Menu Items

Menu Items for the Control Draw Editor

  

Description The View menu allows you to select objects to display and how to display them. Use Save
Display Settings to save the current display settings of the Control Draw Editor for its next
session.

 Many of these Menu Items won't be available unless a Document is open. Also, some of
these Menu Items will only be available when the Control Draw Editor is active.

 

Items Control View/Control Change... Sets the Draw Area to display Control Change Events
and opens the Select a Control dialog box, allowing you
to specify the type of MIDI Control Change Event to
display in the Draw Area. A bullet appears next to the
current selection.

Control View/Poly After Touch... Sets the Draw Area to display Poly After Touch Events
and opens the appropriate Select a Key dialog box,
allowing you to specify the MIDI Pitch of the Poly After
Touch Events to display in the Draw Area. If the currently
selected Line Block is in the Drums Track Category, the
list of available Keys in the Select a Key dialog box will
change accordingly. A bullet appears next to the current
selection.

Control View/Channel After Touch Sets the Draw Area to display Channel After Touch
Events. A bullet appears next to the current selection.

Control View/Program Change Sets the Draw Area to display Program Change Events. A
bullet appears next to the current selection.

Control View/Pitch Bend Sets the Draw Area to display Pitch Bend Events. A bullet
appears next to the current selection.

Grid View/Bar Grid Switches between Show or Hide the Bar Grid in the Text
Info, Lyric and Draw Areas. The Bar Grid is a pattern of
evenly spaced vertical lines marking horizontal divisions
between Bars (Measures) for visual reference. A
checkmark appears next to this Menu Item when set to
Show.

Grid View/Beat Grid Switches between Show or Hide the Beat Grid in the Text
Info, Lyric and Draw Areas. The Beat Grid is a pattern of
evenly spaced vertical lines marking horizontal divisions
between Beats in each Bar for visual reference. A
checkmark appears next to this Menu Item when set to
Show.

Grid View/Value Grid Switches between Show or Hide the Value Grid in the
Draw Area. The Value Grid is a pattern of evenly spaced
horizontal lines marking vertical divisions between MIDI
Control Event data Values for visual reference. A
checkmark appears next to this Menu Item when set to
Show.
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Grid View/Align to Grid Switches between Activate or Deactivate Align To Grid in
the Draw Area. The Align To Grid function causes Control
Events being created or moved to snap their position to
the nearest Grid point as specified in the Grid Setup
dialog box. Depending on your settings in the Grid Setup
dialog box, this Alignment Grid will not necessarily
coincide with the visual Bar or Beat Grids described
above. A checkmark appears next to this Menu Item
when set to Activate.

Grid View/Grid Setup... Opens the Grid Setup dialog box, allowing you to adjust
the Alignment Grid Resolution for the Draw Area of the
Control Draw Editor and various Areas of other Editors.

Toolbars/Main Toolbar Switches between Show or Hide the Main toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Status Bar Switches between Show or Hide the Status Bar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Playback Control Toolbar Switches between Show or Hide the Playback Control
toolbar. A checkmark appears next to this Menu Item
when set to Show.

Toolbars/Record Control Toolbar Switches between Show or Hide the Record Control
toolbar. A checkmark appears next to this Menu Item
when set to Show.

Toolbars/Clock Sync Toolbar Switches between Show or Hide the Clock Sync toolbar.
A checkmark appears next to this Menu Item when set to
Show.

Toolbars/Device Control Toolbar Switches between Show or Hide the Device Control
toolbar. A checkmark appears next to this Menu Item
when set to Show.

Toolbars/Tempo Toolbar Switches between Show or Hide the Tempo toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Note Stamp Toolbar Switches between Show or Hide the Note Stamp toolbar.
A checkmark appears next to this Menu Item when set to
Show.

Toolbars/Rest Toolbar Switches between Show or Hide the Rest toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Beat Toolbar Switches between Show or Hide the Beat toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Time Toolbar Switches between Show or Hide the Time toolbar. A
checkmark appears next to this Menu Item when set to
Show.



Zoom/Zoom Out (H) Incrementally decreases the Horizontal size of the Bar,
Text Info, Note Data, Lyric and Draw Areas, increasing
their viewable area.

Zoom/Zoom In (H) Incrementally increases the Horizontal size of the Bar,
Text Info, Note Data, Lyric, and Draw Areas, decreasing
their viewable area.

Auto Scroll Sets the viewable area in the Bar, Text Info, Note Data,
Lyric and Draw Areas to follow the Playback Pointer. A
checkmark appears next to this item when enabled.

Jump To Location... Opens the Jump To Location dialog box, allowing you to
specify the beginning Bar of the viewable area. Once
specified, Auto Scroll is temporarily deactivated.

Edit Buttons Switches between Show or Hide the Edit Buttons in the
Control Draw Editor. A checkmark appears next to this
Menu Item when set to Show.

Interactive Information Switches between Show or Hide the Interactive
Information display. A checkmark appears next to this
Menu Item when set to Show.

Big Beat Window Switches between Show or Hide the Big Beat Window. A
checkmark appears next to this Menu Item when set to
Show. When Showing, you can drag this Window to
desired location, or use its Close button to hide it again.
See details. See also Beat Toolbar..

Big Time Window Switches between Show or Hide the Big Time Window. A
checkmark appears next to this Menu Item when set to
Show. When Showing, you can drag this Window to
desired location, or use its Close button to hide it again.
See details. See also Time Toolbar..

Background Bitmap Switches between Show or Hide a Background Bitmap
image. A checkmark appears next to this Menu Item
when set to Show. This item will only be available if a
Background Bitmap image is specified in the Preferences
dialog box.

Save Display Settings Saves current Control Draw Editor Display Settings as
defaults for future sessions. Settings included are Grid,
Zoom, Dividing Bar positions, Background Bitmap, etc.
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Menu Items for the Control Draw Editor

  

Description The Editors menu allows you to open Editors and select Editing Tools.

 None of these Menu Items will be available unless a Document is open. Many also require a
related object first be selected.

 

Items Event List Editor Opens the Event List Editor, allowing you to edit individual Events of the
selected Line Block in vertical list format.

Pianoroll Editor Opens the Pianoroll Editor, allowing you to edit Notes of the selected Line
Block in Pianoroll graph format.

Control Draw Editor Opens a new Control Draw Editor window, allowing you to make alternate
Control Event edits in the selected Line Block.

Notation Editor Opens the Notation Editor, allowing you to edit Notes of the selected Line
Block in Musical Notation form.

Tempo List Editor Opens the Tempo List Editor, allowing you to edit individual Tempo
Events of the current Document in vertical list format.

Tempo Draw Editor Opens the Tempo Draw Editor, allowing you to edit Tempo Events of the
current Document with a unique freestyle curve drawing method.

Text List Editor Opens the Text List Editor, allowing you to edit Text Events of the current
Document in vertical list format.

Tool/Arrow Allows you to select and manipulate objects in the Control Draw Editor.

Tool/I Beam Allows you to quickly select regions in the Draw Area.

Tool/Pen Allows you to quickly create and edit Control Events using a freestyle
drawing method.

Tool/Line Allows you to quickly create and edit Control Events using a straight line
drawing method.

Tool/Oval Allows you to quickly create and edit Control Events using an automatic
curve drawing method.

Tool/Eraser Allows you to quickly delete objects.
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Menu Items for the Control Draw Editor

  

Description The Window menu allows you to arrange Document and Editor windows in the work area of the
CAMPS Application Window.

 The Window Menu Item won't be available unless a Document is open.

 

Items New Control Draw Editor Opens a new Control Draw Editor window for the currently selected
Line Block.

Cascade Arranges windows in a diagonal overlapping manner, allowing you to
individually select them. Any maximized windows will be reduced in
size to accommodate the Cascade arrangement.

Tile Arranges windows into horizontal blocks separated vertically, one
above or below the next.

Arrange Icons Arranges minimized window title bars in an orderly fashion within the
CAMPS Application Window.

[Window] Makes the window named here currently active, appearing in front of
any others. The number of windows listed here equals the number of
open windows in CAMPS. A checkmark appears next to the current
selection.
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Menu Items for the Control Draw Editor

  

Description The Help menu allows you to access these Help documents. The Help menu also allows you to
add a background text message to your Composition Document and the currently selected Line
Block.

 The Memo Menu Items won't be available unless a Document is open.

 

Items Help Opens the Table of Contents for these Help documents.

Line Block Memo... Opens the Memo dialog box, allowing you to add an underlying text
message to the currently selected Line Block.

Document Memo... Opens the Memo dialog box, allowing you to add an underlying text
message to your Document.

About CAMPS Opens the CAMPS banner with a text scroll area containing information
about CAMPS and the Microworks Corporation.
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Menu Items

Menu Items for the Document Window

  

Description The File menu allows you to manage Document files and shut down CAMPS.

 Some of these Menu Items won't be available unless a Document is open. Additionally, the
Save and Revert commands won't be available until the current Document has been altered.

 

Items New Creates a New untitled Document as specified by the settings in the New
Document Setup dialog box.

New Setup... Opens the New Document Setup dialog box, allowing you to set basic
defaults for New Documents.

Open... Opens the Open dialog box, allowing you to select and open a Document.

 When opening a Standard MIDI File, CAMPS automatically analyzes
Line data and assigns appropriate Line Blocks and one of six Category
settings to each Track. You can alter these settings at any time.

Close Closes the current Document. If this Document has been altered since
opening, you will be asked whether or not you wish to save changes
before closing.

Save Saves the current Document using its existing filename and location.

Save As... Opens the Save As dialog box, allowing you to save the current Document
to a specified filename and location.

Revert Allows you to close and reopen the current Document in one step,
discarding any changes made after last saving it. You'll be asked if you're
sure you want to proceed before this operation is completed.

Export SMF... Opens the Export Standard MIDI File dialog box, allowing you to save the
current Document as a Standard MIDI File. After specifying a filename and
location and clicking Save, the Export Options dialog box opens, allowing
you to make final file format conversion settings.

[Recent Document] Opens the recently opened Document named here. The number of Recent
Documents listed here is adjustable in the Preferences dialog box which
can be opened from the Edit menu.

Exit Closes CAMPS and any open Documents. If any currently open
Documents have been altered since opening, you will be asked whether or
not you wish to save changes before closing.

 



Menu Items for the Document Window / Edit  
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Menu Items for the Document Window

  

Description The Edit menu allows you to Edit objects in the Document Window. For example, you can Cut,
Copy, Paste, and Clear objects in the Text Info, Chord, Track and Line Areas of the Document
Window.

 Many of these Menu Items won't be available unless a Document is open. Most also require
a related object first be selected. Finally, most of these Menu Items change depending on the
last object or Area selected in the Document Window.

 

Items Undo [Action] [Object] Reverses your last editing action. This command's name and function
change depending on your last action. For example, if you just moved
a Chord, this command's name becomes Undo Move Chord. Once
executed, the Undo command becomes Redo and vice versa.

Cut [Object] Removes selected object from a Document for reinsertion using the
Paste command, if desired. This command's name and function
change depending on your last selection. For example, if you just
selected a Chord, this command's name becomes Cut Chord.

Copy [Object] Specifies selected object for duplication using the Paste command.
This command's name and function change depending on your last
selection. For example, if you just selected a Chord, this command's
name becomes Copy Chord.

Paste [Object] Inserts the last object specified with the Cut or Copy command into
the currently selected relative Area. This command's name and
function change depending on your last action. For example, if you
just Cut a Chord and selected a region in a Chord Block, this
command's name becomes Paste Chord.

Clear [Object] Deletes the currently selected objects.

Select All Automatically selects all relative objects in the currently selected
region or Area. For example, if you just selected a Chord, Select All
selects the rest of the Chords in the current Chord Block.

New [Object]... Opens an appropriate dialog box, allowing you to create a New object.
This command's name and function change depending on your last
selection. For example, if you just selected a Chord, this command's
name becomes New Chord... and opens the New Chord dialog box.

Duplicate [Object] Immediately creates a Duplicate of a selected object. This command's
name and function change depending on your last selection. For
example, if you just selected a Chord, this command's name becomes
Duplicate Chord.

Make Alias of [Object] Immediately creates an Alias (active copy) of a selected Chord Block
or Line Block. This command's name and function change depending
on your last selection. For example, if you just selected a Chord, this
command's name becomes Make Alias of Chord Block.

Suspend Alias Disables the active status of all Aliases of a selected Chord Block or
Line Block, changing them to independent copies.

Merge [Line Block] Merges 2 or more selected Line Blocks into one.



Bring To Front Brings the currently selected overlapping Chord Block or Line Block to
the foreground. In the case of Chord Blocks, this command also
makes the selected Chord Block active.

Send To Back Sends the currently selected overlapping Chord Block or Line Block to
the background. In the case of Chord Blocks, this command also
makes the selected Chord Block inactive.

Time Signature Setup... Opens the Time Signature Setup dialog box, allowing you to change
the Time Signature in a specified region of Bars.

SMPTE Offset Setup... Opens the SMPTE Offset Setup dialog box, allowing you to offset
SMPTE synchronization between CAMPS and a master SMPTE
source.

Preferences... Opens the Preferences dialog box, allowing you to set basic
operational and appearance defaults in CAMPS.
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Menu Items for the Document Window

  

Description The Chord menu allows you to automatically or manually assign Chords to your Composition
Document. CAMPS in turn uses these Chord definitions for Auto Composing and other functions.

 The Chord menu won't be available unless a Document is open. Many of these items also
require a related object first be selected.

 

Items Generate... Opens the Generate Chord Progression dialog box which uses
existing Key and Mode as well as Chord Function settings to
generate alternatives for selected Chords.

EZgenerate Automatically generates new Chords for selected Chords using
existing Key and Mode as well as Chord Function settings
without opening the Generate Chord Progression dialog box.

Harmonize... Opens the Harmonize dialog box which uses existing Line and
Chord data to provide choices for creating Chords and
adjusting Key and Mode.

EZharmonize Automatically creates Chords and adjusts Key and Mode using
existing Line and Chord data without opening the Harmonize
dialog box.

EZharmonize with Same Key Automatically creates new Chords in existing Key and Mode
using selected Line data without opening the Harmonize dialog
box.

Detect from MIDI Instrument... Opens the Chord Detection dialog box, allowing you to "spell"
desired Chord on your MIDI Instrument to replace selected
Chords.

Construct... Opens the Chord Construction dialog box, allowing you to
manually build a desired Chord from lists of components to
replace selected Chords.

EZcompose Lines in Region Automatically Composes Line data in a region of selected
Chords.

EZharmonize All Automatically creates Chords for an entire Document using all
existing Tonal Line data. See details.
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Menu Items for the Document Window

  

Description The Line menu allows you to edit and manipulate Line data, including managing Takes.

 The Line menu won't be available unless a Document is open. Additionally, most of these
items won't be available unless a Line Block is selected.

 

Items Take/Take List... Opens the Take List dialog box, allowing you to manipulate
Takes for a selected Line Block.

Take/New Take... Opens the New Take dialog box, allowing you to create a New
blank or Auto Composed Take for a selected Line Block.

Take/Duplicate Take Duplicates the currently selected Take.

Take/Remove Take Deletes the currently selected Take. This command is only
available when a Take other than the original is selected.

Take/[Take #1] Makes the Take named here currently active, appearing in front
of any others. A bullet appears next to the current selection.

Compose... Opens the Compose dialog box, allowing you to adjust guidelines
for Auto Composing, and to Auto Compose Notes in a selected
Line Block.

EZcompose Automatically Composes Notes in a selected Line Block without
opening the Compose dialog box.

Detect Dissonant Intervals... Opens the Dissonant Intervals Detection dialog box, allowing you
to automatically Detect and resolve Dissonant (harsh sounding)
Intervals between Notes in a selected Line Block and Notes
occurring at the same time in Line Blocks of other Tracks.

Quantize... Opens the Quantize dialog box, allowing you to automatically
correct the start time of Notes on an individual or Line Block
basis.

Transpose... Opens the Transpose dialog box, allowing you to shift the Pitch
of all selected Notes equally.

Adjust Articulation... Opens the Articulation Adjustment dialog box, allowing you to
change the length of Notes on an individual or Line Block basis.

Adjust Velocity... Opens the Velocity Adjustment dialog box, allowing you to
change the loudness of Notes on an individual or Line Block
basis.

Map Pitches.... Opens the Map Pitches dialog box, allowing you to shift the MIDI
Pitch value of all occurrences of specified Notes in selected Line
data.

Half Time Halves the time value of a selected Line Block, doubling its
Playback Tempo.

Double Time Doubles the time value of a selected Line Block, halving its
Playback Tempo.



EZharmonize With Automatically creates Chords and adjusts Key and Mode using
selected Line Blocks without opening the Harmonize dialog box.
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Menu Items for the Document Window

  

 Song Form Detection and Orchestration Role Detection

Description This is, by far, one of the most powerful and unique features avilable only in CAMPS. With just a
single mouse-click, CAMPS automatically creates Chord Blocks containing Chords for an entire
Document using all existing Tonal Line data.

To enable this 100 % Automatic Chord Definition, CAMPS analyzes:

Tonal quality of all Tracks●   

Orchestration Role of all Tracks such as "Melody", "Bass", etc.●   

Song Form●   

of your Composition.

Based on the result of these analyses, CAMPS creates Chords for an entire Composition.

Using Simply import your MIDI Composition into CAMPS and then choose the EZHarmonize All
command from the Chord menu. As you repeatedly choose the command, you will hear
hundreds of different Chord Progressions based on the analysis of your original Composition.

By holding the Shift key down while choosing the EZHarmonize All, CAMPS will look for results
with fewer Chord Blocks (more repetitions of Chord Blocks). By holding the Ctrl key down
instead, CAMPS will look for results with fewer Chords in each Chord Block. You can combine
both keys if you desire.

 The flexibility of the musical tools presented here would not be possible if their functions
were made mostly automatic. For example, the "EZ" tools in CAMPS are designed to give a
quick starting point and help in familiarization with CAMPS objects used for building
compositions. They are not designed to automatically create some great music for you.
Consequentially, the more parameters you define, the better your musical results will be.
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Menu Items for the Document Window

  

Description The MIDI menu allows you to control the CAMPS Sequencer Engine and manage MIDI signals.

 Many of these Menu Items won't be available unless a Document is open.

 

Items Play Starts Playback of the current Document.

Stop Stops Playback of the current Document.

Record/Start Recording Starts Recording in the current Document.

Record/Start Over-dubbing Starts Over-Dub Recording in the current Document.

Record/Start Step Recording Starts Step Recording in the current Document.

Jump To/Top Moves the Playback Pointer position and viewpoint to the
beginning of the current Document. Executing this command
also enables the Auto Scroll function if previously disabled.

Jump To/End Moves the Playback Pointer position and viewpoint to the
end of the current Document. Executing this command also
enables the Auto Scroll function if previously disabled.

Metronome Switches between activate or deactivate the Metronome
during Playback and Recording. A checkmark appears next
to this item when activated.

All Notes Off Sends the "All Notes Off" MIDI Event to current MIDI
Devices. Use this command to stop unwanted sustained
Notes after stopping Playback or inadvertently interrupting
MIDI signaling.

Reset All Controllers Sends the "Reset All Controllers" MIDI Event to current MIDI
Devices. Use this command to reset certain MIDI parameters
such as Volume, Pan or Modulation.

Synchronize With/Internal Clock Sets CAMPS to Playback and Record using its own internal
MIDI Clock. A bullet appears next to the current selection.

Synchronize With/Tap Sets CAMPS to Playback and Record using "freewheel"
Tempo pulses input by you on your computer's keyboard or
your MIDI Instrument. A bullet appears next to the current
selection.

Synchronize With/MIDI Clock Sets CAMPS to Playback and Record in "slave" mode using
an external MIDI Clock source, such as another Sequencer.
A bullet appears next to the current selection.

Synchronize With/SMPTE Sets CAMPS to Playback and Record using MIDI Time Code
converted from an external SMPTE Time Code source, such
as a click track from an audio or video tape deck. A SMPTE
converter must be employed between a raw SMPTE source
and the MIDI port used by CAMPS. A bullet appears next to
the current selection.



Transmit Clock/MIDI Clock Enables CAMPS to send its MIDI Clock signal to an external
device. When using this setting in conjunction with Internal
Clock Sync, CAMPS Plays and Records in "Master" mode,
allowing an external Sequencer to synchronize with CAMPS.
A checkmark appears next to this item when enabled.

Transmit Clock/SMPTE Enables CAMPS to send MIDI Time Code to an external
SMPTE converter. When using this setting in conjunction
with Internal Clock Sync, CAMPS Plays and Records in
"Master" mode, allowing an external Sequencer or other
device to synchronize with CAMPS. A checkmark appears
next to this item when enabled.

MIDI Mapper Switches between enable or disable the Windows Operating
System MIDI Mapper. When enabled, CAMPS passes MIDI
Output Device selection control to the Windows Multimedia
applet in the Control Panel. When disabled, MIDI Output
Devices can be selected from within CAMPS, allowing much
greater flexibility. A checkmark appears next to this item
when enabled.

MIDI Setup... Opens the MIDI Setup dialog box, allowing you to manage
many MIDI signaling details. This includes settings for input,
output, sync and Devices.
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Menu Items for the Document Window

  

Description The View menu allows you to select objects to display and how to display them. Use Save
Display Settings to save the current display settings of the Document Window for its next
session.

 Many of these Menu Items won't be available unless a Document is open.

 

Items Chord View/Roman Numeral Sets display of Chord Containers to Roman Numeral
Analysis (II-7, V7, etc.). A bullet appears next to the
current selection.

Chord View/Chord Name Sets display of Chord Containers to Chord Name (D-7,
G7, etc.). A bullet appears next to the current selection.

Chord View/Scale Name Sets display of Chord Containers to Scale Name, also
known as Mode (Dorian, Mixolydian, etc.). A bullet
appears next to the current selection.

Chord View/Scale Spelling Sets display of Chord Containers to Scale Spelling, listing
intervals from the Root (R, 3,5,7, etc.). A bullet appears
next to the current selection.

Chord View/Key and Mode Sets display of Chord Containers to Key and Mode; the
same as each Chord Container's Key and Mode button. A
bullet appears next to the current selection.

Grid View/Bar Grid Switches between Show or Hide the Bar Grid in the Text
Info, Chord and Line Areas. The Bar Grid is a pattern of
evenly spaced vertical lines marking horizontal divisions
between Bars (Measures) for visual reference. A
checkmark appears next to this Menu Item when set to
Show.

Grid View/Beat Grid Switches between Show or Hide the Beat Grid in the Text
Info, Chord and Line Areas. The Beat Grid is a pattern of
evenly spaced vertical lines marking horizontal divisions
between Beats in each Bar for visual reference. A
checkmark appears next to this Menu Item when set to
Show.

Grid View/Track Grid Switches between Show or Hide the Track Grid in the
Track and Line Areas. The Track Grid is a pattern of
evenly spaced horizontal lines marking vertical divisions
between MIDI Tracks for visual reference. A checkmark
appears next to this Menu Item when set to Show.



Grid View/Align To Grid Switches between Activate or Deactivate Align To Grid in
the Text Info, Chord and Line Areas. The Align To Grid
function causes objects being created or moved to snap
their position to the nearest Grid point as specified in the
Grid Setup dialog box. Depending on your settings in the
Grid Setup dialog box, this Alignment Grid will not
necessarily be the same as the visual Bar or Beat Grids
described above. A checkmark appears next to this Menu
Item when set to Activate.

Grid View/Grid Setup... Opens the Grid Setup dialog box, allowing you to adjust
the Alignment Grid Resolution for individual areas of the
Document Window and applicable Editors. Depending on
which Area of the Document Window is active before
choosing this Menu Item, the corresponding pane in the
Grid Setup dialog box will be preselected.

Toolbars/Main Toolbar Switches between Show or Hide the Main toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Status Bar Switches between Show or Hide the Status Bar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Playback Control Toolbar Switches between Show or Hide the Playback Control
toolbar. A checkmark appears next to this Menu Item
when set to Show.

Toolbars/Record Control Toolbar Switches between Show or Hide the Record Control
toolbar. A checkmark appears next to this Menu Item
when set to Show.

Toolbars/Clock Sync Toolbar Switches between Show or Hide the Clock Sync toolbar.
A checkmark appears next to this Menu Item when set to
Show.

Toolbars/Device Control Toolbar Switches between Show or Hide the Device Control
toolbar. A checkmark appears next to this Menu Item
when set to Show.

Toolbars/Tempo Toolbar Switches between Show or Hide the Tempo toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Note Stamp Toolbar Switches between Show or Hide the Note Stamp toolbar.
A checkmark appears next to this Menu Item when set to
Show.

Toolbars/Rest Toolbar Switches between Show or Hide the Rest toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Beat Toolbar Switches between Show or Hide the Beat toolbar. A
checkmark appears next to this Menu Item when set to
Show.



Toolbars/Time Toolbar Switches between Show or Hide the Time toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Zoom/Zoom Out (V) Incrementally decreases the Vertical size of the Track and
Line Areas, increasing their viewable area.

Zoom/Zoom In (V) Incrementally increases the Vertical size of the Track and
Line Areas, decreasing their viewable area.

Zoom/Zoom Out (H) Incrementally decreases the Horizontal size of the Bar,
Text Info, Chord and Line Areas, increasing their viewable
area.

Zoom/Zoom In (H) Incrementally increases the Horizontal size of the Bar,
Text Info, Chord and Line Areas, decreasing their
viewable area.

Auto Scroll Sets the viewable area in the Bar, Text Info, Chord and
Line Areas to follow the Playback Pointer. A checkmark
appears next to this item when enabled.

Jump To Location... Opens the Jump To Location dialog box, allowing you to
specify the beginning Bar of the viewable area. Once
specified, Auto Scroll is temporarily deactivated.

Edit Buttons Switches between Show or Hide the Edit Buttons in the
Document Window. A checkmark appears next to this
Menu Item when set to Show.

Interactive Information Switches between Show or Hide the Interactive
Information display. A checkmark appears next to this
Menu Item when set to Show.

Line Block Name Switches between Show or Hide Names at the beginning
of Line Blocks. A checkmark appears next to this Menu
Item when set to Show.

Big Beat Window Switches between Show or Hide the Big Beat Window. A
checkmark appears next to this Menu Item when set to
Show. When Showing, you can drag this Window to
desired location, or use its Close button to hide it again.
See details. See also Beat Toolbar..

Big Time Window Switches between Show or Hide the Big Time Window. A
checkmark appears next to this Menu Item when set to
Show. When Showing, you can drag this Window to
desired location, or use its Close button to hide it again.
See details. See also Time Toolbar..

Background Bitmap Switches between Show or Hide a Background Bitmap
image. A checkmark appears next to this Menu Item
when set to Show. This item will only be available if a
Background Bitmap image is specified in the Preferences
dialog box.

Save Display Settings Saves current Document Window Display Settings as
defaults for future sessions. Settings included are Grid,
Zoom, Dividing Bar positions, Background Bitmap, etc.
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Menu Items for the Document Window

  

Description The Editors menu allows you to open Editors and select Editing Tools.

 None of these Menu Items will be available unless a Document is open. Many also require a
related object first be selected.

 

Items Event List Editor Opens the Event List Editor, allowing you to edit individual Events of the
selected Line Block in vertical list format.

Pianoroll Editor Opens the Pianoroll Editor, allowing you to edit Notes of a selected Line
Block in Pianoroll graph format.

Control Draw Editor Opens the Control Draw Editor, allowing you to edit MIDI Control events
of a selected Line Block with a unique freestyle curve drawing method.

Notation Editor Opens the Notation Editor, allowing you to edit Notes of a selected Line
Block in Musical Notation form.

Tempo List Editor Opens the Tempo List Editor, allowing you to edit individual Tempo
Events of the current Document in vertical list format.

Tempo Draw Editor Opens the Tempo Draw Editor, allowing you to edit Tempo Events of the
current Document with a unique freestyle curve drawing method.

Text List Editor Opens the Text List Editor, allowing you to edit Text Events of the current
Document in vertical list format.

Tool/Arrow Allows you to select and manipulate objects in the Document Window.

Tool/Pen Allows you to quickly create objects or define values with a unique
freestyle drawing method. The function of this Tool changes depending on
the Area or Editor you are working in.

Tool/Magic Wand Allows you to quickly create Chord Blocks or Line Blocks with
automatically filled-in data (EZgenerate).

Tool/Eraser Allows you to quickly delete objects in a Document.

Tool/Razor Allows you to quickly split a Chord Block or Line Block at any point in the
selected Block.
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Menu Items for the Document Window

  

Description The Window menu allows you to arrange Document and Editor windows in the work area of the
CAMPS Application Window.

 The Window Menu Item won't be available unless a Document is open.

 

Items New Document Window Opens a new Document Window, allowing you to make alternate
edits of the current Document.

Cascade Arranges windows in a diagonal overlapping manner, allowing you to
individually select them. Any maximized windows will be reduced in
size to accommodate the Cascade arrangement.

Tile Arranges windows into horizontal blocks separated vertically, one
above or below the next.

Arrange Icons Arranges minimized window title bars in an orderly fashion within the
CAMPS Application Window.

[Window] Makes the window named here currently active, appearing in front of
any others. The number of windows listed here equals the number of
open windows in CAMPS. A checkmark appears next to the current
selection.
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Menu Items for the Document Window

  

Description The Help menu allows you to access these Help documents. The Help menu also allows you to
add a background text message to your Composition Document and several of its individual
objects.

 The Memo Menu Items won't be available unless a Document is open. The [Object] Memo
command also requires a related object first be selected.

 

Items Help Opens the Table of Contents for these Help documents.

[Object] Memo... Opens the Memo dialog box, allowing you to add an underlying text
message to different objects in your Document. This command's name and
function change depending on your last action. For example, if you just
selected a Track, this command's name becomes Track Memo....

Document Memo... Opens the Memo dialog box, allowing you to add an underlying text
message to your Document.

About CAMPS Opens the CAMPS banner with a text scroll area containing information
about CAMPS and the Microworks Corporation.

 



Menu Items for the Event List Editor  
Contents

Menu Items

  

Description Here is a complete list of Menu Items when the Event List Editor is active.

 

Items  File    

 New  Ctrl + N  

 New Setup...  Ctrl + Shift + N 
 Open...  Ctrl + O  
 Close    
   
 Save  Ctrl + S  
 Save As...    
 Revert    
   
 Export SMF...    
   
 1  [Recent Document]   
 2  [Recent Document]   
   :    
   
 Exit     

 Edit    
 Undo [Action] [Object] Ctrl + Z  

  
 Cut Event  Ctrl + X 
 Copy Event  Ctrl + C 
 Paste Event  Ctrl + V 

 Clear Event  Del  
 Select All  Ctrl + A 
  
 New Event...  Ctrl + I  
 Duplicate Event  Ctrl + D 
  
 SMPTE Offset Setup...    

  
 Preferences...    

 Line    

 Take  > 
  
 Detect Dissonant Intervals...   
  
 Quantize...    

 Transpose...    
 Adjust Articulation...    
 Adjust Velocity...    
 Map Pitches....    
 Adjust Value...    
  
 Half Time    
 Double Time    

 

 Take    
 Take List...  Ctrl + F  
  
 New Take...  Ctrl + T  
 Duplicate Take Ctrl + U 
 Remove Take    
  
 [Take #1]    



 MIDI    

 Playback    
 Playback with Others   
  
 Play    

 Stop    
 Record   >  
 Jump To   >  
  

 Metronome  Ctrl
+M

 

  
 All Notes Off    

 Reset All Controllers    
  
 Synchronize With   >  

 Transmit Clock   >  
  
 MIDI Mapper    
 MIDI Setup...    

 

 Record    
 Start Recording  F5 

 Start Over-dubbing  F7 
 Start Step Recording F8 

 

 Jump To   
 Top  Home 

 End  End  

 

 Synchronize With 
 Internal Clock  

 Tap  
 MIDI Clock  
 SMPTE  

 

 Transmit Clock 
 MIDI Clock  
 SMPTE  

 View    

 Event View   >  
 Toolbars   >  
  
 Auto Scroll  Ctrl +L 
 Jump To Location...    
  
 Edit Buttons    
 Interactive Information   
  
 Big Beat Window    
 Big Time Window    
   
 Save Display Settings    

 

 Event View  
 Note  
 Control Change  

 Poly After Touch  
 Channel After Touch 
 Program Change  
 Pitch Bend  
 Lyric  
 System Exclusive  
  
 Select Event Types... 

 

 Toolbars  
 Main Toolbar  

 Status Bar  
  
 Playback Control Toolbar 
 Record Control Toolbar  
  
 Clock Sync Toolbar  
 Device Control Toolbar  
 Tempo Toolbar  
  
 Note Stamp Toolbar  
 Rest Toolbar  
  
 Beat Toolbar  
 Time Toolbar  

 Editors    

 Event List Editor  F9  
 Pianoroll Editor  F10 
 Control Draw Editor F11 
 Notation Editor  F12 
  
 Tempo List Editor    
 Tempo Draw Editor    
  
 Text List Editor    



 Window  

 
New Event
List Editor  

 Cascade  
 Tile  
 

Arrange
Icons  

  
 1 [Window] 
 2 [Window] 
   :  

 Help  

 Help  
  
 Line Block Memo... 
 Document Memo...  
  
 About CAMPS  
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Menu Items for the Event List Editor

  

Description The File menu allows you to manage Document files and shut down CAMPS.

 Some of these Menu Items won't be available unless a Document is open. Additionally, the
Save and Revert commands won't be available until the current Document has been altered.

 

Items New Creates a New untitled Document as specified by the settings in the New
Document Setup dialog box.

New Setup... Opens the New Document Setup dialog box, allowing you to set basic
defaults for New Documents.

Open... Opens the Open dialog box, allowing you to select and open a Document.

 When opening a Standard MIDI File, CAMPS automatically analyzes
Line data and assigns appropriate Line Blocks and one of six Category
settings to each Track. You can alter these settings at any time.

Close Closes the current Document. If this Document has been altered since
opening, you will be asked whether or not you wish to save changes
before closing.

Save Saves the current Document using its existing filename and location.

Save As... Opens the Save As dialog box, allowing you to save the current Document
to a specified filename and location.

Revert Allows you to close and reopen the current Document in one step,
discarding any changes made after last saving it. You'll be asked if you're
sure you want to proceed before this operation is completed.

Export SMF... Opens the Export Standard MIDI File dialog box, allowing you to save the
current Document as a Standard MIDI File. After specifying a filename and
location and clicking Save, the Export Options dialog box opens, allowing
you to make final file format conversion settings.

[Recent Document] Opens the recently opened Document named here. The number of Recent
Documents listed here is adjustable in the Preferences dialog box which
can be opened from the Edit menu.

Exit Closes CAMPS and any open Documents. If any currently open
Documents have been altered since opening, you will be asked whether or
not you wish to save changes before closing.
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Menu Items for the Event List Editor

  

Description The Edit menu allows you to Edit MIDI Events in the Event List Editor. For example, you can
Cut, Copy, Paste and Clear Events.

 These Menu Items won't be available unless a Document is open and the Event List Editor is
currently active with an Event selected.

 

Items Undo [Action] [Object] Reverses your last editing action. This command's name and function
change depending on your last action. For example, if you just moved
an Event, this command's name becomes Undo Move Event. Once
executed, the Undo command becomes Redo and vice versa.

Cut Event Removes selected Event from a Document for reinsertion using the
Paste command, if desired.

Copy Event Specifies an Event for duplication using the Paste command.

Paste Event Inserts the last Event specified with the Cut or Copy command into the
currently selected region of the Event List.

Clear Event Deletes the currently selected Events.

Select All Automatically selects all Events in the List.

New Event... Opens the New Event dialog box, allowing you to create a New Event.

Duplicate Event Immediately creates a Duplicate of a selected Event.

SMPTE Offset Setup... Opens the SMPTE Offset Setup dialog box, allowing you to offset
SMPTE synchronization between CAMPS and a master SMPTE
source.

Preferences... Opens the Preferences dialog box, allowing you to set basic
operational and appearance defaults in CAMPS.
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Menu Items for the Event List Editor

  

Description The Line menu allows you to edit and manipulate Line data, including managing Takes.

 The Line menu won't be available unless a Document is open. Additionally, most of these
Menu Items won't be available unless a related Event is selected.

 

Items Take/Take List... Opens the Take List dialog box, allowing you to manipulate
Takes for the selected Line Block.

Take/New Take... Opens the New Take dialog box, allowing you to create a New
blank or Auto Composed Take for the selected Line Block.

Take/Duplicate Take Duplicates the currently selected Take.

Take/Remove Take Deletes the currently selected Take. This command is only
available when a Take other than the original is selected.

Take/[Take #1] Makes the Take named here currently active, appearing in front
of any others. A bullet appears next to the current selection.

Detect Dissonant Intervals... Opens the Dissonant Intervals Detection dialog box, allowing you
to automatically Detect and resolve Dissonant (harsh sounding)
Intervals between a selected Note Event and Notes occurring at
the same time in Line Blocks of other Tracks.

Quantize... Opens the Quantize dialog box, allowing you to automatically
correct the start time of selected Note Events.

Transpose... Opens the Transpose dialog box, allowing you to shift the Pitch
of all selected Note Events equally.

Adjust Articulation... Opens the Articulation Adjustment dialog box, allowing you to
change the length of selected Note Events.

Adjust Velocity... Opens the Velocity Adjustment dialog box, allowing you to
change the loudness of selected Note Events.

Map Pitches.... Opens the Map Pitches dialog box, allowing you to shift the MIDI
Pitch value of selected Note Events.

Adjust Value... Opens the Value Adjustment dialog box, allowing you to adjust
the value of selected MIDI Control Events.

Half Time Halves the time value of a selected Note Event, doubling its
Playback Tempo.

Double Time Doubles the time value of a selected Note Event, halving its
Playback Tempo.
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Menu Items for the Event List Editor

  

Description The MIDI menu allows you to control the CAMPS Sequencer Engine and manage MIDI signals.

 Many of these Menu Items won't be available unless a Document is open.

 

Items Playback Starts Audition Playback of the currently selected Note
Events with an automatically inserted Playback Loop. If no
individual Note Events are selected, CAMPS begins
Playback of the entire selected Line Block.

 If the Chord Track is activated, Chords in the same Bar
region will be also played back.

Playback with Others Starts Audition Playback of the currently selected Note
Events with an automatically inserted Playback Loop along
with all the other activated Tracks in the same Bar region. If
no individual Note Events are selected, CAMPS begins
Playback of the entire selected Line Block.

 If the Chord Track is activated, Chords in the same Bar
region will be also played back.

Play Starts Playback of the current Document.

Stop Stops Playback of the current Document.

Record/Start Recording Starts Recording in the current Document.

Record/Start Over-dubbing Starts Over-Dub Recording in the current Document.

Record/Start Step Recording Starts Step Recording in the current Document.

Jump To/Top Moves the Playback Pointer position and viewpoint to the
beginning of the current Line Block Event List. Executing this
command also enables the Auto Scroll function if previously
disabled.

Jump To/End Moves the Playback Pointer position and viewpoint to the
end of the current Line Block Event List. Executing this
command also enables the Auto Scroll function if previously
disabled.

Metronome Switches between activate or deactivate the Metronome
during Playback and Recording. A checkmark appears next
to this item when activated.

All Notes Off Sends the "All Notes Off" MIDI Event to current MIDI
Devices. Use this command to stop unwanted sustained
Notes after stopping Playback or inadvertently interrupting
MIDI signaling.



Reset All Controllers Sends the "Reset All Controllers" MIDI Event to current MIDI
Devices. Use this command to reset certain MIDI parameters
such as Volume, Pan or Modulation.

Synchronize With/Internal Clock Sets CAMPS to Playback and Record using its own internal
MIDI Clock. A bullet appears next to the current selection.

Synchronize With/Tap Sets CAMPS to Playback and Record using "freewheel"
Tempo pulses input by you on your computer's keyboard or
your MIDI Instrument. A bullet appears next to the current
selection.

Synchronize With/MIDI Clock Sets CAMPS to Playback and Record in "slave" mode using
an external MIDI Clock source, such as another Sequencer.
A bullet appears next to the current selection.

Synchronize With/SMPTE Sets CAMPS to Playback and Record using MIDI Time Code
converted from an external SMPTE Time Code source, such
as a click track from an audio or video tape deck. A SMPTE
converter must be employed between a raw SMPTE source
and the MIDI port used by CAMPS. A bullet appears next to
the current selection.

Transmit Clock/MIDI Clock Enables CAMPS to send its MIDI Clock signal to an external
device. When using this setting in conjunction with Internal
Clock Sync, CAMPS Plays and Records in "Master" mode,
allowing an external Sequencer to synchronize with CAMPS.
A checkmark appears next to this item when enabled.

Transmit Clock/SMPTE Enables CAMPS to send MIDI Time Code to an external
SMPTE converter. When using this setting in conjunction
with Internal Clock Sync, CAMPS Plays and Records in
"Master" mode, allowing an external Sequencer or other
device to synchronize with CAMPS. A checkmark appears
next to this item when enabled.

MIDI Mapper Switches between enable or disable the Windows Operating
System MIDI Mapper. When enabled, CAMPS passes MIDI
Output Device selection control to the Windows Multimedia
applet in the Control Panel. When disabled, MIDI Output
Devices can be selected from within CAMPS, allowing much
greater flexibility. A checkmark appears next to this item
when enabled.

MIDI Setup... Opens the MIDI Setup dialog box, allowing you to manage
many MIDI signaling details. This includes settings for input,
output, sync and Devices.
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Menu Items for the Event List Editor

  

Description The View menu allows you to select objects to display and how to display them. Use Save
Display Settings to save the current display settings of the Event List Editor for its next session.

 Many of these Menu Items won't be available unless a Document is open. Also, some of
these Menu Items will only be available when the Event List Editor is active.

 

Items Event View/Note Switches between Show or Hide Note Events in the Event
List Editor. A checkmark appears next to this Menu Item
when set to Show.

Event View/Control Change Switches between Show or Hide Control Change Events
in the Event List Editor. A checkmark appears next to this
Menu Item when set to Show.

Event View/Poly After Touch Switches between Show or Hide Poly After Touch Events
in the Event List Editor. A checkmark appears next to this
Menu Item when set to Show.

Event View/Channel After Touch Switches between Show or Hide Channel After Touch
Events in the Event List Editor. A checkmark appears
next to this Menu Item when set to Show.

Event View/Program Change Switches between Show or Hide Program Change Events
in the Event List Editor. A checkmark appears next to this
Menu Item when set to Show.

Event View/Pitch Bend Switches between Show or Hide Pitch Bend Events in the
Event List Editor. A checkmark appears next to this Menu
Item when set to Show.

Event View/Lyric Switches between Show or Hide Lyric Events in the Event
List Editor. A checkmark appears next to this Menu Item
when set to Show.

Event View/System Exclusive Switches between Show or Hide System Exclusive
Events in the Event List Editor. A checkmark appears
next to this Menu Item when set to Show.

Event View/Select Event Types... Opens the Displayed Events dialog box, allowing you to
choose which MIDI Event types are displayed in the
Event List Editor using Icon buttons instead of Menu
Items. These settings are the same as the List View
submenu items listed above.

Toolbars/Main Toolbar Switches between Show or Hide the Main toolbar. A
checkmark appears next to this Menu item when set to
Show.

Toolbars/Status Bar Switches between Show or Hide the Status Bar. A
checkmark appears next to this Menu item when set to
Show.



Toolbars/Playback Control Toolbar Switches between Show or Hide the Playback Control
toolbar. A checkmark appears next to this Menu item
when set to Show.

Toolbars/Record Control Toolbar Switches between Show or Hide the Record Control
toolbar. A checkmark appears next to this Menu item
when set to Show.

Toolbars/Clock Sync Toolbar Switches between Show or Hide the Clock Sync toolbar.
A checkmark appears next to this Menu item when set to
Show.

Toolbars/Device Control Toolbar Switches between Show or Hide the Device Control
toolbar. A checkmark appears next to this Menu item
when set to Show.

Toolbars/Tempo Toolbar Switches between Show or Hide the Tempo toolbar. A
checkmark appears next to this Menu item when set to
Show.

Toolbars/Note Stamp Toolbar Switches between Show or Hide the Note Stamp toolbar.
A checkmark appears next to this Menu item when set to
Show.

Toolbars/Rest Toolbar Switches between Show or Hide the Rest toolbar. A
checkmark appears next to this Menu item when set to
Show.

Toolbars/Beat Toolbar Switches between Show or Hide the Beat toolbar. A
checkmark appears next to this Menu item when set to
Show.

Toolbars/Time Toolbar Switches between Show or Hide the Time toolbar. A
checkmark appears next to this Menu item when set to
Show.

Auto Scroll Sets the viewable area to follow the Playback Pointer. A
checkmark appears next to this item when enabled.

Jump To Location... Opens the Jump To Location dialog box, allowing you to
specify the beginning Bar of the viewable area. Once
specified, Auto Scroll is temporarily deactivated.

Edit Buttons Switches between Show or Hide the Edit Buttons in the
Event List Editor window. A checkmark appears next to
this Menu item when set to Show.

Interactive Information Switches between Show or Hide the Interactive
Information display. A checkmark appears next to this
Menu item when set to Show.

Big Beat Window Switches between Show or Hide the Big Beat Window. A
checkmark appears next to this Menu Item when set to
Show. When Showing, you can drag this Window to
desired location, or use its Close button to hide it again.
See details. See also Beat Toolbar..



Big Time Window Switches between Show or Hide the Big Time Window. A
checkmark appears next to this Menu Item when set to
Show. When Showing, you can drag this Window to
desired location, or use its Close button to hide it again.
See details. See also Time Toolbar..

Save Display Settings Saves current Event List Editor Display Settings as
defaults for future sessions. Settings included are List,
Zoom, Dividing Bar positions, Background Bitmap, etc.
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Menu Items for the Event List Editor

  

Description The Editors menu allows you to open Editors.

 None of these Menu Items will be available unless a Document is open.

 

Items Event List Editor Opens a new Event List Editor window, allowing you to make alternate
Event edits in the selected Line Block in vertical list format.

Pianoroll Editor Opens the Pianoroll Editor, allowing you to edit Notes of the selected Line
Block in Pianoroll graph format.

Control Draw Editor Opens the Control Draw Editor, allowing you to edit MIDI Control events
of the selected Line Block with a unique freestyle curve drawing method.

Notation Editor Opens the Notation Editor, allowing you to edit Notes of the selected Line
Block in Musical Notation form.

Tempo List Editor Opens the Tempo List Editor, allowing you to edit individual Tempo
Events of the current Document in vertical list format.

Tempo Draw Editor Opens the Tempo Draw Editor, allowing you to edit Tempo Events of the
current Document with a unique freestyle curve drawing method.

Text List Editor Opens the Text List Editor, allowing you to edit Text Events of the current
Document in vertical list format.
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Menu Items for the Event List Editor

  

Description The Window menu allows you to arrange Document and Editor windows in the work area of the
CAMPS Application Window.

 The Window Menu Item won't be available unless a Document is open.

 

Items New Event List Editor Opens a new Event List Editor window for the currently selected Line
Block.

Cascade Arranges windows in a diagonal overlapping manner, allowing you to
individually select them. Any maximized windows will be reduced in size
to accommodate the Cascade arrangement.

Tile Arranges windows into horizontal blocks separated vertically, one above
or below the next.

Arrange Icons Arranges minimized window title bars in an orderly fashion within the
CAMPS Application Window.

[Window] Makes the window named here currently active, appearing in front of
any others. The number of windows listed here equals the number of
open windows in CAMPS. A checkmark appears next to the current
selection.
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Menu Items for the Event List Editor

  

Description The Help menu allows you to access these Help documents. The Help menu also allows you to
add a background text message to your Composition Document and the currently selected Line
Block.

 The Memo Menu Items won't be available unless a Document is open.

 

Items Help Opens the Table of Contents for these Help documents.

Line Block Memo... Opens the Memo dialog box, allowing you to add an underlying text
message to the currently selected Line Block.

Document Memo... Opens the Memo dialog box, allowing you to add an underlying text
message to your Document.

About CAMPS Opens the CAMPS banner with a text scroll area containing information
about CAMPS and the Microworks Corporation.
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Menu Items

  

Description Here is a complete list of Menu Items when the Notation Editor is active.

 

Items

 File    

 New  Ctrl + N  

 New Setup...  Ctrl + Shift + N 
 Open...  Ctrl + O  
 Close    
   
 Save  Ctrl + S  
 Save As...    
 Revert    
   
 Export SMF...    
   
 1  [Recent Document]   
 2  [Recent Document]   
   :    
   
 Exit     

 Edit    
 Undo [Action] Event  Ctrl + Z  

  
 Cut Note Event  Ctrl + X 
 Copy Note Event  Ctrl + C 
 Paste Note Event  Ctrl + V 

 Clear Note Event  Del  
 Select All  Ctrl + A 
  
 Time Signature Setup...   

 SMPTE Offset Setup...    
  
 Preferences...    

 Line    
 Take  >  
  
 Compose...  Ctrl + Shift + K 
 EZcompose  Ctrl + K  
  

 Voicing...    
 Detect Dissonant Intervals...   
  
 Quantize...    

 Transpose...    
 Adjust Articulation...    
 Adjust Velocity...    
 Map Pitches....    
  
 Half Time    
 Double Time    

 

 Take    
 Take List...  Ctrl + F  
  
 New Take...  Ctrl + T  
 Duplicate Take Ctrl + U 
 Remove Take    
  
 [Take #1]    



 MIDI    

 Playback    
 Playback with Others   
  
 Play    

 Stop    
 Record  >  
 Jump To  >  
  
 Metronome  Ctrl +M  
  
 All Notes Off    

 Reset All Controllers    
  
 Synchronize With  >  

 Transmit Clock  >  
  
 MIDI Mapper    
 MIDI Setup...    

 

 Record    
 Start Recording  F5 

 Start Over-dubbing  F7 
 Start Step Recording F8 

 

 Jump To   
 Top  Home 

 End  End  

 

 Synchronize With 
 Internal Clock  

 Tap  
 MIDI Clock  
 SMPTE  

 

 Transmit Clock 
 MIDI Clock  
 SMPTE  

 View    

 Clef  >  
 Chord View  >  
 Note View  >  
 Grid View  >  
 Toolbars  >  
  
 Auto Scroll  Ctrl +L 
 Jump To Location...    
  
 Edit Buttons    
 Interactive Information   
  
 Big Beat Window    
 Big Time Window    
  
 Save Display Settings    

 

 Clef  
 Treble  

 Octave Treble  
 Bass  
 Sub Bass  
 Soprano  
 Alto  
 Tenor  
  
 [Drums Notation Set]  
  
 Display Defined Notes Only 
 Drums Notation Setup...  

 

 Chord View  
 Roman Numeral 

 Chord Name  
 Scale Name  
 Scale Spelling  
 Key and Mode  

 

 Note View  
 Smart Notation  
  
 Quarter Note Resolution 

 8th Note Resolution  
 16th Note Resolution  
 32nd Note Resolution  
   
 Triplet Resolution  
 Quintuplet Resolution  

 

 Grid View  
 Align To Grid 

 Grid Setup  

 

 Toolbars  
 Main Toolbar  

 Status Bar  
  
 Playback Control Toolbar 
 Record Control Toolbar  
  
 Clock Sync Toolbar  
 Device Control Toolbar  
 Tempo Toolbar  
  
 Note Stamp Toolbar  
 Rest Toolbar  
  
 Beat Toolbar  
 Time Toolbar  

 Editors    

 Event List Editor  F9  
 Pianoroll Editor  F10 
 Control Draw Editor F11 
 Notation Editor  F12 
  
 Tempo List Editor    
 Tempo Draw Editor    
  
 Text List Editor    
  
 Tool  >  

 

 Tool  
 Arrow  

 I Beam  
 Magic Wand 
 Stamp  
 Eraser  

 Window  

 
New
Notation
Editor

 

 Cascade  
 Tile  
 

Arrange
Icons  

  
 1 [Window] 
 2 [Window] 
   :  



 Help  

 Help  
  
 Line Block Memo... 
 Document Memo...  
  
 About CAMPS  
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Menu Items for the Notation Editor

  

Description The File menu allows you to manage Document files and shut down CAMPS.

 Some of these Menu Items won't be available unless a Document is open. Additionally, the
Save and Revert commands won't be available until the current Document has been altered.

 

Items New Creates a New untitled Document as specified by the settings in the New
Document Setup dialog box.

New Setup... Opens the New Document Setup dialog box, allowing you to set basic
defaults for New Documents.

Open... Opens the Open dialog box, allowing you to select and open a Document.

 When opening a Standard MIDI File, CAMPS automatically analyzes
Line data and assigns appropriate Line Blocks and one of six Category
settings to each Track. You can alter these settings at any time.

Close Closes the current Document. If this Document has been altered since
opening, you will be asked whether or not you wish to save changes
before closing.

Save Saves the current Document using its existing filename and location.

Save As... Opens the Save As dialog box, allowing you to save the current Document
to a specified filename and location.

Revert Allows you to close and reopen the current Document in one step,
discarding any changes made after last saving it. You'll be asked if you're
sure you want to proceed before this operation is completed.

Export SMF... Opens the Exporting a Standard MIDI File dialog box, allowing you to save
the current Document as a Standard MIDI File. After specifying a filename
and location and clicking Save, the Export Options dialog box opens,
allowing you to make final file format conversion settings.

[Recent Document] Opens the recently opened Document named here. The number of Recent
Documents listed here is adjustable in the Preferences dialog box which
can be opened from the Edit menu.

Exit Closes CAMPS and any open Documents. If any currently open
Documents have been altered since opening, you will be asked whether or
not you wish to save changes before closing.
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Menu Items for the Notation Editor

  

Description The Edit menu allows you to Edit Notes in the Notation Editor. For example, you can Cut, Copy,
Paste, and Clear Notes.

 Many of these Menu Items won't be available unless a Document is open, and the Notation
Editor is currently active with a Note selected.

 

Items Undo [Action] Event Reverses your last editing action. This command's name and function
change depending on your last action. For example, if you just moved
a Note, this command's name becomes Undo Move Event. Once
executed, the Undo command becomes Redo and vice versa.

Cut Note Event Removes selected Note from a Document for reinsertion using the
Paste command, if desired.

Copy Note Event Specifies selected Note for duplication using the Paste command.

Paste Note Event Inserts the last Note specified with the Cut or Copy command into the
currently selected relative Area.

Clear Note Event Deletes the currently selected Notes.

Select All Automatically selects all Notes in the currently selected region or
Area.

Time Signature Setup... Opens the Time Signature Setup dialog box, allowing you to change
the Time Signature in a specified region of Bars.

SMPTE Offset Setup... Opens the SMPTE Offset Setup dialog box, allowing you to offset
SMPTE synchronization between CAMPS and a master SMPTE
source.

Preferences... Opens the Preferences dialog box, allowing you to set basic
operational and appearance defaults in CAMPS.
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Menu Items for the Notation Editor

  

Description The Line menu allows you to edit and manipulate Line Data (Notes), including managing Takes.

 The Line menu won't be available unless a Document is open. Additionally, most of these
Menu Items won't be available unless a Note is selected.

 

Items Take/Take List... Opens the Take List dialog box, allowing you to manipulate
Takes for the selected Line Block.

Take/New Take... Opens the New Take dialog box, allowing you to create a New
blank or Auto Composed Take for the selected Line Block.

Take/Duplicate Take Duplicates the currently selected Take.

Take/Remove Take Deletes the currently selected Take. This command is only
available when a Take other than the original is selected.

Take/[Take #1] Makes the Take named here currently active, appearing in front
of any others. A bullet appears next to the current selection.

Compose... Opens the Compose dialog box, allowing you to adjust guidelines
for Auto Composing, and to Auto Compose selected Notes.

EZcompose Automatically Composes selected Notes without opening the
Compose dialog box.

Voicing... Opens the Voicing dialog box, allowing you to automatically
analyze selected Notes along with relevant Chords to provide
you with various kinds of voicings for your Line data.

Detect Dissonant Intervals... Opens the Dissonant Intervals Detection dialog box, allowing you
to automatically Detect and resolve Dissonant (harsh sounding)
Intervals between selected Notes and Notes occurring at the
same time in Line Blocks of other Tracks.

Quantize... Opens the Quantize dialog box, allowing you to automatically
correct the start time of selected Notes.

Transpose... Opens the Transpose dialog box, allowing you to shift the Pitch
of all selected Notes equally.

Adjust Articulation... Opens the Articulation Adjustment dialog box, allowing you to
change the length of selected Notes.

Adjust Velocity... Opens the Velocity Adjustment dialog box, allowing you to
change the loudness of selected Notes.

Map Pitches.... Opens the Map Pitches dialog box, allowing you to shift the MIDI
Pitch value of all occurrences of selected Notes in selected Line
data.

Half Time Halves the time value of selected Notes, doubling their Playback
Tempo.

Double Time Doubles the time value of selected Notes, halving their Playback
Tempo.
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Menu Items for the Notation Editor

  

Description The MIDI menu allows you to control the CAMPS Sequencer Engine and manage MIDI signals.

 Many of these Menu Items won't be available unless a Document is open.

 

Items Playback Starts Audition Playback of the currently selected Notes with
an automatically inserted Playback Loop. If no Note Events
are selected, CAMPS begins Playback from the currently
selected Line Block with no Loop.

 If the Chord Track is activated, Chords in the same Bar
region will be also played back.

Playback with Others Starts Audition Playback of the currently selected Notes with
an automatically inserted Playback Loop along with all the
other activated Tracks in the same Bar region. If no Note
Events are selected, CAMPS begins Playback from the
currently selected Line Block with no Loop.

 If the Chord Track is activated, Chords in the same Bar
region will be also played back.

Play Starts Playback of the current Document.

Stop Stops Playback of the current Document.

Record/Start Recording Starts Recording in the current Document.

Record/Start Over-dubbing Starts Over-Dub Recording in the current Document.

Record/Start Step Recording Starts Step Recording in the current Document.

Jump To/Top Moves the Playback Pointer position and viewpoint to the
beginning of the currently selected Line Block. Executing this
command also enables the Auto Scroll function if previously
disabled.

Jump To/End Moves the Playback Pointer position and viewpoint to the
end of the currently selected Line Block. Executing this
command also enables the Auto Scroll function if previously
disabled.

Metronome Switches between activate or deactivate the Metronome
during Playback and Recording. A checkmark appears next
to this item when activated.

All Notes Off Sends the "All Notes Off" MIDI Event to current MIDI
Devices. Use this command to stop unwanted sustained
Notes after stopping Playback or inadvertently interrupting
MIDI signaling.



Reset All Controllers Sends the "Reset All Controllers" MIDI Event to current MIDI
Devices. Use this command to reset certain MIDI parameters
such as Volume, Pan or Modulation.

Synchronize With/Internal Clock Sets CAMPS to Playback and Record using its own internal
MIDI Clock. A bullet appears next to the current selection.

Synchronize With/Tap Sets CAMPS to Playback and Record using "freewheel"
Tempo pulses input by you on your computer's keyboard or
your MIDI Instrument. A bullet appears next to the current
selection.

Synchronize With/MIDI Clock Sets CAMPS to Playback and Record in "slave" mode using
an external MIDI Clock source, such as another Sequencer.
A bullet appears next to the current selection.

Synchronize With/SMPTE Sets CAMPS to Playback and Record using MIDI Time Code
converted from an external SMPTE Time Code source, such
as a click track from an audio or video tape deck. A SMPTE
converter must be employed between a raw SMPTE source
and the MIDI port used by CAMPS. A bullet appears next to
the current selection.

Transmit Clock/MIDI Clock Enables CAMPS to send its MIDI Clock signal to an external
device. When using this setting in conjunction with Internal
Clock Sync, CAMPS Plays and Records in "Master" mode,
allowing an external Sequencer to synchronize with CAMPS.
A checkmark appears next to this item when enabled.

Transmit Clock/SMPTE Enables CAMPS to send MIDI Time Code to an external
SMPTE converter. When using this setting in conjunction
with Internal Clock Sync, CAMPS Plays and Records in
"Master" mode, allowing an external Sequencer or other
device to synchronize with CAMPS. A checkmark appears
next to this item when enabled.

MIDI Mapper Switches between enable or disable the Windows Operating
System MIDI Mapper. When enabled, CAMPS passes MIDI
Output Device selection control to the Windows Multimedia
applet in the Control Panel. When disabled, MIDI Output
Devices can be selected from within CAMPS, allowing much
greater flexibility. A checkmark appears next to this item
when enabled.

MIDI Setup... Opens the MIDI Setup dialog box, allowing you to manage
many MIDI signaling details. This includes settings for input,
output, sync and Devices.
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Menu Items for the Notation Editor

  

Description The View menu allows you to select objects to display and how to display them. Use Save
Display Settings to save the current display settings of the Notation Editor for its next session.

 Many of these Menu Items won't be available unless a Document is open. Also, some of
these Menu Items will only be available when the Notation Editor is active.

 

Items Clef/Treble Sets the Notation Staff to display Note Pitch for Tonal
Tracks in Treble Clef. This allows you to bring Notation
display within the Staff if the current Register of Notes
(Pitch range) falls too far above or below the Staff in
Leger Lines. A bullet appears next to the current
selection.

Clef/Octave Treble Sets the Notation Staff to display Note Pitch for Tonal
Tracks in Octave Treble Clef. This allows you to bring
Notation display within the Staff if the current Register of
Notes (Pitch range) falls too far above or below the Staff
in Leger Lines. A bullet appears next to the current
selection.

Clef/Bass Sets the Notation Staff to display Note Pitch for Tonal
Tracks in Bass Clef. This allows you to bring Notation
display within the Staff if the current Register of Notes
(Pitch range) falls too far above or below the Staff in
Leger Lines. A bullet appears next to the current
selection.

Clef/Sub Bass Sets the Notation Staff to display Note Pitch for Tonal
Tracks in Sub Bass Clef. This allows you to bring Notation
display within the Staff if the current Register of Notes
(Pitch range) falls too far above or below the Staff in
Leger Lines. A bullet appears next to the current
selection.

Clef/Soprano Sets the Notation Staff to display Note Pitch for Tonal
Tracks in Soprano Clef. This allows you to bring Notation
display within the Staff if the current Register of Notes
(Pitch range) falls too far above or below the Staff in
Leger Lines. A bullet appears next to the current
selection.

Clef/Alto Sets the Notation Staff to display Note Pitch for Tonal
Tracks in Alto Clef. This allows you to bring Notation
display within the Staff if the current Register of Notes
(Pitch range) falls too far above or below the Staff in
Leger Lines. A bullet appears next to the current
selection.



Clef/Tenor Sets the Notation Staff to display Note Pitch for Tonal
Tracks in Tenor Clef. This allows you to bring Notation
display within the Staff if the current Register of Notes
(Pitch range) falls too far above or below the Staff in
Leger Lines. A bullet appears next to the current
selection.

Clef/[Drums Notation Set] Sets the Notation Staff to display Drum Notes according
to your definitions in the Drums Notation Setup dialog
box. The default Drums Notation Set is "GM 5 Lines". A
bullet appears next to the current selection.

Clef/Display Defined Notes Only This setting filters out Notation display of any notes that
are not defined in the currently selected Drums Notation
Set. This item is only available when a Drums Notation
Set has been chosen for the Clef View. A checkmark
appears next to this item when selected.

Clef/Drums Notation Setup... Opens the Drums Notation Setup dialog box, allowing you
to define the Notation of individual Drum Sounds.

Chord View/Roman Numeral Sets display of Chord Text to Roman Numeral Analysis
(II-7, V7, etc.). A bullet appears next to the current
selection.

Chord View/Chord Name Sets display of Chord Text to Chord Name (D-7, G7, etc.).
A bullet appears next to the current selection.

Chord View/Scale Name Sets display of Chord Text to Scale Name, also known as
Mode (Dorian, Mixolydian, etc.). A bullet appears next to
the current selection.

Chord View/Scale Spelling Sets display of Chord Text to Scale Spelling, listing
intervals from the Root (R, 3,5,7, etc.). A bullet appears
next to the current selection.

Chord View/Key and Mode Sets display of Chord Text to Key and Mode; the same as
each Chord Container's Key and Mode button. A bullet
appears next to the current selection.

Note View/Smart Notation This setting allows you to adjust Rest time calculation to
avoid excessive Rest displays in the Notation Editor. For
example, if the current Resolution setting is Eighth Note,
any Rest period less than an Eight Note will be added to
the previous Note to avoid display of an additional Rest. A
checkmark appears next to this item when selected.

Note View/Quarter Note Resolution Sets Note duration display to resolve to the nearest
Quarter Note, allowing the most possible number of Bars
to fit in the Notation Editor window with the lowest time
Notation accuracy.

Note View/8th Note Resolution Sets Note duration display to resolve to the nearest 8th
Note, allowing more Bars to fit in the Notation Editor
window with the less time Notation accuracy (compared
to the 16th Note Resolution setting).

Note View/16th Note Resolution Sets Note duration display to resolve to the nearest 16th
Note, allowing less Bars to fit in the Notation Editor
window with the more time Notation accuracy (compared
to the 8th Note Resolution setting).



Note View/32nd Note Resolution Sets Note duration display to resolve to the nearest 32nd
Note, allowing the least possible number of Bars to fit in
the Notation Editor window with the highest time Notation
accuracy.

Note View/Triplet Resolution Sets Note duration display to resolve to the nearest Note
Resolution selected from Quarter, 8th, 16th, 32nd Note or
corresponding Triplet.

Note View/Quintuplet Resolution Sets Note duration display to resolve to the nearest Note
Resolution selected from Quarter, 8th, 16th, 32nd Note or
corresponding Quintuplet.

Grid View/Align to Grid Switches between Activate or Deactivate Align To Grid in
the Pianoroll and Velocity Areas. The Align To Grid
function causes Notes being created or moved to snap
their position to the nearest Grid point as specified in the
Grid Setup dialog box. Depending on your settings in the
Grid Setup dialog box, this Alignment Grid will not
necessarily coincide with the visual Bar or Beat Grids
described above. A checkmark appears next to this Menu
Item when set to Activate.

Grid View/Grid Setup... Opens the Grid Setup dialog box, allowing you to adjust
the Alignment Grid Resolution for certain Areas of the
Notation Editor and other Editors.

Toolbars/Main Toolbar Switches between Show or Hide the Main toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Status Bar Switches between Show or Hide the Status Bar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Playback Control Toolbar Switches between Show or Hide the Playback Control
toolbar. A checkmark appears next to this Menu Item
when set to Show.

Toolbars/Record Control Toolbar Switches between Show or Hide the Record Control
toolbar. A checkmark appears next to this Menu Item
when set to Show.

Toolbars/Clock Sync Toolbar Switches between Show or Hide the Clock Sync toolbar.
A checkmark appears next to this Menu Item when set to
Show.

Toolbars/Device Control Toolbar Switches between Show or Hide the Device Control
toolbar. A checkmark appears next to this Menu Item
when set to Show.

Toolbars/Tempo Toolbar Switches between Show or Hide the Tempo toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Note Stamp Toolbar Switches between Show or Hide the Note Stamp toolbar.
A checkmark appears next to this Menu Item when set to
Show.



Toolbars/Rest Toolbar Switches between Show or Hide the Rest toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Beat Toolbar Switches between Show or Hide the Beat toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Time Toolbar Switches between Show or Hide the Time toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Auto Scroll Sets the viewable area in the Bar, Text Info, Chord, Lyric,
and Notation Areas to follow the Playback Pointer. A
checkmark appears next to this item when enabled.

Jump To Location... Opens the Jump To Location dialog box, allowing you to
specify the beginning Bar of the viewable area. Once
specified, Auto Scroll is temporarily deactivated.

Edit Buttons Switches between Show or Hide the Edit Buttons in the
Notation Editor. A checkmark appears next to this Menu
Item when set to Show.

Interactive Information Switches between Show or Hide the Interactive
Information display. A checkmark appears next to this
Menu Item when set to Show.

Big Beat Window Switches between Show or Hide the Big Beat Window. A
checkmark appears next to this Menu Item when set to
Show. When Showing, you can drag this Window to
desired location, or use its Close button to hide it again.
See details. See also Beat Toolbar..

Big Time Window Switches between Show or Hide the Big Time Window. A
checkmark appears next to this Menu Item when set to
Show. When Showing, you can drag this Window to
desired location, or use its Close button to hide it again.
See details. See also Time Toolbar..

Save Display Settings Saves current Notation Editor Display Settings as defaults
for future sessions. Settings included are Grid,
Resolution, Dividing Bar positions, Background Bitmap,
etc.
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Menu Items for the Notation Editor

  

Description The Editors menu allows you to open Editors and select Editing Tools.

 None of these Menu Items will be available unless a Document is open.

 

Items Event List Editor Opens the Event List Editor, allowing you to edit individual Events of the
selected Line Block in vertical list format.

Pianoroll Editor Opens the Pianoroll Editor, allowing you to edit Notes of the selected Line
Block in Pianoroll graph format.

Control Draw Editor Opens the Control Draw Editor, allowing you to edit MIDI Control events
of the selected Line Block with a unique freestyle curve drawing method.

Notation Editor Opens a new Notation Editor window, allowing you to make alternate
Musical Notation edits of Notes in the selected Line Block.

Tempo List Editor Opens the Tempo List Editor, allowing you to edit individual Tempo
Events of the current Document in vertical list format.

Tempo Draw Editor Opens the Tempo Draw Editor, allowing you to edit Tempo Events in the
current Document with a unique freestyle curve drawing method.

Text List Editor Opens the Text List Editor, allowing you to edit Text Events of the current
Document in vertical list format.

Tool/Arrow Allows you to select and manipulate Notes in the Notation Editor.

Tool/I Beam Allows you to quickly select regions in the Note Area of the Notation
Editor.

Tool/Magic Wand Allows you to quickly Auto Compose existing Notes in the Notation Editor.

Tool/Stamp Allows you to quickly create Notes using a point and click method.

Tool/Eraser Allows you to quickly delete Notes.

 



Menu Items for the Notation Editor / Window  
Menu Items

Menu Items for the Notation Editor

  

Description The Window menu allows you to arrange Document and Editor windows in the work area of the
CAMPS Application Window.

 The Window Menu Item won't be available unless a Document is open.

 

Items New Notation Editor Opens a new Notation Editor for the currently selected Line Block.

Cascade Arranges windows in a diagonal overlapping manner, allowing you to
individually select them. Any maximized windows will be reduced in size
to accommodate the Cascade arrangement.

Tile Arranges windows into horizontal blocks separated vertically, one above
or below the next.

Arrange Icons Arranges minimized window title bars in an orderly fashion within the
CAMPS Application Window.

[Window] Makes the window named here currently active, appearing in front of any
others. The number of windows listed here equals the number of open
windows in CAMPS. A checkmark appears next to the current selection.
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Menu Items for the Notation Editor

  

Description The Help menu allows you to access these Help documents. The Help menu also allows you to
add a background text message to your Composition Document and the currently selected Line
Block.

 The Memo Menu Items won't be available unless a Document is open.

 

Items Help Opens the Table of Contents for these Help documents.

Line Block Memo... Opens the Memo dialog box, allowing you to add an underlying text
message to the currently selected Line Block.

Document Memo... Opens the Memo dialog box, allowing you to add an underlying text
message to your Document.

About CAMPS Opens the CAMPS banner with a text scroll area containing information
about CAMPS and the Microworks Corporation.
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Menu Items

  

Description Here is a complete list of Menu Items when the Pianoroll Editor is active.

 

Items
 File    

 New  Ctrl + N  

 New Setup...  Ctrl + Shift + N 
 Open...  Ctrl + O  
 Close    
   
 Save  Ctrl + S  
 Save As...    
 Revert    
   
 Export SMF...    
   
 1  [Recent Document]   
 2  [Recent Document]   
   :    
   
 Exit     

 Edit    
 Undo [Action] [Object]  Ctrl + Z  

  
 Cut [Object]  Ctrl + X 
 Copy [Object]  Ctrl + C 
 Paste [Object]  Ctrl + V 

 Clear [Object]  Del  
 Select All  Ctrl + A 
  
 New [Object]...  Ctrl + I  
 Duplicate [Object]  Ctrl + D 
  
 Bring To Front    

 Send To Back    
  
 Time Signature Setup...   

 SMPTE Offset Setup...    
  
 Preferences...    

 Chord    
 Generate...  Ctrl + Shift + G 
 EZgenerate  Ctrl + G  
  
 Harmonize...  Ctrl + Shift + H 
 EZharmonize  Ctrl + H  
 EZharmonize with Same Key    
  
 Detect from MIDI Instrument...   

 Construct...    
  
 EZcompose Lines in Region  Ctrl + R  



 Line    
 Take  >  
  
 Compose...  Ctrl + Shift + K 
 EZcompose  Ctrl + K  
  

 Voicing...    
 Detect Dissonant Intervals...   
  
 Quantize...    

 Transpose...    
 Adjust Articulation...    
 Adjust Velocity...    
 Map Pitches....    
  
 Half Time    
 Double Time    

 

 Take    
 Take List...  Ctrl + F  
  
 New Take...  Ctrl + T  
 Duplicate Take Ctrl + U 
 Remove Take    
  
 [Take #1]    

 MIDI    

 Playback    
 Playback with Others   
  
 Play    

 Stop    
 Record  >  
 Jump To  >  
  

 Metronome  Ctrl
+M

 

  
 All Notes Off    

 Reset All Controllers    
  
 Synchronize With  >  

 Transmit Clock  >  
  
 MIDI Mapper    
 MIDI Setup...    

 

 Record    
 Start Recording  F5 

 Start Over-dubbing  F7 
 Start Step Recording F8 

 

 Jump To   
 Top  Home 

 End  End  

 

 Synchronize With 
 Internal Clock  

 Tap  
 MIDI Clock  
 SMPTE  

 

 Transmit Clock 
 MIDI Clock  
 SMPTE  

 View    

 Chord View  >  
 Note View  >  
 Grid View  >  
 Toolbars  >  
 Zoom  >  
  
 Auto Scroll  Ctrl +L 
 Jump To Location...    
  
 Edit Buttons    
 Interactive Information   
  
 Big Beat Window    
 Big Time Window    
  
 Background Bitmap    
  
 Save Display Settings    

 

 Chord View  
 Roman Numeral 

 Chord Name  
 Scale Name  
 Scale Spelling  
 Key and Mode  

 

 Note View  
 All Pitches  

 Scale Notes  
 Chord Tones 
 Avoid Notes  

 

 Grid View  
 Bar Grid  

 Beat Grid  
 Pitch Grid  
 Velocity Grid  
  
 Align To Grid 
 Grid Setup...  

 

 Toolbars  
 Main Toolbar  

 Status Bar  
  
 Playback Control Toolbar 
 Record Control Toolbar  
  
 Clock Sync Toolbar  
 Device Control Toolbar  
 Tempo Toolbar  
  
 Note Stamp Toolbar  
 Rest Toolbar  
  
 Beat Toolbar  
 Time Toolbar  

 

 Zoom  
 Zoom Out (V) 

 Zoom In (V)  
 Zoom Out (H) 
 Zoom In (H)  



 Editors    

 Event List Editor  F9  
 Pianoroll Editor  F10 
 Control Draw Editor F11 
 Notation Editor  F12 
  
 Tempo List Editor    
 Tempo Draw Editor    
  
 Text List Editor    
  
 Tool  >  

 

 Tool  
 Arrow  

 I Beam  
 Pen  
 Magic Wand 
 Line  
 Oval  
 Stamp  
 Eraser  
 Razor  

 Window  

 
New
Pianoroll
Editor

 

 Cascade  
 Tile  
 

Arrange
Icons  

  
 1 [Window] 
 2 [Window] 
   :  

 Help  

 Help  
  
 Line Block Memo... 
 Document Memo...  
  
 About CAMPS  
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Menu Items for the Pianoroll Editor

  

Description The File menu allows you to manage Document files and shut down CAMPS.

 Some of these Menu Items won't be available unless a Document is open. Additionally, the
Save and Revert commands won't be available until the current Document has been altered.

 

Items New Creates a New untitled Document as specified by the settings in the New
Document Setup dialog box.

New Setup... Opens the New Document Setup dialog box, allowing you to set basic
defaults for New Documents.

Open... Opens the Open dialog box, allowing you to select and open a Document.

 When opening a Standard MIDI File, CAMPS automatically analyzes
Line data and assigns appropriate Line Blocks and one of six Category
settings to each Track. You can alter these settings at any time.

Close Closes the current Document. If this Document has been altered since
opening, you will be asked whether or not you wish to save changes
before closing.

Save Saves the current Document using its existing filename and location.

Save As... Opens the Save As dialog box, allowing you to save the current Document
to a specified filename and location.

Revert Allows you to close and reopen the current Document in one step,
discarding any changes made after last saving it. You'll be asked if you're
sure you want to proceed before this operation is completed.

Export SMF... Opens the Exporting a Standard MIDI File dialog box, allowing you to save
the current Document as a Standard MIDI File. After specifying a filename
and location and clicking Save, the Export Options dialog box opens,
allowing you to make final file format conversion settings.

[Recent Document] Opens the recently opened Document named here. The number of Recent
Documents listed here is adjustable in the Preferences dialog box which
can be opened from the Edit menu.

Exit Closes CAMPS and any open Documents. If any currently open
Documents have been altered since opening, you will be asked whether or
not you wish to save changes before closing.
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Menu Items for the Pianoroll Editor

  

Description The Edit menu allows you to Edit objects in the Pianoroll Editor. For example, you can Cut,
Copy, Paste, and Clear objects in the Text Info, Chord, Lyric and Line Areas of the Pianoroll
Editor.

 Many of these Menu Items won't be available unless a Document is open. Most also require
a related object first be selected. Finally, most of these Menu Items change depending on the
last object or Area selected in the Pianoroll Editor.

 

Items Undo [Action] [Object] Reverses your last editing action. This command's name and function
change depending on your last action. For example, if you just moved
a Chord, this command's name becomes Undo Move Chord. Once
executed, the Undo command becomes Redo and vice versa.

Cut [Object] Removes selected object from a Document for reinsertion using the
Paste command, if desired. This command's name and function
change depending on your last selection. For example, if you just
selected a Chord, this command's name becomes Cut Chord.

Copy [Object] Specifies selected object for duplication using the Paste command.
This command's name and function change depending on your last
selection. For example, if you just selected a Chord, this command's
name becomes Copy Chord.

Paste [Object] Inserts the last object specified with the Cut or Copy command into
the currently selected relative Area. This command's name and
function change depending on your last action. For example, if you
just Cut a Chord and selected a region in a Chord Block, this
command's name becomes Paste Chord.

Clear [Object] Deletes the currently selected objects.

Select All Automatically selects all relative objects in the currently selected
region or Area. For example, if you just selected a Chord, Select All
selects the rest of the Chords in the current Chord Block.

New [Object]... Opens an appropriate dialog box, allowing you to create a New object.
This command's name and function change depending on your last
selection. For example, if you just selected a Chord, this command's
name becomes New Chord... and opens the New Chord dialog box.

Duplicate [Object] Immediately creates a Duplicate of a selected object. This command's
name and function change depending on your last selection. For
example, if you just selected a Chord, this command's name becomes
Duplicate Chord.

Bring To Front Brings the currently selected overlapping Chord Block or Line Block to
the foreground. In the case of Chord Blocks, this command also
makes the selected Chord Block active.

Send To Back Sends the currently selected overlapping Chord Block or Line Block to
the background. In the case of Chord Blocks, this command also
makes the selected Chord Block inactive.



Time Signature Setup... Opens the Time Signature Setup dialog box, allowing you to change
the Time Signature in a specified region of Bars.

SMPTE Offset Setup... Opens the SMPTE Offset Setup dialog box, allowing you to offset
SMPTE synchronization between CAMPS and a master SMPTE
source.

Preferences... Opens the Preferences dialog box, allowing you to set basic
operational and appearance defaults in CAMPS.
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Menu Items for the Pianoroll Editor

  

Description The Chord menu allows you to automatically or manually assign Chords to your Composition
Document. CAMPS in turn uses these Chord definitions for Auto Composing and other functions.

 The Chord menu won't be available unless a Document is open. Many also require a related
object first be selected.

 

Items Generate... Opens the Generate Chord Progression dialog box which uses
existing Key and Mode as well as Chord Function settings to
generate alternatives for selected Chords.

EZgenerate Automatically generates new Chords for selected Chords using
existing Key and Mode as well as Chord Function settings
without opening the Generate Chord Progression dialog box.

Harmonize... Opens the Harmonize dialog box which uses existing Line and
Chord data to provide choices for creating Chords and
adjusting Key and Mode.

EZharmonize Automatically creates Chords and adjusts Key and Mode using
existing Line and Chord data without opening the Harmonize
dialog box.

EZharmonize with Same Key Automatically creates new Chords in existing Key and Mode
using selected Line data without opening the Harmonize dialog
box.

Detect from MIDI Instrument... Opens the Chord Detection dialog box, allowing you to "spell"
desired Chord on your MIDI Instrument to replace selected
Chords.

Construct... Opens the Chord Construction dialog box, allowing you to
manually build a desired Chord from lists of components to
replace selected Chords.

EZcompose Lines in Region Automatically Composes Line data in the region of selected
Chords.
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Menu Items for the Pianoroll Editor

  

Description The Line menu allows you to edit and manipulate Line data, including managing Takes.

 The Line menu won't be available unless a Document is open. Additionally, most of these
Menu Items won't be available unless a Line Block is selected.

 

Items Take/Take List... Opens the Take List dialog box, allowing you to manipulate
Takes for the selected Line Block.

Take/New Take... Opens the New Take dialog box, allowing you to create a New
blank or Auto Composed Take for the selected Line Block.

Take/Duplicate Take Duplicates the currently selected Take.

Take/Remove Take Deletes the currently selected Take. This command is only
available when a Take other than the original is selected.

Take/[Take #1] Makes the Take named here currently active, appearing in front
of any others. A bullet appears next to the current selection.

Compose... Opens the Compose dialog box, allowing you to adjust guidelines
for Auto Composing, and to Auto Compose selected Notes.

EZcompose Automatically Composes selected Notes without opening the
Compose dialog box.

Voicing... Opens the Voicing dialog box, allowing you to automatically
analyze the selected Note data along with relevant Chords to
provide you with various kinds of voicings for Notes in the
selected Line Block.

Detect Dissonant Intervals... Opens the Dissonant Intervals Detection dialog box, allowing you
to automatically Detect and resolve Dissonant (harsh sounding)
Intervals between selected Notes and Notes occurring at the
same time in Line Blocks of other Tracks.

Quantize... Opens the Quantize dialog box, allowing you to automatically
correct the start time of selected Notes.

Transpose... Opens the Transpose dialog box, allowing you to shift the Pitch
of all selected Notes equally.

Adjust Articulation... Opens the Articulation Adjustment dialog box, allowing you to
change the length of selected Notes.

Adjust Velocity... Opens the Velocity Adjustment dialog box, allowing you to
change the loudness of Notes in the selected Line Block.

Map Pitches.... Opens the Map Pitches dialog box, allowing you to shift the MIDI
Pitch value of all occurrences of specified Notes in selected Line
data.

Half Time Halves the time value of selected Notes, doubling their Playback
Tempo.



Double Time Doubles the time value of selected Notes, halving their Playback
Tempo.
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Menu Items for the Pianoroll Editor

  

Description The MIDI menu allows you to control the CAMPS Sequencer Engine and manage MIDI signals.

 Many of these Menu Items won't be available unless a Document is open.

 

Items Playback Starts Audition Playback of the currently selected Note
Events with an automatically inserted Playback Loop. If no
individual Note Events are selected, CAMPS begins
Playback from the currently selected Line Block with no
Loop.

 If the Chord Track is activated, Chords in the same Bar
region will be also played back.

Playback with Others Starts Audition Playback of the currently selected Note
Events with an automatically inserted Playback Loop along
with all the other activated Tracks in the same Bar region. If
no individual Note Events are selected, CAMPS begins
Playback from the currently selected Line Block with no
Loop.

 If the Chord Track is activated, Chords in the same Bar
region will be also played back.

Play Starts Playback of the current Document.

Stop Stops Playback of the current Document.

Record/Start Recording Starts Recording in the current Document.

Record/Start Over-dubbing Starts Over-Dub Recording in the current Document.

Record/Start Step Recording Starts Step Recording in the current Document.

Jump To/Top Moves the Playback Pointer position and viewpoint to the
beginning of the currently selected Line Block. Executing this
command also enables the Auto Scroll function if previously
disabled.

Jump To/End Moves the Playback Pointer position and viewpoint to the
end of the currently selected Line Block. Executing this
command also enables the Auto Scroll function if previously
disabled.

Metronome Switches between activate or deactivate the Metronome
during Playback and Recording. A checkmark appears next
to this item when activated.

All Notes Off Sends the "All Notes Off" MIDI Event to current MIDI
Devices. Use this command to stop unwanted sustained
Notes after stopping Playback or inadvertently interrupting
MIDI signaling.



Reset All Controllers Sends the "Reset All Controllers" MIDI Event to current MIDI
Devices. Use this command to reset certain MIDI parameters
such as Volume, Pan or Modulation.

Synchronize With/Internal Clock Sets CAMPS to Playback and Record using its own internal
MIDI Clock. A bullet appears next to the current selection.

Synchronize With/Tap Sets CAMPS to Playback and Record using "freewheel"
Tempo pulses input by you on your computer's keyboard or
your MIDI Instrument. A bullet appears next to the current
selection.

Synchronize With/MIDI Clock Sets CAMPS to Playback and Record in "slave" mode using
an external MIDI Clock source, such as another Sequencer.
A bullet appears next to the current selection.

Synchronize With/SMPTE Sets CAMPS to Playback and Record using MIDI Time Code
converted from an external SMPTE Time Code source, such
as a click track from an audio or video tape deck. A SMPTE
converter must be employed between a raw SMPTE source
and the MIDI port used by CAMPS. A bullet appears next to
the current selection.

Transmit Clock/MIDI Clock Enables CAMPS to send its MIDI Clock signal to an external
device. When using this setting in conjunction with Internal
Clock Sync, CAMPS Plays and Records in "Master" mode,
allowing an external Sequencer to synchronize with CAMPS.
A checkmark appears next to this item when enabled.

Transmit Clock/SMPTE Enables CAMPS to send MIDI Time Code to an external
SMPTE converter. When using this setting in conjunction
with Internal Clock Sync, CAMPS Plays and Records in
"Master" mode, allowing an external Sequencer or other
device to synchronize with CAMPS. A checkmark appears
next to this item when enabled.

MIDI Mapper Switches between enable or disable the Windows Operating
System MIDI Mapper. When enabled, CAMPS passes MIDI
Output Device selection control to the Windows Multimedia
applet in the Control Panel. When disabled, MIDI Output
Devices can be selected from within CAMPS, allowing much
greater flexibility. A checkmark appears next to this item
when enabled.

MIDI Setup... Opens the MIDI Setup dialog box, allowing you to manage
many MIDI signaling details. This includes settings for input,
output, sync and Devices.
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Menu Items for the Pianoroll Editor

  

Description The View menu allows you to select objects to display and how to display them. Use Save
Display Settings to save the current display settings of the Pianoroll Editor for its next session.

 Many of these Menu Items won't be available unless a Document is open.

 

Items Chord View/Roman Numeral Sets display of Chord Containers to Roman Numeral
Analysis (II-7, V7, etc.). A bullet appears next to the
current selection.

Chord View/Chord Name Sets display of Chord Containers to Chord Name (D-7,
G7, etc.). A bullet appears next to the current selection.

Chord View/Scale Name Sets display of Chord Containers to Scale Name, also
known as Mode (Dorian, Mixolydian, etc.). A bullet
appears next to the current selection.

Chord View/Scale Spelling Sets display of Chord Containers to Scale Spelling, listing
intervals from the Root (R, 3,5,7, etc.). A bullet appears
next to the current selection.

Chord View/Key and Mode Sets display of Chord Containers to Key and Mode; the
same as each Chord Container's Key and Mode button. A
bullet appears next to the current selection.

Note View/All Pitches Sets Pianoroll Area background to display all horizontal
Pitch areas without any additional background
designation. A bullet appears next to the current
selection.

Note View/Scale Notes Sets Pianoroll Area background to display a light gray
background color to differentiate between Scale Notes
and other Notes. A bullet appears next to the current
selection.

Note View/Chord Tones Sets Pianoroll Area background to display a light gray
background color to differentiate between Chord Tones
and other Notes. A bullet appears next to the current
selection.

Note View/Avoid Notes Sets Pianoroll Area background to display a light gray
background color to differentiate between Avoid Notes
and other Notes. A bullet appears next to the current
selection.

Grid View/Bar Grid Switches between Show or Hide the Bar Grid in the Text
Info, Chord, Lyric, Pianoroll and Velocity Areas. The Bar
Grid is a pattern of evenly spaced vertical lines marking
horizontal divisions between Bars (Measures) for visual
reference. A checkmark appears next to this Menu Item
when set to Show.



Grid View/Beat Grid Switches between Show or Hide the Beat Grid in the Text
Info, Chord, Lyric, Pianoroll and Velocity Areas. The Beat
Grid is a pattern of evenly spaced vertical lines marking
horizontal divisions between Beats in each Bar for visual
reference. A checkmark appears next to this Menu Item
when set to Show.

Grid View/Pitch Grid Switches between Show or Hide the Pitch Grid in the
Pianoroll Area. The Note Grid is a pattern of evenly
spaced horizontal lines marking vertical divisions between
MIDI Pitches for visual reference. A checkmark appears
next to this Menu Item when set to Show.

Grid View/Velocity Grid Switches between Show or Hide the Velocity Grid in the
Velocity Area. The Velocity Grid is a pattern of evenly
spaced horizontal lines marking vertical divisions between
MIDI Velocity values for visual reference. A checkmark
appears next to this Menu Item when set to Show.

Grid View/Align to Grid Switches between Activate or Deactivate Align To Grid in
the Pianoroll and Velocity Areas. The Align To Grid
function causes Notes being created or moved to snap
their position to the nearest Grid point as specified in the
Grid Setup dialog box. Depending on your settings in the
Grid Setup dialog box, this Alignment Grid will not
necessarily coincide with the visual Bar or Beat Grids
described above. A checkmark appears next to this Menu
Item when set to Activate.

Grid View/Grid Setup... Opens the Grid Setup dialog box, allowing you to adjust
the Alignment Grid Resolution for certain Areas of the
Pianoroll Editor and other Editors.

Toolbars/Main Toolbar Switches between Show or Hide the Main toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Status Bar Switches between Show or Hide the Status Bar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Playback Control Toolbar Switches between Show or Hide the Playback Control
toolbar. A checkmark appears next to this Menu Item
when set to Show.

Toolbars/Record Control Toolbar Switches between Show or Hide the Record Control
toolbar. A checkmark appears next to this Menu Item
when set to Show.

Toolbars/Clock Sync Toolbar Switches between Show or Hide the Clock Sync toolbar.
A checkmark appears next to this Menu Item when set to
Show.

Toolbars/Device Control Toolbar Switches between Show or Hide the Device Control
toolbar. A checkmark appears next to this Menu Item
when set to Show.



Toolbars/Tempo Toolbar Switches between Show or Hide the Tempo toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Note Stamp Toolbar Switches between Show or Hide the Note Stamp toolbar.
A checkmark appears next to this Menu Item when set to
Show.

Toolbars/Rest Toolbar Switches between Show or Hide the Rest toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Beat Toolbar Switches between Show or Hide the Beat toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Time Toolbar Switches between Show or Hide the Time toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Zoom/Zoom Out (V) Incrementally decreases the Vertical size of the Pianoroll
Area, increasing its viewable area.

Zoom/Zoom In (V) Incrementally increases the Vertical size of the Pianoroll
Areas, decreasing its viewable area.

Zoom/Zoom Out (H) Incrementally decreases the Horizontal size of the Bar,
Text Info, Chord, Lyric Pianoroll and Velocity Areas,
increasing their viewable area.

Zoom/Zoom In (H) Incrementally increases the Horizontal size of the Bar,
Text Info, Chord, Lyric, Pianoroll and Velocity Areas,
decreasing their viewable area.

Auto Scroll Sets the viewable area in the Bar, Text Info, Chord, Lyric,
Pianoroll and Velocity Areas to follow the Playback
Pointer. A checkmark appears next to this item when
enabled.

Jump To Location... Opens the Jump To Location dialog box, allowing you to
specify the beginning Bar of the viewable area. Once
specified, Auto Scroll is temporarily deactivated.

Edit Buttons Switches between Show or Hide the Edit Buttons in the
Pianoroll Editor. A checkmark appears next to this Menu
Item when set to Show.

Interactive Information Switches between Show or Hide the Interactive
Information display. A checkmark appears next to this
Menu Item when set to Show.

Big Beat Window Switches between Show or Hide the Big Beat Window. A
checkmark appears next to this Menu Item when set to
Show. When Showing, you can drag this Window to
desired location, or use its Close button to hide it again.
See details. See also Beat Toolbar..



Big Time Window Switches between Show or Hide the Big Time Window. A
checkmark appears next to this Menu Item when set to
Show. When Showing, you can drag this Window to
desired location, or use its Close button to hide it again.
See details. See also Time Toolbar..

Background Bitmap Switches between Show or Hide a Background Bitmap
image. A checkmark appears next to this Menu Item
when set to Show. This item will only be available if a
Background Bitmap image is specified in the Preferences
dialog box.

Save Display Settings Saves current Pianoroll Editor Display Settings as
defaults for future sessions. Settings included are Grid,
Zoom, Dividing Bar positions, Background Bitmap, etc.

 



Menu Items for the Pianoroll Editor / Editors  
Menu Items

Menu Items for the Pianoroll Editor

  

Description The Editors menu allows you to open Editors and select Editing Tools.

 None of these Menu Items will be available unless a Document is open. Also, a line Block
must be selected for these items to be available.

 

Items Event List Editor Opens the Event List Editor, allowing you to edit individual Events of the
selected Line Block in vertical list format.

Pianoroll Editor Opens a new Pianoroll Editor window, allowing you to make alternate
edits in the selected Line Block.

Control Draw Editor Opens the Control Draw Editor, allowing you to edit MIDI Control events
of the selected Line Block with a unique freestyle curve drawing method.

Notation Editor Opens the Notation Editor, allowing you to edit Notes of the selected Line
Block in Musical Notation form.

Tempo List Editor Opens the Tempo List Editor, allowing you to edit individual Tempo
Events of the current Document in vertical list format.

Tempo Draw Editor Opens the Tempo Draw Editor, allowing you to edit Tempo Events of the
current Document with a unique freestyle curve drawing method.

Text List Editor Opens the Text List Editor, allowing you to edit Text Events of the current
Document in vertical list format.

Tool/Arrow Allows you to select and manipulate objects in the Pianoroll Editor.

Tool/I Beam Allows you to quickly select regions in the Note and Velocity Areas of the
Pianoroll Editor.

Tool/Pen Allows you to quickly create Notes and edit multiple Velocity Events using
a freestyle drawing method.

Tool/Magic Wand Allows you to quickly create Chord Blocks or Line Blocks with
automatically filled-in data (EZgenerate).

Tool/Line Allows you to quickly create Notes and edit multiple Velocity Events using
a straight line drawing method.

Tool/Oval Allows you to quickly create Notes using a straight line drawing method,
and edit multiple Velocity Events using an automatic curve drawing
method.

Tool/Stamp Allows you to quickly create Notes using a point and click or straight line
drawing method, and allows you to edit multiple Velocity Events using a
freestyle drawing method.

Tool/Eraser Allows you to quickly delete objects.

Tool/Razor Allows you to quickly split a Chord Block at any point.
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Menu Items for the Pianoroll Editor

  

Description The Window menu allows you to arrange Document and Editor windows in the work area of the
CAMPS Application Window.

 The Window Menu Item won't be available unless a Document is open.

 

Items New Pianoroll Editor Opens a new Pianoroll Editor for the currently selected Line Block.

Cascade Arranges windows in a diagonal overlapping manner, allowing you to
individually select them. Any maximized windows will be reduced in size
to accommodate the Cascade arrangement.

Tile Arranges windows into horizontal blocks separated vertically, one above
or below the next.

Arrange Icons Arranges minimized window title bars in an orderly fashion within the
CAMPS Application Window.

[Window] Makes the window named here currently active, appearing in front of any
others. The number of windows listed here equals the number of open
windows in CAMPS. A checkmark appears next to the current selection.
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Menu Items for the Pianoroll Editor

  

Description The Help menu allows you to access these Help documents. The Help menu also allows you to
add a background text message to your Composition Document and the currently selected Line
Block.

 The Memo Menu Items won't be available unless a Document is open.

 

Items Help Opens the Table of Contents for these Help documents.

Line Block Memo... Opens the Memo dialog box, allowing you to add an underlying text
message to the currently selected Line Block.

Document Memo... Opens the Memo dialog box, allowing you to add an underlying text
message to your Document.

About CAMPS Opens the CAMPS banner with a text scroll area containing information
about CAMPS and the Microworks Corporation.
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Menu Items

  

Description Here is a complete list of Menu Items when the Tempo Draw Editor is active.

 

Items

 File    

 New  Ctrl + N  

 New Setup...  Ctrl + Shift + N 
 Open...  Ctrl + O  
 Close    
   
 Save  Ctrl + S  
 Save As...    
 Revert    
   
 Export SMF...    
   
 1  [Recent Document]   
 2  [Recent Document]   
   :    
   
 Exit     

 Edit    
 Undo [Action] [Object]  Ctrl + Z  

  
 Cut Tempo Event  Ctrl + X 
 Copy Tempo Event  Ctrl + C 
 Paste Tempo Event  Ctrl + V 

 Clear Tempo Event  Del  
 Select All  Ctrl + A 
  
 Duplicate Tempo Event Ctrl + D 
  

 Time Signature Setup...   
 SMPTE Offset Setup...    
  
 Preferences...    

 Line  
 Adjust Value... 



 MIDI    

 Play    

 Stop    
 Jump To  >  
  
 Metronome  Ctrl +M 
  
 All Notes Off    

 Reset All Controllers   
  
 Synchronize With  >  

 Transmit Clock  >  
  
 MIDI Mapper    
 MIDI Setup...    

 

 Jump To   
 Top  Home 

 End  End  

 

 Synchronize With 
 Internal Clock  

 Tap  
 MIDI Clock  
 SMPTE  

 

 Transmit Clock 
 MIDI Clock  
 SMPTE  

 View    

 Tempo View  >  
 Grid View  >  
 Toolbars  >  
 Zoom  >  
  
 Auto Scroll  Ctrl +L 
 Jump To Location...    
  
 Edit Buttons    
 Interactive Information   
  
 Big Beat Window    
 Big Time Window    
  
 Background Bitmap    
  
 Save Display Settings    

 

 Tempo View  
 Half Note  

 Quarter Note 
 8th Note  
 16th Note  

 

 Grid View  
 Bar Grid  

 Beat Grid  
 Value Grid  
  
 Align To Grid 
 Grid Setup...  

 

 Toolbars  
 Main Toolbar  

 Status Bar  
  
 Playback Control Toolbar 
 Record Control Toolbar  
  
 Clock Sync Toolbar  
 Device Control Toolbar  
 Tempo Toolbar  
  
 Note Stamp Toolbar  
 Rest Toolbar  
  
 Beat Toolbar  
 Time Toolbar  

 

 Zoom  
 Zoom Out (H) 
 Zoom In (H)  

 Editors    

 Tempo List Editor    
 Tempo Draw Editor   
  
 Text List Editor    
  
 Tool  > 

 

 Tool  
 Arrow  

 I Beam 
 Pen  
 Line  
 Oval  
 Eraser  



 Window  

 
New Tempo
Draw Editor  

 Cascade  
 Tile  
 

Arrange
Icons  

  
 1 [Window] 
 2 [Window] 
   :  

 Help  

 Help  
  
 Document Memo... 
  
 About CAMPS  
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Menu Items for the Tempo Draw Editor

  

Description The File menu allows you to manage Document files and shut down CAMPS.

 Some of these Menu Items won't be available unless a Document is open. Additionally, the
Save and Revert commands won't be available until the current Document has been altered.

 

Items New Creates a New untitled Document as specified by the settings in the New
Document Setup dialog box.

New Setup... Opens the New Document Setup dialog box, allowing you to set basic
defaults for New Documents.

Open... Opens the Open dialog box, allowing you to select and open a Document.

 When opening a Standard MIDI File, CAMPS automatically analyzes
Line data and assigns appropriate Line Blocks and one of six Category
settings to each Track. You can alter these settings at any time.

Close Closes the current Document. If this Document has been altered since
opening, you will be asked whether or not you wish to save changes
before closing.

Save Saves the current Document using its existing filename and location.

Save As... Opens the Save As dialog box, allowing you to save the current Document
to a specified filename and location.

Revert Allows you to close and reopen the current Document in one step,
discarding any changes made after last saving it. You'll be asked if you're
sure you want to proceed before this operation is completed.

Export SMF... Opens the Export Standard MIDI File dialog box, allowing you to save the
current Document as a Standard MIDI File. After specifying a filename and
location and clicking Save, the Export Options dialog box opens, allowing
you to make final file format conversion settings.

[Recent Document] Opens the recently opened Document named here. The number of Recent
Documents listed here is adjustable in the Preferences dialog box which
can be opened from the Edit menu.

Exit Closes CAMPS and any open Documents. If any currently open
Documents have been altered since opening, you will be asked whether or
not you wish to save changes before closing.
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Menu Items for the Tempo Draw Editor

  

Description The Edit menu allows you to Edit objects in the Tempo Draw Editor. For example, you can Cut,
Copy, Paste, and Clear objects in the Text Info and Draw Areas of the Tempo Draw Editor.

 Many of these Menu Items won't be available unless a Document is open. Most also require
a related object first be selected. Finally, most of these Menu Items change depending on the
last object or Area selected in the Tempo Draw Editor.

 

Items Undo [Action] [Object] Reverses your last editing action. This command's name and function
change depending on your last action. For example, if you just moved
a Tempo Event, this command's name becomes Undo Move Event.
Once executed, the Undo command becomes Redo and vice versa.

Cut [Object] Removes selected object from a Document for reinsertion using the
Paste command, if desired. This command's name and function
change depending on your last selection. For example, if you just
selected a Tempo Event, this command's name becomes Cut Tempo
Event.

Copy [Object] Specifies selected object for duplication using the Paste command.
This command's name and function change depending on your last
selection. For example, if you just selected a Tempo Event, this
command's name becomes Copy Tempo Event.

Paste [Object] Inserts the last object specified with the Cut or Copy command into
the currently selected relative Area. This command's name and
function change depending on your last action. For example, if you
just Cut a Tempo Event and selected a region in the Draw Area, this
command's name becomes Paste Tempo Event.

Clear [Object] Deletes the currently selected objects.

Select All Automatically selects all relative objects in the currently selected
region or Area. For example, if you just selected a region in the Draw
Area, Select All selects all the Tempo Events in the Draw Area.

Duplicate [Object] Immediately creates a Duplicate of a selected object. This command's
name and function change depending on your last selection. For
example, if you just selected a Tempo Event, this command's name
becomes Duplicate Tempo Event.

Time Signature Setup... Opens the Time Signature Setup dialog box, allowing you to change
the Time Signature in a specified region of Bars.

SMPTE Offset Setup... Opens the SMPTE Offset Setup dialog box, allowing you to offset
SMPTE synchronization between CAMPS and a master SMPTE
source.

Preferences... Opens the Preferences dialog box, allowing you to set basic
operational and appearance defaults in CAMPS.
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Menu Items for the Tempo Draw Editor

  

Description The Line menu allows you to edit and manipulate Line Tempo Event data.

 The Line menu won't be available unless a Document is open.

 

Items Adjust Value... Opens the Value Adjustment dialog box, allowing you to adjust the value of
selected MIDI Tempo Events.
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Menu Items for the Tempo Draw Editor

  

Description The MIDI menu allows you to control the CAMPS Sequencer Engine and manage MIDI signals.

 Many of these Menu Items won't be available unless a Document is open.

 

Items Play Starts Playback of the current Document.

Stop Stops Playback of the current Document.

Jump To/Top Moves the Playback Pointer position and viewpoint to the
beginning of the current Document. Executing this command
also enables the Auto Scroll function if previously disabled.

Jump To/End Moves the Playback Pointer position and viewpoint to the
end of the current Document. Executing this command also
enables the Auto Scroll function if previously disabled.

Metronome Switches between activate or deactivate the Metronome
during Playback and Recording. A checkmark appears next
to this item when activated.

All Notes Off Sends the "All Notes Off" MIDI Event to current MIDI
Devices. Use this command to stop unwanted sustained
Notes after stopping Playback or inadvertently interrupting
MIDI signaling.

Reset All Controllers Sends the "Reset All Controllers" MIDI Event to current MIDI
Devices. Use this command to reset certain MIDI parameters
such as Volume, Pan or Modulation.

Synchronize With/Internal Clock Sets CAMPS to Playback and Record using its own internal
MIDI Clock. A bullet appears next to the current selection.

Synchronize With/Tap Sets CAMPS to Playback and Record using "freewheel"
Tempo pulses input by you on your computer's keyboard or
your MIDI Instrument. A bullet appears next to the current
selection.

Synchronize With/MIDI Clock Sets CAMPS to Playback and Record in "slave" mode using
an external MIDI Clock source, such as another Sequencer.
A bullet appears next to the current selection.

Synchronize With/SMPTE Sets CAMPS to Playback and Record using MIDI Time Code
converted from an external SMPTE Time Code source, such
as a click track from an audio or video tape deck. A SMPTE
converter must be employed between a raw SMPTE source
and the MIDI port used by CAMPS. A bullet appears next to
the current selection.

Transmit Clock/MIDI Clock Enables CAMPS to send its MIDI Clock signal to an external
device. When using this setting in conjunction with Internal
Clock Sync, CAMPS Plays and Records in "Master" mode,
allowing an external Sequencer to synchronize with CAMPS.
A checkmark appears next to this item when enabled.



Transmit Clock/SMPTE Enables CAMPS to send MIDI Time Code to an external
SMPTE converter. When using this setting in conjunction
with Internal Clock Sync, CAMPS Plays and Records in
"Master" mode, allowing an external Sequencer or other
device to synchronize with CAMPS. A checkmark appears
next to this item when enabled.

MIDI Mapper Switches between enable or disable the Windows Operating
System MIDI Mapper. When enabled, CAMPS passes MIDI
Output Device selection control to the Windows Multimedia
applet in the Control Panel. When disabled, MIDI Output
Devices can be selected from within CAMPS, allowing much
greater flexibility. A checkmark appears next to this item
when enabled.

MIDI Setup... Opens the MIDI Setup dialog box, allowing you to manage
many MIDI signaling details. This includes settings for input,
output, sync and Devices.
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Menu Items for the Tempo Draw Editor

  

Description The View menu allows you to select objects to display and how to display them. Use Save
Display Settings to save the current display settings of the Tempo Draw Editor for its next
session.

 Many of these Menu Items won't be available unless a Document is open. Also, some of
these Menu Items will only be available when the Tempo Draw Editor is active.

 

Items Tempo View/Half Note Sets the vertical Value scale in the Draw Area of the
Tempo Draw Editor to use a Half Note time value as a
basis, i.e. Half Note = 75 Beats Per Minute. A bullet
appears next to the current selection.

Tempo View/Quarter Note Sets the vertical Value scale in the Draw Area of the
Tempo Draw Editor to use a Quarter Note time value as a
basis (standard Metronome scale), i.e. Quarter Note =
150 Beats Per Minute. A bullet appears next to the
current selection.

Tempo View/8th Note Sets the vertical Value scale in the Draw Area of the
Tempo Draw Editor to use an 8th Note time value as a
basis, i.e. 8th Note = 300 Beats Per Minute. A bullet
appears next to the current selection.

Tempo View/16th Note Sets the vertical Value scale in the Draw Area of the
Tempo Draw Editor to use a 16th Note time value as a
basis, i.e. 16th Note = 600 Beats Per Minute. A bullet
appears next to the current selection.

Grid View/Bar Grid Switches between Show or Hide the Bar Grid in the Text
Info and Draw Areas. The Bar Grid is a pattern of evenly
spaced vertical lines marking horizontal divisions between
Bars (Measures) for visual reference. A checkmark
appears next to this Menu Item when set to Show.

Grid View/Beat Grid Switches between Show or Hide the Beat Grid in the Text
Info and Draw Areas. The Beat Grid is a pattern of evenly
spaced vertical lines marking horizontal divisions between
Beats in each Bar for visual reference. A checkmark
appears next to this Menu Item when set to Show.

Grid View/Value Grid Switches between Show or Hide the Value Grid in the
Draw Area. The Value Grid is a pattern of evenly spaced
horizontal lines marking vertical divisions between MIDI
Tempo Event data Values for visual reference. A
checkmark appears next to this Menu Item when set to
Show.



Grid View/Align to Grid Switches between Activate or Deactivate Align To Grid in
the Draw Area. The Align To Grid function causes Tempo
Events being created or moved to snap their position to
the nearest Grid point as specified in the Grid Setup
dialog box. Depending on your settings in the Grid Setup
dialog box, this Alignment Grid will not necessarily
coincide with the visual Bar or Beat Grids described
above. A checkmark appears next to this Menu Item
when set to Activate.

Grid View/Grid Setup... Opens the Grid Setup dialog box, allowing you to adjust
the Alignment Grid Resolution for the Text Info and Draw
Areas of the Tempo Draw Editor and various Areas of
other Editors.

Toolbars/Main Toolbar Switches between Show or Hide the Main toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Status Bar Switches between Show or Hide the Status Bar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Playback Control Toolbar Switches between Show or Hide the Playback Control
toolbar. A checkmark appears next to this Menu Item
when set to Show.

Toolbars/Record Control Toolbar Switches between Show or Hide the Record Control
toolbar. A checkmark appears next to this Menu Item
when set to Show.

Toolbars/Clock Sync Toolbar Switches between Show or Hide the Clock Sync toolbar.
A checkmark appears next to this Menu Item when set to
Show.

Toolbars/Device Control Toolbar Switches between Show or Hide the Device Control
toolbar. A checkmark appears next to this Menu Item
when set to Show.

Toolbars/Tempo Toolbar Switches between Show or Hide the Tempo toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Note Stamp Toolbar Switches between Show or Hide the Note Stamp toolbar.
A checkmark appears next to this Menu Item when set to
Show.

Toolbars/Rest Toolbar Switches between Show or Hide the Rest toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Beat Toolbar Switches between Show or Hide the Beat toolbar. A
checkmark appears next to this Menu Item when set to
Show.

Toolbars/Time Toolbar Switches between Show or Hide the Time toolbar. A
checkmark appears next to this Menu Item when set to
Show.



Zoom/Zoom Out (H) Incrementally decreases the Horizontal size of the Bar,
Text Info and Draw Areas, increasing their viewable area.

Zoom/Zoom In (H) Incrementally increases the Horizontal size of the Bar,
Text Info and Draw Areas, decreasing their viewable
area.

Auto Scroll Sets the viewable area in the Bar, Text Info and Draw
Areas to follow the Playback Pointer. A checkmark
appears next to this item when enabled.

Jump To Location... Opens the Jump To Location dialog box, allowing you to
specify the beginning Bar of the viewable area. Once
specified, Auto Scroll is temporarily deactivated.

Edit Buttons Switches between Show or Hide the Edit Buttons in the
Tempo Draw Editor. A checkmark appears next to this
Menu Item when set to Show.

Interactive Information Switches between Show or Hide the Interactive
Information display. A checkmark appears next to this
Menu Item when set to Show.

Big Beat Window Switches between Show or Hide the Big Beat Window. A
checkmark appears next to this Menu Item when set to
Show. When Showing, you can drag this Window to
desired location, or use its Close button to hide it again.
See details. See also Beat Toolbar..

Big Time Window Switches between Show or Hide the Big Time Window. A
checkmark appears next to this Menu Item when set to
Show. When Showing, you can drag this Window to
desired location, or use its Close button to hide it again.
See details. See also Time Toolbar..

Background Bitmap Switches between Show or Hide a Background Bitmap
image. A checkmark appears next to this Menu Item
when set to Show. This item will only be available if a
Background Bitmap image is specified in the Preferences
dialog box.

Save Display Settings Saves current Tempo Draw Editor Display Settings as
defaults for future sessions. Settings included are Grid,
Zoom, Dividing Bar positions, Background Bitmap, etc.

 



Menu Items for the Tempo Draw Editor / Editors  
Menu Items

Menu Items for the Tempo Draw Editor

  

Description The Editors menu allows you to open Editors and select Editing Tools.

 None of these Menu Items will be available unless a Document is open. Many also require a
related object first be selected.

 

Items Tempo List Editor Opens the Tempo List Editor, allowing you to edit individual Tempo Events
of the current Document in vertical list format.

Tempo Draw Editor Opens a new Tempo Draw Editor window, allowing you to make alternate
Tempo Event edits in the current Document differently.

Text List Editor Opens the Text List Editor, allowing you to edit Text Events of the current
Document in vertical list format.

Tool/Arrow Allows you to select and manipulate objects in the Tempo Draw Editor.

Tool/I Beam Allows you to quickly select regions in the Draw Area.

Tool/Pen Allows you to quickly create and edit Tempo Events using a freestyle
drawing method.

Tool/Line Allows you to quickly create and edit Tempo Events using a straight line
drawing method.

Tool/Oval Allows you to quickly create and edit Tempo Events using an automatic
curve drawing method.

Tool/Eraser Allows you to quickly delete objects.

 



Menu Items for the Tempo Draw Editor / Window  
Menu Items

Menu Items for the Tempo Draw Editor

  

Description The Window menu allows you to arrange Document and Editor windows in the work area of the
CAMPS Application Window.

 The Window Menu Item won't be available unless a Document is open.

 

Items New Tempo Draw Editor Opens a new Tempo Draw Editor window for the currently selected
Line Block.

Cascade Arranges windows in a diagonal overlapping manner, allowing you to
individually select them. Any maximized windows will be reduced in
size to accommodate the Cascade arrangement.

Tile Arranges windows into horizontal blocks separated vertically, one
above or below the next.

Arrange Icons Arranges minimized window title bars in an orderly fashion within the
CAMPS Application Window.

[Window] Makes the window named here currently active, appearing in front of
any others. The number of windows listed here equals the number of
open windows in CAMPS. A checkmark appears next to the current
selection.

 



Menu Items for the Tempo Draw Editor / Help  
Menu Items

Menu Items for the Tempo Draw Editor

  

Description The Help menu allows you to access these Help documents. The Help menu also allows you to
add a background text message to your Composition Document.

 The Memo Menu Items won't be available unless a Document is open.

 

Items Help Opens the Table of Contents for these Help documents.

Document Memo... Opens the Memo dialog box, allowing you to add an underlying text
message to your Document.

About CAMPS Opens the CAMPS banner with a text scroll area containing information
about CAMPS and the Microworks Corporation.

 



Menu Items for the Tempo List Editor  
Contents

Menu Items

  

Description Here is a complete list of the Menu Items when the Tempo List Editor is active.

 

Items

 File    

 New  Ctrl + N  

 New Setup...  Ctrl + Shift + N 
 Open...  Ctrl + O  
 Close    
   
 Save  Ctrl + S  
 Save As...    
 Revert    
   
 Export SMF...    
   
 1  [Recent Document]   
 2  [Recent Document]   
   :    
   
 Exit     

 Edit    
 Undo [Action] [Object]  Ctrl + Z  

  
 Cut Tempo Event  Ctrl + X 
 Copy Tempo Event  Ctrl + C 
 Paste Tempo Event  Ctrl + V 

 Clear Tempo Event  Del  
 Select All  Ctrl + A 
  
 New Tempo Event  Ctrl + I  
 Duplicate Tempo Event Ctrl + D 
  

 SMPTE Offset Setup...    
  
 Preferences...    

 Line  
 Adjust Value... 



 MIDI    

 Play    

 Stop    
 Jump To  >  
  
 Metronome  Ctrl +M 
  
 All Notes Off    

 Reset All Controllers   
  
 Synchronize With  >  

 Transmit Clock  >  
  
 MIDI Mapper    
 MIDI Setup...    

 

 Jump To   
 Top  Home 

 End  End  

 

 Synchronize With 
 Internal Clock  

 Tap  
 MIDI Clock  
 SMPTE  

 

 Transmit Clock 
 MIDI Clock  
 SMPTE  

 View    

 Toolbars  >  
  
 Auto Scroll  Ctrl +L 
 Jump To Location...    
  
 Edit Buttons    
 Interactive Information   
  
 Big Beat Window    
 Big Time Window    
  
 Save Display Settings    

 

 Toolbars  
 Main Toolbar  

 Status Bar  
  
 Playback Control Toolbar 
 Record Control Toolbar  
  
 Clock Sync Toolbar  
 Device Control Toolbar  
 Tempo Toolbar  
  
 Note Stamp Toolbar  
 Rest Toolbar  
  
 Beat Toolbar  
 Time Toolbar  

 Editors    

 Tempo List Editor    
 Tempo Draw Editor   
  
 Text List Editor    

 Window  

 
New Tempo
List Editor  

 Cascade  
 Tile  
 

Arrange
Icons  

  
 1 [Window] 
 2 [Window] 
   :  



 Help  

 Help  
  
 Document Memo... 
  
 About CAMPS  

 



Menu Items for the Tempo List Editor / File  
Menu Items

Menu Items for the Tempo List Editor

  

Description The File menu allows you to manage Document files and shut down CAMPS.

 Some of these Menu Items won't be available unless a Document is open. Additionally, the
Save and Revert commands won't be available until the current Document has been altered.

 

Items New Creates a New untitled Document as specified by the settings in the New
Document Setup dialog box.

New Setup... Opens the New Document Setup dialog box, allowing you to set basic
defaults for New Documents.

Open... Opens the Open dialog box, allowing you to select and open a Document.

 When opening a Standard MIDI File, CAMPS automatically analyzes
Line data and assigns appropriate Line Blocks and one of six Category
settings to each Track. You can alter these settings at any time.

Close Closes the current Document. If this Document has been altered since
opening, you will be asked whether or not you wish to save changes
before closing.

Save Saves the current Document using its existing filename and location.

Save As... Opens the Save As dialog box, allowing you to save the current Document
to a specified filename and location.

Revert Allows you to close and reopen the current Document in one step,
discarding any changes made after last saving it. You'll be asked if you're
sure you want to proceed before this operation is completed.

Export SMF... Opens the Export Standard MIDI File dialog box, allowing you to save the
current Document as a Standard MIDI File. After specifying a filename and
location and clicking Save, the Export Options dialog box opens, allowing
you to make final file format conversion settings.

[Recent Document] Opens the recently opened Document named here. The number of Recent
Documents listed here is adjustable in the Preferences dialog box which
can be opened from the Edit menu.

Exit Closes CAMPS and any open Documents. If any currently open
Documents have been altered since opening, you will be asked whether or
not you wish to save changes before closing.

 



Menu Items for the Tempo List Editor / Edit  
Menu Items

Menu Items for the Tempo List Editor

  

Description The Edit menu allows you to Edit MIDI Tempo Events in the Tempo List Editor. For example, you
can Cut, Copy, Paste and Clear Tempo Events.

 These Menu Items won't be available unless a Document is open and the Tempo List Editor
is currently active with a Tempo Event selected.

 

Items Undo [Action] [Object] Reverses your last editing action. This command's name and function
change depending on your last action. For example, if you just moved
a Tempo Event, this command's name becomes Undo Move Event.
Once executed, the Undo command becomes Redo and vice versa.

Cut Tempo Event Removes selected Tempo Event from a Document for reinsertion
using the Paste command, if desired.

Copy Tempo Event Specifies a Tempo Event for duplication using the Paste command.

Paste Tempo Event Inserts the last Tempo Event specified with the Cut or Copy command
into the currently selected region of the Tempo List.

Clear Tempo Event Deletes the currently selected Tempo Events.

Select All Automatically selects all Tempo Events in the List.

New Tempo Event Inserts a New Tempo Event at the selected location.

Duplicate Tempo Event Immediately creates a Duplicate of a selected Tempo Event.

SMPTE Offset Setup... Opens the SMPTE Offset Setup dialog box, allowing you to offset
SMPTE synchronization between CAMPS and a master SMPTE
source.

Preferences... Opens the Preferences dialog box, allowing you to set basic
operational and appearance defaults in CAMPS.

 



Menu Items for the Tempo List Editor / Line  
Menu Items

Menu Items for the Tempo List Editor

  

Description The Line menu allows you to edit and manipulate Line data.

 The Line menu won't be available unless a Document is open.

 

Items Adjust Value... Opens the Value Adjustment dialog box, allowing you to adjust the value of
selected MIDI Tempo Events.

 



Menu Items for the Tempo List Editor / MIDI  
Menu Items

Menu Items for the Tempo List Editor

  

Description The MIDI menu allows you to control the CAMPS Sequencer Engine and manage MIDI signals.

 Many of these Menu Items won't be available unless a Document is open.

 

Items Play Starts Playback of the current Document.

Stop Stops Playback of the current Document.

Jump To/Top Moves the Playback Pointer position and viewpoint to the
beginning of the current Document. Executing this command
also enables the Auto Scroll function if previously disabled.

Jump To/End Moves the Playback Pointer position and viewpoint to the
end of the current Document. Executing this command also
enables the Auto Scroll function if previously disabled.

Metronome Switches between activate or deactivate the Metronome
during Playback and Recording. A checkmark appears next
to this item when activated.

All Notes Off Sends the "All Notes Off" MIDI Event to current MIDI
Devices. Use this command to stop unwanted sustained
Notes after stopping Playback or inadvertently interrupting
MIDI signaling.

Reset All Controllers Sends the "Reset All Controllers" MIDI Event to current MIDI
Devices. Use this command to reset certain MIDI parameters
such as Volume, Pan or Modulation.

Synchronize With/Internal Clock Sets CAMPS to Playback and Record using its own internal
MIDI Clock. A bullet appears next to the current selection.

Synchronize With/Tap Sets CAMPS to Playback and Record using "freewheel"
Tempo pulses input by you on your computer's keyboard or
your MIDI Instrument. A bullet appears next to the current
selection.

Synchronize With/MIDI Clock Sets CAMPS to Playback and Record in "slave" mode using
an external MIDI Clock source, such as another Sequencer.
A bullet appears next to the current selection.

Synchronize With/SMPTE Sets CAMPS to Playback and Record using MIDI Time Code
converted from an external SMPTE Time Code source, such
as a click track from an audio or video tape deck. A SMPTE
converter must be employed between a raw SMPTE source
and the MIDI port used by CAMPS. A bullet appears next to
the current selection.

Transmit Clock/MIDI Clock Enables CAMPS to send its MIDI Clock signal to an external
device. When using this setting in conjunction with Internal
Clock Sync, CAMPS Plays and Records in "Master" mode,
allowing an external Sequencer to synchronize with CAMPS.
A checkmark appears next to this item when enabled.



Transmit Clock/SMPTE Enables CAMPS to send MIDI Time Code to an external
SMPTE converter. When using this setting in conjunction
with Internal Clock Sync, CAMPS Plays and Records in
"Master" mode, allowing an external Sequencer or other
device to synchronize with CAMPS. A checkmark appears
next to this item when enabled.

MIDI Mapper Switches between enable or disable the Windows Operating
System MIDI Mapper. When enabled, CAMPS passes MIDI
Output Device selection control to the Windows Multimedia
applet in the Control Panel. When disabled, MIDI Output
Devices can be selected from within CAMPS, allowing much
greater flexibility. A checkmark appears next to this item
when enabled.

MIDI Setup... Opens the MIDI Setup dialog box, allowing you to manage
many MIDI signaling details. This includes settings for input,
output, sync and Devices.

 



Menu Items for the Tempo List Editor / View  
Menu Items

Menu Items for the Tempo List Editor

  

Description The View menu allows you to select objects to display and how to display them. Use Save
Display Settings to save the current display settings of the Tempo List Editor for its next
session.

 Many of these Menu Items won't be available unless a Document is open.

 

Items Toolbars/Main Toolbar Switches between Show or Hide the Main toolbar. A
checkmark appears next to this Menu item when set to
Show.

Toolbars/Status Bar Switches between Show or Hide the Status Bar. A
checkmark appears next to this Menu item when set to
Show.

Toolbars/Playback Control Toolbar Switches between Show or Hide the Playback Control
toolbar. A checkmark appears next to this Menu item
when set to Show.

Toolbars/Record Control Toolbar Switches between Show or Hide the Record Control
toolbar. A checkmark appears next to this Menu item
when set to Show.

Toolbars/Clock Sync Toolbar Switches between Show or Hide the Clock Sync toolbar.
A checkmark appears next to this Menu item when set to
Show.

Toolbars/Device Control Toolbar Switches between Show or Hide the Device Control
toolbar. A checkmark appears next to this Menu item
when set to Show.

Toolbars/Tempo Toolbar Switches between Show or Hide the Tempo toolbar. A
checkmark appears next to this Menu item when set to
Show.

Toolbars/Note Stamp Toolbar Switches between Show or Hide the Note Stamp toolbar.
A checkmark appears next to this Menu item when set to
Show.

Toolbars/Rest Toolbar Switches between Show or Hide the Rest toolbar. A
checkmark appears next to this Menu item when set to
Show.

Toolbars/Beat Toolbar Switches between Show or Hide the Beat toolbar. A
checkmark appears next to this Menu item when set to
Show.

Toolbars/Time Toolbar Switches between Show or Hide the Time toolbar. A
checkmark appears next to this Menu item when set to
Show.

Auto Scroll Sets the viewable area to follow the Playback Pointer. A
checkmark appears next to this item when enabled.



Jump To Location... Opens the Jump To Location dialog box, allowing you to
specify the beginning Bar of the viewable area. Once
specified, Auto Scroll is temporarily deactivated.

Edit Buttons Switches between Show or Hide the Edit Buttons in the
Tempo List Editor. A checkmark appears next to this
Menu item when set to Show.

Interactive Information Switches between Show or Hide the Interactive
Information display. A checkmark appears next to this
Menu item when set to Show.

Big Beat Window Switches between Show or Hide the Big Beat Window. A
checkmark appears next to this Menu Item when set to
Show. When Showing, you can drag this Window to
desired location, or use its Close button to hide it again.
See details. See also Beat Toolbar..

Big Time Window Switches between Show or Hide the Big Time Window. A
checkmark appears next to this Menu Item when set to
Show. When Showing, you can drag this Window to
desired location, or use its Close button to hide it again.
See details. See also Time Toolbar..

Save Display Settings Saves current Tempo List Editor Display Settings as
defaults for future sessions. Settings included are List,
Zoom, Dividing Bar positions, Background Bitmap, etc.

 



Menu Items for the Tempo List Editor / Editors  
Menu Items

Menu Items for the Tempo List Editor

  

Description The Editors menu allows you to open Editors.

 None of these Menu Items will be available unless a Document is open.

 

Items Tempo List Editor Opens a new Tempo List Editor window, allowing you to alternate edits of
Tempo Events in the current Document.

Tempo Draw Editor Opens the Tempo Draw Editor, allowing you to edit Tempo Events in the
current Document with a unique freestyle curve drawing method.

Text List Editor Opens the Text List Editor, allowing you to edit Text Events of the current
Document in vertical list format.

 



Menu Items for the Tempo List Editor / Window  
Menu Items

Menu Items for the Tempo List Editor

  

Description The Window menu allows you to arrange Document and Editor windows in the work area of the
CAMPS Application Window.

 The Window Menu Item won't be available unless a Document is open.

 

Items New Tempo List Editor Opens a new Tempo List Editor window for the currently selected
Document.

Cascade Arranges windows in a diagonal overlapping manner, allowing you to
individually select them. Any maximized windows will be reduced in
size to accommodate the Cascade arrangement.

Tile Arranges windows into horizontal blocks separated vertically, one
above or below the next.

Arrange Icons Arranges minimized window title bars in an orderly fashion within the
CAMPS Application Window.

[Window] Makes the window named here currently active, appearing in front of
any others. The number of windows listed here equals the number of
open windows in CAMPS. A checkmark appears next to the current
selection.

 



Menu Items for the Tempo List Editor / Help  
Menu Items

Menu Items for the Tempo List Editor

  

Description The Help menu allows you to access these Help documents. The Help menu also allows you to
add a background text message to your Composition Document.

 The Document Memo Menu Item won't be available unless a Document is open.

 

Items Help Opens the Table of Contents for these Help documents.

Document Memo... Opens the Memo dialog box, allowing you to add an underlying text
message to your Document.

About CAMPS Opens the CAMPS banner with a text scroll area containing information
about CAMPS and the Microworks Corporation.

 



Menu Items for the Text List Editor  
Contents

Menu Items

  

Description Here is a complete list of the Menu Items when the Text List Editor is active.

 

Items

 File    

 New  Ctrl + N  

 New Setup...  Ctrl + Shift + N 
 Open...  Ctrl + O  
 Close    
   
 Save  Ctrl + S  
 Save As...    
 Revert    
   
 Export SMF...    
   
 1  [Recent Document]   
 2  [Recent Document]   
   :    
   
 Exit     

 Edit    
 Undo [Action] [Object] Ctrl + Z  

  
 Cut Text Event  Ctrl + X 
 Copy Text Event  Ctrl + C 
 Paste Text Event  Ctrl + V 

 Clear Text Event  Del  
 Select All  Ctrl + A 
  
 New Text Event...  Ctrl + I  
 Duplicate Text Event  Ctrl + D 
  

 SMPTE Offset Setup...    
  
 Preferences...    



 MIDI    

 Play    

 Stop    
 Jump To  >  
  
 Metronome  Ctrl +M 
  
 All Notes Off    

 Reset All Controllers   
  
 Synchronize With  >  

 Transmit Clock  >  
  
 MIDI Mapper    
 MIDI Setup...    

 

 Jump To   
 Top  Home 

 End  End  

 

 Synchronize With 
 Internal Clock  

 Tap  
 MIDI Clock  
 SMPTE  

 

 Transmit Clock 
 MIDI Clock  
 SMPTE  

 View    

 Toolbars  >  
  
 Auto Scroll  Ctrl +L 
 Jump To Location...    
  
 Edit Buttons    
 Interactive Information   
  
 Big Beat Window    
 Big Time Window    
  
 Save Display Settings    

 

 Toolbars  
 Main Toolbar  

 Status Bar  
  
 Playback Control Toolbar 
 Record Control Toolbar  
  
 Clock Sync Toolbar  
 Device Control Toolbar  
 Tempo Toolbar  
  
 Note Stamp Toolbar  
 Rest Toolbar  
  
 Beat Toolbar  
 Time Toolbar  

 Editors    

 Tempo List Editor    
 Tempo Draw Editor   
  
 Text List Editor    

 Window  

 
New Text
List Editor  

 Cascade  
 Tile  
 

Arrange
Icons  

  
 1 [Window] 
 2 [Window] 
   :  



 Help  

 Help  
  
 Document Memo... 
  
 About CAMPS  

 



Menu Items for the Text List Editor / File  
Menu Items

Menu Items for the Text List Editor

  

Description The File menu allows you to manage Document files and shut down CAMPS.

 Some of these Menu Items won't be available unless a Document is open. Additionally, the
Save and Revert commands won't be available until the current Document has been altered.

 

Items New Creates a New untitled Document as specified by the settings in the New
Document Setup dialog box.

New Setup... Opens the New Document Setup dialog box, allowing you to set basic
defaults for New Documents.

Open... Opens the Open dialog box, allowing you to select and open a Document.

 When opening a Standard MIDI File, CAMPS automatically analyzes
Line data and assigns appropriate Line Blocks and one of six Category
settings to each Track. You can alter these settings at any time.

Close Closes the current Document. If this Document has been altered since
opening, you will be asked whether or not you wish to save changes
before closing.

Save Saves the current Document using its existing filename and location.

Save As... Opens the Save As dialog box, allowing you to save the current Document
to a specified filename and location.

Revert Allows you to close and reopen the current Document in one step,
discarding any changes made after last saving it. You'll be asked if you're
sure you want to proceed before this operation is completed.

Export SMF... Opens the Export Standard MIDI File dialog box, allowing you to save the
current Document as a Standard MIDI File. After specifying a filename and
location and clicking Save, the Export Options dialog box opens, allowing
you to make final file format conversion settings.

[Recent Document] Opens the recently opened Document named here. The number of Recent
Documents listed here is adjustable in the Preferences dialog box which
can be opened from the Edit menu.

Exit Closes CAMPS and any open Documents. If any currently open
Documents have been altered since opening, you will be asked whether or
not you wish to save changes before closing.

 



Menu Items for the Text List Editor / Edit  
Menu Items

Menu Items for the Text List Editor

  

Description The Edit menu allows you to Edit Text Events in the Text List Editor. For example, you can Cut,
Copy, Paste and Clear Text Events.

 These Menu Items won't be available unless a Document is open and the Text List Editor is
currently active with a Text Event selected.

 

Items Undo [Action] [Object] Reverses your last editing action. This command's name and function
change depending on your last action. For example, if you just moved a
Text Event, this command's name becomes Undo Move Event. Once
executed, the Undo command becomes Redo and vice versa.

Cut Text Event Removes selected Text Event from a Document for reinsertion using
the Paste command, if desired.

Copy Text Event Specifies a Text Event for duplication using the Paste command.

Paste Text Event Inserts the last Text Event specified with the Cut or Copy command
into the currently selected region of the Text List.

Clear Text Event Deletes the currently selected Text Events.

Select All Automatically selects all Text Events in the List.

New Text Event... Opens the New Text Event dialog box, allowing you to create a New
Event.

Duplicate Text Event Immediately creates a Duplicate of a selected Text Event.

SMPTE Offset Setup... Opens the SMPTE Offset Setup dialog box, allowing you to offset
SMPTE synchronization between CAMPS and a master SMPTE
source.

Preferences... Opens the Preferences dialog box, allowing you to set basic
operational and appearance defaults in CAMPS.

 



Menu Items for the Text List Editor / MIDI  
Menu Items

Menu Items for the Text List Editor

  

Description The MIDI menu allows you to control the CAMPS Sequencer Engine and manage MIDI signals.

 Many of these Menu Items won't be available unless a Document is open.

 

Items Play Starts Playback of the current Document.

Stop Stops Playback of the current Document.

Jump To/Top Moves the Playback Pointer position and viewpoint to the
beginning of the current Document. Executing this command
also enables the Auto Scroll function if previously disabled.

Jump To/End Moves the Playback Pointer position and viewpoint to the
end of the current Document. Executing this command also
enables the Auto Scroll function if previously disabled.

Metronome Switches between activate or deactivate the Metronome
during Playback and Recording. A checkmark appears next
to this item when activated.

All Notes Off Sends the "All Notes Off" MIDI Event to current MIDI
Devices. Use this command to stop unwanted sustained
Notes after stopping Playback or inadvertently interrupting
MIDI signaling.

Reset All Controllers Sends the "Reset All Controllers" MIDI Event to current MIDI
Devices. Use this command to reset certain MIDI parameters
such as Volume, Pan or Modulation.

Synchronize With/Internal Clock Sets CAMPS to Playback and Record using its own internal
MIDI Clock. A bullet appears next to the current selection.

Synchronize With/Tap Sets CAMPS to Playback and Record using "freewheel"
Tempo pulses input by you on your computer's keyboard or
your MIDI Instrument. A bullet appears next to the current
selection.

Synchronize With/MIDI Clock Sets CAMPS to Playback and Record in "slave" mode using
an external MIDI Clock source, such as another Sequencer.
A bullet appears next to the current selection.

Synchronize With/SMPTE Sets CAMPS to Playback and Record using MIDI Time Code
converted from an external SMPTE Time Code source, such
as a click track from an audio or video tape deck. A SMPTE
converter must be employed between a raw SMPTE source
and the MIDI port used by CAMPS. A bullet appears next to
the current selection.

Transmit Clock/MIDI Clock Enables CAMPS to send its MIDI Clock signal to an external
device. When using this setting in conjunction with Internal
Clock Sync, CAMPS Plays and Records in "Master" mode,
allowing an external Sequencer to synchronize with CAMPS.
A checkmark appears next to this item when enabled.



Transmit Clock/SMPTE Enables CAMPS to send MIDI Time Code to an external
SMPTE converter. When using this setting in conjunction
with Internal Clock Sync, CAMPS Plays and Records in
"Master" mode, allowing an external Sequencer or other
device to synchronize with CAMPS. A checkmark appears
next to this item when enabled.

MIDI Mapper Switches between enable or disable the Windows Operating
System MIDI Mapper. When enabled, CAMPS passes MIDI
Output Device selection control to the Windows Multimedia
applet in the Control Panel. When disabled, MIDI Output
Devices can be selected from within CAMPS, allowing much
greater flexibility. A checkmark appears next to this item
when enabled.

MIDI Setup... Opens the MIDI Setup dialog box, allowing you to manage
many MIDI signaling details. This includes settings for input,
output, sync and Devices.

 



Menu Items for the Text List Editor / View  
Menu Items

Menu Items for the Text List Editor

  

Description The View menu allows you to select objects to display and how to display them. Use Save
Display Settings to save the current display settings of the Text List Editor for its next session.

 Many of these Menu Items won't be available unless a Document is open.

 

Items Toolbars/Main Toolbar Switches between Show or Hide the Main toolbar. A
checkmark appears next to this Menu item when set to
Show.

Toolbars/Status Bar Switches between Show or Hide the Status Bar. A
checkmark appears next to this Menu item when set to
Show.

Toolbars/Playback Control Toolbar Switches between Show or Hide the Playback Control
toolbar. A checkmark appears next to this Menu item
when set to Show.

Toolbars/Record Control Toolbar Switches between Show or Hide the Record Control
toolbar. A checkmark appears next to this Menu item
when set to Show.

Toolbars/Clock Sync Toolbar Switches between Show or Hide the Clock Sync toolbar.
A checkmark appears next to this Menu item when set to
Show.

Toolbars/Device Control Toolbar Switches between Show or Hide the Device Control
toolbar. A checkmark appears next to this Menu item
when set to Show.

Toolbars/Tempo Toolbar Switches between Show or Hide the Tempo toolbar. A
checkmark appears next to this Menu item when set to
Show.

Toolbars/Note Stamp Toolbar Switches between Show or Hide the Note Stamp toolbar.
A checkmark appears next to this Menu item when set to
Show.

Toolbars/Rest Toolbar Switches between Show or Hide the Rest toolbar. A
checkmark appears next to this Menu item when set to
Show.

Toolbars/Beat Toolbar Switches between Show or Hide the Beat toolbar. A
checkmark appears next to this Menu item when set to
Show.

Toolbars/Time Toolbar Switches between Show or Hide the Time toolbar. A
checkmark appears next to this Menu item when set to
Show.

Auto Scroll Sets the viewable area to follow the Playback Pointer. A
checkmark appears next to this item when enabled.



Jump To Location... Opens the Jump To Location dialog box, allowing you to
specify the beginning Bar of the viewable area. Once
specified, Auto Scroll is temporarily deactivated.

Edit Buttons Switches between Show or Hide the Edit Buttons in the
Text List Editor. A checkmark appears next to this Menu
item when set to Show.

Interactive Information Switches between Show or Hide the Interactive
Information display. A checkmark appears next to this
Menu item when set to Show.

Big Beat Window Switches between Show or Hide the Big Beat Window. A
checkmark appears next to this Menu Item when set to
Show. When Showing, you can drag this Window to
desired location, or use its Close button to hide it again.
See details. See also Beat Toolbar..

Big Time Window Switches between Show or Hide the Big Time Window. A
checkmark appears next to this Menu Item when set to
Show. When Showing, you can drag this Window to
desired location, or use its Close button to hide it again.
See details. See also Time Toolbar..

Save Display Settings Saves current Text List Editor Display Settings as defaults
for future sessions. Settings included are List, Zoom,
Dividing Bar positions, Background Bitmap, etc.

 



Menu Items for the Text List Editor / Editors  
Menu Items

Menu Items for the Text List Editor

  

Description The Editors menu allows you to open Editors.

 None of these Menu Items will be available unless a Document is open.

 

Items Tempo List Editor Opens the Tempo List Editor, allowing you to edit individual Tempo Events
of the current Document in vertical list format.

Tempo Draw Editor Opens the Tempo Draw Editor, allowing you to edit Tempo Events of the
current Document with a unique freestyle curve drawing method.

Text List Editor Opens a new Text List Editor window, allowing you to make alternate Text
Event edits in the current Document in vertical list format.

 



Menu Items for the Text List Editor / Window  
Menu Items

Menu Items for the Text List Editor

  

Description The Window menu allows you to arrange Document and Editor windows in the work area of the
CAMPS Application Window.

 The Window Menu Item won't be available unless a Document is open.

 

Items New Text List Editor Opens a new Text List Editor window for the currently selected Line
Block.

Cascade Arranges windows in a diagonal overlapping manner, allowing you to
individually select them. Any maximized windows will be reduced in size
to accommodate the Cascade arrangement.

Tile Arranges windows into horizontal blocks separated vertically, one above
or below the next.

Arrange Icons Arranges minimized window title bars in an orderly fashion within the
CAMPS Application Window.

[Window] Makes the window named here currently active, appearing in front of any
others. The number of windows listed here equals the number of open
windows in CAMPS. A checkmark appears next to the current selection.

 



Menu Items for the Text List Editor / Help  
Menu Items

Menu Items for the Text List Editor

  

Description The Help menu allows you to access these Help documents. The Help menu also allows you to
add a background text message to your Composition Document.

 The Memo Menu Items won't be available unless a Document is open.

 

Items Help Opens the Table of Contents for these Help documents.

Document Memo... Opens the Memo dialog box, allowing you to add an underlying text
message to your Document.

About CAMPS Opens the CAMPS banner with a text scroll area containing information
about CAMPS and the Microworks Corporation.

 



Toolbars  Contents

  

Using Eleven "Toolbars" are employed in CAMPS for MIDI data recording, playback and editing
control, as well as file management and situation monitoring. You can choose which Toolbars
appear, and freely move them to desired locations in the top or bottom of the CAMPS
application window. The View status and location of each Toolbar are saved when exiting
CAMPS, and will appear as you last set them when CAMPS is relaunched unless you resize
the CAMPS application window.

 

Toolbar Types Main Includes the basic commands from File and Edit menus as well as MIDI
Setup and Help commands.

Status This area displays Tool Tips and computer keyboard status.

Playback Control Includes the commands from the MIDI menu for controlling Playback,
including Location.

Record Control Includes the commands from the MIDI menu for controlling Recording, as
well as two other related Toolbars' show/hide status.

Clock Sync Includes the MIDI Sync Input commands from the MIDI menu, as well as
a Tempo control.

Device Control Includes the MIDI Sync Output, Metronome and Reset commands from
the MIDI menu.

Note Stamp Sets the Length of Notes to be created with Step Recording or the Note
Stamp Tool.

Rest Advances location between Note Events by each button's specified
amount during Step Recording, effectively inserting Rests.

Beat Displays Playback and Recording Location in MIDI form, expressed as
"Bar:Beat:Divisions".

Time Displays Playback and Recording Location in SMPTE Time Code form,
expressed as "Hours:Minutes:Seconds:Frames".

Tempo  

 



Beat Toolbar  
Contents
Toolbars

  

Description The Beat toolbar displays the Playback/Record Location in the current Document in MIDI form,
expressed as "Bar:Beat:Divisions".

 

Uses You can drag this toolbar to any location in the top or bottom of the CAMPS Application window
frame. Additionally, double clicking this toolbar between buttons or dragging it outside the
CAMPS Application window brings it into its own window that can be put anywhere, even on the
Microsoft Windows desktop. Double clicking it again or dragging it back into the top or bottom of
the CAMPS Application window reintegrates it with the CAMPS Application window frame.

You can choose to Show or Hide this toolbar with the corresponding command in the Toolbars
submenu of the View menu. When contained in its own window, you can hide this toolbar by
clicking its top-right "Close window" ("X") button. Hiding or liberating toolbars can increase the
useable work area in the CAMPS Application window.

 

  



Device Control Toolbar  
Contents
Toolbars

  

Description The Device Control toolbar gives you quick access to the Metronome and Sync output settings.

 

Uses Use the Device Control toolbar for turning the Metronome on or off, as well as choosing a MIDI
Sync output signal.

You can drag this toolbar to any location in the top or bottom of the CAMPS Application window
frame. Additionally, double clicking this toolbar between buttons or dragging it outside the
CAMPS Application window brings it into its own window that can be put anywhere, even on the
Microsoft Windows desktop. Double clicking it again or dragging it back into the top or bottom of
the CAMPS Application window reintegrates it with the CAMPS Application window frame.

You can choose to Show or Hide this toolbar with the corresponding command in the Toolbars
submenu of the View menu. When contained in its own window, you can hide this toolbar by
clicking its top-right "Close window" ("X") button. Hiding or liberating toolbars can increase the
useable work area in the CAMPS Application window.

  

Items Metronome button
Transmit MIDI Clock button
Transmit SMPTE button
All Notes Off button
Reset All Controllers button

 

  



Items in the Device Control Toolbar  Description of this Toolbar

  

Controlling the
Metronome

Metronome
button

Switches between activate or deactivate the Metronome during
Playback and Recording.

Setting Sync
Output

Transmit MIDI Clock
button

Enables CAMPS to send its MIDI Clock signal to an external device.
When using this setting in conjunction with Internal Clock Sync,
CAMPS Plays and Records in "Master" mode, allowing an external
Sequencer to synchronize with CAMPS.

Transmit SMPTE
button

Enables CAMPS to send MIDI Time Code to an external SMPTE
converter. When using this setting in conjunction with Internal Clock
Sync, CAMPS Plays and Records in "Master" mode, allowing an
external Sequencer or other device to synchronize with CAMPS.

Resetting
MIDI Devices

All Notes Off
button

Sends the "All Notes Off" MIDI Event to current MIDI Devices. Click
this button to stop unwanted sustained Notes after stopping Playback
or inadvertently interrupting MIDI signaling.

Reset All Controllers
button

Sends the "Reset All Controllers" MIDI Event to current MIDI Devices.
Click this button to reset certain MIDI parameters such as Volume,
Pan or Modulation.

 

  



Main Toolbar  
Contents
Toolbars

  

Description The Main toolbar offers quick access to the most common File and Edit menu commands, as
well as MIDI Setup and Help.

 This toolbar's functions won't be available unless a Document is open.

 

Uses The Main toolbar allows you to open and edit files, as well as set MIDI signaling defaults and
open CAMPS on-line Help.

You can drag this toolbar to any location in the top or bottom of the CAMPS Application window
frame. Additionally, double clicking this toolbar between buttons or dragging it outside the
CAMPS Application window brings it into its own window that can be put anywhere, even on the
Microsoft Windows desktop. Double clicking it again or dragging it back into the top or bottom of
the CAMPS Application window reintegrates it with the CAMPS Application window frame.

You can choose to Show or Hide this toolbar with the corresponding command in the Toolbars
submenu of the View menu. When contained in its own window, you can hide this toolbar by
clicking its top-right "Close window" ("X") button. Hiding or liberating toolbars can increase the
useable work area in the CAMPS Application window.

  

Items New button
New Setup button
Open button
Save button
Cut button
Copy button
Paste button
Preferences button
MIDI Setup button
Help button

 

  



Items in the Main Toolbar  Description of this Toolbar

  

Managing Files New
button

Creates a New untitled Document as specified by your settings in the New
Document Setup dialog box.

New Setup
button

Opens the New Document Setup dialog box, allowing you to set basic defaults
for New Documents.

Open
button

Opens the Open dialog box, allowing you to select and open a Document.

Save
button Saves the current Document using its existing filename and location.

Editing and
Preferences

Cut
button

Removes selected objects from a Document for reinsertion using the Paste
command, if desired. For example, if you just selected a Chord, this
command's function becomes Cut Chord.

Copy
button

Specifies selected object for duplication using the Paste command. For
example, if you just selected a Chord, this command's function becomes Copy
Chord.

Paste
button

Inserts the last object specified with the Cut or Copy command into the
currently selected relative Area. For example, if you just Cut a Chord and
selected a region in a Chord Block, this command's function becomes Paste
Chord.

Preferences
button

Opens the Preferences dialog box, allowing you to set basic operational and
appearance defaults in CAMPS.

Adjusting
MIDI Defaults

MIDI Setup
button

Opens the MIDI Setup dialog box, allowing you to manage many MIDI
signaling details. This includes settings for input, output, sync and Devices.

Getting Help Help
button

Opens these Help documents.

 

  

file:///C|/My Documents/DialogBoxes/NewDocument/Main.htm
file:///C|/My Documents/DialogBoxes/MIDISetup/Main.htm


Note Stamp Toolbar  
Contents
Toolbars

  

Description The Note Stamp toolbar offers quick access to Step Recording and Stamp tool adjustments.

 This toolbar's functions won't be useable unless a Document is open. Further, you must be
in Step Record mode or using the Stamp tool.

 

Uses The Note Stamp toolbar allows you to set the Length of Notes created with Step Recording or
the Note Stamp Tool.

The Note Stamp toolbar is available for use with Step Recording from your MIDI Instrument in
the Document Window, as well as the Event List, Pianoroll, Control Draw and Notation Editors. It
also provides control of the Stamp tool in the Pianoroll and Notation Editors.

You can drag this toolbar to any location in the top or bottom of the CAMPS Application window
frame. Additionally, double clicking this toolbar between buttons or dragging it outside the
CAMPS Application window brings it into its own window that can be put anywhere, even on the
Microsoft Windows desktop. Double clicking it again or dragging it back into the top or bottom of
the CAMPS Application window reintegrates it with the CAMPS Application window frame.

You can choose to Show or Hide this toolbar with the corresponding command in the Toolbars
submenu of the View menu. When contained in its own window, you can hide this toolbar by
clicking its top-right "Close window" ("X") button. Hiding or liberating toolbars can increase the
usable work area in the CAMPS Application window.

  

Items Whole Note Stamp button
Half Note Stamp button
Quarter Note Stamp button
8th Note Stamp button
16th Note Stamp button
32nd Note Stamp button
64th Note Stamp button
Dotted button
Triplet button
Quintuplet button
Fine Adjustment edit box

 

  



Items in the Note Stamp Toolbar  Description of this Toolbar

  

Setting
Note Duration

Whole Note Stamp
button

Click this button to insert Whole Notes with the Stamp tool or in Step
Record mode.

Half Note Stamp
button

Click this button to insert Half Notes with the Stamp tool or in Step
Record mode.

Quarter Note Stamp
button

Click this button to insert Quarter Notes with the Stamp tool or in Step
Record mode.

8th Note Stamp
button

Click this button to insert 8th Notes with the Stamp tool or in Step
Record mode.

16th Note Stamp
button

Click this button to insert 16th Notes with the Stamp tool or in Step
Record mode.

32nd Note Stamp
button

Click this button to insert 32nd Notes with the Stamp tool or in Step
Record mode.

64th Note Stamp
button

Click this button to insert 64th Notes with the Stamp tool or in Step
Record mode.

Modifying
Note Duration

Dotted
button

Click this button to add half of the currently selected Note Stamp value
to the Note Stamp value. For example, if the 8th Note Stamp button is
currently active, clicking this button will "Dot" the 8th Note, adding a
16th Note value for a total duration of 8th + 16th (three 16ths). Unlike
the Note Stamp buttons, this button toggles on and off.

Triplet
button

Click this button to reduce a Note's duration by 1/3rd of its next greater
value; the amount necessary to facilitate its role in a Triplet figure. For
example, if the 8th Note Stamp button is currently active, clicking this
button will reduce it to 1/3rd of a Quarter Note in length, preparing it for
use in a triplet figure. Three of these Triplet-adjusted 8th Notes will
equal the duration of a Quarter Note. Unlike the Note Stamp buttons,
this button toggles on and off.

Quintuplet
button

Click this button to reduce a Note's duration by 1/5th of its 2nd greater
value; the amount necessary to facilitate its role in a Quintuplet figure.
For example, if the 8th Note Stamp button is currently active, clicking
this button will reduce it to 1/5th of a Half Note in length, preparing it for
use in a Quintuplet figure. Five of these Quintuplet-adjusted 8th Notes
will equal the duration of a Half Note. Unlike the Note Stamp buttons,
this button toggles on and off.

Fine Adjustment
edit box

This adjustment allows you to "smear" the actual Note length according
to the percentage number entered in this box. For example, if the 8th
Note Stamp button is currently active, entering 50% will reduce it by
half, making its actual duration equal to a 16th Note. Choosing an "in
between" value allows you to Stamp or Step Record Notes of irregular
length.

 



Playback Control Toolbar  
Contents
Toolbars

  

Description The Playback Control toolbar offers one-touch control of CAMPS Sequencer Playback and
Recording.

 This toolbar's functions won't be available unless a Document is open.

 

Uses The Playback Control toolbar allows you to start and stop Playback, as well as reposition the
current Playback point.

You can drag this toolbar to any location in the top or bottom of the CAMPS Application window
frame. Additionally, double clicking this toolbar between buttons or dragging it outside the
CAMPS Application window brings it into its own window that can be put anywhere, even on the
Microsoft Windows desktop. Double clicking it again or dragging it back into the top or bottom of
the CAMPS Application window reintegrates it with the CAMPS Application window frame.

You can choose to Show or Hide this toolbar with the corresponding command in the Toolbars
submenu of the View menu. When contained in its own window, you can hide this toolbar by
clicking its top-right "Close window" ("X") button. Hiding or liberating toolbars can increase the
useable work area in the CAMPS Application window.

  

Items Jump to Top button
Rewind button
Stop button
Play button
Fast Forward button
Jump to End button

 

  



Items in the Playback Control Toolbar  Description of this Toolbar

  

Executing a Function Jump to Top
button

Moves the Playback Pointer position and viewpoint to the beginning of
the currently selected Document or Line Block, whichever is in the
currently active window. Executing this command also enables the Auto
Scroll function if previously disabled.

Rewind
button

Quickly moves the Playback Pointer and viewpoint behind its current
position. This function can be performed whether CAMPS is Playing or
Stopped. Executing this command also enables the Auto Scroll function
if previously disabled. Rewind speed is adjustable in the Default pane
of the MIDI Setup dialog box.

Stop
button

Stops Playback of the currently selected Document or Line data.

Play
button Starts Playback of the currently selected Document or Line data.

Fast Forward
button

Quickly moves the Playback Pointer and viewpoint ahead of its current
position. This function can be performed whether CAMPS is Playing or
Stopped. Executing this command also enables the Auto Scroll function
if previously disabled. Fast Forward speed is adjustable in the Default
pane of the MIDI Setup dialog box.

Jump to End
button

Moves the Playback Pointer position and viewpoint to the end of the
currently selected Document or Line Block, whichever is in the currently
active window. Executing this command also enables the Auto Scroll
function if previously disabled.

 

  



Record Control Toolbar  
Contents
Toolbars

  

Description The Record Control toolbar offers quick access to record functions in CAMPS.

 This toolbar's functions won't be available unless a Document is open. Further, a Track must
be Armed for recording in the Document Window, or one of the other Editors must be opened.

 

Uses Use the Record Control toolbar to start real time, Over-Dub or Step Recording with a click of
your mouse. Additionally, the Note Stamp toolbar and Rest toolbar can be enabled with their
respective toggle buttons in the Record Control toolbar for use with Step Recording.

You can drag this toolbar to any location in the top or bottom of the CAMPS Application window
frame. Additionally, double clicking this toolbar between buttons or dragging it outside the
CAMPS Application window brings it into its own window that can be put anywhere, even on the
Microsoft Windows desktop. Double clicking it again or dragging it back into the top or bottom of
the CAMPS Application window reintegrates it with the CAMPS Application window frame.

You can choose to Show or Hide this toolbar with the corresponding command in the Toolbars
submenu of the View menu. When contained in its own window, you can hide this toolbar by
clicking its top-right "Close window" ("X") button. Hiding or liberating toolbars can increase the
useable work area in the CAMPS Application window.

  

Items Rec button
OverDub Rec button
Step Rec button
NoteStamp Toolbar Toggle button
Rest Toolbar Toggle button

 

  



Items in the Record Control Toolbar  
Description of this Toolbar

Using this Toolbar

  

Starting Recording Rec
button

Starts real time Recording in the current Document.

OverDub Rec
button

Starts Over-Dub Recording in the current Document.

Step Rec
button

Starts Step Recording in the current Document.

Activating
Related Toolbars

NoteStamp Toolbar Toggle
button

Toggles the show/hide status of the Note Stamp toolbar for
use with Step Recording in the Document Window, as well
as the Event List, Pianoroll, Control Draw and Notation
Editors (and for use with the Stamp tool found in the
Pianoroll and Notation Editors).

Rest Toolbar Toggle
button

Toggles the show/hide status of the Rest toolbar for use
with Step Recording in the Document Window, as well as
the Event List, Pianoroll, Control Draw and Notation
Editors.

 

  



Using the Record Control Toolbar  
Description of this Toolbar

Items in this Toolbar

  

Starting
Recording

Overview CAMPS can Record in real time, Over-Dub or Step modes in the Document
Window, as well as the Event List, Pianoroll, Control Draw and Notation Editors.

CAMPS can only Record one Track at a time. In the Document Window, the
desired Track must be Armed for Recording. In the Event List, Pianoroll, Control
Draw and Notation Editors, your Track (Line Block) selection has already been
made, so Recording is immediately available.

Rec
button

In the Document Window:

With the Playback Pointer at the beginning of your Document, Arm desired Track
for recording, click the Record button in the Record Control Toolbar and begin
playing your MIDI Instrument to create a new Line Block from the beginning of the
current Document. Whether or not a Line Block already exists, a new Line Block
will be created as you play, located on top of any existing ones.

If you wish to create a New Line Block "on the fly" from some point other than the
beginning of a document, you'll first need to insert a Punch In/Out region for the
desired location. In this case however, any existing Line Block matching the size
and location of your Punch In/Out region and Armed Track will be replaced.

If you wish to Record a new Take of a particular Line Block or otherwise manage
Takes, use the Take List dialog box.

In Other Editors:

Click the Record button in the Record Control toolbar and begin playing your MIDI
Instrument to start Recording from the beginning of the currently selected Line
Block. Unless you create them, a Loop and Punch In/Out region will be
automatically created for the length of the Line Block, and any existing data will be
replaced as soon as you start playing your MIDI Instrument. To Record new data
in a specific location of the currently selected Line Block, insert a Punch In/Out
region for that location. Recording will be active for the Punch In/Out region, but
the rest of the Line Block will remain intact.

If you wish to Record a new Take of a particular Line Block or otherwise manage
Takes in the Document Window or other Editors, use the Take List dialog box.



OverDub Rec
button

In the Document Window:

Whether you are Over-Dubbing an entire Line Block or just a Punch In/Out region,
Over-Dub Recording in the Document Window creates a new Line Block on top of
the original. Besides Arming the desired Track for Recording, a Loop and Punch
In/Out region must be defined for the OverDub Rec button to be available in the
Record Control Toolbar.

In Other Editors:

Over-Dub Recording in the Editors is an additive process. Whether you are
Recording an entire Line Block or just a Punch In/Out region, Over-Dub Recording
in the Event List, Pianoroll, Control Draw or Notation Editors simply adds MIDI
data to existing MIDI data in the currently selected Line Block. Unless you create
them, a Loop and Punch In/Out region will be automatically created for the length
of the Line Block. However, a Loop region is not mandatory to use Over-Dub
Recording in the Editors. To Over-Dub in a specific location of the currently
selected Line Block, insert a Punch In/Out region for that location. Over-Dub
Recording will only be active for the Punch In/Out region.

If you wish to Over-Dub a different Take of a particular Line Block or otherwise
manage Takes in the Document Window or other Editors, use the Take List dialog
box.

Step Rec
button

Unlike the real time and Over-Dub Recording modes, Step Recording doesn't run
the Sequencer "Transport". In other words, the Playback Pointer remains
stationary until you insert a Note with your MIDI Instrument or click a Rest button
in the Rest toolbar. The Playback Pointer advances for the length of new data
when you insert it, but remains stationary otherwise. Some other functions won't
be available in CAMPS until you click the Stop button in the Playback Control
Toolbar or choose Stop from the MIDI menu.

In the Document Window:

Whether you are Step Recording an entire Line Block or just a Punch In/Out
region, Step Recording in the Document Window creates a new Line Block on top
of any originals. A Track must be Armed for Recording for the Step Rec button to
be available in the Record Control toolbar. Use the Note Stamp Toolbar to set the
length of Step Recorded Notes. Use the Rest Toolbar to advance the Playback
Pointer by a specified amount before inserting another Note.

In Other Editors:

Step Recording in the Editors is an additive process. Whether you are Recording
an entire Line Block or a smaller Punch In/Out region, Step Recording in the
Event List, Pianoroll, Control Draw or Notation Editors simply adds MIDI data to
existing MIDI data in the currently selected Line Block. Unless you create them, a
Loop and Punch In/Out region will be automatically created for the length of the
Line Block. To Step Record in a specific location of the currently selected Line
Block, insert a Punch In/Out region for that location. Step Recording will only be
active for the Punch In/Out region. Use the Note Stamp Toolbar to set the length
of Step Recorded Notes. Use the Rest Toolbar to advance the Playback Pointer
by a specified amount before inserting another Note.

If you wish to Step Record a different Take of a particular Line Block or otherwise
manage Takes in the Document Window or other Editors, use the Take List dialog



box.

 

 



Rest Toolbar  
Contents
Toolbars

  

Description The Rest toolbar provides one-click Rest insertion during Step Recording.

 This toolbar's functions won't be available unless a Document is open. Further, a Track must
be Armed for recording in the Document Window, or one of the other Editors must be opened,
and CAMPS must be in Step Record mode.

 

Uses Use the Rest toolbar to advance the Record Location between Note Events by each button's
specified amount during Step Recording, effectively inserting Rests.

The Note Stamp toolbar is available for use with Step Recording from your MIDI Instrument in
the Document Window, as well as the Event List, Pianoroll, Control Draw and Notation Editors.

You can drag this toolbar to any location in the top or bottom of the CAMPS Application window
frame. Additionally, double clicking this toolbar between buttons or dragging it outside the
CAMPS Application window brings it into its own window that can be put anywhere, even on the
Microsoft Windows desktop. Double clicking it again or dragging it back into the top or bottom of
the CAMPS Application window reintegrates it with the CAMPS Application window frame.

You can choose to Show or Hide this toolbar with the corresponding command in the Toolbars
submenu of the View menu. When contained in its own window, you can hide this toolbar by
clicking its top-right "Close window" ("X") button. Hiding or liberating toolbars can increase the
usable work area in the CAMPS Application window.

  

Items Whole Note Rest button
Half Note Rest button
Quarter Note Rest button
8th Note Rest button
16th Note Rest button
32nd Note Rest button
64th Note Rest button
Dotted button
Triplet button
Quintuplet button

 

  



Status Bar  
Contents
Toolbars

  

Description The Status Bar displays Tool Tips and computer keyboard status at the bottom of the CAMPS
Application window.

 

Uses The left side of the Status Bar displays Tool Tips when you "hover" your mouse cursor over any
area in CAMPS which has them. The right side of the Status Bar displays the toggle status of
you computer keyboard's "Num Lock", "Caps Lock" and "Scroll Lock" keys.

You can choose to Show or Hide the Status Bar with the corresponding command in the
Toolbars submenu of the View menu. Hiding the Status Bar increases the useable work area in
the CAMPS Application window.

  



Items in the Rest Toolbar  Description of this Toolbar

  

Setting
Rest Duration

Whole Note Rest
button

Click this button to insert a Whole Note Rest after the last Note entered in
Step Record mode.

Half Note Rest
button

Click this button to insert a Half Note Rest after the last Note entered in
Step Record mode.

Quarter Note Rest
button

Click this button to insert a Quarter Note Rest after the last Note entered
in Step Record mode.

8th Note Rest
button

Click this button to insert a 8th Note Rest after the last Note entered in
Step Record mode.

16th Note Rest
button

Click this button to insert a 16th Note Rest after the last Note entered in
Step Record mode.

32nd Note Rest
button

Click this button to insert a 32nd Note Rest after the last Note entered in
Step Record mode.

64th Note Rest
button

Click this button to insert a 64th Note Rest after the last Note entered in
Step Record mode.

Modifying
Note Duration

Dotted
button

Click this button to add half of the currently selected Rest value to the
Rest value. For example, if the 8th Note Rest button is currently active,
clicking this button will "Dot" the 8th Note Rest, adding a 16th Note value
for a total duration of 8th + 16th (three 16ths). Unlike the Rest buttons,
this button toggles on and off.

Triplet
button

Click this button to reduce a Rest's duration by 1/3rd of its next greater
value; the amount necessary to facilitate its role in a Triplet figure. For
example, if the 8th Note Rest button is currently active, clicking this
button will reduce it to 1/3rd of a Quarter Note Rest in length, preparing it
for use in a triplet figure. Three of these Triplet-adjusted 8th Note Rests
will equal the duration of a Quarter Note Rest. Unlike the Rest buttons,
this button toggles on and off.

Quintuplet
button

Click this button to reduce a Rest's duration by 1/5th of its 2nd greater
value; the amount necessary to facilitate its role in a Quintuplet figure.
For example, if the 8th Note Rest button is currently active, clicking this
button will reduce it to 1/5th of a Half Note Rest in length, preparing it for
use in a Quintuplet figure. Five of these Quintuplet-adjusted 8th Note
Rests will equal the duration of a Half Note Rest. Unlike the Rest buttons,
this button toggles on and off.

 

  



Clock Sync Toolbar  
Contents
Toolbars

  

Description The Clock Sync toolbar allows quick Tempo and Sync input changes.

 

Uses Use the Clock Sync toolbar for temporarily adjusting Playback and Record Tempo, as well as
selecting a MIDI Sync input source.

You can drag this toolbar to any location in the top or bottom of the CAMPS Application window
frame. Additionally, double clicking this toolbar between buttons or dragging it outside the
CAMPS Application window brings it into its own window that can be put anywhere, even on the
Microsoft Windows desktop. Double clicking it again or dragging it back into the top or bottom of
the CAMPS Application window reintegrates it with the CAMPS Application window frame.

You can choose to Show or Hide this toolbar with the corresponding command in the Toolbars
submenu of the View menu. When contained in its own window, you can hide this toolbar by
clicking its top-right "Close window" ("X") button. Hiding or liberating toolbars can increase the
useable work area in the CAMPS Application window.

  

Items Tempo Adjustment display
Tempo Adjustment slider
Internal Sync button
Tap Sync button
MIDI Clock Sync button
SMPTE Sync button

 

  



Items in the Clock Sync Toolbar  Description of this Toolbar

  

Adjusting Tempo Tempo Adjustment
display

Displays the current Tempo Adjustment slider setting as a
percentage of the current Document's MIDI Tempo data value. For
example, 100% equals unchanged, 50% equals half, and 200%
equals double the original Tempo data value.

Tempo Adjustment
slider

Adjusts the current Playback and Record Tempo. This adjustment is
temporary, and does not change a Document's actual MIDI Tempo
data. To edit Tempo data permanently, use the Tempo List Editor or
the Tempo Draw Editor.

Setting Sync Input Internal Sync
button

Sets CAMPS to Playback and Record using its own internal MIDI
Clock.

Tap Sync
button

Sets CAMPS to Playback and Record using "freewheel" Tempo
pulses input by you on your computer's keyboard or your MIDI
Instrument.

MIDI Clock Sync
button

Sets CAMPS to Playback and Record in "slave" mode using an
external MIDI Clock source, such as another Sequencer.

SMPTE Sync
button

Sets CAMPS to Playback and Record using MIDI Time Code
converted from an external SMPTE Time Code source, such as a
click track from an audio or video tape deck. A SMPTE converter
must be employed between a raw SMPTE source and the
corresponding MIDI input port used by CAMPS.

 

  



Tempo Toolbar  
Contents
Toolbars

  

Description The Tempo toolbar simply displays the currently active Tempo setting of the current Document in
the format "Basis=Tempo", where Basis is shown in musical Time Notation and Tempo is shown
as the number of Beats Per Minute. If no Document is currently open, the Tempo of the last open
Document during the current CAMPS session is displayed.

 

Uses Any Tempo changes that occur in your Composition Document will be displayed by the Tempo
toolbar when the Playback Pointer reaches the corresponding region. This is true whether
Playback is running or Stopped. The current Basis and Tempo displayed here are adjustable in
the Tempo List Editor and the Tempo Draw Editor.

You can drag this toolbar to any location in the top or bottom of the CAMPS Application window
frame. Additionally, double clicking this toolbar between buttons or dragging it outside the
CAMPS Application window brings it into its own window that can be put anywhere, even on the
Microsoft Windows desktop. Double clicking it again or dragging it back into the top or bottom of
the CAMPS Application window reintegrates it with the CAMPS Application window frame.

You can choose to Show or Hide this toolbar with the corresponding command in the Toolbars
submenu of the View menu. When contained in its own window, you can hide this toolbar by
clicking its top-right "Close window" ("X") button. Hiding or liberating toolbars can increase the
useable work area in the CAMPS Application window.

  

 

  



Time Toolbar  
Contents
Toolbars

  

Description The Time toolbar displays the Playback/Record Location in the current Document in SMPTE
Time Code form, expressed as "Hours:Minutes:Seconds:Frames".

 

Uses The Time Display Mode button on the right side of this toolbar includes a drop-down list button
which allows you to select SMPTE Frame Rate, as well as Offset display. Clicking the main part
of this button (clock icon) advances the Time Display Mode to the next Frame Rate choice in the
list.

You can drag this toolbar to any location in the top or bottom of the CAMPS Application window
frame. Additionally, double clicking this toolbar between buttons or dragging it outside the
CAMPS Application window brings it into its own window that can be put anywhere, even on the
Microsoft Windows desktop. Double clicking it again or dragging it back into the top or bottom of
the CAMPS Application window reintegrates it with the CAMPS Application window frame.

You can choose to Show or Hide this toolbar with the corresponding command in the Toolbars
submenu of the View menu. When contained in its own window, you can hide this toolbar by
clicking its top-right "Close window" ("X") button. Hiding or liberating toolbars can increase the
usable work area in the CAMPS Application window.
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Overview Here is a list of several music terms often used in CAMPS. Understanding these terms will help
you get more control of CAMPS features.

 

Bar

Chord and Chord Progression

Chord Function

Chord Name

Continuity between Adjacent Chords

Harmonic Tension

Harmonize

Key and Mode

Lower Interval Limit

Middle C

Roman Numerals

Scale Name

Scale Notes

Scale Spelling

Time Signature

Transpose

Voicing
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PLEASE READ THIS LICENSE CAREFULLY BEFORE OPENING/INSTALLING THE MICROWORKS
SOFTWARE. BY OPENING/INSTALLING THE PROGRAM YOU ACCEPT ALL THE TERMS AND
CONDITIONS OF THIS AGREEMENT.
If you do not agree with the terms and conditions of this agreement, return the software, unsealed, along with
the rest of the package, immediately to the place where you obtained it or to Microworks Corporation (
"Microworks" )

 

1. License Microworks Software, whether on disk or on any other machine-readable
media, is licensed to you by Microworks.
The disk on which Microworks Software is recorded is your property, but
Microworks and/or Microworks's licenser(s) retain title to the Microworks
Software.
This license allows you to use the Microworks Software on a single central
processing unit.
You may transfer your license rights in Microworks Software, the related
documentation and this license agreement to another party. The transferred
party agrees to accept the terms and conditions of this license.

2. Restrictions The Microworks Software and the related documentation are fully copyrighted,
and contain trademark materials and patents.
You may not decompile, disassemble or reverse engineer the Microworks
Software to a human-perceivable form.
You may not rent, lease, loan, distribute, upload, modify or create derivative
works based upon the Microworks Software in whole or in part.

3. Termination This license is effective until terminated.
You may terminate this license at any time by destroying the Microworks
Software and the related documentation.
This license will terminate without notice from Microworks, if you fail to comply
with any provision of this license agreement.
Upon termination you must destroy the Microworks Software and the related
documentation thereof.

4. Export You agree that neither the Microworks Software nor the related documentation
will be exported outside the United States except as authorized and as
permitted by the laws and regulations of the United States.
You agree that you will not re-export the Microworks Software nor the related
documentation except as authorized and as permitted by the laws and
regulations of the United States and the laws and regulations of the jurisdiction
in which you obtained the Microworks Software and the related documentation.



5. Government
End Users

If you are acquiring the Microworks software on behalf of any group of the
United States Government, the following provisions apply. The Government
agrees:
if Microworks software is supplied to the Department of Defense (DoD), the
Microworks software is classified as Commercial Computer Software and the
Government is acquiring only restricted rights in the Microworks software, its
documentation as that term is defined in Clause 252.227-7013(c)(1) of the
DFARS; and
if Microworks software is supplied to any group of the United States
Government other than DoD, the Government's rights in the Microworks
software, its documentation will be as defined in Clause 52.227-19(c)(2) of the
FAR or, in the case of NASA, in Clause 18-52.227-86(d) of the NASA
Supplement of the FAR.

6. Limited Warranty
on Media

Microworks warrants the disks on which the Microworks Software is recorded to
be free from defects in materials and workmanship under normal use for a
period of ninety days from the date of purchase as evidenced by a copy of the
receipt.
Microworks's entire liability and your exclusive remedy will be replacement of
the disk

7. Disclaimer of Warranty on
Microworks Software

Microworks can not warrant the performance or results you may obtain by using
the Microworks Software and the related documentation.
Microworks disclaims all other warranties, express or implied, including, but not
limited to, the implied warranties of merchantability and fitness for a particular
purpose or those arising from trade usage or course of dealing. No oral or
written information or advice given by Microworks, its employees, distributors,
dealers or agents shall increase the scope of the above warranties or create
any new warranties.

8. Limitation of Liability In no event including negligence, shall Microworks be liable to you for any
consequential, incidental or special damages, whether based on contract, tort,
warranty or other legal or equitable grounds, including any lost profits or lost
savings, even if a Microworks representative has been advised of the possibility
of such damages, or for any claim by any party.
Some jurisdictions do not allow the limitation or exclusion of liability for
consequential or incidental damages so the above limitation or exclusion may
not apply to you.
In no event shall Microworks's total liability to you for all damages, losses, and
causes of action exceed the amount paid by you for the Microworks Software.

9. Controlling Law and
Severability

This agreement will be governed by the laws in force in the State of
Massachusetts excluding the application of its conflicts of law rules.

10. Agreement You acknowledge that you have read this agreement, understand it and that it is
the complete and exclusive statement of your agreement with Microworks which
supersedes any prior agreement, oral or written, between Microworks and you.
No amendment to or modification of this agreement will be binding unless in
written and signed by a duly authorized representative of Microworks.

 

CAMPS, MelodyDraw are registered trademarks of Microworks Corp. Windows95, 98, NT and 2000 are
registered trademarks of Microsoft Corp. Netscape Navigator is registered trademark of Netscape
Communications Corp. Microsoft Explorer is registered trademark of Microsoft Corp.

Specification may be changed without notice.

U.S.Patent Pending. All Rights Reserved. (C)1989-2000 Microworks
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Overview The term "Bar" actually refers to vertical lines dividing a musical Notation Staff into Measures of
time, but this term is commonly used to refer to the Measures themselves, as is the case in
CAMPS.

That said, Bars are divisions of musical time containing Notes or Rests whose duration add up to
the amount of time allotted to each Bar. This amount of time is defined by a Time Signature.

CAMPS allows you to assign different Time Signatures to individual Bars.
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Chord A Chord is two or more notes played at the same time. Chords create a variety of
feelings or moods in music, such as reassurance, or unease and tension.

In nature, sounds consists of a fundamental frequency (Pitch) and many Harmonics.
Harmonic overtones occur at different levels within the fundamental frequency, blending
to form the sounds we hear. Pitches or Notes in western 12-tone musical Scales follow
the same intervalic patterns as those found in nature's Harmonics, however, they are
sounded at similar levels, each with a fundamental or tonic Pitch of it's own. Sounding
these Notes simultaneously makes it possible to form a variety of Chords.

For example, Chords with three pitches comprised of the first, third, and fifth degree of
the Scale to which the Chord corresponds are called Triads. Chords with four pitches
comprised of the first, third, fifth, and seventh (or sixth) degree of the Scale are called 7th
Chords. CAMPS supports all types of Chords.

Chord Progression A Chord Progression is formed from a series of Chords sounded one after the next.
Each Chord can evoke certain feelings and the order in which Chords are sounded
creates changing feelings, thereby defining the mood of a Song as it progresses. CAMPS
knows a broad spectrum of Chord Progressions, from classical music, to rock, blues
and modal jazz. CAMPS always chooses Chords which flow smoothly from one to the
next when Auto-Harmonizing and generating Chord Progressions.
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Overview A Chord's Chord Function settings describe how it functions within a Chord progression
relative to its Key. Chord Function choices may differ depending on whether a Chord's Key
is Major, Minor or "Modal".

In CAMPS, Chord Functions are organized from the top down in several levels from basic
to advanced using music terms such as "Diatonic" and "Secondary Dominant".

CAMPS displays Chords in different shades of gray according to their corresponding Chord
Functions. The more basic the Chord Function, the lighter the shade; The more
advanced the Chord Function, the darker the shade.

 

Chord Functions CAMPS supports the following Chord Functions:

 

Major Diatonic●   

Diminished●   

Secondary Dominant●   

Related II of Secondary Dominant●   

Substitute V●   

Related II of Substitute V●   

 

Minor Diatonic●   

Diminished●   

Secondary Dominant●   

Related II of Secondary Dominant●   

Substitute V●   

Related II of Substitute V●   

  

Modes Ionian●   

Dorian●   

Phrygian●   

Lydian●   

Mixolydian●   

Aeolian●   

Locrian●   
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Overview In CAMPS, a Chord is built by defining four elements: Symbol , Quality, Tension and
Inversion. By skillfully using these elements with certain Chords in a Chord Progression, you
can add to the complexity or uniqueness of the Chord motion in your composition.

Four Elements Symbol Indicates the pitch of a Chord's Root; its Tonic Note.

The Notes which comprise a Chord are selected from a group of Harmonics
which are naturally produced from this Root. The Root is the main element
representing a Chord.

Quality Special sound characteristics of the basic Chord (before a Tension or Inversion
is applied).

A Chord's Quality, such as Major or Diminished, defines its Tonality. These
names are typically abbreviated as maj, dim, etc.

Tension A Chord Tension is a Note above the first Octave of the Chord's Root (above
the regular three or four Chord Tones) which adds relative dissonance to the
Chord.

Chords with Tensions tend to sound broader and more dissonant.

 The Tension Notes used in a Chord's construction are called Harmonic
Tensions.

Inversion When a Chord is Inverted, the same Notes are used, but their order is changed.
A Chord is Inverted when its lowest Note is not its Root. In an Inversion, one or
more of a Chord's Notes can be moved by one octave.

For example, the Chord "C" is composed in the ascending order of the Notes C,
E, and G but the Chord "C/E" is inverted to the order of E, G, and C.
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Overview To create pleasing Chord Progressions, we tend to arrange Chords for a feeling of
continuity. However, when attempting to create unique Chord Progressions, it is
sometimes difficult to find a Chord in the desired Tonality which still maintains a smooth
transition from one Chord to the next. In such situations, Chord Progression continuity may
be lost, which has the effect of drawing attention to the boundaries between parts of a
song which have variation in its Chord Progressions.

Musical continuity CAMPS always tries to generate Chords that give a feeling of musical continuity between
them when auto-generating Chords or auto-harmonizing Lines which fall within the
boundaries of a Chord Block.

One way to take advantage of this feature is to assign a separate Chord Block or Blocks to
each Section of your Composition, making a contrast in continuity between these different
Sections.
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Overview In CAMPS, Harmonization is the process of creating Chord Progressions based on Melodic
lines.

How It Works Chord progressions need to blend with the Melody when composing or arranging music.
Sometimes a Chord Progression is composed first and the Melody is later composed to blend
with the Chord Progression. There are usually a number of Chord Progressions that blend with
a Melody, not just one. When looking for a Chord, you not only want one that blends with the
Melody, but also one that allows smooth transitions with preceding and following Chords.

The CAMPS Harmonize feature looks at these elements when it runs. It automatically
composes Chord Progressions that harmonize with the Melody, as well as preserve continuity.

 As explained above, during Auto-Harmonization, CAMPS automatically suggests Chords
that will blend in smoothly and with continuity to chords preceding and following it. This,
however, works only within a Chord Block.
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Overview A Key is established when a composition primarily uses one Scale.

Scales and Modes CAMPS uses 10 different seven-note Scales and Modes. A Mode is simply a major scale
where the starting point or root is changed to a different degree. For example, the 2nd
degree of a Major Scale is the root of the "Dorian Mode".

 

Major A seven note Scale having half step intervals between the third and
fourth and the seventh and eighth degrees. The other intervals are
whole steps.

Minor A seven note Scale having half step intervals between the second
and third and the fifth and sixth degrees. The other intervals are
whole steps.



Harmonic Minor A seven note Scale having half step intervals between the second
and third, the fifth and sixth, and the seventh and eighth degrees, as
well as an augmented second (or minor 3rd) between the sixth and
the seventh degrees. the other intervals are whole steps.

Melodic Minor A seven note Scale having half step intervals between the second
and third and the seventh and eighth degrees. The other intervals
are whole steps.

Ionian
( same as Major )

A seven note Scale having half step intervals between the third and
fourth and the seventh and eighth degrees. The other intervals are
whole steps.

Dorian A seven note Scale having half step intervals between the second
and third and the sixth and seventh degrees. The other intervals are
whole steps.



Phrygian A seven note Scale having half step intervals between the first and
second and the fifth and sixth degrees. The other intervals are whole
steps.

Lydian A seven note Scale having half step intervals between the fourth and
fifth and the seventh and eighth degrees. The other intervals are
whole steps.

Mixolydian A seven note Scale having half step intervals between the third and
fourth and the sixth and seventh degrees. The other intervals are
whole steps.

Aeolian
( same as Minor )

A seven note Scale having half step intervals between the second
and third and the fifth and sixth degrees. The other intervals are
whole steps.



Locrian A seven note Scale having half step intervals between the first and
second and the fourth and fifth degrees. The other intervals are
whole steps.
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Overview When forming Chords, there are instances when particular intervals in the low register result in
a "muddy" sound. Each interval has a different point at which this "muddiness" occurs and that
point is known as the interval's Lower Interval Limit.

How It Works The CAMPS L.I.L. feature prevents intervals from occurring below their Lower Interval Limits
during auto composition.

 



Middle C
Contents

Music Glossary

  

Overview In music, the center of the Great Staff is called Middle C. Middle C defines the base of the
register.

How It Works There are instances when pressing a key on your MIDI instrument yields a pitch one or two
octaves off depending on the MIDI device and sound Program you use. The Middle C setting
makes it so that you hear the same pitch even when there is such a shift in register.

To get the most out of CAMPS features, it is important to understand defining the fundamental
pitch.

 A staff combining the Bass cleft and Treble cleft is known as the Great Staff. It is used for
instruments that covers a wide register such as the piano or organ.
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Overview Roman Numerals are a way to display Chord Names that show a Chord's relationship to the
Key.

Although ordinary Chord Names are called "Absolute Chord Names", Roman Numerals are
known as "Relative Chord Names" because they do not depend on the actual Key.

An example For example, if Gmaj7 is displayed with its Relative (Roman Numeral) Name as IVmaj7, this
means the Chord is the 4th Diatonic Chord in the Key of D, and its corresponding Scale Name
is Lydian. If Gmaj7 is displayed as Roman Numeral Imaj7, this means the Chord is the 1st
Diatonic Chord in the Key of G, and its corresponding Scale Name is Ionian.
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Overview Chords contain one or more Scales whose main constituents are harmonics derived from the Root
of the Chords. Each Scale that has a name such as "Ionian" or "Lydian" for the Note arrangements
is called a Scale Name.
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Overview A Scale is typically comprised of 7 Notes called Scale Notes.

Details An octave has 12 Notes, so that the 5 remaining Notes, which are not included in the Scale are
called Chromatic Notes. Chromatic Notes create dissonance (harsh or uneasy sound) when
played simultaneously with Chords, and therefore they are generally played as momentary Passing
Notes unless a dissonant Chord is desired. There are one or two Scale Notes called Avoid Notes
in a Scale which also lend a dissonant flavor when played simultaneously with a corresponding
Chord. In particular, the 9th, 11th and 13th degrees of a Scale are considered Tension Notes.

 

 Harmonic Tensions are Tension Notes which are not Avoid Notes. Adding Harmonic
Tensions Notes to a Chord makes it sound richer.

 Depending on a given Scale, its 9th, 11th, and 13th degrees may be altered.

( 9th ) ----> ( b9th ), ( #9th )●   

( 11th ) ----> ( #11th )●   

( 13th ) ----> ( b13th )●   

More Depending on the Notes involved, certain Scales in CAMPS are named as follows:

 

Pentatonic A Scale comprised of 5 Notes, the Root, 9th, 3rd, 5th and 13th of the original Scale

Chordal A Scale comprised of 4 Notes, the Root, 3rd, 5th and 7th (or 13th) of the original
Scale

Triadic A Scale comprised of 3 Notes, the Root, 3rd and 5th of the original Scale
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Overview The degrees of a Scale are called Scale Notes, and each of these are given a name such as 9th or
b7th. These numbers are based on the Major Scale starting with the Root as 1 and ascending
consecutively. This is called Scale Spelling.
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Overview A Time Signature indicates the number of Beats in each Bar and the value of each Beat.

Time Signatures are expressed as a numerical fraction located at the beginning of a musical
Notation Staff. The fraction numerator indicates the number of Beats per Bar, and the fraction
denominator indicates the type (duration) of Note which gets one Beat. For example, 6/8 signifies
six Beats in each Bar, with each Beat having the duration of an Eighth Note.

CAMPS allows you to assign different Time Signatures to individual Bars.
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Overview Changing to a different Key in the middle of a song is called Modulation. Changing an entire song
to a different Key from the outset is called Transposition. CAMPS calls both of these
Transposition.

Transposing allows you to give a song "Variation" or "Development" as it progresses.

CAMPS allows Transposition of individual Chords. It is also possible to temporarily transpose the
entire Chord Track or entire Line Tracks during playback and recording.
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Overview Most often melody lines consist of a series of individual Notes, but sometimes Harmonies are
added in certain places to provide musical variation or impact. The different arrangement of
harmony Notes under the melody is known as Voicing.

 The top Note of a Voicing is is called the Lead Note.

 Voicing cannot be performed if the Lead Note is a Chromatic Note and is not specifically
assigned by the user as a Tension or Passing Tone.

How It Works During the creation of Harmonies, available Notes are limited according to the Chord allocated
to the Lead Note, but there is no limitation on the order of usage. Voicing is a technique related
to this order of usage. There are actually a number of available notes with different nuances
within the same chord while retaining the same Lead Note. A variety of Voicing techniques are
available depending on several factors including the number of Notes used.

Voicing techniques are essential when arranging any accompaniment section.

Voicing
Techniques

CAMPS supports 3 to 6 voices, techniques ranging from Closed and Spread all the way to
U.S.T., and a Harmonic Tension feature for filtering Dissonance. These features make it easy
to instantly compare a variety of Voicing nuances.

Cluster Harmonies consisting of Notes a 2nd apart, thereby developing
in a relatively narrow pitch range. Clusters are very effective
when used for low-tone melodies, backgrounds, and high-tone
melodies that require bright sounds.

Closed The most basic Harmonies where Notes that form the nearest
Harmony are arranged in order below the Lead Note.

Drop2 Harmonies developing in a somewhat wide register, dropping a
Closed 2nd one octave below.

Drop3 Harmonies developing in an even a wider register, dropping a
Closed 3rd one octave below.

Drop2+4 Harmonies developing in a relatively wide register, dropping a
Closed 2nd and 4th one octave below.



4th Harmonies developing in a relatively wide register. The interval
between the Notes forming the Chord is the Perfect 4th. This is
very effective when used for long Notes, rhythmic Melodies and
Pedal Point, among other things.

Spread Harmonies developing in a wide register including the Root as
the lowest Note, with the 3rd and 7th above the Root. This is
very effective when used for long Notes, rhythmic Melodies,
backgrounds and vocals.

UST (Upper Structure Triad) Harmonies consisting of three Notes forming Chord Tones and
Tensions. This is very effective when used for rhythmic
Melodies, climaxes and endings, among other things.
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PLEASE READ THIS LICENSE CAREFULLY BEFORE OPENING/INSTALLING THE MICROWORKS
SOFTWARE. BY OPENING/INSTALLING THE PROGRAM YOU ACCEPT ALL THE TERMS AND
CONDITIONS OF THIS AGREEMENT.
If you do not agree with the terms and conditions of this agreement, return the software, unsealed, along with
the rest of the package, immediately to the place where you obtained it or to Microworks Corporation (
"Microworks" )

 

1. License Microworks Software, whether on disk or on any other machine-readable
media, is licensed to you by Microworks.
The disk on which Microworks Software is recorded is your property, but
Microworks and/or Microworks's licenser(s) retain title to the Microworks
Software.
This license allows you to use the Microworks Software on a single central
processing unit.
You may transfer your license rights in Microworks Software, the related
documentation and this license agreement to another party. The transferred
party agrees to accept the terms and conditions of this license.

2. Restrictions The Microworks Software and the related documentation are fully copyrighted,
and contain trademark materials and patents.
You may not decompile, disassemble or reverse engineer the Microworks
Software to a human-perceivable form.
You may not rent, lease, loan, distribute, upload, modify or create derivative
works based upon the Microworks Software in whole or in part.

3. Termination This license is effective until terminated.
You may terminate this license at any time by destroying the Microworks
Software and the related documentation.
This license will terminate without notice from Microworks, if you fail to comply
with any provision of this license agreement.
Upon termination you must destroy the Microworks Software and the related
documentation thereof.

4. Export You agree that neither the Microworks Software nor the related documentation
will be exported outside the United States except as authorized and as
permitted by the laws and regulations of the United States.
You agree that you will not re-export the Microworks Software nor the related
documentation except as authorized and as permitted by the laws and
regulations of the United States and the laws and regulations of the jurisdiction
in which you obtained the Microworks Software and the related documentation.



5. Government
End Users

If you are acquiring the Microworks software on behalf of any group of the
United States Government, the following provisions apply. The Government
agrees:
if Microworks software is supplied to the Department of Defense (DoD), the
Microworks software is classified as Commercial Computer Software and the
Government is acquiring only restricted rights in the Microworks software, its
documentation as that term is defined in Clause 252.227-7013(c)(1) of the
DFARS; and
if Microworks software is supplied to any group of the United States
Government other than DoD, the Government's rights in the Microworks
software, its documentation will be as defined in Clause 52.227-19(c)(2) of the
FAR or, in the case of NASA, in Clause 18-52.227-86(d) of the NASA
Supplement of the FAR.

6. Limited Warranty
on Media

Microworks warrants the disks on which the Microworks Software is recorded to
be free from defects in materials and workmanship under normal use for a
period of ninety days from the date of purchase as evidenced by a copy of the
receipt.
Microworks's entire liability and your exclusive remedy will be replacement of
the disk

7. Disclaimer of Warranty on
Microworks Software

Microworks can not warrant the performance or results you may obtain by using
the Microworks Software and the related documentation.
Microworks disclaims all other warranties, express or implied, including, but not
limited to, the implied warranties of merchantability and fitness for a particular
purpose or those arising from trade usage or course of dealing. No oral or
written information or advice given by Microworks, its employees, distributors,
dealers or agents shall increase the scope of the above warranties or create
any new warranties.

8. Limitation of Liability In no event including negligence, shall Microworks be liable to you for any
consequential, incidental or special damages, whether based on contract, tort,
warranty or other legal or equitable grounds, including any lost profits or lost
savings, even if a Microworks representative has been advised of the possibility
of such damages, or for any claim by any party.
Some jurisdictions do not allow the limitation or exclusion of liability for
consequential or incidental damages so the above limitation or exclusion may
not apply to you.
In no event shall Microworks's total liability to you for all damages, losses, and
causes of action exceed the amount paid by you for the Microworks Software.

9. Controlling Law and
Severability

This agreement will be governed by the laws in force in the State of
Massachusetts excluding the application of its conflicts of law rules.

10. Agreement You acknowledge that you have read this agreement, understand it and that it is
the complete and exclusive statement of your agreement with Microworks which
supersedes any prior agreement, oral or written, between Microworks and you.
No amendment to or modification of this agreement will be binding unless in
written and signed by a duly authorized representative of Microworks.

 

CAMPS, MelodyDraw are registered trademarks of Microworks Corp. Windows95, 98, NT and 2000 are
registered trademarks of Microsoft Corp. Netscape Navigator is registered trademark of Netscape
Communications Corp. Microsoft Explorer is registered trademark of Microsoft Corp.

Specification may be changed without notice.

U.S.Patent Pending. All Rights Reserved. (C)1989-2000 Microworks
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